vk_rs232 краш в тонком клиенте

1. marku 63 29.02.24 11:46 Сейчас в теме
Нашел в инете vk_rs232.
Работает, но при выходе из процедуры вылетает 1с
Коллеги, поделитесь ссылкой работающей компонентой vk_rs232

Внешняя обработка с одной процедурой
Вот такая процедура. Вылетает при выходе из неё

&НаКлиенте
Процедура Подключитьvk_rs232(Команда)
    
    Попытка
        
        ПодключитьВК = ПодключитьВнешнююКомпоненту("C:\vk_rs232\vk_rs232.dll", "AAA", AddInType.COM);    
        //ПодключитьВК = ПодключитьВнешнююКомпоненту("rs232.dll", "AAA", ТипВнешнейКомпоненты.Native);    
        
    Исключение
        Сообщить("1. "+ОписаниеОшибки());
        Возврат;
    КонецПопытки;
    
    ПортОткрыт = Ложь;
    
    Если ПодключитьВК Тогда
        КОМПорт = Новый ("AddIn.AAA.vk_rs232");
          
        Попытка
            КОМПорт.OpenPort("COM2");        
            Сообщить("2. "+"Порт открыт!");
            
            ПортОткрыт = Истина;
        Исключение
            Сообщить("2. "+ОписаниеОшибки());
        КонецПопытки;  
    Иначе
        Сообщить("2. ВК не подключилась");
        
    КонецЕсли;
    
    МенеджерОборудованияКлиент.Пауза(5);
    
    Если ПортОткрыт Тогда
        //Возврат;
        Попытка
            КОМПорт.ClosePort();
            Сообщить("Порт закрыт!");
            
        Исключение
            Сообщить("3. "+ОписаниеОшибки());
        КонецПопытки;        
    КонецЕсли;
    
    КОМПорт=Неопределено;
    ПодключитьВК=Неопределено;
    
КонецПроцедуры
Показать
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. CheBurator 3125 29.02.24 11:54 Сейчас в теме
Насколько я знаю эта ВК для 7.7 была написана.
Будет ли она работать с 8-кой...?
3. CheBurator 3125 29.02.24 11:55 Сейчас в теме
Попробуй
ПодключитьВК=0; или ПодключитьВК="";
4. marku 63 29.02.24 13:17 Сейчас в теме
(3) вылетает
Прикрепленные файлы:
5. starik-2005 3052 29.02.24 14:46 Сейчас в теме
В режиме совместимости с Версия 8.2.13 vk_rs232 работает и читает Сom и под x64, правда после ручной её регистрации Код немного другой:
ЗагрузитьВнешнююКомпоненту(КаталогПрограммы()+"vk_rs232.dll");
ПодключитьВнешнююКомпоненту("AddIn.vk_rs232");
rs232=новый ("AddIn.vk_rs232");
Найдено на мисте от пользователя с ником veslo.
6. marku 63 29.02.24 15:05 Сейчас в теме
(5)
ЗагрузитьВнешнююКомпоненту


Доступность:
Толстый клиент.

мне нужно на Тонком
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот