Использование встроенного сканера ТСД на Android в мобильном клиенте и мобильном приложении (драйвер сканера Android для 1С)

0. 596 08.10.20 11:50 Сейчас в теме
Используя данный драйвер, можно без единой строки кода, просто установив на ТСД мобильный клиент 1С, сразу начать подбирать товары в документах вашей учётной системы. А, адаптировав нужные формы под небольшой размер экрана ТСД, можно просто создать полноценное рабочее место для выполнения операций с помощью ТСД, не прибегая к стороннему софту. Если же на складе плохая связь (или её нет вовсе), то можно использовать возможности мобильного клиента в автономном режиме (потребуется доработка вашей конфигурации).
Драйвер также можно использовать и для Android приложения на мобильной платформе. В результате чего можно обойтись без ненужных полей ввода и клавиатуры «на пол-экрана».

Перейти к публикации

user12klk67694; +1 Ответить
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. gzharkoj 361 09.10.20 08:52 Сейчас в теме
В целом полезно, но есть БПО для мобильных приложений, он не заработал?
2. ltfriend 596 09.10.20 09:28 Сейчас в теме
(1) нужно было, чтобы заработало в мобильном клиенте. Из типовых драйверов обычной БПО ни чего не заработало.
Библиотека для мобильного приложения создана, как опция, т.к. внешней компоненте без разницы где работать: в мобильном клиенте или мобильном приложении. Но, если в мобильном приложении используется только сканер ТСД, то можно не добавлять всю мобильную БПО, а использовать только драйвер.
Вообще, делалось для клиента, чтобы без танцев с бубнами, дорогого стороннего софта и обменов кладовщик мог через мобильный клиент собирать заказы. Результатом работы решил поделиться с сообществом.
Yuri1988; +1 Ответить
3. ltfriend 596 09.10.20 09:34 Сейчас в теме
(1) ещё дополню. Если в приложении используется мобильная БПО, но типовые драйвера не подходят, то в ней так же можно использовать этот драйвер. Библиотека сканера для мобильного приложения, описанная в публикации, создана для облегчения внедрения драйвера сканера и работы с ним, если мобильная БПО по какой-то причине не используется.
4. user790708 16.10.20 14:38 Сейчас в теме
1) Для использования в конфигурации с использованием мобильной БПО в обработке ЗаполнениеОписанияДрайвераСканераШтрихкодовAndroid
в процедуре ЗаполнитьОписаниеНаСервере нужно изменить команду подключения на:
Справочники.ДрайверыОборудования.ЗаполнитьПредопределенныйЭлемент(
		Перечисления.ТипыПодключаемогоОборудования.УстройствоВвода,
		"ДрайверСканерыШтрихкодаAndroid",
		"ДрайверСканерыШтрихкодаAndroid",
		"AddIn.com_ptolkachev_AndroidScannerExtension",
		Ложь,
		"1.0.1.1",
		Истина
		);
Показать

2) Понизьте, пожалуйста, версию совместимости конфигурации для интерации,
3) Драйвер работает с ТСД Sumni L2
5. VSydorenko 17.10.20 20:15 Сейчас в теме
Данные параметры необходимо узнать для своей модели ТСД. Обычно, они располагаются в настройках сканера.


А где найти эти настройки для ТСД zebra MC40?
Те, что указаны на скриншотах подходят для UROVO - там все завелось сразу
6. user12klk67694 21.10.20 17:37 Сейчас в теме
Спасибо большое.
Наконец то заработал сканер на UROVO i6200A.
Подскажите где есть информация, где можно почитать о том что нужно прописать параметры:
ОбъектДрайвера.УстановитьПараметр("ActionName", <данные_вашего_ТСД>);
ОбъектДрайвера.УстановитьПараметр("ExtraName", <данные_вашего_ТСД>);
?

В автономном режиме подключчение/инициализация сканера точно такая же как и для мобильного клиента , никаких дополнительных параметров прописывать не надо ?
7. V_K 24.10.20 18:44 Сейчас в теме
На мобильном клиенте при попытке настроить светит красным что "Драйвер устройства на текущем рабочем месте не установлен". Нажимаю "Установить драйвер" не помогает
8. ltfriend 596 26.10.20 09:07 Сейчас в теме
(7) напишите модель вашего устройства.
9. V_K 26.10.20 09:12 Сейчас в теме
10. Oliver 29.10.20 03:37 Сейчас в теме
Добрый день скачал Вашу разработку. Не могу найти параметры: ActionName и ExtraName для ТСД Атол Smart Pro. В комплекте с ТСД идёт утилита ScanWedge в ней есть настройки:
Action: com.hht.scanwedge
Scan Data Label: com.hht.datawedge.data_string
пробовал их вставлять в настройки ТСД - но Обработка внешнего события не вызывается.
Какие возможны решения данной проблемы?
11. ltfriend 596 29.10.20 09:11 Сейчас в теме
(10) Судя по приведённым вами настройкам - это то. Если есть настройки режима сканирования (например, как в Smart.Lite), то проверьте чтобы было что-то типа BROADCASE_MODE (не KEYBOARD или CLIPBOARD).
А вообще, про Smart Pro не скажу, но на Smart.Lite настройки следующие:
Action Name: com.xcheng.scanner.action.BARCODE_DECODING_BROADCAST
Extra Data: EXTRA_BARCODE_DECODING_DATA

Есть в наличии ещё какой-то Smart (не уверен, что Pro, но не Lite точно). Там такие настройки:

ActionName: DATA_SCAN
Extra Data: com.hht.emdk.datawedge.data_string

p.s. Т.е. на втором ТСД Extra Data такая же, как у вас. Попробуйте прописать Action Name: DATA_SCAN. Ну, и режим сканирования проверьте. Так на Smart.Lite у меня есть отдельный режим BROADCAST_MODE, а на втором только keyboard и clipboard, а broadcast работает независимо от настроек.

p.p.s. Для второго ТСД (который не Lite) я вообще искал настройки в интернете, т.к. в ScanWedge такого вообще не было.
12. ltfriend 596 29.10.20 09:22 Сейчас в теме
(10) И еще одно дополнение: регистр параметров важен!
13. Ukubaeva 29.10.20 16:47 Сейчас в теме
Добрый день! Устанавливаю драйвер на мобильном устройстве на мобильном клиенте, версия Android 7.1.1. Пишет следующее:
"Установка внешней компоненты не выполнена. В процессе установки произошла ошибка. Возможно, отсутствует компонента для используемого клиентского приложения."
Прикрепленные файлы:
14. alxper 02.11.20 17:05 Сейчас в теме
Добрый день! А кто-нибудь использовал ТСД IPDA035? Как там узнать action?
15. ASK7 04.11.20 11:57 Сейчас в теме
Коллеги добрый день, нужна помощь. ТСД АТОЛ Smart.Droid, версия Android 4.4.2. При попытке установить драйвер НачатьУстановкуВнешнейКомпоненты(ОписаниеОповещения, "ОбщийМакет.ДрайверСканерыШтрихкодаAndroid") выдает такую же ошибку как у (13) Ukubaeva "Установка внешней компоненты не выполнена. В процессе установки произошла ошибка. Возможно, отсутствует компонента для используемого клиентского приложения." У кого нибудь заработало на таком ТСД?

Для тех у кого такой ТСД ActionName = "DATA_SCAN", ExtraName = "com.hht.emdk.datawedge.data_string". Но к сожалению драйвер даже не устанавливается.
17. ltfriend 596 05.11.20 11:59 Сейчас в теме
(15) тестирование проводилось и на такой терминале, всё работает. Проверьте ещё раз, всё ли правильно вы сделали. Скачайте прилагаемую библиотеку сканера для мобильного приложения в качестве примера, посмотрите как там сделано (или вообще используйте её). Эту библиотеку можно свободно скачать с github по приведённой в конце статьи ссылки.
18. ASK7 05.11.20 17:08 Сейчас в теме
(17) Порядок действий ведь такой:

1.) Создал пустую конфигурацию для мобильного приложения (у меня автономное приложение на ТСД, не мобильный клиент, которое я потом соединяю с основной базой по http)

2.) Добавил в общий макет "Внешняя компонента" zip. архив с драйвером
"AndroidScanerDriverFor1C_1.0.1.3", который отмечен красным на скриншоте, и залил на ТСД (весь комплект скачал с этой публикации)

3.) На клиенте пытаюсь установить драйвер методом НачатьУстановкуВнешнейКомпоненты(ОписаниеОповещения, "ОбщийМакет.ДрайверСканерыШтрихкодаAndroid") на этом этапе выдает ошибку

Все правильно? Поправьте меня если я что-то сделал не так
Прикрепленные файлы:
19. ltfriend 596 06.11.20 10:34 Сейчас в теме
(18) а как вы заливали мобильное приложение на ТСД? Для того, чтобы работали внешние компоненты необходимо собрать мобильное приложение в APK с использованием конфигурации "Сборщик приложений для мобильных устройств". Тогда в состав включаются внешние компоненты.
Подробнее можно ознакомится на ИТС: https://its.1c.ru/db/v8311doc#bookmark:dev:TI000001865
Для того чтобы собрать мобильное приложение с включением внешних компонент, необходимо выгружать конфигурацию (для сборщика мобильных приложений) в виде zip-архива (1cema.zip). Если конфигурация содержит внешние компонентиы, то при выполнении команды Главное меню ‑ Конфигурация ‑ Мобильное приложение ‑ Записать в файл будет автоматически предложен именно такой вариант сохранения. Сборщик мобильных приложений автоматически будет учитывать наличие внешних компонент при загрузке мобильной конфигурации и последующей сборке мобильного приложения.
Прикрепленные файлы:
Ukubaeva; +1 Ответить
20. ASK7 06.11.20 13:07 Сейчас в теме
(19) Залил на ТСД так:

1) Зашел в конфигуратор ==> Конфиргурация ==> Мобильное приложение ==> Публиковать(как на скриншоте).

2) Затем поставил на ТСД мобильную платформу, добавил новое приложение, указал адрес опубликованного ранее приложения на моем ПК и нажал Загрузить(как на скриншоте). Все!

Сборщик мобильных приложений в своих действиях не использовал, просто раньше с внешними компонентами дела не имел, не знал таких тонкостей, что внешние компоненты в мобильном приложении 1С работают только через сборщик мобильных приложений
Прикрепленные файлы:
Ukubaeva; +1 Ответить
21. ltfriend 596 06.11.20 14:02 Сейчас в теме
(20) да я сам с таким только столкнулся, когда делал. Забыл упомянуть об этом в публикации. В ближайшее время дополню.
P.S. а сколько времени было потрачено. Как говорится, если не чего не помогает, то нужно прочитать инструкцию ) вот и я, намучавшись с мобильной платформой, все же решил на ИТС заглянуть и тогда узнал об особенностях внешних компонент в мобильном приложении.
22. ASK7 06.11.20 15:40 Сейчас в теме
(21) Попробую разобраться со сборщиком мобильных приложений, " В ближайшее время дополню" если будет подробная инструкция со сборщиком было бы просто отлично, спасибо за помощь ))
23. ASK7 09.11.20 15:27 Сейчас в теме
(21) Собрал приложение через сборщик мобильных приложений, установил на ТСД, все работает, внешнее событие вызывается! Спасибо за компоненту!

P.S. все таки было было бы не плохо в публикации сказать про сборщик мобильных приложений, чтобы не было таких как я ))
Ukubaeva; +1 Ответить
16. ASK7 04.11.20 14:15 Сейчас в теме
Использую как мобильное приложение(не мобильный клиент), мобильная платформа 8.3.15.105, 1cem-arm.apk. Создал пустую конфигурацию, добавил в общий макет "Внешняя компонента" zip. архив с драйвером, залил на ТСД, но драйвер не устанавливается. Что может быть? Куда копать?
24. newbas 601 11.11.20 20:15 Сейчас в теме
Если не трудно - подскажите - происходит такая же ошибка как у (13).
Используется мобильный клиент - т.е. конфигурация опубликована на WEB сервере, а на ТСД АТОЛ.Смарт лайт установлен мобильный клиент. В него добавлены параметры подключения.

В конфигурацию добавлен общий макет "ДрайверСканерыШтрихкодаAndroid" и в него загружен zip файл из публикации и пробовал из github.



В форме обработки (где нужно сканирование) добавлен реквизит "ОбъектДрайвера" с типом произвольный.

Далее

&НаКлиенте
Процедура ПриОткрытии(Отказ)
		яПослеУстановкиКомпоненты = Новый ОписаниеОповещения("ПослеУстановкиКомпоненты", ЭтотОбъект, Истина);
		НачатьУстановкуВнешнейКомпоненты(яПослеУстановкиКомпоненты, "ОбщийМакет.ДрайверСканераШтрихкодовAndroid");
КонецПроцедуры

&НаКлиенте
Процедура ПослеУстановкиКомпоненты(Результат) Экспорт	
	Если Результат Тогда
		ПодключитьВнешнююКомпоненту("ОбщийМакет.ДрайверСканераШтрихкодовAndroid", "com_ptolkachev_AndroidScannerExtension", ТипВнешнейКомпоненты.Native);
		ProgID = "AddIn.com_ptolkachev_AndroidScannerExtension.com_ptolkachev_AndroidScannerExtension";
		ОбъектДрайвера = Новый(ProgID);
		ОбъектДрайвера.УстановитьПараметр("ActionName", "com.xcheng.scanner.action.BARCODE_DECODING_BROADCAST");	
		ОбъектДрайвера.УстановитьПараметр("ExtraName", "EXTRA_BARCODE_DECODING_DATA");
		ОбъектДрайвера.Подключить("");		
		
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю("подключено!");
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
		Если ЗначениеЗаполнено(ОбъектДрайвера) Тогда
			ОбъектДрайвера.Отключить("");
		КонецЕсли;
КонецПроцедуры

Показать


но при запуске происходит ошибка "Установка компоненты не выполнена!"
27. vvv_vit 12 15.11.20 19:39 Сейчас в теме
(24) через сборщик соберите, взлетит
30. Ukubaeva 19.11.20 14:59 Сейчас в теме
(24)
ДрайверСканерыШтрихкодаAndroid
ДрайверСканерыШтрихкодаAndroid - вот здесь скорее всего ошибка - наименование общего макета и то, как к нему идет обращение в коде - разные.
НачатьУстановкуВнешнейКомпоненты(яПослеУстановкиКомпоненты, "ОбщийМакет.ДрайверСканераШтрихкодовAndroid");
25. Ukubaeva 12.11.20 14:56 Сейчас в теме
(19) (24) мне помогло то, что написано в 19 - заново выгрузить конфигурацию для мобильного клиента и пересобрать, тогда драйвер устанавливается
26. user686570 13.11.20 00:56 Сейчас в теме
Добрый день скачал Вашу разработку. Не могу найти параметры: ActionName и ExtraName для ТСД HoneyWell EDA60K. Не подскажете где искать?
28. Ukubaeva 18.11.20 15:45 Сейчас в теме
Добрый день!
После сохранения необходимо перейти в настройки и указать параметры подключения.

Подскажите. пожалуйста, где надо указывать Настройки подключения? Кнопка Настройка отправляет в общую форму Настройка универсального драйвера, там такого нет! Где указывать их надо? Драйвер на ТСД установился, но не сканирование на мобильном клиенте не работает так же, как на тонком клиенте, только через поле ввода, а это за счет того драйвера, который уже стоит на ТСД. Спасибо! Буду благодарна очень за ответ, потому что с этим сканированием на мобильном клиенте уже очень много времени убила
29. Ukubaeva 18.11.20 15:50 Сейчас в теме
И еще подскажите, пожалуйста, должно ли работать, если запускать мобильный клиент на телефоне и по bluetooth подключать сканер штрихкодов или ТСД? Спасибо!
31. Ukubaeva 19.11.20 15:10 Сейчас в теме
В общем, драйвер установился, но не отрабатывает в мобильном клиенте так, как должно. Я не могу понять, то ли сам ТСД не генерирует внешнее событие, то ли мобильный клиент его не отлавливает. Не заходит даже в поцедуру ОбработатьСобытие. Подскажите, в каком направлении копать? У меня модель ТСД Urovo DT50. Настройки подключения прописала вручную в коде при подключении компоненты. Спасибо!
32. Ukubaeva 19.11.20 15:41 Сейчас в теме
(31)вот такие у меня настройки сканера на ТСД
Прикрепленные файлы:
33. ltfriend 596 19.11.20 16:31 Сейчас в теме
(32) используйте в параметрах сканера
Action Name: android.intent.ACTION_DECODE_DATA
Extra Data: barcode_string
34. Ukubaeva 19.11.20 16:47 Сейчас в теме
(33)Спасибо за ответ! При подключении компоненты так и прописываю
&НаКлиенте
Процедура ПослеУстановкиКомпоненты(Результат) Экспорт    
    Если Результат Тогда
        ПодключитьВнешнююКомпоненту("ОбщийМакет.ДрайверСканерыШтрихкодаAndroid", "com_ptolkachev_AndroidScannerExtension", ТипВнешнейКомпоненты.Native);
        ProgID = "AddIn.com_ptolkachev_AndroidScannerExtension.com_ptolkachev_AndroidScannerExtension";
        ОбъектДрайвера = Новый(ProgID);
        ОбъектДрайвера.УстановитьПараметр("ActionName", "android.intent.ACTION_DECODE_DATA");
		ОбъектДрайвера.УстановитьПараметр("ExtraName", "barcode_string");
        ОбъектДрайвера.Подключить("");        
		//ОбщегоНазначенияКлиентСервер.СообщитьПользователю("подключено!");
    КонецЕсли;
КонецПроцедуры
Показать

Но событие не ловится
35. ltfriend 596 19.11.20 16:51 Сейчас в теме
(34) Попробуйте в настройках из вашего скриншота выше установить флаг "Scan Handle"
Ukubaeva; +1 Ответить
36. ltfriend 596 19.11.20 16:55 Сейчас в теме
И ещё. Если вы самостоятельно подключаете компоненту (а не через типовую настройку "Подключаемое оборудование", то ловить нужно событие "ВнешнееСобытие".
Ukubaeva; +1 Ответить
37. Ukubaeva 19.11.20 17:15 Сейчас в теме
(36)все сделала, как Вы посоветовали, но реакции на внешнее событие по прежнему нет -
&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	сообщить("захожу во внешнее событие");
КонецПроцедуры
Прикрепленные файлы:
41. newbas 601 27.11.20 10:16 Сейчас в теме
(34)
Скажите, а ошибок на установку нет?
Вы используете мобильный клиент или мобильное приложение?
43. Ukubaeva 27.11.20 13:40 Сейчас в теме
(41)Мобильный клиент с автономным режимом. Ошибок нет. Я в итоге вручную код прописала для мобильного клиента весь - в приложенной конфигурации для мобильного клиента отсутствует важная часть, без которой сканер не работает - это подключение и инициализация драйвера. И все заработало.
38. romanagatiy 2 22.11.20 18:29 Сейчас в теме
После переустановки собранного демо-приложения ТСД не реагирует на вызов сканирования...Кто-то сталкивался с такой-же проблемой?
39. dmryzhkov 23.11.20 11:34 Сейчас в теме
Добрый день! В типовую ERP 2.4.11 прикрутил драйвер, пытаюсь в Мобильной ERP 2.5.5 установить (из Play market) - к Urovo i6300, ошибка "Установка внешней компоненты не выполнена. В процессе установки произошла ошибка. Возможно, отсутствует компонента для используемого клиентского приложения."
Подскажите, что может быть?
40. user805455 23.11.20 13:54 Сейчас в теме
Добрый день, пытаюсь подключить тсд zebra mc33. Не могу найти параметр "ExtraData". Можете подсказать где искать или значение этого параметра?
42. newbas 601 27.11.20 10:17 Сейчас в теме
(40) В приложении настройки сканера ТСД
Оставьте свое сообщение
Вопросы с вознаграждением