1. user5300 37 13.08.19 14:59 Сейчас в теме

Сканер штрих кодов, команды

Приветствую коллеги, нужна ваша помощь.
В общем есть сканер штрих кодов и простая Управляемая форма. Можно ли привязать обработчики событий на действия сканера ? То есть, провели штрих код по сканеру и выполнилось какое то действие , можно ли такое осуществить вообще ? у кого нибудь есть опыт по этой теме ?, Спасибо ! )
Найденные решения
6. ediks 328 13.08.19 16:40 Сейчас в теме
(3)
ФормаКлиентскогоПриложения (ClientApplicationForm)
ВнешнееСобытие (ExternalEvent)
Синтаксис:
ВнешнееСобытие(<Источник>, <Событие>, <Данные>)
Параметры:
<Источник>
Тип: Строка.
Источник внешнего события.
<Событие>
Тип: Строка.
Наименование события.
<Данные>
Тип: Строка.
Данные для события.
Описание:
Обработка события от внешнего компонента.
Примечание:
Обработка следующего события возможна только после завершения обработки текущего события.
Показать

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	//Вставить содержимое обработчика
КонецПроцедуры


Переменная Данные и есть считанный штрихкод.
user5300; +1 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. DJDUH 17 13.08.19 15:10 Сейчас в теме
3. user5300 37 13.08.19 15:16 Сейчас в теме
(2)
ExternEventProcessing()
обработка внешних событий ? и как его использовать ? куда вставить ?
6. ediks 328 13.08.19 16:40 Сейчас в теме
(3)
ФормаКлиентскогоПриложения (ClientApplicationForm)
ВнешнееСобытие (ExternalEvent)
Синтаксис:
ВнешнееСобытие(<Источник>, <Событие>, <Данные>)
Параметры:
<Источник>
Тип: Строка.
Источник внешнего события.
<Событие>
Тип: Строка.
Наименование события.
<Данные>
Тип: Строка.
Данные для события.
Описание:
Обработка события от внешнего компонента.
Примечание:
Обработка следующего события возможна только после завершения обработки текущего события.
Показать

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	//Вставить содержимое обработчика
КонецПроцедуры


Переменная Данные и есть считанный штрихкод.
user5300; +1 Ответить
4. coollerinc 40 13.08.19 15:42 Сейчас в теме
Да легко,

Если Штрихкод = "12345678910" Тогда
   СоздатьРеализацию();
ИначеЕсли  Штрихкод = "66666666666" Тогда
   УдалитьВсеДокументыРеализация();
КонецЕсли;
5. user5300 37 13.08.19 15:49 Сейчас в теме
(4) так тут к реквизиту "штрихкод" привязано, а мне надо чтоб как команда, или как обработчикСобытий выполнялось действие...
Вот пустая форма, провели по ней штрихкодом ( или например нажали клавишу на клавиатуре) - происходит какое то действие, примерно такая реализация задумана ))
7. Xershi 683 13.08.19 17:07 Сейчас в теме
(5) сначала разберись как работает сканер, а потом уже строй алгоритм.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист стажер 1С
Нижний Новгород
зарплата от 30 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программисты 1С УТ / БУЗ/ЗУП / БИТ ФИНАНС
Москва
зарплата от 100 000 руб. до 180 000 руб.
Полный день