1. yadexter1986 376 08.01.19 12:51 Сейчас в теме

Атол 30ф и 1с 77

Доброго времени. Есть касса Атол 30ф, есть конфа 1С 77 ТИС 7.70.998(типовая). Перепрошили кассу под новый НДС. Когда нажимаем в 1С пробить чек, то чек выходит с надписью "Чек аннулирован", в 1с встает "Чек пробит".
Обновил обработку frATOL54_comm.ert и компоненту FprnM1C82_54FZ.dll. Результата не было, до перепрошивки кассы все было нормально.
Организация, которая прошивала кассу, говорит, что проблема в 1С, у них дескать все тесты проходят.
Кто сталкивался, подскажите куда рыть?
Найденные решения
Остальные ответы
Избранное Подписка Сортировка: Древо
27. user1135946 23.01.19 11:58 Сейчас в теме
(1) АТОЛ-30Ф в режиме ФР используете?
2. Sapiens_bru 08.01.19 19:29 Сейчас в теме
3. yadexter1986 376 08.01.19 19:41 Сейчас в теме
4. Sapiens_bru 09.01.19 04:32 Сейчас в теме
(3)Тогда вангую несоответствие версий прошивки-драйвера атол-интеграционной компоненты (...54fz.dll) - обработки в 1с - версии 1с.
Все эти 5 частей последовательно передают друг другу информацию по согласованным между ними протоколам. Вы сменили прошивку? Придется обновить драйвер. Обновили драйвер? Регистрируйте новую компоненту в системе итд.
user1135946; +1 Ответить
5. yadexter1986 376 09.01.19 06:45 Сейчас в теме
Прошивала организация, сказали прошивка актуальная. Версию драйвера обновили тоже они. Компоненту и обработку взял из дистрибутива последнего обновления 1С.

Что еще:
1) Не указал, что касса подключена к компьютеру, а доступ к 1С по RDP, на сервере драйвер был не обновлен, обновил. - Не помогло.
2) Тест драйвера кассу видит. И на локальном компьютере и на сервере.
3) Среди обработок была еще обработка с приставкой 105, то есть новый формат обмена, который как раз с 2019 начинает работать. Но при подключении этой обработки выходит ошибка, что-то типа Поле агрегатного состояния на найдено(DeviceEnabled). В 1с 77 не силен, запустил отладчик и нашел функцию в обработке ОтключитьсяОтФР и там есть поле Объект.DeviceEnabled = 1, отладчик в объекте ничего не показывает. - Возможно проблема в этом, сегодня вечером покопаю в этом направлении.
6. yadexter1986 376 09.01.19 14:59 Сейчас в теме
7. moonchild1 36 10.01.19 08:17 Сейчас в теме
Такая же проблема,помогло что-нибудь?
8. yadexter1986 376 10.01.19 08:45 Сейчас в теме
(7)Сегодня буду испытывать еще пару способов. Если не выйдет, то думаю https://infostart.ru/public/603118/
9. moonchild1 36 10.01.19 08:50 Сейчас в теме
Самое что интересное,через драйвер все работает,а касса перестала работать одна из 4-х,все одинаковые.ТиС тоже типовой.
10. yadexter1986 376 10.01.19 08:59 Сейчас в теме
(9) А вот это интересно уже. Может быть прошивка криво встала и вся беда из-за этого?
11. dvk09 10.01.19 09:00 Сейчас в теме
Не, он же пишет, что через драйвер работает.
13. yadexter1986 376 10.01.19 09:01 Сейчас в теме
(11)Да я просто размышляю. Просто 4 одинаковых кассы, одна база, 3 работают 4ая нет.
12. dvk09 10.01.19 09:01 Сейчас в теме
Напиши обработку печати напрямую через драйвер.
14. yadexter1986 376 10.01.19 09:02 Сейчас в теме
(12)В 1С 7.7 никогда не работал. Со стороны программиста.
15. moonchild1 36 10.01.19 09:44 Сейчас в теме
Походу дело в ставке НДС,поставил в номенклатуре обратно 18% вместо 20%, чек пробился
user1135946; yadexter1986; +2 Ответить
16. moonchild1 36 10.01.19 10:36 Сейчас в теме
Если ставка нужна не "без ндс" , то помогает доработка frATOL54_comm.ert:
правда при указании ставки 18, у меня пробивает НДС 0%
СписокТоваров.ВыбратьСтроки();
	Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
		XMLFiscalString = XMLPositions.СоздатьПодчиненныйЭлемент("FiscalString");
		Атрибут(XMLFiscalString, "Name", СписокТоваров.ТовНаим);
		Атрибут(XMLFiscalString, "Quantity", СписокТоваров.Количество);
		Атрибут(XMLFiscalString, "Price", СписокТоваров.Цена);
		Атрибут(XMLFiscalString, "Department", "4");
		Атрибут(XMLFiscalString, "Amount", СписокТоваров.Сумма);
		Если СистемаНалогообложения=0 Тогда
		Атрибут(XMLFiscalString, "Tax", СписокТоваров.СтавкаНДС);
	//Атрибут(XMLFiscalString, "Department", "4");
	Иначе
		Атрибут(XMLFiscalString, "Tax", "18");
		КонецЕсли;
	КонецЦикла;
Показать
yadexter1986; +1 Ответить
17. yadexter1986 376 10.01.19 10:42 Сейчас в теме
18. yadexter1986 376 10.01.19 15:14 Сейчас в теме
В общем со ставкой 20% штатными средствами пока не выходит.
19. Иваныч 23 11.01.19 08:43 Сейчас в теме
Мы работаем с Атол22 и Атол30 через переделанную frcomm.ert
там сделано так:
//Проверка наличия колонки "НДС" в таблице значений.
НДСЕсть = "";
Попытка
НДС = СписокТоваров.НДС;
НДСЕсть = 1;
Исключение
НДСЕсть = 0;
КонецПопытки;

Если НДСЕсть = 1 Тогда
Объект.Name = "";
Иначе
Объект.Name = Лев(СписокТоваров.ТовНаим, ДлинаНаименования);
КонецЕсли;

Объект.Price = Окр(СписокТоваров.Цена,2,1);
Объект.Quantity = СписокТоваров.Количество;

Если ПризнВозврата = 0 Тогда
//Если СписокТоваров.СтавкаНДС = "none" Тогда
Объект.TaxTypeNumber = 4;
//ИначеЕсли СписокТоваров.СтавкаНДС = "18" Тогда
// Объект.TaxTypeNumber = 3;
//ИначеЕсли СписокТоваров.СтавкаНДС = "10" Тогда
// Объект.TaxTypeNumber = 2;
//ИначеЕсли СписокТоваров.СтавкаНДС = "0" Тогда
// Объект.TaxTypeNumber = 1;
//КонецЕсли;

Объект.Регистрация();
Иначе
Объект.Возврат();
КонецЕсли;

Должно быть в прошивке самой ККМ вариант выбора ставки НДС, а в обработке добавить строку соответственно. И в номенклатуре тоже с18% на 20% поменять ставку НДС. Но нам проще, мы ИП без НДС работаем.
20. Иваныч 23 11.01.19 08:47 Сейчас в теме
Правда, после перешивки ККМ с ФФД 1.0 на 1.05 все сбилось, ККМ жила своей жизнью, все выводилось в чек со строкой в.т.ч НДС 18%, поэтому пришлось вовремя все подправить в обработке.
21. moonchild1 36 11.01.19 16:43 Сейчас в теме
Все-таки самое правильно делать через FprnM1C.dll или этой обработкой https://infostart.ru/public/603118/
У меня вроде получилось
22. yadexter1986 376 11.01.19 16:58 Сейчас в теме
Тоже сегодня оплатили. В понедельник придет. С тех. поддержкой этого решения общался, сказали, что их обработка данную проблему решит. По результату отпишусь.
23. slavikss 12.01.19 18:08 Сейчас в теме
В последней обработке обслуживания frATOL54_comm_105.ert нужно добавить 2 строчки и будет вам счастье.

в
Функция ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, ПУП, Кассир, НомерСекции, НомерЧека, ДлинаСтроки)
...
...
Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл

Объект.Name = СписокТоваров.ТовНаим;
Объект.Price = СписокТоваров.Цена;
Объект.Quantity = СписокТоваров.Количество;

Если СписокТоваров.СтавкаНДС = "none" Тогда
Объект.TaxTypeNumber = 4;
ИначеЕсли СписокТоваров.СтавкаНДС = "18" Тогда
Объект.TaxTypeNumber = 3;

//!!! ДОБАВЛЯЕМ
ИначеЕсли СписокТоваров.СтавкаНДС = "20" Тогда
Объект.TaxTypeNumber = 3;
//!!! КОНЕЦ ДОБАВЛЕНИЯ

ИначеЕсли СписокТоваров.СтавкаНДС = "10" Тогда
Объект.TaxTypeNumber = 2;
ИначеЕсли СписокТоваров.СтавкаНДС = "0" Тогда
Объект.TaxTypeNumber = 1;
КонецЕсли;

Если ПризнВозврата = 0 Тогда
Если Объект.Registration() <> 0 тогда
ОписаниеРезультата = Объект.ResultDescription;
Возврат Рез;
КонецЕсли;
Иначе
Если Объект.Return() <> 0 тогда
ОписаниеРезультата = Объект.ResultDescription;
Возврат Рез;
КонецЕсли;
КонецЕсли;

КонецЦикла;


И все, можно ничего не покупать :)
24. yadexter1986 376 15.01.19 13:52 Сейчас в теме
(23)Не помогло. Та же ошибка, что (5) пункте 3.
26. dvk09 17.01.19 10:27 Сейчас в теме
(25) Ну так он напрямую к 8му драйверу и обращается...
Я Вам предложил сделать это самостоятельно))
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 120 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день