Возникает ошибка при подключении библиотеки шифрования на 64-битном сервере 1С

1. Алексей Пашков (alex_pshkv) 20 12.10.17 16:21 Сейчас в теме
Возникает ошибка при подключении библиотеки шифрования на 64-битном сервере 1С.

Криптография = Новый COMОбъект("System.Security.Cryptography.SHA512Managed");

Unknown error 0x80131700

Кто-нибудь сталкивался с этим и как это исправить?
Найденные решения
8. Artem Narchuk (burni4) 2 07.02.18 09:35 Сейчас в теме
(7) да, сыпались ошибки, был установлен net 4.5, доставили ASP, тоже не завелось, как только установили 3.5, сразу запустилось без проблем, к EXMO подключился :)
Остальные ответы
2. Сергей Сизов (sssss_aaaaa_2011) 12.10.17 16:39 Сейчас в теме
Интересно, почему в последнее время почти все вопросы начинаются со слова "Кто"? Как-будто все собрались составлять какие-то списки столкнувшихся с проблемами, а не сами проблемы решать.

С этим сталкиваются все, кто пытается, например, использовать на 64-битном сервере 32-битную библиотеку.
3. Алексей Пашков (alex_pshkv) 20 12.10.17 17:19 Сейчас в теме
Разве в составе Net Framework нет 64-битных версий этих библиотек? Судя по файлам они есть, надо ли их специально регистрировать?
4. Artem Narchuk (burni4) 2 05.02.18 17:10 Сейчас в теме
(3) нашли решение проблемы?
5. Алексей Пашков (alex_pshkv) 20 06.02.18 04:35 Сейчас в теме
К сожалению нет. Пришлось использовать вместо Net Framework библиотеку Capicom. Ее можно настроить для использования на 64-битном 1С сервере.
6. Artem Narchuk (burni4) 2 06.02.18 14:36 Сейчас в теме
(5) у меня взлетело, оказывается нужен net 3.5
7. Алексей Пашков (alex_pshkv) 20 07.02.18 07:56 Сейчас в теме
(6)
Надо, попробовать. То есть заработало без всякого шаманства после установки Net 3.5?
8. Artem Narchuk (burni4) 2 07.02.18 09:35 Сейчас в теме
(7) да, сыпались ошибки, был установлен net 4.5, доставили ASP, тоже не завелось, как только установили 3.5, сразу запустилось без проблем, к EXMO подключился :)
Оставьте свое сообщение