Фотография с камеры через DirectX

0. 32 04.11.16 17:26 Сейчас в теме
Компонента для получения фотографии с WEB-камеры с использованием DirectX

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. premierex 05.11.16 19:32 Сейчас в теме
(0) Автор, поправьте, пожалуйста, в названии понятие "вёб" на одно из общепринятых понятий: веб, вэб (или используйте его англоязычное написание /web/). Честно говоря, непривычно как-то. А так - тема интересная. Direct-X (DirectShow - это как раз тот набор компонентов, позволяющий работать с видео-потоками) - на данный момент, как мне кажется, самый функциональный набор решений для работы с ними в OS Windows.
Цена компоненты несколько завышена (imho). Есть более функциональные компоненты для работы с web-камерами, размещёнными на infostart.ru.
2. 7OH 32 05.11.16 20:47 Сейчас в теме
(1) premier, сейчас поправлю и описание и цену понижу.
Пример кода
11. D_E_S131 3 20.12.18 14:57 Сейчас в теме
А что в примере (2) за переменная (или реквизит формы) "dsWebCam"?
12. 7OH 32 25.12.18 02:04 Сейчас в теме
(11) верно подметили - там должно быть Компонента
3. 7OH 32 01.02.17 17:18 Сейчас в теме
Добавлен метод наложения водяного знака.

СтрокаОригинал = Base64Строка(Данные1.ПолучитьДвоичныеДанные());
СтрокаВодяной   = Base64Строка(Данные2.ПолучитьДвоичныеДанные());
		
Положение = 5; // 1 - 9 
Прозрачность = 80; //1-100
двДанныеРезультат = dsWebCam.ДобавитьВодянойЗнак(СтрокаОригинал, СтрокаВодяной, Положение, Прозрачность);

Показать
4. user702269_vabuyak 28.02.17 16:59 Сейчас в теме
ребята на 1с 8.3 и Server 2012 R2 работать будет?
5. 7OH 32 28.02.17 23:14 Сейчас в теме
У нас 2012 и 8.3.9, но это на сервере - всё работает.
На клиентах - от 7-ки до 10-ки.
На ХР тоже проблем нет.
6. Tanenok 05.05.17 14:46 Сейчас в теме
7. 7OH 32 05.05.17 21:20 Сейчас в теме
(6) Да, конечно.
У нас УТ 3.1.2 (Украина - аналог УТ 11).
Нативные компоненты появились ещё в 8.2, так что должно работать в большинстве конфигураций.
9. LtNas 09.05.17 13:59 Сейчас в теме
Я конечно дико извиняюсь, но где описание??? (см.использование) ???? В аттаче только dll и manifest
10. 7OH 32 09.05.17 20:26 Сейчас в теме
(9) пост 2 и 3.
В шапку код не пропустили без спойлера, а спойлер туда не ставится - пришлось отдельным постом делать.
13. nsirotkin@mail.ru 72 05.06.19 09:58 Сейчас в теме
Скачал компоненту. Окно с видео открывается, но в результате dsWebCam.Успех=Ложь Win7Sp1 (1C 8.3.14.1630), версия dll 2.2.1.6.
Что еще можно посмотреть/сделать?

ps: Тестовую обработку было бы полезно приложить в архив для скачивания... Версии x64 нет/не будет?
upd: убрал макет с компонентой
Прикрепленные файлы:
ТестWebКамера3.epf
14. 7OH 32 05.06.19 15:14 Сейчас в теме
(13) в вашей обработке немного можно подправить код
Функция КартинкаИзСтроки(стрКартинка, УникальныйИдентификатор)
в стрКартинка уже двоичные данные приходят (если нет - постучите в личку).
--
В целом проверил - работает.
directX установлен ?
15. nsirotkin@mail.ru 72 06.06.19 05:07 Сейчас в теме
(14) С новой компонентой (2.2.1.8) работает нормально. Спасибо.
16. ИНТЕГРА 24 17.10.19 17:43 Сейчас в теме
(14)
е приходят (если нет - постучите в личку)

Мне не приходят )

После вызова: dsWebCam.Старт(), открывается видео-окно, в нем нажимаю "сфотографировать" и далее по условию не проходит (Если dsWebCam.Успех Тогда ... ):
dsWebCam.Успех == Ложь

Подскажите в чем может быть проблема?

PS:
32бит, 8.3.12.1529. На более новых платформах не тестировал.
виртуальне веб камеры, вечером дома попробую на "железной" - отпишусь.
17. 7OH 32 17.10.19 18:56 Сейчас в теме
(16) не в курсе , что это за камеры.
Успеха нет видимо потому, что не выходит вывод с этой камеры из BMP в JPG запихнуть.
Опять же - с обычными камерами работает.
С пробросом в РДП средствами винды тоже работает.
От версии 1С не зависит - работает и на 8.3.15.1700.
Тут что-то специфическое в виртуальности.
18. ИНТЕГРА 24 17.10.19 22:15 Сейчас в теме
(17) проверил на железной камере, на другой конфигурации ПК - результат тот-же :(
Видео с камеры транслируется. Но в строку ничего не приходит:
&НаКлиенте
Функция ПодключитьКамеру(ID) Экспорт
    Если Не ПроинициализироватьКомпоненту() Тогда
        Возврат НСтр("ru= 'Компонента не установлена'");
    КонецЕсли;
	dsWebCam.ИмяКамеры = ID;
	dsWebCam.Старт();
	
	Если dsWebCam.Успех Тогда
        
      стрКартинка = dsWebCam.стрКартинка;
      сообщить(dsWebCam.стрКартинка);  
      Если Не стрКартинка = Неопределено Тогда	            
          АдресКартинки = КартинкаИзСтроки(стрКартинка, УникальныйИдентификатор);	         
	  КонецЕсли;
  иначе
	  сообщить("Ничего не пришло") /// *** валится сюда *** ///
   КонецЕсли;
	   
КонецФункции
Показать


Возможно кокой-то "Дельфийской" компоненты не хватает. Конвертация BMP->JPG каким методом происходит? Эксепшены посмотреть нигде нельзя в логах каких-нибудь?
Прикрепленные файлы:
19. ИНТЕГРА 24 17.10.19 23:36 Сейчас в теме
(18)Автор прислал новую версию - все получилось. Спасибо ему за это!
(обещал обновить в публикации)
20. ratter 4 20.02.20 07:59 Сейчас в теме
Дорогой автор, обновите, пожалуйста, здесь компоненту.
У меня в точности проблема как в (13) .
21. 7OH 32 20.02.20 10:22 Сейчас в теме
22. qwinter 628 15.01.21 14:26 Сейчас в теме
компонента умеет сохранять видео?
23. 7OH 32 15.01.21 15:11 Сейчас в теме
(22) нет.
не было необходимости.
Основной посыл - текст QR, ну и как доп функционал - сохранение фото с этими QR.
Видео то зачем ?
Оставьте свое сообщение
Вопросы с вознаграждением