Native компонента для чтения из Com порта

0. Владимир Вагин (compguru) 65 17.07.16 19:53 Сейчас в теме
Компонента позволяет посредством ВнешнегоСобытия получать данные из Com-порта

Перейти к публикации

Комментарии
1. Ярослав Володимирович (myr4ik07) 110 19.07.16 10:56 Сейчас в теме
Дуже дуже вдячний, якщо все гуд, то це супер, це то, що нам якраз треба з специфічним сканером штрих-кодів. Буду тестувати.
2. Ярослав Володимирович (myr4ik07) 110 19.07.16 11:07 Сейчас в теме
Получаю
{Форма.Форма.Форма(7)}: Тип не определен (AddIn.allsp_1C_ComPort.allsp_1C_ComPort)
КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");

с таким подключением
&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("C:\ComPort_x64.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native); 
	КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
КонецПроцедуры

Показать


да и
ПодключитьВнешнююКомпоненту("G:\WH-ОБМЕН\ComPort_x64.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native) = Ложь


Толстый клиент. Управляемое приложение.
4. Владимир Вагин (compguru) 65 19.07.16 11:21 Сейчас в теме
(2) myr4ik07, Отвечу в ближайшее время
6. Ярослав Володимирович (myr4ik07) 110 19.07.16 11:35 Сейчас в теме
(4)
спасибо, работает, бомба
&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("G:\log\ComPort_x32.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
	КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
	КомПорт.ИмяПорта = "com3";	
	КомПорт.ОткрытьПорт();
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	Сообщить(Данные);
	Сообщить(Источник);
	Сообщить(Событие);
КонецПроцедуры


Показать
compguru; +1 Ответить
7. Владимир Вагин (compguru) 65 19.07.16 11:37 Сейчас в теме
(6) myr4ik07, Это хорошо. Будут проблемы, пишите
myr4ik07; +1 Ответить
9. Руслан Галиев (RuslanGaliev) 2 02.11.16 14:23 Сейчас в теме
(7) Компонента подключается, но внешнее событие так и не получил.
3. Ярослав Володимирович (myr4ik07) 110 19.07.16 11:20 Сейчас в теме
У кого то подключилась данная компонента?
5. Владимир Вагин (compguru) 65 19.07.16 11:23 Сейчас в теме
(3) myr4ik07, Подключать необходимо версию х32
8. Александр Закиров (sasha777666) 261 20.10.16 13:23 Сейчас в теме
Как проверить используется ли порт чем-то другим
Оставьте свое сообщение