Native компонента для чтения из Com порта

0. 87 17.07.16 19:53 Сейчас в теме
Компонента позволяет посредством ВнешнегоСобытия получать данные из Com-порта

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. jaroslav.h 19.07.16 10:56 Сейчас в теме
Дуже дуже вдячний, якщо все гуд, то це супер, це то, що нам якраз треба з специфічним сканером штрих-кодів. Буду тестувати.
2. jaroslav.h 19.07.16 11:07 Сейчас в теме
Получаю
{Форма.Форма.Форма(7)}: Тип не определен (AddIn.allsp_1C_ComPort.allsp_1C_ComPort)
КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");

с таким подключением
&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("C:\ComPort_x64.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native); 
	КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
КонецПроцедуры

Показать


да и
ПодключитьВнешнююКомпоненту("G:\WH-ОБМЕН\ComPort_x64.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native) = Ложь


Толстый клиент. Управляемое приложение.
4. compguru 87 19.07.16 11:21 Сейчас в теме
(2) myr4ik07, Отвечу в ближайшее время
6. jaroslav.h 19.07.16 11:35 Сейчас в теме
(4)
спасибо, работает, бомба
&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("G:\log\ComPort_x32.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
	КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
	КомПорт.ИмяПорта = "com3";	
	КомПорт.ОткрытьПорт();
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	Сообщить(Данные);
	Сообщить(Источник);
	Сообщить(Событие);
КонецПроцедуры


Показать
compguru; +1 Ответить
7. compguru 87 19.07.16 11:37 Сейчас в теме
(6) myr4ik07, Это хорошо. Будут проблемы, пишите
jaroslav.h; +1 Ответить
9. RuslanGaliev 1 02.11.16 14:23 Сейчас в теме
(7) Компонента подключается, но внешнее событие так и не получил.
3. jaroslav.h 19.07.16 11:20 Сейчас в теме
У кого то подключилась данная компонента?
5. compguru 87 19.07.16 11:23 Сейчас в теме
(3) myr4ik07, Подключать необходимо версию х32
8. sasha777666 309 20.10.16 13:23 Сейчас в теме
Как проверить используется ли порт чем-то другим
10. user921229 22.02.18 17:02 Сейчас в теме
ComPort_x64.dll не генерирует событие. кто нибудь подключал успешно?
11. herfis 404 22.02.18 17:26 Сейчас в теме
(10) Я после плясок вокруг разных наколенных компонет по работе с ком-портом остановился на старом добром MSCOMMLib, известном еще с 7.7 (майкрософтовский драйвер). Его повыпиливали, но по-прежнему можно найти, скачать и установить. Правда, чтобы он заработал, его еще нужно зарегистрировать, записав в реестр нужные ключи. Все это гуглится.
По внешнему событию через него работать не пробовал, но майкрософтовская дока говорит, что у него есть для этого событие OnComm. А в 8-ке есть оператор ДобавитьОбработчик, с помощью которого можно подписываться на события ком-объектов. Я таким образом успешно подписывался на события сторонних ком-объектов по работе со сканерами (которые не по технологии создания внешних компонент 1С писаны). Думаю, и тут должно получиться.
ЗЫ. И на всякий случай я бы заглянул в свежую библиотеку подключаемого оборудования - вдруг туда уже засунули православный драйвер.
12. tka4enk0 140 10.11.18 00:56 Сейчас в теме
Компонента вроде подключается. Открытие порта происходит без ошибок. Но внешнее событие не генерируется.
Так же если открыть какой нибудь монитор порта по этому номеру, то он свободно открывается и получается данные. Хотя при уже открытом порте должен был бы падать в ошибку.
criptid; Alv_prog; +2 Ответить
13. Alv_prog 24.12.18 13:16 Сейчас в теме
Почему автор не отвечает? Внешнее событие не генерируется!
"хотя в настоящее время и работает в реальных решениях" - это в каких интересно оно может работать, если не генерирует НИЧЕГО?
Что за обман? Хотите отзывов - ставьте скачку бесплатной! А так получается минус 1 стармани!
14. jaroslav.h 168 24.12.18 14:48 Сейчас в теме
(13)

&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
    ПодключитьВнешнююКомпоненту("G:\log\ComPort_x32.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
    КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
    КомПорт.ИмяПорта = "com3";    
    КомПорт.ОткрытьПорт();
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Сообщить(Данные);
    Сообщить(Источник);
    Сообщить(Событие);
КонецПроцедуры
Показать
15. Alv_prog 24.12.18 15:30 Сейчас в теме
(14) я читать умею, и ваш код прочитал и попробовал использовать сразу же. Но у меня х64 платформа. Со всеми вытекающими. И не только я написал что нет внешнего события.
16. jaroslav.h 168 24.12.18 16:41 Сейчас в теме
(15) если ты прочитал что х64 не работает, зачем качать и возмущения высказывать, думаешь что то изменилось ...
17. jaroslav.h 168 24.12.18 16:42 Сейчас в теме
(15) плюс он же пишет "Внимание! Компонента выпущена в бета версии, никаких гарантий на ее работу не предусмотрено"
18. ut2k5 15 16.05.19 09:37 Сейчас в теме
спасибо за материал, очень помогли
19. e-rogov 8 02.10.20 07:14 Сейчас в теме
20. criptid 16.10.20 14:50 Сейчас в теме
Доброго всем, кто-нибудь победил почему внешнее событие не отрабатывает? 8.3.15.1830 x86, подключаю x32.dll
Оставьте свое сообщение
Вопросы с вознаграждением