1. x2z7yy 06.12.16 08:17 Сейчас в теме

Не работает отладка на одной БД

Такая беда: На компьютере не работает отладка на одной базе. Все остальные базы отлаживаются нормально. Платформа одна и таже 8.3.6...., пробовал другие, бесполезно.

"Начать отладку" не нажимается (хотя кнопка активна, просто ничего не происходит).
Если запустить просто 1С, в предметах отладки база появляется. Но даже если ее подключить, отладка не работает.
Ответы
Сортировка: Древо
2. Swetlana 10 06.12.16 08:21 Сейчас в теме
попробуйте почистить кеш
3. x2z7yy 06.12.16 10:18 Сейчас в теме
4. alxarz 28 06.12.16 18:46 Сейчас в теме
5. x2z7yy 07.12.16 06:12 Сейчас в теме
6. Fox-trot 69 07.12.16 06:57 Сейчас в теме
(5) заново создай иб в списке иб
7. alxarz 28 07.12.16 07:13 Сейчас в теме
8. Fox-trot 69 07.12.16 08:00 Сейчас в теме
9. x2z7yy 07.12.16 09:44 Сейчас в теме
(6), это сопостовимо с удалением кэша. Но все равно попробовал - нет результата.
(7), это действительно чересчур
10. x2z7yy 07.12.16 09:58 Сейчас в теме
Причем один раз отладка запускается, через Ф5. Естественно она не работает ни в какую. Но если закрыть предприятие, больше она не запускается (через ф5), нужно перезаходить в конфигуратор.

Плюс, на глаз заметно, что эта отладка запускается достаточно долго. Так не должно быть, да и не было, когда все работало нормально (что именно изменялось и делалось трудно сказать, возможно и ничего)
11. GreenDragon 07.12.16 17:18 Сейчас в теме
(10) У тебя включена отладка серверных вызовов? После остановки первой отладки зайди в "отладка - Подключение..." и посмотри подключённые предметы отладки
12. x2z7yy 08.12.16 06:13 Сейчас в теме
(11), я писал про это в первом посте.
База есть в доступных предметах отладки, 2 строки (сервер и клиент). Они даже подключаются, но на отладку это ни как не влияет - не работает.
13. GreenDragon 08.12.16 08:59 Сейчас в теме
(12) не мешай всё в одну кучу.
1. Если серверная часть подключилась в отладке, то на F5 нажимать бесполезно. Убери "сервер" из подключенных предметов отладки и нажми F5
2. Если отладка подключена, но точка останова не срабатывает, то с высокой долей вероятности можно утверждать, что выбранный кусок кода не выполняется. Попробуй воспользоваться замером времени выполнения, либо прогнать код там, где он гарантированно выполнятся будет
14. x2z7yy 08.12.16 13:45 Сейчас в теме
(13)
1. Эм, что? Кнопка Ф5 запускает отладку, при чем тут сервер/несервер? Всю жизнь по умолчанию запускается отладка и клиента и сервера (т.е. попадают в предметы отладки)
2. Нет такой вероятности, не первый год я с 1с. Тоже самое с замером производительности - пусто.
15. GreenDragon 08.12.16 14:06 Сейчас в теме
1. При том тут сервер/клиент. Наведи на иконку отладки - как она подписана? "Начать отладку" или "Продолжить отладку"?
http://joxi.ru/NDrlMW0t1vzvmP.jpg

2. Есть такая вероятность, не первый десяток лет с 1С работаю
16. x2z7yy 08.12.16 15:08 Сейчас в теме
(15),

на картинке 1, я просто запустил отладку

можно двойними кликами подключить предметы, они вроде подключаются (картинка 2)

Ни на каком этапе подцепиться по точке останова или замером производительности не получается.

Закрывают приложение через крестик, остается тоже состояние, что на картинке 2. В диспетчере задач, тоже исчезает приложение.
После этого собственно заново запустить отладку не получается, т.к. она висит в подключенных. После отключения можно заново запустить отладку, но она также не будет работать.

Чем черт не шутит, обратил внимание на порты, попробовал отключить брендмауэр, не помогает.
Прикрепленные файлы:
17. Sanek32 15 09.12.16 17:21 Сейчас в теме
переставить винду на сервере и все заработает 100%.
18. x2z7yy 12.12.16 06:07 Сейчас в теме
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии



Ведущий программист 1С
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день

Руководитель проектов 1С
Москва
Полный день

Консультант-аналитик 1С: ЗУП
Санкт-Петербург
Полный день