Расширение для создания собственных подсистем БСП

0. 1514 20.11.20 10:00 Сейчас в теме
В этой статье поделюсь некоторыми изысканиями о внутреннем устройстве стандартной подсистемы "Обновление версии ИБ" и расскажу, как разработать свою подсистему, в которой будет работать отчёт с описанием изменений.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. dhurricane 21.11.20 13:29 Сейчас в теме
Чтобы обновление стартовала при запуске приложения без указания ключа "ЗапуститьОбновлениеИнформационнойБазы", можно поступить так:

1. Добавить в модуль своей подсистемы (ОбновлениеИнформационнойБазыХХХ) экспортный метод:
// Проверить необходимость обновления информационной базы при смене версии подсистемы.
//
Функция НеобходимоОбновлениеИнформационнойБазы() Экспорт
	
	ОписаниеПодсистемы = Новый Структура;
	ОписаниеПодсистемы.Вставить("Имя");
	ОписаниеПодсистемы.Вставить("Версия");
	ОписаниеПодсистемы.Вставить("ИдентификаторИнтернетПоддержки");
	ОписаниеПодсистемы.Вставить("ТребуемыеПодсистемы", Новый Массив);
	ОписаниеПодсистемы.Вставить("РежимВыполненияОтложенныхОбработчиков");
	
	ПриДобавленииПодсистемы(ОписаниеПодсистемы);
	
	Если ОбновлениеИнформационнойБазыСлужебный.НеобходимоВыполнитьОбновление(
			ОписаниеПодсистемы.Версия, ОбновлениеИнформационнойБазыСлужебный.ВерсияИБ(ОписаниеПодсистемы.Имя)) Тогда
		Возврат Истина;
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции
Показать

2. Расширить типовой метод "НеобходимоОбновлениеИнформационнойБазы" общего модуля "ОбновлениеИнформационнойБазыСлужебныйПовтИсп" следующим образом:
&Вместо("НеобходимоОбновлениеИнформационнойБазы")
Функция Расш1_НеобходимоОбновлениеИнформационнойБазы() Экспорт
	
	Возврат ОбновлениеИнформационнойБазыХХХ.НеобходимоОбновлениеИнформационнойБазы()
		Или ПродолжитьВызов();
	
КонецФункции
VKislitsin; alevnev; stas_ganiev; JohnyDeath; Cmapnep; +5 Ответить
2. sytkosa 119 21.11.20 18:48 Сейчас в теме
((0) Без кода из комментарии (0) картинка не полная. Автор выпустите обновление
stas_ganiev; Cmapnep; +2 Ответить
3. stas_ganiev 1514 23.11.20 01:11 Сейчас в теме
(1)
(2)
Спасибо за совет! Коррективы внесу в ближайшее время, вместе с выходом следующей версии ))
4. sergvagner2018 02.12.20 15:44 Сейчас в теме
(0) Полезно. Положил в избранное
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С: ЗУП
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Разработчик 1C: ERP (Блоки: Снабжение, закупки, склад; Финансы и казначейство)
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству