Расширение для создания собственных подсистем БСП

0. 1545 20.11.20 10:00 Сейчас в теме
В этой статье поделюсь некоторыми изысканиями о внутреннем устройстве стандартной подсистемы "Обновление версии ИБ" и расскажу, как разработать свою подсистему, в которой будет работать отчёт с описанием изменений.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. dhurricane 21.11.20 13:29 Сейчас в теме
Чтобы обновление стартовала при запуске приложения без указания ключа "ЗапуститьОбновлениеИнформационнойБазы", можно поступить так:

1. Добавить в модуль своей подсистемы (ОбновлениеИнформационнойБазыХХХ) экспортный метод:
// Проверить необходимость обновления информационной базы при смене версии подсистемы.
//
Функция НеобходимоОбновлениеИнформационнойБазы() Экспорт
	
	ОписаниеПодсистемы = Новый Структура;
	ОписаниеПодсистемы.Вставить("Имя");
	ОписаниеПодсистемы.Вставить("Версия");
	ОписаниеПодсистемы.Вставить("ИдентификаторИнтернетПоддержки");
	ОписаниеПодсистемы.Вставить("ТребуемыеПодсистемы", Новый Массив);
	ОписаниеПодсистемы.Вставить("РежимВыполненияОтложенныхОбработчиков");
	
	ПриДобавленииПодсистемы(ОписаниеПодсистемы);
	
	Если ОбновлениеИнформационнойБазыСлужебный.НеобходимоВыполнитьОбновление(
			ОписаниеПодсистемы.Версия, ОбновлениеИнформационнойБазыСлужебный.ВерсияИБ(ОписаниеПодсистемы.Имя)) Тогда
		Возврат Истина;
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции
Показать

2. Расширить типовой метод "НеобходимоОбновлениеИнформационнойБазы" общего модуля "ОбновлениеИнформационнойБазыСлужебныйПовтИсп" следующим образом:
&Вместо("НеобходимоОбновлениеИнформационнойБазы")
Функция Расш1_НеобходимоОбновлениеИнформационнойБазы() Экспорт
	
	Возврат ОбновлениеИнформационнойБазыХХХ.НеобходимоОбновлениеИнформационнойБазы()
		Или ПродолжитьВызов();
	
КонецФункции
VKislitsin; alevnev; stas_ganiev; JohnyDeath; Cmapnep; +5 Ответить
2. sytkosa 119 21.11.20 18:48 Сейчас в теме
((0) Без кода из комментарии (0) картинка не полная. Автор выпустите обновление
stas_ganiev; Cmapnep; +2 Ответить
3. stas_ganiev 1545 23.11.20 01:11 Сейчас в теме
(1)
(2)
Спасибо за совет! Коррективы внесу в ближайшее время, вместе с выходом следующей версии ))
4. sergvagner2018 02.12.20 15:44 Сейчас в теме
(0) Полезно. Положил в избранное
5. vat-74 166 16.11.21 10:23 Сейчас в теме
Если подсистема установлено в единственное расширение, то отрабатывается хорошо. А если таких расширений больше, тогда возникает конфликт внутренних идентификаторов.
6. vat-74 166 16.11.21 12:48 Сейчас в теме
(5) Решил проблему копипастом.
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Ведущий программист-консультант 1С (УХ)
Москва
зарплата от 250 000 руб. до 250 000 руб.
Полный день

Программист 1С (розница)
Москва
зарплата от 160 000 руб. до 160 000 руб.
Полный день

Архитектор 1С
Москва
зарплата от 200 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Администратор 1C
Москва
зарплата до 110 000 руб.
Полный день