Пересчет товаров: сортировка товаров по иерархии (расширение) и внешняя печатная форма "Бланк задания на пересчет товаров" с группами номенклатуры. УТ 11.4

0. 9 21.05.20 15:47 Сейчас в теме
При заполнении товаров по отбору расширение сортирует номенклатуру по иерархии номенклатуры. Внешняя печатная форма создана на основе типовой и выводит номенклатуру с рабочим наименованием и группой номенклатуры.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. yura-100 7 06.09.20 15:27 Сейчас в теме
Печатная форма работает. А расширение не работает.

Переделал процедуру

&НаСервере
&После("ЗаполнитьСервер")
Процедура АХГ_СВПТ_ЗаполнитьСервер()	
	Товары = Объект.Товары.Выгрузить();	
	Запрос = Новый Запрос;	
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	Товары.Номенклатура КАК НоменклатураСорт,
	|	*
	|ПОМЕСТИТЬ ВТТовары
	|ИЗ
	|	&Товары КАК Товары
	|;	             	             
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	СпрНоменклатура.Наименование КАК НоменСорт,
	|	Товары.НоменклатураСорт КАК НоменклатураС,
	|	Товары.*
	|ИЗ  Справочник.Номенклатура КАК СпрНоменклатура
	|	Левое СОЕДИНЕНИЕ ВТТовары КАК Товары
	|    ПО СпрНоменклатура.Ссылка = Товары.НоменклатураСорт
	|УПОРЯДОЧИТЬ ПО
	|	СпрНоменклатура.Наименование ИЕРАРХИЯ
	|"
	;	
	Запрос.УстановитьПараметр("Товары", Товары);
	ТЗДан = Новый ТаблицаЗначений;
	ТЗДан = Запрос.Выполнить().Выгрузить();
	
	Индекс = ТЗДан.Количество() - 1; 
	Пока Индекс >= 0 Цикл 
		СтрокаТЗ = ТЗДан.Получить(Индекс);	
		Если СтрокаТЗ.Номенклатура = Null Тогда 
			ТЗДан.Удалить(Индекс); 				
		КонецЕсли; 
		Индекс = Индекс - 1; 
	КонецЦикла;
	
	Объект.Товары.Загрузить(ТЗДан);
КонецПроцедуры
Показать
3. EVKash 9 07.09.20 08:35 Сейчас в теме
(1) Жуткий велосипед...
Предполагаю, что во время своих экспериментов, вы все-же отключили безопасный режим у расширения. Но выбирать в ТЗ ВСЮ номенклатуру, а потом удалять не нужную - так себе занятие.
(2) Хозяин - барин)))
2. yura-100 7 06.09.20 15:31 Сейчас в теме
Добавил группировки в Пересчет товаров через ЕЩЕ - Изменить форму
Прикрепленные файлы:
Оставьте свое сообщение
Вопросы с вознаграждением