0. hakerxp 2273 31.03.20 09:55 Сейчас в теме

Отображение цен и остатков в списке номенклатуры и подборах "как в УТ 10.3" в УТ 11, КА 2, ERP 2 (расширение, платформа 8.3.12+)

Посвящается Всем, кто привык к удобному отображению цен и остатков в конфигурации "Управление торговлей 10.3" в списке номенклатуры! Не требует модификации конфигурации, устанавливается как расширение! Выбранные виды цен сохраняются в рамках пользователя. Отображение идет в виде дерева по характеристикам. Работа проверена на конфигурациях УТ 11.4, КА 2, ERP2. (Обновление от 17.04.2020)

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. FSerg 66 17.04.20 08:19 Сейчас в теме
Спасибо за крутое расширение!
Есть небольшая ошибка в процедурах СоздатьКолонкиЦен()
Процедура СоздатьКолонкиЦен()
	УдалитьКолонки();
	Для каждого ЭлементСписка Из СписокВидовЦен Цикл
		Если НЕ ЭлементСписка.Пометка Тогда Возврат; КонецЕсли;	 // Возврат; нужно поменять на Продолжить;	
		//КЧ = Новый КвалификаторыЧисла(15, 2, ДопустимыйЗнак.Неотрицательный);
		КС = Новый КвалификаторыСтроки(50);
		ИмяКолонки = "ВЦ_" + СтрЗаменить(ЭлементСписка.Значение.УникальныйИдентификатор(), "-", ""); 
		Заголовок = СокрЛП(ЭлементСписка.Представление);		
		ДобавитьКолонку("ДеревоЦеныИОстатки", ИмяКолонки, Новый ОписаниеТипов("Строка", , , , КС), Заголовок);
	КонецЦикла; 
КонецПроцедуры
Показать

Иначе выборочно цены не дает включить. только все подряд.
2. FSerg 66 17.04.20 08:31 Сейчас в теме
(1)
И еще там же в СоздатьКолонкиЦен() я бы поменял переменную Заголовок на ЗаголовокКолонки, а то при выборе вида цен меняется заголовок формы. Может быть так и было задумано, но мне кажется это случайно )
...
		// Заголовок = СокрЛП(ЭлементСписка.Представление);
		// ДобавитьКолонку("ДеревоЦеныИОстатки", ИмяКолонки, Новый ОписаниеТипов("Строка", , , , КС), Заголовок);
		ЗаголовокКолонки = СокрЛП(ЭлементСписка.Представление);
		ДобавитьКолонку("ДеревоЦеныИОстатки", ИмяКолонки, Новый ОписаниеТипов("Строка", , , , КС), ЗаголовокКолонки);

...
Показать
3. hakerxp 2273 17.04.20 08:48 Сейчас в теме
4. rumabox 12.06.20 03:06 Сейчас в теме
Здравствуйте! А подборе в РМК на УТ 11.4 будет работать? Ищем сейчас такую обработку, чтобы кассиры могли видеть остатки по всем складам, резервы, а в идеале еще и ожидаемый товар прямо из подбора в РМК.
5. user1362147 18.06.20 10:50 Сейчас в теме
Добрый день.
Скажите, можно доработать вашу обработку аналогично подбору в УПП?
Чтоб через заказ можно было подобрать товар. Расположение областей не имеет значения, главное функционал.
Прикрепленные файлы:
6. hakerxp 2273 18.06.20 12:57 Сейчас в теме
(5) , в вашем случае не обойтись расширением, и нужно все переносить в конфигурацию. Данная процедура платная.
7. user1362147 18.06.20 13:10 Сейчас в теме
Можете написать ваше предложение?
8. hakerxp 2273 18.06.20 13:52 Сейчас в теме
(7) , напишите мне в личку лучше
9. user1362147 18.06.20 14:40 Сейчас в теме
К сожалению, я не могу вам написать т.к. у меня нет абонемента. Как с вами можно связаться?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Екатеринбург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Разработчик 1С
Санкт-Петербург
зарплата от 140 000 руб.
Полный день

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 90 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 200 000 руб.
Полный день