Отображение цен и остатков в списке номенклатуры и подборах "как в УТ 10.3" в УТ 11, КА 2, ERP 2 (расширение, платформа 8.3.12+)

0. 2485 31.03.20 09:55 Сейчас в теме
Посвящается Всем, кто привык к удобному отображению цен и остатков в конфигурации "Управление торговлей 10.3" в списке номенклатуры! Не требует модификации конфигурации, устанавливается как расширение! Выбранные виды цен сохраняются в рамках пользователя. Отображение идет в виде дерева по характеристикам. Работа проверена на конфигурациях УТ 11.4, КА 2, ERP2. (Обновление от 17.04.2020)

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. FSerg 66 17.04.20 08:19 Сейчас в теме
Спасибо за крутое расширение!
Есть небольшая ошибка в процедурах СоздатьКолонкиЦен()
Процедура СоздатьКолонкиЦен()
	УдалитьКолонки();
	Для каждого ЭлементСписка Из СписокВидовЦен Цикл
		Если НЕ ЭлементСписка.Пометка Тогда Возврат; КонецЕсли;	 // Возврат; нужно поменять на Продолжить;	
		//КЧ = Новый КвалификаторыЧисла(15, 2, ДопустимыйЗнак.Неотрицательный);
		КС = Новый КвалификаторыСтроки(50);
		ИмяКолонки = "ВЦ_" + СтрЗаменить(ЭлементСписка.Значение.УникальныйИдентификатор(), "-", ""); 
		Заголовок = СокрЛП(ЭлементСписка.Представление);		
		ДобавитьКолонку("ДеревоЦеныИОстатки", ИмяКолонки, Новый ОписаниеТипов("Строка", , , , КС), Заголовок);
	КонецЦикла; 
КонецПроцедуры
Показать

Иначе выборочно цены не дает включить. только все подряд.
2. FSerg 66 17.04.20 08:31 Сейчас в теме
(1)
И еще там же в СоздатьКолонкиЦен() я бы поменял переменную Заголовок на ЗаголовокКолонки, а то при выборе вида цен меняется заголовок формы. Может быть так и было задумано, но мне кажется это случайно )
...
		// Заголовок = СокрЛП(ЭлементСписка.Представление);
		// ДобавитьКолонку("ДеревоЦеныИОстатки", ИмяКолонки, Новый ОписаниеТипов("Строка", , , , КС), Заголовок);
		ЗаголовокКолонки = СокрЛП(ЭлементСписка.Представление);
		ДобавитьКолонку("ДеревоЦеныИОстатки", ИмяКолонки, Новый ОписаниеТипов("Строка", , , , КС), ЗаголовокКолонки);

...
Показать
3. hakerxp 2485 17.04.20 08:48 Сейчас в теме
4. rumabox 12.06.20 03:06 Сейчас в теме
Здравствуйте! А подборе в РМК на УТ 11.4 будет работать? Ищем сейчас такую обработку, чтобы кассиры могли видеть остатки по всем складам, резервы, а в идеале еще и ожидаемый товар прямо из подбора в РМК.
5. user1362147 18.06.20 10:50 Сейчас в теме
Добрый день.
Скажите, можно доработать вашу обработку аналогично подбору в УПП?
Чтоб через заказ можно было подобрать товар. Расположение областей не имеет значения, главное функционал.
Прикрепленные файлы:
6. hakerxp 2485 18.06.20 12:57 Сейчас в теме
(5) , в вашем случае не обойтись расширением, и нужно все переносить в конфигурацию. Данная процедура платная.
10. user1424285 23.07.20 06:32 Сейчас в теме
(6) подскажите пожалуйста, для продуктового среднего магазина убоднее использовать ут 10.3 или розницу 8.3 старая версия?
18. the1 892 18.06.21 10:33 Сейчас в теме
7. user1362147 18.06.20 13:10 Сейчас в теме
Можете написать ваше предложение?
8. hakerxp 2485 18.06.20 13:52 Сейчас в теме
(7) , напишите мне в личку лучше
9. user1362147 18.06.20 14:40 Сейчас в теме
К сожалению, я не могу вам написать т.к. у меня нет абонемента. Как с вами можно связаться?
11. user1457497 10.09.20 14:11 Сейчас в теме
Добрый день! КА 2.4.11.46. В плане закупок в подборе номенклатуры будет показывать остатки?
12. warbird88 12 22.12.20 09:32 Сейчас в теме
не все цены показываются в списке УТ 11.4.12.102
13. suhoi 30 17.01.21 13:57 Сейчас в теме
Также интересует.
А подборе в РМК на УТ 11.4 будет работать? Ищем сейчас такую обработку, чтобы кассиры могли видеть остатки по всем складам, резервы.
Если да - работает ли на последних релизах УТ?
14. hakerxp 2485 17.01.21 14:13 Сейчас в теме
(13) , в РМК не выводит такие данные. Только список номенклатуры и в подборах в документах.
15. zhuravlev_as 280 28.01.21 19:19 Сейчас в теме
Спасибо. Отличная наработка. В КА 2.4.13.71 на 8.3.17.1851 показывает исправную работу. Существенная экономия времени. Пользователи привыкли, им этот функционал после КА 1.1 как воздух нужен. Странно, почему в КА 2 это не сделали? Только хочется уточнить один момент - если цена в валюте хранится в регистре "Цены номенклатуры", то происходит ли пересчет цены по курсу?
16. zhuravlev_as 280 02.02.21 10:58 Сейчас в теме
(15) по коду посмотрел - не пересчитывается((
17. Mdwebstudio 28.05.21 21:34 Сейчас в теме
Добрый день, а как добавить еще один вид цен чтоб отображался, в справочнике Виды цен, цену добавили, но она не отображается в списке цен
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Пермь
зарплата до 120 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата до 130 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 150 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 200 000 руб.
Полный день

Архитектор 1С
Пермь
зарплата до 200 000 руб.
Полный день