Управление ассортиментом в Комплексной 1С 7.7 (оптовая торговля). Анализ выполнения плана по ассортименту для Комплексной 1С 7.7

0. 530 08.10.19 08:07 Сейчас в теме
Понятие ассортимента в Комплексной 1С 7.7 отсутствует, но торговому предприятию необходимо управлять ассортиментом. Достигается цель - обеспечиться необходимым товаром для торговли, при этом не переплатив. Товар на полках должен быть в достаточном количестве, в то же время закупочная цена должна быть рентабельная. Оптовик заключает с поставщиками договора дистрибьюции, в соответствии с которыми обязуется иметь неснижаемые остатки определенных товаров (обеспечивая их непрерывную доступность своим клиентам), и за это имеет возможность получать от поставщика товары со скидками.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. CheBurator 3372 21.03.21 23:49 Сейчас в теме
Превращаем многоэтажную лестницу в линейный код ;-)

Пока ПолучитьСтроку()= 1 Цикл
ЗаблокированАссортимент = 0;

Если СокрЛП(Склад.Код)<>"2" Тогда Продолжить; КонецЕсли; // только по основному складу

Если Лев(Номенклатура.Наименование,4)<>"****" Тогда Продолжить; КонецЕсли; // только изменяемый ассортимент

ОстатокТовара = Регистр.ОстаткиТМЦ.СводныйОстаток(Фирма,Номенклатура,Склад,,"Количество")-

Регистр.РезервыТМЦ.СводныйОстаток(Фирма,Номенклатура,Склад,,,"Количество");

Если ОстатокТовара > 0 Тогда Продолжить; КонецЕсли; // только по какимто критериям остатка

Если ВыгруженВExceed<>0 Тогда Продолжить; КонецЕсли; // только по неушедшим наружу

ЗаблокированАссортимент = 1;
Сообщить(Номенклатура.ОсновнаяЕдиница.Штрихкод+", "+Номенклатура.Код+", "+Номенклатура.Наименование+" выведен и отсутствует на остатках, удалите его из заявки.");

КонецЦикла;
2. CheBurator 3372 21.03.21 23:51 Сейчас в теме
использование конструкций типа кода склада и символов в наименованиях - весьма спорные решения, работают только при наличии адских жестких регламентов и документирования почему и как и передачи сих сокровенных знаний по цепочке от увольняющихся к нанимаемым (что вообще непросто).

но раз работает - то и ок...
3. ksnik 530 21.03.21 23:53 Сейчас в теме
(2) поделитесь опытом, как ведете ассортимент в ТиС.
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 140 000 руб. до 180 000 руб.
Полный день

Консультант 1С (переквалификация для бухгалтеров)
Пермь
зарплата от 50 000 руб.
Полный день

Консультант 1С (переквалификация для бухгалтеров)
Нижний Новгород
зарплата от 50 000 руб.
Полный день

Консультант 1С (переквалификация для бухгалтеров)
Ульяновск
зарплата от 50 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день