Список граждан для сверки с военкоматом (с детализацией по семейному положению и образованию) для ЗУП 3.1, Зик ГУ

0. erutan 66 14.02.19 17:57 Сейчас в теме
С помощью расширения заполняем отчет так, как нужно Военкомату (а, следовательно, и Отделу кадров) - добавляем дни рождения членов семьи и полные данные об образовании.
Добавлен вариант с выводом адреса прописки вместо адреса проживания (отдельным файлом)

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. invistik 1 19.02.19 17:53 Сейчас в теме
Доброе время суток, у меня вопрос, адрес проживания в отчете берется по прописке или место проживания, если мне нужно, что бы в отчет попадал место по прописке как это реализовать?
2. erutan 66 19.02.19 21:48 Сейчас в теме
(1) Здравствуйте!
Тупой и быстрый метод "В лоб" - как последний абзац, перезаполнить ячейку, вызвав свою функцию, которая по ссылке на физлицо вернет нужный нам адрес из запроса.

Возможно, более правильно будет изменить сам запрос, собирающий данные для печати.

Задачи такой не стояло, так что не окунался.
3. erutan 66 19.02.19 23:05 Сейчас в теме
(1) Да, по умолчанию берутся данные Проживания, а не прописки.
Под прописку можно сделать так


&Вместо("ВывестиМакетСписокДляСверкиСВоенкоматом")
Процедура Расш_ВывестиМакетСписокДляСверкиСВоенкоматом(ДокументРезультат, РезультатКомпоновки, ДатаОтчета)
.......
ЗарплатаКадрыОтчеты.ЗаполнитьПараметрыОбластиМакета(СтрокаТаблицы, ТекСтрока, ДанныеПользовательскихПолейСсылки);
			//доработанный блок ++
			ФЛСтроки = ТекСтрока.физическоелицо;
			//ДанныеОбОбразовании = ПолучитьДанныеОбОбразованииФЛ(ФЛСтроки);
			//СтрокаТаблицы.Параметры.ВидОбразования	 = ДанныеОбОбразовании;
			АдресПрописки = ПолучитьАдресПоФЛ(ФЛСтроки);
			если не АдресПрописки="" тогда
				СтрокаТаблицы.Параметры.АдресМестаПроживанияПредставление	 = АдресПрописки;
			конецесли;
			//доработанный блок --
			СтрокаТаблицы.Параметры.ДатаРождения = Формат(ТекСтрока.ДатаРождения, "ДЛФ=Д");

.....
КонецПроцедуры


функция ПолучитьАдресПоФЛ(фл)    
	адрес = "";
	 запрос = новый запрос;
	 запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
	|Сотрудники.Ссылка КАК Ссылка
	|ИЗ
	|	Справочник.Сотрудники КАК Сотрудники
	|ГДЕ
	|Сотрудники.ФизическоеЛицо = &ФизическоеЛицо";
	 запрос.УстановитьПараметр("ФизическоеЛицо", фл);
	 выборка = запрос.Выполнить().Выбрать();
	 если выборка.Следующий() тогда
		 
    КадровыеДанныеСотрудников = КадровыйУчет.КадровыеДанныеСотрудников(Истина, 
  		выборка.Ссылка, "АдресПоПропискеПредставление", ТекущаяДата());
		 адрес = КадровыеДанныеСотрудников[0].АдресПоПропискеПредставление 
	 конецесли;
	 
	 возврат адрес
КонецФункции
Показать
invistik; +1 Ответить
4. invistik 1 20.02.19 09:12 Сейчас в теме
(3)
(1) Да, по умолчанию берутся данные Проживания, а не прописки.
Под прописку можно сделать так


Спасибо, попробую добавить в форму, запрос...
или в модуль объекта...

Еще рас спасибо за помощь!!!
5. user1282364 17.10.19 11:37 Сейчас в теме
Добрый день. Стоит актуализировать расширение, так как процедура ПервоначальноеЗаполнение…. была убрана из регистра вместо нее теперь ОбновитьСтроковыеСведенияФизическогоЛица.
6. erutan 66 17.10.19 11:46 Сейчас в теме
(5) здравствуйте!
Спасибо за отзыв.

Однако на 3.1 (3.1.10.174) процедура на месте/
Вы уже перешли на ветку 3.1.11 ?
7. user1282364 22.10.19 14:37 Сейчас в теме
8. alex_dor 3 16.01.20 10:53 Сейчас в теме
на релизе 3.1 (3.1.12.113) в процедуре обновления данных в Регистре Сведений написать вот это и работать начнет


&НаСервере
Процедура ОбновитьЗаписиНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ФизическиеЛица.Ссылка КАК Ссылка
		|ИЗ
		|	Справочник.ФизическиеЛица КАК ФизическиеЛица
		|ГДЕ
		|	НЕ ФизическиеЛица.ПометкаУдаления";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			РегистрыСведений.СтроковыеСведенияФизическихЛиц.ОбновитьСтроковыеСведенияФизическогоЛица(ВыборкаДетальныеЗаписи.Ссылка);
	КонецЦикла;
Показать


КонецПроцедуры
TanitLi; erutan; +2 Ответить
9. user1233998 07.08.20 17:42 Сейчас в теме
На ЗиК ГУ тоже работает, огромное спасибо))))
10. erutan 66 11.08.20 12:20 Сейчас в теме
(9) спасибо за отзыв и за ценную информацию!
Оставьте свое сообщение
Вопросы с вознаграждением