Управляемая консоль запросов, отчетов 3.8.9 (расширение, внешняя обработка)

0. 3206 24.05.18 11:27 Сейчас в теме
Работа с запросом и СКД,
Полная поддержка пакетных запросов, временных таблиц,
Сравнение результатов, текстов,
Разбор структуры запроса в виде дерева,
Анализ плана запроса,
Групповая обработка

Перейти к публикации

ByNiko1984; mixperm; AlexandrSmith; +3 Ответить
Вознаграждение за ответ
Показать полностью
Лучшие комментарии
363. Evg-Lylyk 3206 24.09.19 10:47 Сейчас в теме
Разработка выиграла в номинации "Лучшая разработка" Infostart Awards 2019
SiAl; fvr2000; kaliuzhnyi; wowik; DoctorRoza; DrAku1a; leoxz; StanAn; pavelpribytkin96; McLer; shoy; rpgshnik; cosmo2004; Kolunya; IvanGorbunov; lefthander; maXon777; boevik; tormozit; IgorXml; Jokemas; dhurricane; +22 Ответить
375. shoy 26.09.19 16:26 Сейчас в теме
Отличная консоль!
SiAl; kaliuzhnyi; DrAku1a; pavelpribytkin96; McLer; IvanGorbunov; Evg-Lylyk; +7 Ответить
526. Evg-Lylyk 3206 03.04.20 11:21 Сейчас в теме
Сегодня 2 года проекту, события за год:
Вышла Топ1-2 (загрузок), получила 1С-Совместимо, были доклады на Event 2019, Meetup Krasnodar 2020

Скачиваний: 1722 (всего), рост за год 430%
Плюсов: 438 (всего), рост за год 213%
За рубли продано: 16 копий (~16*2500р = 40000р)
Последние месяцы выпускаю только исправление ошибок,
активно ведется работа над новыми инструментами (все хорошо, большой уровень готовности)
К моменту запуска будет много новых возможностей которые должны приятно удивить

Работаем, всем спасибо
SiAl; Tarlich; Kolunya; yegorovnv; Aleskey_K; +5 Ответить
88. Kostt 13.02.19 13:23 Сейчас в теме
Скачал Вашу консоль, внешне мне больше нравится, чем консоль Кораблева и работает на порядок шустрее. Все в привычных мне местах и интуитивно понятно. Сразу могу работать с результатов запроса, не надо не нажимать ни каких кнопок, чтобы свернуть панели параметров и структуры запроса. за неделю работы устал от его консоли. За минимализм в интерфейсе огромный +.

Подскажите как мне как мне задать в параметре границу включая дату? Если ли возможность задать отбор по полю во временной таблице не меняя запрос?
SiAl; maximsagaydak; pavelpribytkin96; Evg-Lylyk; +4 Ответить
154. u_n_k_n_o_w_n 09.04.19 10:05 Сейчас в теме
Отличная консоль. Особенно порадовали параметры с типом выражение.
SiAl; pavelpribytkin96; Evg-Lylyk; +3 Ответить
220. jmi 26.06.19 10:34 Сейчас в теме
Отличная версия! Особенно при работе с большими данными. Удобно регулировать кол-во строк к результате + отличии от все остальных не подвисает на больших данных!!!
user598655_ilia-bers; Evg-Lylyk; +2 Ответить
295. Diks_Soft 15.08.19 10:49 Сейчас в теме
Отличная консоль. Пока даже придраться не к чему). Не бросай..
SiAl; Evg-Lylyk; +2 Ответить
311. Nuuq 16.08.19 10:26 Сейчас в теме
Офигенно сделано! Спасибо!!!
Evg-Lylyk; +1 Ответить
429. Legolas 85 24.10.19 16:18 Сейчас в теме
спасибо. удобный инструмент! особенно запрос из отладки.
Evg-Lylyk; +1 Ответить
544. it_ankon 29.04.20 20:54 Сейчас в теме
Получил эстетическое удовольствие от использования.
Такое бывает редко. Так обычно пилят под себя. Молодцы.
Evg-Lylyk; +1 Ответить
640. Evg-Lylyk 3206 02.09.20 15:41 Сейчас в теме
Вышел релиз новых инструментов
Множество улучшений, продолжение этой разработки
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
383. coolseo 74 28.09.19 14:54 Сейчас в теме
При экспорте в ексель
3.7.1 обработка
Прикрепленные файлы:
387. Evg-Lylyk 3206 30.09.19 15:07 Сейчас в теме
(383) Исправлено в 3.7.2 от 30.09.2019
385. Evg-Lylyk 3206 30.09.19 15:06 Сейчас в теме
3.7.2 от 30.09.2019
Исправлены ошибки
388. coolseo 74 30.09.19 15:41 Сейчас в теме
(385) Предлагаю добавить в экспорт внешнего СКД отчета, какой-то конструктор который добавлял бы данные нужные для запуска через доп обработки

Функция ПолучитьТаблицу_Команд()

  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

  Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;    

КонецПроцедуры

 Функция СведенияОВнешнейОбработке() Экспорт
  ПараметрыРегистрации	= Новый Структура;
  ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
  ПараметрыРегистрации.Вставить("Наименование", "Переоценка номенклатуры");
  ПараметрыРегистрации.Вставить("Версия", "1.0" );
  ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
  ПараметрыРегистрации.Вставить("Информация", "Переоценка номенклатуры");

  ТаблицаКоманд = ПолучитьТаблицу_Команд();

  ДобавитьКоманду(ТаблицаКоманд,
  		"Переоценка номенклатуры",
  		"ПереоценкаНоменклатуры",
  		"ОткрытиеФормы",
  		Истина,
  		"");

  ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

  Возврат ПараметрыРегистрации;
  
  
  
  
  

КонецФункции
Показать
389. Evg-Lylyk 3206 30.09.19 15:42 Сейчас в теме
(388) Хорошее пожелание, учту
394. coolseo 74 04.10.19 12:59 Сейчас в теме
(389) 3.7.1 Обработка
Криво отображается текст запроса
Прикрепленные файлы:
395. Evg-Lylyk 3206 04.10.19 13:31 Сейчас в теме
(394) Конструктор запроса это объект платформы это в нем ошибка
Можно запустить в толстом клиенте
396. Evg-Lylyk 3206 08.10.19 15:35 Сейчас в теме
3.7.3 от 08.10.2019
Исправлены ошибки
397. Evg-Lylyk 3206 08.10.19 16:45 Сейчас в теме
Развитие разработки приостанавливается будут только исправления ошибок.
На основе текущей будет разрабатываться новый инструмент скорее всего он будет платным.
Планируется представить его через год на Infostart Event 2020
IvanGorbunov; +1 Ответить
398. dhurricane 08.10.19 19:11 Сейчас в теме
(397) Детали до релиза не раскроете?
399. Evg-Lylyk 3206 08.10.19 19:20 Сейчас в теме
(398) Нет. Есть определённые планы... год работы посмотрим что удастся что нет. Если есть пожелания пишите.
435. coolseo 74 30.10.19 02:30 Сейчас в теме
(399)Готов поучаствовать в тестировании
436. Evg-Lylyk 3206 30.10.19 08:05 Сейчас в теме
400. Wishich 09.10.19 16:52 Сейчас в теме
Выбрал ВСе из РН Себестоимость Товара
Прикрепленные файлы:
401. Evg-Lylyk 3206 09.10.19 16:52 Сейчас в теме
(400) Эта ошибка исправлена в версии 3.7.3
402. FReIM 5 10.10.19 10:20 Сейчас в теме
Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.10.135) (http://v8.1c.ru/hrmcorp)
1С:Предприятие 8.3 (8.3.13.1644) толстый клиент управляемое приложение
Версия консоли 3.7.3
Вышибает конфигурацию при попытке развернуть в конструкторе запроса дерево мета данных на справочник.
И падаете при том же действии в конструкторе запроса в СКД при разворачивании дерева справочников.
Прикрепленные файлы:
403. Zerkon 96 11.10.19 11:35 Сейчас в теме
(402)
У меня на ERP похожие ошибки вылазят, возможно это не проблема консоли, т.к. аналогичные возникают и на других консолях. Замечено и в толстом и в тонком клиенте. Причем сабж просто табличку кажет, за что ему честь и хвала) А в других обработках просто 1С закрывается аварийно.

Автору: возможно уже писали, в версии 3.6.1 есть баг при работе с запросом с удалением временных таблиц - при проверке в функции УКО_Запрос_ПроверитьТекст() есть текст:
		// Получение данных временных таблиц
		Для Каждого ЗапросПакета Из СхемаЗапроса.ПакетЗапросов Цикл 
			
			ИмяВременнойТаблицы = ЗапросПакета.ТаблицаДляПомещения;
			Если ЗначениеЗаполнено(ИмяВременнойТаблицы) Тогда
				
				ОписаниеВременнойТаблицы = Новый Структура;
				ВременныеТаблицы.Вставить(ИмяВременнойТаблицы, ОписаниеВременнойТаблицы);
				
			КонецЕсли;
			
		КонецЦикла;
Показать


Конструкция ЗапросПакета.ТаблицаДляПомещения не обернута и не обрабатывает отсутствие таблиц при уничтожении временной таблицы. В принципе несущественно, но сообщение об ошибке невразумительное
(1,1) Поле объекта не обнаружено (Таблица для помещения)


И еще, можно сделать параметр, чтобы параметры запроса сортировались по алфавиту. В каждой новой версии первым делом вставляю такую сортировку, ибо неудобно) А если еще и сортировку двойную сделать, по типу, а в них по имени, то вообще сказка будет.
UniversaLL; +1 Ответить
405. Evg-Lylyk 3206 11.10.19 11:46 Сейчас в теме
(403) Скачайте последнию версию это исправлено
Для Каждого ЗапросПакета Из СхемаЗапроса.ПакетЗапросов Цикл

Если ТипЗнч(ЗапросПакета) = Тип("ЗапросУничтоженияТаблицыСхемыЗапроса") Тогда
Продолжить;
КонецЕсли;

ИмяВременнойТаблицы = ЗапросПакета.ТаблицаДляПомещения;
Если ЗначениеЗаполнено(ИмяВременнойТаблицы) Тогда

ОписаниеВременнойТаблицы = Новый Структура;
ВременныеТаблицы.Вставить(ИмяВременнойТаблицы, ОписаниеВременнойТаблицы);

КонецЕсли;

КонецЦикла;
408. Evg-Lylyk 3206 11.10.19 11:54 Сейчас в теме
(403) "И еще, можно сделать параметр, чтобы параметры запроса сортировались по алфавиту. В каждой новой версии первым делом вставляю такую сортировку, ибо неудобно) А если еще и сортировку двойную сделать, по типу, а в них по имени, то вообще сказка будет."
спасибо учту
"двойную сделать, по типу, а в них по имени" поясни как это вот так Сортировать("Тип,Имя)?
409. Zerkon 96 11.10.19 12:08 Сейчас в теме
(408)
Да, чтобы параметры сортировались сперва по типу, а потом в прделах каждого типа еще и по имени. Но это уже вкусовщина, а просто сортировка по имени была бы полезна, имхо.
(407)
Неверно выразился, я имел ввиду команду разработки платформы 1С ))

P.S.: скачал новую версию, опять затык на запросе с уничтожением временных таблиц. Вероятно проблема в них же. Сейчас ругается вот так
Прикрепленные файлы:
410. Evg-Lylyk 3206 11.10.19 12:28 Сейчас в теме
(409) Уточните как воспроизвести проблему
404. Evg-Lylyk 3206 11.10.19 11:39 Сейчас в теме
(402) Это проблема платформе в конструкторе запустите к тонком клиенте или в толстом в настройках снимите галочку Использовать конструктор толстого клиента
406. Zerkon 96 11.10.19 11:48 Сейчас в теме
(404)
А подскажите, это в баг-трекере есть? Обещали исправить? Очень неудобно
407. Evg-Lylyk 3206 11.10.19 11:52 Сейчас в теме
(406) Это в конструкторе платформы я это исправить не могу
Видимо при раскрытии веток происходит инициализация модуля менеджера, а там ошибка это нужно конфигурацию править
411. director04 3622 16.10.19 09:21 Сейчас в теме
Добрый день всем.
Кто может подсказать как изменить тип параметра на НЕОПРЕДЕЛЕНО, если по умолчанию тип данного параметра СправочникСсылка.
412. Evg-Lylyk 3206 16.10.19 09:23 Сейчас в теме
(411) Тип выражение и в виде кода
director04; +1 Ответить
413. IgorXml 664 17.10.19 15:06 Сейчас в теме
Выкладываю ошибку. Написал отчет, где при выгрузке в менеджер врем.таблиц список Видов субконто, нельзя перенести запрос в настройки или файл. Проверить можно на демонстрационной конфигурации "Библиотека стандартных подсистем", редакция 3.1(3.1.1.109 и платформа 8.3.14.1854 ) + расширение УправляемаяКонсольОтчетов 3.7.3. Смотреть надо в строке останова 43
	ТЗ =  Запрос.Выполнить().Выгрузить();  //  УКО_Запрос.СохранитьВНастройки(Запрос) {УправляемаяКонсольОтчетов ОбщийМодуль.УКО_MCRФормат.Модуль(823)}: Ошибка при вызове метода контекста (XMLСтрока)	

И когда успешно строка 102:
	ТЗ =  Запрос.Выполнить().Выгрузить(); //УКО_Запрос.СохранитьВНастройки(Запрос)   "Сохранено успешно"
Прикрепленные файлы:
ВнешнийОтчет1.erf
415. Evg-Lylyk 3206 17.10.19 16:04 Сейчас в теме
(413) Спасибо огромное, исправил в 3.7.4
414. Evg-Lylyk 3206 17.10.19 16:03 Сейчас в теме
3.7.4 от 17.10.2019
Исправлены ошибки
AlexandrSmith; +1 Ответить
416. Evg-Lylyk 3206 18.10.19 08:53 Сейчас в теме
3.7.5 от 18.10.2019
Исправлены ошибки
417. isn 15 18.10.19 12:15 Сейчас в теме
Жаль, что данная консоль в режиме совместимости 8.3.9 и выше.
Переделал консоль на режим совместимости 8.3.5.
Может быть, переделка привела к частичной потерей функциональности, но я пока этого не заметил. Если автору интересно могу выслать.
418. Evg-Lylyk 3206 18.10.19 12:20 Сейчас в теме
(417) Конечно интересно присылайте мне на почту постараюсь учесть. Не будет работать Анализ планов запросов.
419. isn 15 18.10.19 12:45 Сейчас в теме
Потеря / изменение функциональности после изменения консоли на режим совместимости 8.3.5:
вывод результата запроса с выводом временных таблиц - выводит в обратной последовательности (чуть позже подправлю).
420. arkarimov 21.10.19 11:51 Сейчас в теме
Спасибо за консоль, очень удобная.
Хотелки принимаются?
1. Очень удобно было в одном инструменте запросов, что текст запроса выгружался в отдельный лист при экспорте данных - запросы не статичны, плюс часто бывает попросят тебя разово данные сбросить, а потом оказывается это было не разово. Или коллега, 3 года назад подавал сведения и тп.
2. При экспорте в эксель выгрузка лишних столбцов, которые отвечают за тип в выводе только мешает, в идеале выгружаться должны только данные, без какого либо оформления.
421. Evg-Lylyk 3206 21.10.19 11:55 Сейчас в теме
(420) Спасибо за отзыв, постараюсь учесть
1. Записал пожелание
2. Поясните что вам мешает?
422. arkarimov 21.10.19 14:53 Сейчас в теме
(421)
2. Прикрепил файлом может так будет нагляднее.
Словами получается так: выгрузка в эксель чаще всего нужна для анализа данных, чтобы поиграться фильтрами, построить сводную и проанализировать данные.
Действующая выгрузка
А) Добавляет картинки с типами которые только мешают
Б) На одну колонку с данными выгружает 2 столбца в одном все данные, в другой наименование поля с данными, и для нормальной работы приходится их вычищать.
При этом сам табдок в 1С весьма удобен в том виде в котором представлен, для быстрой примерки понимание типа поля, расцветка разных строк это удобно.
Прикрепленные файлы:
423. Evg-Lylyk 3206 21.10.19 17:31 Сейчас в теме
(422) Спасибо, учту видимо из за картинок делает две ячейки
428. Evg-Lylyk 3206 24.10.19 12:33 Сейчас в теме
424. Olenevod 26 22.10.19 10:10 Сейчас в теме
Есть такая неприятная фишечка, как безопасный режим. Я даже не сразу понял в чем дело. Даже подумал "вот и нет киллер фичи". Предлагаю в обработке в конструкторе строки добавить параметр "Ложь"

ВнешниеОбработки.Создать("D:\УправляемаяКонсольОтчетов.epf", Ложь).СохранитьВНастройки(Запрос)
Прикрепленные файлы:
427. Evg-Lylyk 3206 24.10.19 12:32 Сейчас в теме
426. Evg-Lylyk 3206 24.10.19 12:32 Сейчас в теме
3.7.6 от 24.10.2019
Исправлены ошибки
429. Legolas 85 24.10.19 16:18 Сейчас в теме
спасибо. удобный инструмент! особенно запрос из отладки.
Evg-Lylyk; +1 Ответить
430. alfir70 168 25.10.19 11:42 Сейчас в теме
Есть расширение, есть внешняя обработка для управляемого приложения
но нет возможности встроить в конфигурацию в обычное приложение (т к внешние обработки там не открываются)
нет планов сделать такой механизм?
Возможность встроить в конфигурацию на обычных формах

смысл делать внешнюю обработку на обычных формах конечно нет, но если встроить в конфу то можно работать
мешает только
хард код
"СтрШаблон("ВнешняяОбработка.%1%2.Форма.""
431. Evg-Lylyk 3206 25.10.19 11:44 Сейчас в теме
(430) Поддержка обычных форм не планируется и в новой разработке пока планируется отказаться от внешних обработок
432. alfir70 168 25.10.19 11:47 Сейчас в теме
да понятно что обычные формы не нужны
но есть конфигурации на обычных формах (типа упп)

в конфу которой можно было встроить как внутреннюю обработку
если
поменять трШаблон("ВнешняяОбработка.%1%2.Форма
на "Обработки"
434. Evg-Lylyk 3206 25.10.19 11:57 Сейчас в теме
(432) Доработайте самостоятельно, я понимаю проблемы которые вы озвучиваете, решать их не планируется.
Разработка нацелена на будущее, для облегчения разработки некоторые проблемы которые в будущем потеряют актуальность не планируется решать.
На Инфостарт Евент 2019 был мой доклад я там об этом рассказывал

(433) ИМХО моя значительно более развита. Думаю это можно реализовать запишу в план.
433. alfir70 168 25.10.19 11:50 Сейчас в теме
до этого пользовался

https://forum.infostart.ru/forum9/topic126858/
но сейчас хочу отказаться , т к не хочу встраивать в конфу обработку с закрытым кодом

есть ли в ваше обработке импорт запросов

из его формата ?

там запросы и таблицы сохраняются в текстовом файле
437. coolseo 74 03.11.19 05:50 Сейчас в теме
Предложение:
В настройках сделать галочку "сохранять запрос в файл сохранения" перед вызовом процедуры выполнить.

Пример: ошибка в запросе и 1ска бесконечно пытается его выполнить, а пользователь забыл его сохранить и происходит потеря запроса
Evg-Lylyk; +1 Ответить
438. Evg-Lylyk 3206 03.11.19 09:28 Сейчас в теме
650. Evg-Lylyk 3206 03.09.20 18:46 Сейчас в теме
(437) В новых инструментах реализовано
Периодическое автосохранение
Сохранение перед выполнением
Восстановление данных при аварийном завершении

И еще т.к. запрос выполняется в фоне, если он зависнет его можно прервать
Прикрепленные файлы:
439. manuzin 4 06.11.19 07:13 Сейчас в теме
Добрый день, уважаемый разработчик.

Консоль хорошая, вы молодец. Но если в запросе встречается конструкция "УНИЧТОЖИТЬ", то всё сыпится... Прошу протестировать.

Также для удобства прошу реализовать смену параметров запроса на предопределенные элементы в тексте запроса (возможно это уже есть, я просто не знаю), к примеру (если нет, то ничего страшного :) ):

"&Пол" (после зажатия на кнопку) "Значение(Перечисление.ПолФизическогоЛица.Мужской)"
Evg-Lylyk; +1 Ответить
440. Evg-Lylyk 3206 06.11.19 09:21 Сейчас в теме
(439) Добрый, какая у вас версия?

"Также для удобства прошу реализовать смену параметров запроса на предопределенные элементы в тексте запроса" этого нет
реализую в будущем
Спасибо за отзыв
441. manuzin 4 06.11.19 11:25 Сейчас в теме
442. Evg-Lylyk 3206 06.11.19 12:52 Сейчас в теме
(441) Поясните как воспроизвести проблему что сообщает?
443. manuzin 4 06.11.19 14:41 Сейчас в теме
(442) 1. Открываем обработку.

2. Вставляем текст запроса:

ВЫБРАТЬ
	&Тест КАК Поле1
ПОМЕСТИТЬ ВТ1
;


////////////////////////////////////////////////////////////­////////////////////
ВЫБРАТЬ
	ВТ1.Поле1 КАК Поле1
ПОМЕСТИТЬ ВТ2
ИЗ
	ВТ1 КАК ВТ1
;
////////////////////////////////////////////////////////////­////////////////////
УНИЧТОЖИТЬ ВТ1
;

////////////////////////////////////////////////////////////­////////////////////
ВЫБРАТЬ
	ВТ2.Поле1 КАК Поле1
ИЗ
	ВТ2 КАК ВТ2
Показать


3. Переходим на закладку "Параметры" и наживаем "Проверить".

4. Результат
660. Evg-Lylyk 3206 03.09.20 19:15 Сейчас в теме
(439) Реализовано в новых инструментах
Прикрепленные файлы:
444. jif 11.11.19 11:43 Сейчас в теме
Добрый день! Скачал версию 3.2.1, подскажите пожалуйста можно получить актуальную версию консоли? Спасибо!
445. Evg-Lylyk 3206 11.11.19 11:46 Сейчас в теме
446. jif 11.11.19 11:48 Сейчас в теме
Отсутствие См) Ок, я просто хотел уточнить, что новая версия качается отдельно. Спасибо!
447. Evg-Lylyk 3206 11.11.19 11:50 Сейчас в теме
(446) Отдельно, цена за SM минимальная. Есть позиция за рубли.
448. jif 11.11.19 11:51 Сейчас в теме
449. nikkke 11.11.19 21:50 Сейчас в теме
Ну блин... скоро весь конфигуратор в режим предприятия перекочует)))))
450. Evg-Lylyk 3206 12.11.19 08:59 Сейчас в теме
3.7.7 от 11.11.2019
Исправлены ошибки
451. MURzzz 94 14.11.19 10:04 Сейчас в теме
в консоли не хватает полезной, на мой взгляд, возможности для ссылочных полей выводить GUID или я не нашёл?
Evg-Lylyk; dhurricane; +2 Ответить
452. Evg-Lylyk 3206 14.11.19 10:12 Сейчас в теме
(451) Это постобработка результата это сильно замедлит вывод, для каких целей это вам нужно, постараюсь учесть в будующем
457. tvm 15.11.19 10:16 Сейчас в теме
(452) можно при выводе не обрабатывать. А сделать возможность при необходимости запускать некую процедурку. Вещь эта нужная
Evg-Lylyk; +1 Ответить
458. Evg-Lylyk 3206 15.11.19 10:19 Сейчас в теме
(457) Размышляю так, это редкий случай, требуется пост обработка это очень медленно, обрабатывать весь результат - плохо
Задумана реализация выделяешь ячейки нажимаешь копировать UID в буфер обмена, копируются все ячейки (те для которых удастся получить UID будут преобразованы). На данный момент есть такая функция но она копирует только одну ячейку
460. tvm 18.11.19 11:20 Сейчас в теме
(458) а ну да здесь же вывод в табличный документ идет. В инструментах разработчика в ТЗ выводилось. А вот вопрос такой тогда (скорее всего глупый и наивный)- возможность сделать выбор куда выводить в табличный документ или в ТЗ сильно проблематично? Тогда бы и постобработку проще было реализовать
461. Evg-Lylyk 3206 18.11.19 11:26 Сейчас в теме
(460) Вывод в ТЗ у меня не в приоритете, в ближ. планах нет.
Пост обработка всего результата это долго так не планирую сделать
659. Evg-Lylyk 3206 03.09.20 19:08 Сейчас в теме
(451) В новых инструментах реализовано работа со ссылкой как GUID
Приложил гиф как работает
Прикрепленные файлы:
670. MURzzz 94 10.09.20 20:21 Сейчас в теме
(659) во Внешняя обработка (8.3.10+, режим совместимости: 8.3.9) не добавлена эта функциональность?
671. Evg-Lylyk 3206 11.09.20 09:01 Сейчас в теме
(670) Нет, консоль дальше не развивается, вся новая функциональность в новых инструментах
453. MURzzz 94 14.11.19 15:27 Сейчас в теме
Спасибо! Зачастую это нужно при решении интеграционных задач, например, создали или нужно создать элемент в системе с GUIDом подобного элемента другой системы.
Evg-Lylyk; +1 Ответить
454. Evg-Lylyk 3206 14.11.19 15:32 Сейчас в теме
(453) В контекстном меню результата есть несколько функций для этого Копировать ссылку и др.
455. MURzzz 94 15.11.19 10:12 Сейчас в теме
(454) Да, это вариант, спасибо. Но иногда нужно списком вывести Наименование элемента - GUID элемента. Но это в качестве пожелания, на Ваше усмотрение.
Evg-Lylyk; +1 Ответить
456. Evg-Lylyk 3206 15.11.19 10:15 Сейчас в теме
(455) учту в будущем.Планирую сделать при копирование выделенной области копируется все (те ячейки которые удается преобразовать в UID будут преобразованы)
459. Adeptus 105 18.11.19 11:13 Сейчас в теме
Предлагаю добавить кнопку, которая будет заменять в тексте запроса некоторые параметры (перечисления, предопределенные элементы, Пустые ссылки) на конструкцию вида Значение(МнеджерОбъекта.ИмяЭлемента..). Это очень удобно для читабельности запроса.
Например вместо:
Код
ВЫБРАТЬ
   ABCКлассификация.Ссылка
ИЗ
   Перечисление.ABCКлассификация КАК ABCКлассификация
ГДЕ
   ABCКлассификация.Ссылка = &АКласс
Показать полностью


Сделает:
Код
ВЫБРАТЬ
   ABCКлассификация.Ссылка
ИЗ
   Перечисление.ABCКлассификация КАК ABCКлассификация
ГДЕ
   ABCКлассификация.Ссылка = Значение(Перечисление.ABCКлассификация.AКласс)
Показать полностью


Вот код такой кнопки:

Код

   Для каждого СтрокаТЗ Из ПараметрыЗапроса Цикл
      
      СтрокаЗаменыПараметры = "";
      
      Если Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(СтрокаТЗ.Представление)) Тогда
      
         Если ЗначениеЗаполнено(СтрокаТЗ.Представление.ИмяПредопределенныхДанных) Тогда
            СтрокаЗаменыПараметры = "Значение(Справочник." + СтрокаТЗ.Представление.Метаданные().Имя + "." + СтрокаТЗ.Представление.ИмяПредопределенныхДанных +  ")";
         ИначеЕсли ЗначениеЗаполнено(СтрокаТЗ.Представление) Тогда
            СтрокаЗаменыПараметры = "Значение(Справочник." + СтрокаТЗ.Представление.Метаданные().Имя + ".ПустаяСсылка)";
         КонецЕсли;   
         
      ИначеЕсли ПланыВидовХарактеристик.ТипВсеСсылки().СодержитТип(ТипЗнч(СтрокаТЗ.Представление)) Тогда
      
         Если ЗначениеЗаполнено(СтрокаТЗ.Представление.ИмяПредопределенныхДанных) Тогда
            СтрокаЗаменыПараметры = "Значение(ПланВидовХарактеристик." + СтрокаТЗ.Представление.Метаданные().Имя + "." + СтрокаТЗ.Представление.ИмяПредопределенныхДанных +  ")";
         ИначеЕсли ЗначениеЗаполнено(СтрокаТЗ.Представление) Тогда
            СтрокаЗаменыПараметры = "Значение(ПланВидовХарактеристик." + СтрокаТЗ.Представление.Метаданные().Имя + ".ПустаяСсылка)";
         КонецЕсли;   
         
      ИначеЕсли Перечисления.ТипВсеСсылки().СодержитТип(ТипЗнч(СтрокаТЗ.Представление)) Тогда
      
         Если ЗначениеЗаполнено(СтрокаТЗ.Представление) Тогда
            СтрокаЗаменыПараметры = "Значение(Перечисление." + СтрокаТЗ.Представление.Метаданные().Имя + "." + XMLСтрока(СтрокаТЗ.Представление) +  ")";
         Иначе
            СтрокаЗаменыПараметры = "Значение(Перечисление." + СтрокаТЗ.Представление.Метаданные().Имя + ".ПустаяСсылка)";
         КонецЕсли;   
         
      КонецЕсли;
      
      Если ЗначениеЗаполнено(СтрокаЗаменыПараметры) Тогда
         ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "&" + СтрокаТЗ.Имя, СтрокаЗаменыПараметры);
      КонецЕсли;
   
   КонецЦикла;
   
Показать полностью


Так же очень полезна кнопка для отправки результат запроса по почте
Код
   Представление = "ОТЧЕТ 1С " + ЭтаФорма.Представление;
   
   ТабличныеДокументы = Новый СписокЗначений;
   ТабличныеДокументы.Добавить(ТабличныйДокументРезультат, Представление);
   
   ПараметрыФормы = Новый Структура;
   ПараметрыФормы.Вставить("ТабличныеДокументы", ТабличныеДокументы);
   ПараметрыФормы.Вставить("Тема",               Представление);
   ПараметрыФормы.Вставить("Тело",               Представление);
   ПараметрыФормы.Вставить("Заголовок",          "Отправка отчета по почте");
   
   ОткрытьФорму("ОбщаяФорма.ОтправкаТабличныхДокументовПоПочте", ПараметрыФормы, , );
Показать полностью
462. Evg-Lylyk 3206 18.11.19 11:32 Сейчас в теме
(459) Спасибо, учту в будущем
661. Evg-Lylyk 3206 03.09.20 19:16 Сейчас в теме
663. Adeptus 105 04.09.20 08:57 Сейчас в теме
463. Evg-Lylyk 3206 06.12.19 10:02 Сейчас в теме
3.7.8 от 06.12.2019
Исправлены ошибки
464. Evg-Lylyk 3206 11.12.19 16:31 Сейчас в теме
Никита Грызлов в интервью отметил полезность разработки
"Из последних открытий для меня стала управляемая консоль отчетов от Евгения Люлюка. Я наткнулся на нее еще когда там была версия 2.7. Очень открытый человек, открытый разработчик. Какие-то ошибки, которые я находил, буквально в течение одного-двух дней исправлял."
465. SergeyN 831 12.12.19 14:48 Сейчас в теме
Ошибка при открытии файла от типовой консоли:
Прикрепленные файлы:
466. Evg-Lylyk 3206 12.12.19 14:49 Сейчас в теме
(465) Скиньте файл. Попробую исправить
467. SergeyN 831 12.12.19 15:19 Сейчас в теме
(466) во вложении.
Прикрепленные файлы:
Запросы.q1c
469. Evg-Lylyk 3206 12.12.19 15:53 Сейчас в теме
470. SergeyN 831 12.12.19 17:21 Сейчас в теме
468. Evg-Lylyk 3206 12.12.19 15:52 Сейчас в теме
3.7.9 от 12.12.2019
Исправлена ошибка экспорта формата q1c
471. maXon777 112 16.12.19 14:35 Сейчас в теме
Спасибо за обработку! Пока лучшее, что я видел из консолей, но не могу понять как работать с временными таблицами.
Например, такой запрос
http://joxi.ru/vAW9OvCqOM5EmW.jpg
При попытке запустить конструктор в условии выдает ошибку
http://joxi.ru/RmzGoNTRMEwy2O.jpg

Консоль последняя 3.7.9, может где-то есть описание как можно делать выборку из временных таблиц?
472. Evg-Lylyk 3206 16.12.19 14:47 Сейчас в теме
(471) Конструктор запроса это объект платформы.
Попытаюсь угадать вам надо выделить все что в скобках и нажать конструктор
473. maXon777 112 16.12.19 14:48 Сейчас в теме
(472)
Запрос выше я так и собрал в конфигураторе, в консоли при этом вылетает ошибка (на втором скриншоте).
474. maXon777 112 16.12.19 14:56 Сейчас в теме
(472)
перечитал ваш ответ, уточню - если взять готовый запрос с "выбрать" - все работает.
Проблема наступает, когда пытаешься собрать новое условие с временной таблицей:
Прикрепленные файлы:
477. Evg-Lylyk 3206 23.12.19 13:59 Сейчас в теме
(474) это проблема конструктора тонкого клиента. Можно попробовать в толстом клиенте.
478. maXon777 112 23.12.19 15:32 Сейчас в теме
(477) эх - беда :) В УНФ не работает толстый клиент и разработчики не планируют его поддерживать.
475. khabibullin.tu 89 23.12.19 13:23 Сейчас в теме
Не могу понять, на видео показано фоновое выполнение запроса, в расширении этого не нашел. В настройках тоже нет, в последних релизах выпилили это ?
476. Evg-Lylyk 3206 23.12.19 13:56 Сейчас в теме
(475) Было в версиях до 3.7 потом переделывал и не решил все проблемы пришлось выпилить. В будующей платной версии будет.
479. user1173836 25.12.19 11:47 Сейчас в теме
мы значит тестировщики, да еще и за стартмани перед выходом платной версии...

вот вам запрос с ошибкой

ВЫБРАТЬ
	1 КАК Поле1,
	НЕОПРЕДЕЛЕНО КАК Поле2
ПОМЕСТИТЬ ВременнаяТаблица

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
	НЕОПРЕДЕЛЕНО,
	2
Показать
481. Evg-Lylyk 3206 25.12.19 12:34 Сейчас в теме
(479) Исправлено в версии 3.8.0
если качали меньше месяца назад должно качаться без снятия SM
480. Evg-Lylyk 3206 25.12.19 12:33 Сейчас в теме
3.8.0 от 25.12.2019
Исправлены ошибки
* работа с типом колонки НеизвестныйОбъект
* установка параметра типа УникальныйИдентификатор
Оставьте свое сообщение
Вопросы с вознаграждением