0. Техподдержка 31.01.17 13:27

54-ФЗ: Обработка для фискальных регистраторов АТОЛ, ШТРИХ и других (бесплатная демо обработка) с поддержкой НДС20%

Обработки осуществляют обслуживание фискальных регистраторов, поддерживаемых драйвером "АТОЛ: Драйвер ККМ v.8.12", "ШТРИХ-М: Драйвер ККМ v 4.13", "ВИКИ: Драйвер CSI v 1.0", "СПАРК: Драйвер v1.0" для конфигураций "Бухгалтерия 2.0", "Управление торговлей 10.3" (релиз 10.3.40.1), "Комплексная автоматизация 1.1" (релиз 1.1.82.1), "Управление производственным предприятием 1.3" (релиз 1.3.87.1), "Розница 1.0" (релиз 1.0.19.16), соответствующих требованиям закона ФЗ-54 о применении контрольно-кассовой техники. Никаких изменений в конфигурациях вносить не требуется! Поддержка НДС 20%.

Перейти к публикации

Лучшие комментарии
240. Tatitutu 28.02.17 14:23 Сейчас в теме
Печать Х- отчета для драйвера АТОЛ из 1С совместными усилями побеждена и протестирована.
Думаю автор в ближайшее время добавит в обработки функционал.
1818694@mail.ru; gerasimov; +2 Ответить
Остальные комментарии
Избранное Подписка Сортировка: Древо
649. dortalan87 31.05.17 14:33 Сейчас в теме
(648) Понял, не обратил внимание на список обработок. До нас дошли сведения, что ПИРИТы с 1С плохо работали на управляемых формах, сейчас есть такая проблема с обычными формами?
(649) У нас клиент с ПИРИТОМ работает в мск на БП перепиленной. Проблем нет. Единственно наш сисадмин долго настраивал связь с ОФД.
1. karpik666 2717 03.02.17 04:50 Сейчас в теме
Очень интересно, и как же обработка понимает откуда ее запустили, чтобы сформировать xml файл для передачи в офд.
2. zaoproxy 36 03.02.17 07:35 Сейчас в теме
передача в ОФД осуществляется не обработкой! ККТ сама отправляет чеки в ОФД.
5. karpik666 2717 03.02.17 13:03 Сейчас в теме
(2) вы уже подключали ккт к 1С, что уверенно так говорите? В последней версии обработки для обслуживания ккт используется метод ФискализацияЧека, который полностью выполнят функцию печати, при этом в него должен быть передана xml структура с данными о продаже по чеку, такая структура формируется из документа печати, это может быть либо приходной кассовый ордер, либо документ ЧекККМ (если говорить об Ут 10.3).
6. Техподдержка 03.02.17 13:46
(5)
Подключали на нашей конфигурации Ресторан в 3-х городах.
Для "Управление торговлей", редакция 10.3 (10.3.36.1) пример:
Прикрепленные файлы:
7. karpik666 2717 03.02.17 13:48 Сейчас в теме
(6) раз у вас оборудоване подключено как фискальный регистратор, то оно не использует данный метод, хотелось бы узнать как обстоит дело с корректностью передаваемых данных, и получается ли получить к ним доступ онлайн?
8. Техподдержка 03.02.17 13:56
(7)
1. Смена открывается
2. Чек печатается
3. Смена закрывается

Пример данной функции у 1С:

Функция ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал) Экспорт

	Результат = мНетОшибки;
	
	КодСистемыНалогообложения = ?(Объект.Параметры.КодСистемыНалогообложения = Неопределено,0,Объект.Параметры.КодСистемыНалогообложения);
	ОтправительEmail = ?(Объект.Параметры.ОтправительEmail = Неопределено,0,Объект.Параметры.ОтправительEmail);
	ОтбиватьЧек = ?(Объект.Параметры.ОтбиватьЧек = Неопределено,0,Объект.Параметры.ОтбиватьЧек);
	
	ПокупательEmail = "";
	ПокупательНомер = "";
	
	Если ОтбиватьЧек=1 Тогда
		ВвестиЗначение(ПокупательНомер,"Введите номер телефона покупателя:");
	КонецЕсли;	
	Если ОтбиватьЧек=2 Тогда
		ВвестиЗначение(ПокупательEmail,"Введите Е-mail покупателя:");
	КонецЕсли;	
	Если ОтбиватьЧек=3 Тогда
		ВвестиЗначение(ПокупательНомер,"Введите номер телефона покупателя:");
		ВвестиЗначение(ПокупательEmail,"Введите Е-mail покупателя:");
	КонецЕсли;	

	ПризнакВозврата= Объект.ПризнакВозврата;
	Чек = Объект.Чек;
	
	Электронно  = Ложь;
	НомерЧека = 0;
	НомерСмены  = 0;
	ФискальныйПризнак = "";
	AddressSiteInspections = "";
	
	ДанныеЧека = "";
	ЗаписьXML = Новый ЗаписьXML();
	ЗаписьXML.УстановитьСтроку("UTF-8");
	ЗаписьXML.ЗаписатьОбъявлениеXML();
	ЗаписьXML.ЗаписатьНачалоЭлемента("CheckPackage");
	
	ЗаписьXML.ЗаписатьНачалоЭлемента("Parameters");	
	Если ПризнакВозврата = Неопределено 
		ИЛИ НЕ ПризнакВозврата Тогда
		ЗаписьXML.ЗаписатьАтрибут("PaymentType" , XMLСтрока(ПолучитьКодТипаРасчетаДенежнымиСредствами("ПриходДенежныхСредств")));
	Иначе
		ЗаписьXML.ЗаписатьАтрибут("PaymentType" , XMLСтрока(ПолучитьКодТипаРасчетаДенежнымиСредствами("ВозвратДенежныхСредств")));
	КонецЕсли;	
	Если КодСистемыНалогообложения<>0 Тогда
		ЗаписьXML.ЗаписатьАтрибут("TaxVariant" , XMLСтрока(КодСистемыНалогообложения));
	КонецЕсли;
	
	ЗаписьXML.ЗаписатьАтрибут("SenderEmail", XMLСтрока(СокрЛП(ОтправительEmail)));
	// Email 
	Если СокрЛП(ПокупательEmail)<>"" Тогда
		ЗаписьXML.ЗаписатьАтрибут("CustomerEmail", XMLСтрока(СокрЛП(ПокупательEmail)));
	КонецЕсли;
	// SMS 
	Если СокрЛП(ПокупательНомер)<>"" Тогда
		ЗаписьXML.ЗаписатьАтрибут("CustomerPhone", XMLСтрока(СокрЛП(ПокупательНомер)));
	КонецЕсли;

	ЗаписьXML.ЗаписатьКонецЭлемента();
	
	// Табличная часть
	СуммаЧека = 0;
	Если Чек.Количество()>0 Тогда
		ЗаписьXML.ЗаписатьНачалоЭлемента("Positions");
		Для ИндексМассива = 0 По Чек.Количество() - 1 Цикл
			ТекущаяПозиция = Чек[ИндексМассива];
			Если ТекущаяПозиция.Свойство = "ФискальнаяСтрока" Тогда
				ЗаписьXML.ЗаписатьНачалоЭлемента("FiscalString");
				ЗаписьXML.ЗаписатьАтрибут("Name"      , XMLСтрока(ТекущаяПозиция.Номенклатура));
				ЗаписьXML.ЗаписатьАтрибут("Quantity"  , XMLСтрока(ТекущаяПозиция.Количество));
				ЗаписьXML.ЗаписатьАтрибут("Price"     , XMLСтрока(ТекущаяПозиция.Цена));
				ЗаписьXML.ЗаписатьАтрибут("Amount"    , XMLСтрока(ТекущаяПозиция.Сумма));
				ЗаписьXML.ЗаписатьАтрибут("Tax"       , XMLСтрока(ТекущаяПозиция.СтавкаНДС));
				ЗаписьXML.ЗаписатьКонецЭлемента();
				СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			ИначеЕсли ТекущаяПозиция.Свойство = "ТекстоваяСтрока" Тогда
				ЗаписьXML.ЗаписатьНачалоЭлемента("TextString");
				ЗаписьXML.ЗаписатьАтрибут("Text", XMLСтрока(ТекущаяПозиция.Текст));
				ЗаписьXML.ЗаписатьКонецЭлемента();
			ИначеЕсли ТекущаяПозиция.Свойство = "ШтрихКод" Тогда
				ЗаписьXML.ЗаписатьНачалоЭлемента("Barcode");
				ЗаписьXML.ЗаписатьАтрибут("BarcodeType", XMLСтрока(ТекущаяПозиция.ТипШтрихкода));
				ЗаписьXML.ЗаписатьАтрибут("Barcode", XMLСтрока(ТекущаяПозиция.ШтрихКод));
				ЗаписьXML.ЗаписатьКонецЭлемента();
			Иначе
				ТекстОшибки = НСтр("ru='Не определен тип позиции чека.'"); 
				Сообщить("ОШИБКА! "+ТекстОшибки);
				Возврат мОшибкаНеизвестно;
			КонецЕсли;
		КонецЦикла;
		ЗаписьXML.ЗаписатьКонецЭлемента();	
	КонецЕсли;
	
	// Таблица оплат
	Если СуммаЧека <> 0 Тогда
		СуммаНаличнойОплаты     = СуммаНал;
		СуммаЭлектроннойОплаты1 = СуммаБезнал;
		СуммаЭлектроннойОплаты2 = 0;
		СуммаЭлектроннойОплаты3 = 0;
		ЗаписьXML.ЗаписатьНачалоЭлемента("Payments");
		ЗаписьXML.ЗаписатьАтрибут("Cash", XMLСтрока(СуммаНаличнойОплаты));
		ЗаписьXML.ЗаписатьАтрибут("CashLessType1", XMLСтрока(СуммаЭлектроннойОплаты1));
		ЗаписьXML.ЗаписатьАтрибут("CashLessType2", XMLСтрока(СуммаЭлектроннойОплаты2));
		ЗаписьXML.ЗаписатьАтрибут("CashLessType3", XMLСтрока(СуммаЭлектроннойОплаты3));
		ЗаписьXML.ЗаписатьКонецЭлемента();
	КонецЕсли;
	
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ДанныеЧека = ЗаписьXML.Закрыть();
	
	Если НЕ Объект.Драйвер.СформироватьЧек(Объект.ИДУстройства,СокрЛП(Кассир),Электронно, ДанныеЧека, НомерЧека, НомерСмены, ФискальныйПризнак, AddressSiteInspections) Тогда
		Результат = мОшибкаНеизвестно;
		Объект.Драйвер.ПолучитьОшибку(Объект.ОписаниеОшибки);
	КонецЕсли;	
	
	//Сообщить("Номер чека: "+СокрЛП(НомерЧека));
	//Сообщить("Номер смены: "+СокрЛП(НомерСмены));
	//Сообщить("Фискальный признак: "+СокрЛП(ФискальныйПризнак));
	//Сообщить("Адрес проверки чека: "+СокрЛП(AddressSiteInspections));

	Возврат Результат;

КонецФункции // ЗакрытьЧек()
Показать
karpik666; +1 Ответить
9. zaoproxy 36 05.02.17 17:49 Сейчас в теме
(5)Да подключал. Скажу для примера передача смс со ссылкой на электронный чек не для каждого клиента подсильная задача. Поэтому эти действия выполняет оператор фискальных данных как и отправку электронного письма.
Обращаю внимание всех кто в теме что все обработки хоть Атол, хоть Штрих работают с последними версиями драйверов (8.12 и 4.13 соответственно)
488. mcmaxima 03.04.17 08:10 Сейчас в теме
(2) Передачу в ОФД осуществляет Драйвер. Не ККТ.
(488) А зачем тогда нужны кассы, если можно было бы программно отправлять чеки в ОФД?
492. mcmaxima 03.04.17 12:51 Сейчас в теме
(490) Сначала чек фиксируется в фискальной памяти ККМ. Потом, на основе установок в драйвере, происходит их отправка на ОФД. Если речь идет о кассах, которые работают под управлением ПК.
3. zaoproxy 36 03.02.17 07:39 Сейчас в теме
В обновлениях к указанным версиям есть бесплатные (от 1С) обработки обслуживания.
+ появилось новое оборудование "ККТ".
В чём отличие Вашей платной разработки от стандартной?
4. Техподдержка 03.02.17 08:27
Новые обработки обслуживания будут работать только в обновленных конфигурациях 1С, т.к. в них используется общий модуль ПодключаемоеОборудованиеУниверсальныйДрайверКлиент... Другими словами в старых конфигурациях придется перекапывать программу программисту. А данная обработка подключается к любым старым конфигурациям.
10. solntsasvet 38 05.02.17 20:07 Сейчас в теме
Добрый день.
Уточните, пожалуйста, как происходит и происходит ли печать QR-кода на чеке при использовании обработки и каким образом реализованы функции для чеков коррекции и получения текущего состояния расчетов с ккт-онлайн.
11. Техподдержка 06.02.17 08:31
(10) Добрый день, печать QR кода происходит по признаку наличия в печатаемой строке слов "html" или "ШтрихКод". Для получения текущего состояния расчетов есть кнопка в настройках или X отчет (отчет без гашения).
Прикрепленные файлы:
120. chubkin 20.02.17 15:06 Сейчас в теме
(11) Не очень понятно где должна содержаться строка "html" для печати QR кода?
(120)
1. Для ЕГАИС: сделайте печать не фискальной строки, в которой есть слово http. Например http:\\www.ya.ru (не html, я не верно написал) или "|ШтрихКод|QR|www.ya.ru"

2. Если речь идет о печати QR кода чека, то это настраивается в самом ККТ. За передачу данных в ОФД и печать чека отвечает сам регистратор.
12. linkforget 10 07.02.17 21:21 Сейчас в теме
Добрый день. Скачал у вас файл dll. При добавлении нового драйвера в УТ 11.3 пишет версию 8.10 вместо указанной версии 8.12.1.0. Соответственно в списке подключаемого оборудования при дальнейшей настройке нет нужного мне АТОЛ 77Ф. Подскажите как можно корректно загрузить данную компоненту чтобы появился нужный список оборудования при настройке кассы?
13. Техподдержка 08.02.17 07:58
Проверьте в свойствах dll (проводник-свойства файла) какая версия? Скорее всего у Вас зарегистрирована в системе предыдущая версия библиотеки.
Прикрепленные файлы:
14. linkforget 10 08.02.17 09:04 Сейчас в теме
(13) В свойствах файла указана 12 версия. Регистрировал на сервере данную компоненту через regsvr32. Подскажите что еще можно попробовать сделать чтобы она заработала?
16. linkforget 10 08.02.17 09:20 Сейчас в теме
(13) порядок действий был следующий. Выгрузил архив со старым драйвером. взял из него манифест и файл с информацией. Заархивировал в новый архив с новой компонентой. Если название архива совпадает с тем который я выгружал то происходит ситуацию описанная выше, если я меняю название архива. то выходи сообщение что драйвер установлен но в текущем статусе указано "Не установлен на текущем компьютере. Не определен тип: AddIn.ATOL_KKM_1C82_54FZ"
15. Техподдержка 08.02.17 09:20
У Вас подключается интегрированный драйвер в УТ 11.3. Для конфигураций, работающих в управляемых формах, достаточно обновления до последнего релиза.
17. Техподдержка 08.02.17 09:38
Тогда в файле INFO.XML
<?xml version="1.0" encoding="UTF-8"?>
<drivers>
<component progid="AddIn.ATOL_KKM_1C82_54FZ" type="ККТ" name="АТОЛ: Драйвер ККМ (54ФЗ)"/>
</drivers>

В файле MANIFEST.XML
<?xml version="1.0" encoding="UTF-8" ?>
<bundle xmlns="http://v8.1c.ru/8.2/addin/bundle">
<component os="Windows" path="FprnM1C82_54FZ.dll" type="com" arch="i386" />
</bundle>

18. Кадош 08.02.17 11:48 Сейчас в теме
Добрый день.
Надо ли покупать лицензию драйвера у Атола на Штрих?
19. Техподдержка 08.02.17 12:02
Атол пишет в форуме, что поддержка других ККТ будет только по отдельным условиям. А зачем покупать лицензию на ШТРИХ, если можно использовать бесплатный драйвер штриха (4.13.538), который можно скачать тут: http://www.shtrih-m.ru/catalog/programmno-tekhnicheskie-kompleksy-fr-i-aspd/shtrikh-m-01f/#download
20. Кадош 08.02.17 12:33 Сейчас в теме
(19) Ваша обработка поддерживает работу с ФР Штрих на драйвере Штриха в части ФЗ.54?
21. Техподдержка 08.02.17 12:41
(20)Обработка для Штриха предназначена для поддержки работы по 54-ФЗ.
Всего выложено 3 отдельных обработки производителей ККТ:
1. АТОЛ
2. ШТРИХ
3. ВИКИ
Каждая из которых поддерживает ККТ своего производителя.
22. Кадош 08.02.17 15:09 Сейчас в теме
(21) Спасибо. А как осуществляется отправка чека по СМС м почте?
23. Техподдержка 08.02.17 15:32
(22) В настройках обработки выбирается необходимость запроса номера телефона или почты покупателя, после передается в XML при закрытии чека. Оператор фискальных данных на основе этих данных осуществляет передачу смс или на e-mail.
24. Кадош 08.02.17 15:47 Сейчас в теме
(23) Сейчас будем тестировать.
25. tarassov 96 08.02.17 19:05 Сейчас в теме
Действительно ли тестировалась эта разработка на Viki Print 57 ?

Какой именно драйвер вы используете для Viki Print 57?
26. Техподдержка 08.02.17 19:21
Да, тестировалась. Использовался драйвер, по адресу http://help.dreamkas.ru/hc/ru
Прикрепленные файлы:
27. Кадош 09.02.17 12:33 Сейчас в теме
Розница, редакция 1.0 (1.0.19.16) (http://v8.1c.ru/retail/)
Copyright © ООО "1C", 2003-2012. Все права защищены
(http://www.1c.ru)

При пробитии чека через РМК не происходит запроса телефона или почты.
В обычном режиме - работает.
28. Техподдержка 09.02.17 13:07
В настройках обработки выбрали - "Запрашивать номер телефона и (или) E-mail покупателя"?

437. diso 273 24.03.17 09:08 Сейчас в теме
(28)
В настройках обработки выбрали - "Запрашивать номер телефона и (или) E-mail покупателя"?


Опубликуйте скрин окна настройки обработки
29. Техподдержка 09.02.17 14:01
Я проверил в РМК, пример запроса e-mail
Прикрепленные файлы:
30. Кадош 09.02.17 14:16 Сейчас в теме
(29) пардон. работает.
В чеке телефон выводится со строкой Адрес покупателя. Так и должно быть?

Например, после ввода почты и адреса в чеке:
Адр.покупателя: 891100000000
Адр.покупателя: test@mail.ru
31. Техподдержка 09.02.17 14:24
Чек формирует сам ККТ, что в нем происходит известно только производителю. Для Вашего видимо так.
32. tanyafwd 10.02.17 08:22 Сейчас в теме
Подскажите, подойдёт ли эта обработка для ERP 2.2.1.142? Версия УТ в ней 11.3.1.142.
33. Техподдержка 10.02.17 08:38
В ERP 2.2 используются управляемые формы и другие механизмы работы с торговым оборудованием. Вам достаточно загрузить драйвера для работы с 1С. Вот для примера: https://drive.google.com/file/d/0BziKUa3VXRo6R0ZESXVaZ256RXc/view
34. tanyafwd 10.02.17 09:15 Сейчас в теме
(33) На этой версии не получается подключить новый драйвер почему-то (ККТ АТОЛ FPrint-22ПТK). В системе он установлен, но при нажатии на кнопку "Настроить..." 1С пишет, что "Драйвер устройства на текущем рабочем месте не установлен", при попытке установки также возникает ошибка (архив с драйвером брала с сайта АТОЛ - FR-ATOL_54FZ.zip).

На последней выпущенной под 54-ФЗ версии конфигурации 2.2.2.192 с ККТ и драйверами всё ок, связка из РМК работает, но по техническим причинам обновиться пока не можем.

То есть ваша обработка для этой версии не подойдёт, я правильно понимаю?
35. rsvp201 160 12.02.17 20:42 Сейчас в теме
Добрый день

Конфигурация : "Управление торговлей", редакция 10.3 (10.3.35.1). Конфигурация доработана! Подойдет ли ваша обработка к этой редакции, или все таки нужно обновлять?
37. Техподдержка 13.02.17 08:21
"(35) Добрый день, для Конфигурация : "Управление торговлей", редакция 10.3 (10.3.35.1), которая доработана" - подойдет. ОБНОВЛЯТЬ НЕ НАДО!!!

(36) Поддержка Бухгалтерии 2.0 тоже есть. Если раньше у Вас работали фискальные регистраторы, то и сейчас будут работать новые (54-фЗ) с данными обработками.

...УПП тоже подойдет и т.д. (т.е. все конфигурации в обычных формах)

КОНФИГУРАЦИИ ОБНОВЛЯТЬ НЕ НАДО!
36. AlPepper 13.02.17 06:51 Сейчас в теме
38. Erne100 246 13.02.17 11:32 Сейчас в теме
Допустим: Мы "застряли" в Бух 2.0, и до Бух 3.0 как до луны. В базе несколько организаций у каждой по ШТРИХ-ФР-К.
С 01.03.2017 На 54-фз переводим только одну. Уже заказали апгрейд одного фискальника до ШТРИХ-ФР-01Ф.

Вопрос 1: Ваша обработка - это то чего нам не хватает?
Вопрос 2: Возможна ли параллельная работа с новым и старым железом?
39. Техподдержка 13.02.17 13:23
(100) Общий ответ ДА
Вопрос 1. Только обработки
Вопрос 2. Не проверял. Но смысл. Ставите новую обработку, у Вас будет 2. Используете, указанную в настройках. Принцип в этом случае, если применять 2 фискальных регистратора на одном рабочем месте.
40. Erne100 246 13.02.17 16:14 Сейчас в теме
(39) Понял. Спасибо за ответ. Смысл - работа в переходный период.

Вопрос 3: А как из Бух 2.0 передать строки с номенклатурой?
Они ведь обязательны теперь!

В Бух 2.0 в ПКО код простой: СтрокаТаблицы.Заголовок = "Принято от " + ПринятоОт + Основание: " + Основание;

Пример решения из Бух 3.0 строки берутся из привязанного к ПКО счета, иначе "Аванс".
41. Техподдержка 13.02.17 17:52
(39) Вопрос 3. Также как и раньше. По закону до 21 года ИП не обязаны передавать наименование номенклатуры. Т.е. можно одной строкой, например как было раньше.

Предлагаю для Вас сделать как в бух 3.0. Для какой ККМ необходимо данное решение?
42. Vol_M 13.02.17 21:25 Сейчас в теме
на конфигурации Розница 1.0.16.8 работать будет?
код обработки открыт?
44. Техподдержка 14.02.17 07:01
(42) На конфигурации "Розница 1.0.16.8" работать будет. Код обработки открыт. В конфигурации ничего изменять не надо!
43. itdirectdominus 14.02.17 04:58 Сейчас в теме
Добрый день. УТ 10.3 36.1 сильно переписанная. ККМ Атол Fprint 22ПТК зарегистрирован и подключен в налоговой и ОФД. Интересуют вопросы:
1) Пробитие розничных чеков по ФЗ-54?
2) Чеки из документов ПКО и РКО? Одной суммой будет пробитие чека? Оплата за товар?
В вашей обработке все реализовано?
45. Техподдержка 14.02.17 07:05
(43) "УТ 10.3 36.1 сильно переписанная".
1) Чеки пробиваются по ФЗ-54.
2) Чеки будут пробиваться как и раньше. Т.е. как это происходило в предыдущих фискальных регистраторах, точно также будет и с новой ККТ.
714. Alex11041973 23.06.17 16:51 Сейчас в теме
Не применима для вариант 8.2 в режиме эмуляции 8.3
Выдает при попытке настроить параметры :

{ВнешняяОбработка.АТОЛККТ.Форма.ФормаНастройкиУниверсальныйДрайвер.Форма(43)}: Значение не является значением объектного типа (Драйвер) РезультатВыполнения = ВыполнитьКоманду("ПолучитьОписаниеДрайвера",

"Управление торговлей", редакция 10.3 (10.3.13.2)
1С:Предприятие 8.3 (8.3.9.2170)
715. Alex11041973 23.06.17 16:54 Сейчас в теме
Дравйвера сначала поставил 8.14, потом Атоловцы объяснили, что если WIN 7, то надо ставить только 8,12
Вот после этого и перестала обработка открывать параметры - видимо она только последние драйвера понимает, но именно их и нельзя ставить.
Замкнутый круг. Как отключить встроенные драйвера ?
(714) ВАЖНО! Драйвера Атола ТОЛЬКО ПО 32х разрядную 1С!!! Если ставили 64х - переставьте на 32х
(715) Все не так. Удалить 8.12. Поставить 8.14.00.00- именно это! Перегрузить компьютер и далее запускать. Для проверки могу выслать тестовые обработки, если напишите свой адрес.
717. Epishko 24.06.17 12:17 Сейчас в теме
(716) epishko.a@szar.ru - буду признателен, за любую помощь. Вчера что-то даже получилось, но ненадолго. Какая-то плавающая ошибка - то определяются драйвера. Вышел из 1С, вошел снова - все, уже опять не определяются....
46. Техподдержка 14.02.17 11:12
Пример вариантов подключения для ШТРИХ-М:
Прикрепленные файлы:
47. sambuevs 14.02.17 11:52 Сейчас в теме
(46) что указать в поле Имя компьютера (обработка для Штриха)
48. Техподдержка 14.02.17 12:00
(46) Можно ничего не указывать. Главное - тип подключения, порт ис корость (если COM) или IP и порт (если TCP) и систему налогообложения.
49. sambuevs 15.02.17 04:47 Сейчас в теме
(48) добрый день Алексей,
приобрели вашу обработку помогите разобраться с настройками ккм,
касса штрих фр01ф модернизированная для офд, подключаем к УТ 10.3 через ком1,
добавился ethernet (в тесте вижу настройки офд ip адрес и порт),
в параметрах ккм указал тип подключения dcom
запрашиваю отчет о текущем состоянии расчетов:
ШТРИХ-ФР-Ф: Ошибка получения отчета.
Дополнительное описание: 38h
52. Техподдержка 15.02.17 07:40
(49)
: Добрый день, на адрес alexey@paltusov.ru пришлите подключение по Ammy или TeamViewer 38h
50. itdirectdominus 15.02.17 05:33 Сейчас в теме
Купили данную обработку есть несколько вопросов.
1. Какие образом происходит закрытие кассовой смены? Как вызывать меню с выбором команд: Открыть, закрыть смену, текущее состояние?
2. Каким образом происходит отправка по копии чека на почту? СМС я так понимаю через ОФД реализовано, а почта?
3. Прилагаю скрин, печатаю из приходного кассового ордера. В наименование платежа непонятные символы, где косяк?
Все операции выполнял на не фискализированом аппарате и не подключенном к ОФД, чтоб просто потестировать.
Печать QR кода?
Прикрепленные файлы:
53. Техподдержка 15.02.17 08:40
(50)
1. Закрытие кассовой смены происходит также как и раньше Z отчет происходил. Отдельно данные команды доступны в параметрах обработки (кнопка Функции).
2. Тоже через ОФД.
3. Косяк может быть в переданных данных от 1С. Где-то происходит конвертация символов в КОИ-8 например (кусок наименования ведь нормально напечатался). QR код печатается при наличии в строке слова http.
Прикрепленные файлы:
193. myip00@bk.ru 27.02.17 08:46 Сейчас в теме
(50)
(53)
Косяк может быть в переданных данных от 1С. Где-то происходит конвертация символов в КОИ-8 например (кусок наименования ведь нормально напечатался)


У меня точно такая же проблема при печати чека из приходного кассового ордера. В наименование платежа непонятные символы
(193) Попробуйте в процедуре модуля обработки ЗакрытьЧек заменить строку:

ЗаписьXML.ЗаписатьАтрибут("Name" , XMLСтрока(ТекущаяПозиция.Номенклатура));

на

ЗаписьXML.ЗаписатьАтрибут("Name" , XMLСтрока(КонвертацияAnsiToOem(ТекущаяПозиция.Номенклатура)));
264. myip00@bk.ru 01.03.17 15:40 Сейчас в теме
(194)
(50)
(53)
Вот в этом случае вторую часть строки печатает не читаемыми символами.
СтрокаТаблицы.Заголовок = "Выдать: " + Выдать
+ "
|Основание: " + Основание;
Как только убираем разделитель, то вывод осуществляется прекрасно
В старых релизах - это печать чека ККМ из РКО И ПКО в процедуре "ОсновныеДействияФормыЧек"
(264) Разделитель это символ.вк?
279. myip00@bk.ru 02.03.17 06:30 Сейчас в теме
(270) Не можем сказать, потому что текст взят из оригинала модуля.
Поэтому какие символы были использованы при написании этого текста, мы сказать не можем.
(264) Для исправления необходимо заменить в модуле обработки строку

НоваяСтрока.Номенклатура = СокрЛП(Наименование);

на

НоваяСтрока.Номенклатура = СокрЛП(СтрЗаменить(Наименование,Символы.ПС," "));
280. myip00@bk.ru 02.03.17 08:13 Сейчас в теме
(271) Теперь все нормально, спасибо
51. itdirectdominus 15.02.17 05:41 Сейчас в теме
e-mail организации для отправки чека для чего? указал ящик организации каким образом происходит отправка?
54. Техподдержка 15.02.17 08:42
(51) Через ОФД. При отправке в чек данных ящика получателя необходима отправка и ящика отправителя.
55. dortalan87 15.02.17 11:58 Сейчас в теме
Добрый день. Оплата по безналу возможна?
57. EdGreen 9 15.02.17 14:30 Сейчас в теме
Здравствуйте. Поможет ли эта обработка подключить Атол 55Ф к УТ 11.0.6.9 ?
AlexanderEkb; +1 Ответить
58. erlsm 15.02.17 15:50 Сейчас в теме
Здравствуйте!
Для УТ 10.2 на платформе 8.1 есть реализация 54-ФЗ?
59. Техподдержка 15.02.17 16:00
(58) Именно эти обработки и будут работать. Открываете текущую свою рабочую в конфигураторе. копируете модуль обработки и модуль формы настройки из этих. В модуле формы настройки добавляете реквизиты и таблицу руками.
508. stro71 12.04.17 11:58 Сейчас в теме
(59) И как потом эту обработку цеплять к обородуванию, если обработки обслуживания в 10.2 зашиты в конфигурации?
Прикрепленные файлы:
(508) Никак, переписывать конфигурацию.
927. burga 11 11.09.17 10:39 Сейчас в теме
(59)
Открываете текущую свою рабочую в конфигураторе. копируете модуль обработки и модуль формы настройки из этих. В модуле формы настройки добав


Подскажите, а под "текущей рабочей в конфигураторе" какая обработка имеется ввиду?
(927) Добрый день, речь шла о конвертации обработки для платформы 1С 8.2 в 8.1
936. burga 11 12.09.17 08:46 Сейчас в теме
(928)
тки для платформы 1С 8.2 в 8.1


Т.е. я скачал обработку для 8.1 мне этого для установки достаточно, или что-то еще надо?
(936) Если у Вас платформа 8.1 то надо обработку для 8.1.
Если у Вас платформа 8.2 или 8.3 надо использовать обработку для 8.2. Тогда Вам не придется регистрировать dll, т.к. она входит в состав обработки. Обработка сама подключает данную библиотеку.
949. burga 11 13.09.17 11:36 Сейчас в теме
(937)
Если у Вас платформа 8.1 то надо обработку для 8.1.


Извините, не понял.
У меня в УТ 10.2 есть настройка ТО, где указывается обработка обслуживания, где выбирается форма из существующих.
Ее надо заменить или что? в модулях тех форм точка входа - функция "выполнить операцию", в вашей обработке идет ссылка на Перечисления.ТООшибкиОбщие, которых нет в конфигурации.
Что не так делаю?


https://yadi.sk/i/5dQoiWfG3MqqW8
(949) Не будет работать! Есть обработка для Трактира, которая использует эту технологию. Могу ее переслать еще адрес почты напишите, но ее возможно допиливать придется.
1163. jdxeee 02.04.18 09:11 Сейчас в теме
(950)
технологию

(950)
(950)
(950)
Добрый день!
Приобрели обработку АТОЛ ККТ с передачей данных в ОФД (54-ФЗ) Формат ФН 1_05 не можем встроить в конфигурацию УТ 10.2, просим выслать для трактира, нам необходимо подключить Атол ф30 с версией 1.05.
1165. jdxeee 02.04.18 09:23 Сейчас в теме
60. dortalan87 15.02.17 16:12 Сейчас в теме
Будет ли работать обработка с типовой конфигурацией Розница - Магазин строительных и отделочных материалов для Украины, редакция 1.0? много общего с той же Розницей 1.0 для России.
61. Техподдержка 15.02.17 16:23
(60) Должна. Предлагаю отправит Вам обработку, оплатите в инфостарт, если ок.
62. dortalan87 15.02.17 16:51 Сейчас в теме
(61) Не совсем понял. Отправите нам обработку, если оплатим в инфостарте?
63. Техподдержка 15.02.17 16:56
(62) Я отправлю Вам обработку для тестирования, если необходимо помогаю при запуске, без оплаты, далее Вы по стандартной схеме покупаете если довольны.
64. dortalan87 15.02.17 17:27 Сейчас в теме
(63) Понятно, можно попробовать. Для начала можно проверить работу обработки с конфигурацией и тестовые команды с ФР. Можно ли проверить отправку чека на ОФД, если на реальной кассе еще работает фискалка с ЭКЛЗ?
65. Техподдержка 15.02.17 17:32
Можно попробовать работу с новой кассой (54--ФЗ) или перешитой по 54-ФЗ. Если у Вас ЭКЛЗ, то работать не будет. Могу сказать, что из данного форума я помогал в запуске Атол и Штрих. Все работают, кроме MSTAR, с данной ККМ надо рыть...
71. dortalan87 16.02.17 09:56 Сейчас в теме
(65) У нас АТОЛ 55Ф, осталось только перерегистрировать на новый адрес, тогда можно будет проверить обработку?
66. chubkin 15.02.17 17:40 Сейчас в теме
Работает данная обработка в УПП 1.2?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий программист 1С
Санкт-Петербург
зарплата от 130 000 руб.
Полный день

Программист 1С
Москва
зарплата от 130 000 руб. до 200 000 руб.
Полный день

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день

Консультант-методолог 1С
Краснодар
зарплата от 110 000 руб.
Полный день