Обмен с ЕГАИС из 1С V7.7

0. Техподдержка 09.11.15 00:39
Дорогие друзья! Предлагаю Вашему вниманию обработку, предназначенную для обмена данными из Вашей учетной системы с ЕГАИС, через универсальный транспортный модуль (УТМ).
В обработке реализован весь функционал обмена:
- загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции;
- загрузка справочных данных по номенклатуре алкогольной продукции;
- загрузка остатков;
- помощник сопоставления справочных данных и запись их в базу данных;
- загрузка приходных ТТН и справок Б от поставщиков, отправка по ним актов всех типов, создание по ним приходных документов;
- выгрузка расходных ТТН покупателям;
- управление Марками и ведение Регистра 3;
Обработку возможно использовать автономно, не внося изменений в Вашу Учетную систему.
Код открыт.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
(380) vin1c,
Марку требует при отправке или в ответе?
397. vin1c 22.12.15 17:16 Сейчас в теме
381. Dimasan2006 22.12.15 10:44 Сейчас в теме
(378) Не дает заполнить акт постановки на баланс методом подбора. Только методом ШК
385. alenaalenkina 22.12.15 13:13 Сейчас в теме
(378) подскажите, в начале работы вылетает окошко с надписью "Для корректной работы установите С++" (дословно, точую формулировку не помню). Нам нужно еще и С++ установить, как из ответа 332? Куда ее устанавливать? Просто на комп или в определенную папку?
379. pfa 22.12.15 08:39 Сейчас в теме
Надо сделать кнопку "Переиндексация БД", например на закладке "Настройка", для перестроения или восстановления индексных файлов с которыми работает обработка.
При разрушении индексных файлов не возможно продолжить работу с обработкой.
(379) pfa,
Согасен. переиндексация будет..
382. Pagoo 22.12.15 11:26 Сейчас в теме
куда делась кнопка "Выбрать документ "во вкладке Инвентаризация?
2 недели не можем ввести остатки по пиву в ЕГАИС.
неужели нельзя просто перечнем их внести после привязки???
(382) Pagoo,
Да скорее всего по пиву действительно надо оставить подбор или документ...согласен. .
399. knight 22.12.15 19:48 Сейчас в теме
(387) нам бы это очень пригодилось тоже голову ломаем..
(382) Pagoo,
Ну а по креп АП без Сканера никак. .
383. Dimasan2006 22.12.15 12:54 Сейчас в теме

Процедура ПолучитьТранспорт()

Последние 2 строчки:
ТекПараметры.ДобавитьЗначение( глПредставлениеАдреса(Док.Фирма.ФактАдрес),"ПунктПогрузки");
ТекПараметры.ДобавитьЗначение(глПредставлениеАдреса(Док.Контрагент.ФактАдрес),"ПунктРазгрузки");

Предлагаю заменить на:
ТекПараметры.ДобавитьЗначение( глПредставлениеАдреса(Док.Фирма.ЮрЛицо.ФактАдрес),"ПунктПогрузки");
ТекПараметры.ДобавитьЗначение(глПредставлениеАдреса(Док.Контрагент.ЮрФизЛицо.ФактАдрес),"ПунктРазгрузки");

Причина:
В типовой торговле 9.2 в справочниках Фирмы и Контрагенты нет адресов, адреса в подчиненных справочниках ЮрЛицо и ЮрФизЛицо соответственно.



Процедура СоздатьДок()

Строки:
Если ПустоеЗначение(Док.Проект) = 1 Тогда
Док.Проект = Док.Контрагент.ОсновнойПроект;
КонецЕсли;

Предлагаю заменить на:
Если ПустоеЗначение(Док.Проект) = 1 Тогда
Док.Проект = глПользователь.ОсновнойПроект;
КонецЕсли;

Причина:
В типовой ТиС 9.2 реквизит ОсновнойПроект только у пользователя, у контрагента нет.
384. Brad 22.12.15 13:01 Сейчас в теме
Отправьте, пожалуйста, ТТН (через тестовый сервис)

ИНН: 7813110500
ФСРАР_ИД: 010000006442
398. Brad 22.12.15 18:24 Сейчас в теме
386. RUS63 7 22.12.15 13:26 Сейчас в теме
Купил у Вас обработку. У меня версия 1,4 без помощника и инструкции. Как получить новую версию?
e-mail: ruaskerov@yandex.ru
(386) RUS63,
По той-же ссылке что и 1.4...
390. alenaalenkina 22.12.15 14:44 Сейчас в теме
(386) rvs-slim , ответьте пож-та на 385 вопрос.
(390) alenaalenkina,
Давайте в личку версию ОС редакцию? Так действительно был удивлен подобным требованинм...
395. alenaalenkina 22.12.15 15:50 Сейчас в теме
(392) хорошо, завтра с утра, компьютер находиться в другом месте.
394. enter 16 22.12.15 15:44 Сейчас в теме
(390) alenaalenkina,
Мы столкнулись с тем, что на ОС Вин Сервер 2008 64 при нажатии кнопки "проверить УТМ" система сообщала об отсутствии разных DLL. После установки С++ (см.ссылку ниже, выберите 32 или 64 разр.ОС) проблема исчезла. Установку С++ сделали куда предложено было самой установочной программой. Думаю, путь установки не имеет значения.

http://blog.spreendigital.de/2015/09/01/how-to-fix-the-api-ms-win-crt-runtime-l1-1-0-dll-is-missing-error-for-delphi-10-seattle/
trofimovalexey; +1 Ответить
400. vin1c 23.12.15 00:09 Сейчас в теме
можно предоставить список доработок в конфигурации которые нужно сделать чтобы корректно работала обработка, а то приходится по мере возникновения ошибок делать доработки в ТиС.
401. vin1c 23.12.15 00:18 Сейчас в теме
и еще проблема на сервере терминалов захожу под админом настраиваю программу выполняю определенные действия, далее захожу под пользователем он предлагает по новой инициализировать базу т.е не видит твоих дбфок
(401) vin1c,
а каталог доступен для пользователей, т. е. с доступом все в порядке?
Добавлены кнопки Подбор в Инвентаризацию...
Устранены мелкие ошибки ...
По подтверждению ТТН наблюдается картина когда ТТН давностью более ... дней нельзя подтвердить...
ситуация выясняется (по обсуждениям фигурировало 3 дня)...
Текущая V1.6.1
403. Roman1101 23.12.15 01:10 Сейчас в теме
И как сейчас инвентаризацию по пиву делать? В предыдущей версии создавал документ Оприходование ТМЦ, (предварительно закомментив строку, проверяющую введен ли БарКод), вроде все проходило. А тут кнопка выбора документа на вкладке "инвентаризация" пропала.
404. Roman1101 23.12.15 01:14 Сейчас в теме
А кнопка подбор не активна. Какую-нить альтернативу пивникам оставьте.

О, сорри в новой загрузке подбор заработал, может для пивных документов какой-нить чек-бокс придумать, чтоб барКоды не проверял?
Я тут вроде не один с пивом связан.
405. Roman1101 23.12.15 01:56 Сейчас в теме
01:45:01 - Отправка акта Постановка на Баланс
DBFTovarInfo.Ключ.AlcCode = AlcCode;
{D:\НОУТ\ОБЩАЯ\1C\FAVORIT\EXTFORMS\OBMEN_EGAIS.ERT(4323)}: Не соответствие типов!

Раньше такой не было. Ставил на баланс 30-литровую кегу пива.
Кнопка "применить для всех" в правой части окна работает точно так же ка и кнопка "применить",
т.е устанавливает значения только для текущего элемента, а не для всех.
И еще такое пожелание чтоб можно было сохранять частично введенный документ.
Ну например ту же инвентаризацию.
(405) John1703,
Кнопка "применить для всех" в правой части окна работает точно так же ка и кнопка "применить",
т.е устанавливает значения только для текущего элемента, а не для всех.
-> кнопка "применить для всех" работает по другому, представьте у Вас куча отсканированных марок одной (текущей Ном-ры), затем идет другая...и т.д. чтобы не применять параметры к каждой строке (кн Применить) Вы используете кнопку "применить для всех" и у всех строчек Текущей номенклатуры эти параметры заполнятся...

И еще такое пожелание чтоб можно было сохранять частично введенный документ.
Ну например ту же инвентаризацию.
-> можно подробнее... пока не понял(пропускать не корректные позиции?)
406. vin1c 23.12.15 07:51 Сейчас в теме
Установлена ТЕКУЩАЯ Номенклатура:Жигул 0.5*20 т/у
Параметры АП необходимо адаптировать к Вашей системе! (что нужно сделать?)
07:53:25 - Отправка акта Постановка на Баланс
DBFTovarInfo.Ключ.AlcCode = AlcCode;
{E:\1CBASE\DB\EXTFORMS\EGAIS\OBMEN_EGAIS.ERT(4323)}: Не соответствие типов!
Ошибка!
Ок давайте сегодня, устраним проблемы связанные с Постановкой на баланс. ..
Версия должна быть 1.6.1..
Жду Ваши проблемы, ошибки предложения. ..Спасибо...
408. edstary 23.12.15 08:13 Сейчас в теме
Обработкой можно сделать перемещение алкоголя между обособленными подразделениями в рознице?
(408) edstary,
Можно...
Все движения в ЕГАис ТТН...
Чек боксов думаю не нужно (пока)..
Проверка на пиво
1. КодСпиртПродукции начинается с "5" (да в Тис м.б. КодАлкоПродукции..)
2. в наименовании найдено "пиво","пивн"
3. в Группе "пиво"
4. Реквизит "Категория" = "пиво")
по идее при положительном ответе хотя бы на один вопрос товар считается ПИВОМ и не требует заполнения Марок и фикс ЕГАИС...
458. serg75 23.12.15 19:56 Сейчас в теме
(410) Здравствуйте. К категории пива, декларация форма 12, также относится пуаре, сидр, медовуха коды вида 261,262,263
411. Гость 23.12.15 09:20
Добрый день!
Если выполнять запрос номенклатуры по ИНН производителя, а у производителя есть номенклатура в кегах, т.е. емкость не указана.
Созванивались с завод производителем, сказали, что у них все выгружается нормально, может быть в ЕГАИС что-то не так, но при загрузке номенклатуры у некоторой номенклатуры нет поля Capacity.

И найдена, возможно ошибка в:
Функция ДобавитьТовар(хмл_Товар,DBFTovar,DBFFirms,DBFTovarInfo,DBFFirmsInfo,TTN = 0,ТолькоНовое = 1)
...
...
АПТЗ.ProductVCode = СокрЛП(хмл_Товар.getElementsByTagName("pref:ProductVCode").item(0).Text);
АПТЗ.FullName = СокрЛП(хмл_Товар.getElementsByTagName("pref:FullName").item(0).Text);
Попытка
АПТЗ.Capacity = СокрЛП(хмл_Товар.getElementsByTagName("pref:Capacity").item(0).Text);
Исключение
АПТЗ.Capacity = "";
КонецПопытки;
АПТЗ.AlcVolume = СокрЛП(хмл_Товар.getElementsByTagName("pref:AlcVolume").item(0).Text);
...
...
Конецфункции;

Проблемы получилось миновать через конструкцию попытка исключение.
(411) alanstorm,
ок! это значит и в выгрузке Capacity не нужен...
Понял Спасибо подправил...
Друзья, по пиву особенности принимаю подправляю...
413. dvoinik 9 23.12.15 09:45 Сейчас в теме
При подтверждении акта.
Он ищет накладные но номеру Акта согласия или разногласия.
А должен по номеру ТТН
акте нет номере ТТ но есть номер ТТН-ЕГАИС.
Я так понимая нужно ТТ-ЕГАИС найти в справке Б там найти ТТН из 1С. И потом уже искать документы
Или в акте должен быть не номер акта (Номер акта клиента) , а номер ТТН из 1С.

(413) dvoinik,
Нет, ищет по номеру ТТН ACTNUMBER и дате ActDate
эти параметры записываются в созданном Документе Поступление ТМЦ в реквизит НомерДокВходящий...
Последние присланные ошибки исправлены: Версия 1.6.2
415. vostrikova 23.12.15 09:58 Сейчас в теме
Не можем разобраться с вкладкой "Остатки". Как ей пользоваться? Расскажите, пожалуйста...
(415) khrapova@vcbalance,
Вкладка Остатки показывает продукцию на Балансе в ЕГАИС
Кнопка Запросить: отправляет запрос в ЕГАИС...(можете ждать 2-5 мин и ответ загрузится автоматом при получении)
можете не ждать, нажать Отмена (продолжить др. работу), а по истечении указанного времени перейти на вкладу Входящие и поставить галку на самый последний документ Остатки..
нажать здесь же кнопку загрузить Ответы..
при этом
- создастся файл rests.dbf в котором будут находится текущие остатки, чтобы не запрашивать постоянно, и по нему будет проверятся возможность отправки и грузиться Справка А..
- заполнится вкладка Остатки, отобразится все что зарегистрировано...
Наверно не очень пока удобно, думаю добавлю возможность работать с остатками через Помощник...
418. vin1c 23.12.15 10:16 Сейчас в теме
при отправке акта постановки на баланс пишет файл Rests не найден и потом вылетает браузе и в нем

<?xml version="1.0"?>
-<A><error>org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '\S+(.*\S+)*' for type 'NoEmptyString50'.</error><ver>2</ver></A>
(418) vin1c,
417 сделайте...
просто там два Варианта Актов (Баланс и Списание)
ок, подправлю сделаю изоляцию по остаткам, а пока 417..
420. vin1c 23.12.15 10:25 Сейчас в теме
запросил остатки файл rest пришел ошибка убралась но ошбика в браузере осталась

<?xml version="1.0"?>
-<A><error>org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '\S+(.*\S+)*' for type 'NoEmptyString50'.</error><ver>2</ver></A>
(420) vin1c,
417 по алгоритму не ждать...
423. vin1c 23.12.15 10:28 Сейчас в теме
(421) всмысле по алгоритму не ждать?
(423) vin1c,
Кнопка Запросить: отправляет запрос в ЕГАИС...
можете не ждать, нажать Отмена (продолжить др. работу), а по истечении указанного времени перейти на вкладу Входящие и поставить галку на самый последний документ Остатки..
нажать здесь же кнопку загрузить Ответы..
при этом
- создастся файл rests.dbf в котором будут находится текущие остатки, чтобы не запрашивать постоянно, и по нему будет проверятся возможность отправки и грузиться Справка А..
422. vin1c 23.12.15 10:28 Сейчас в теме
10:31:58 - Отправка акта Постановка на Баланс
Ошибка!
и потом в браузере вылетает
<?xml version="1.0"?>
-<A><error>org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '\S+(.*\S+)*' for type 'NoEmptyString50'.</error><ver>2</ver></A>
(422) vin1c,
Ошибка у Вас связана с незаполненным параметром.. каким будет ясно если пришлете файл query.xml полученный сразу после отправка АПБ...
лучше в личку чтобы здесь не засорять...
424. vin1c 23.12.15 10:31 Сейчас в теме
все я получил файл rest правда остатков пока нет, отправляю акт и вылетает ошибка
427. vin1c 23.12.15 10:40 Сейчас в теме
<?xml version="1.0" encoding="UTF-8"?>
<ns:Documents Version="1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01" xmlns:oref="http://fsrar.ru/WEGAIS/ClientRef" xmlns:pref="http://fsrar.ru/WEGAIS/ProductRef" xmlns:ainp="http://fsrar.ru/WEGAIS/ActChargeOn" xmlns:iab="http://fsrar.ru/WEGAIS/ActInventoryABInfo"><ns:Owner><ns:FSRAR_ID>030000002238</ns:FSRAR_ID></ns:Owner><!--Акт инвентаризации продукции--><ns:Document><ns:ActChargeOn><ainp:Header><!--номер акта--><ainp:Number></ainp:Number><!--дата акта--><ainp:ActDate></ainp:ActDate><!--Комментарий--><ainp:Note>Необходимо поставить товарные позиции на баланс</ainp:Note></ainp:Header><ainp:Content><ainp:Position><ainp:Identity>1</ainp:Identity><!--Информация о продукции--><ainp:Product><pref:Type>АП</pref:Type><pref:FullName>Пиво "Жигулевское" пастеризованное фильтрованное светлое</pref:FullName><pref:AlcCode>0036827000001263034</pref:AlcCode><pref:Capacity>0.500</pref:Capacity><pref:AlcVolume>4.000</pref:AlcVolume><pref:ProductVCode>500</pref:ProductVCode><pref:Producer><oref:ClientRegId>030000019705</oref:ClientRegId><oref:FullName>ОТКРЫТОЕ АКЦИОНЕРНОЕ ОБЩЕСТВО "ЗАВОД ПИВОВАРЕННЫЙ "МОРШАНСКИЙ"</oref:FullName><oref:ShortName>ОАО "ЗАВОД ПИВОВАРЕННЫЙ "МОРШАНСКИЙ"</oref:ShortName><oref:INN>6826000686</oref:INN><oref:KPP>682601001</oref:KPP><oref:address><oref:Country>643</oref:Country><oref:RegionCode>68</oref:RegionCode><oref:description>Россия, 393950,ТАМБОВСКАЯ обл,ДАЧНЫЙ пер,МОРШАНСК г,19 ,</oref:description></oref:address></pref:Producer></ainp:Product><!--Количество - шт для фасованной, Дал для нефасованной--><ainp:Quantity>1.000</ainp:Quantity><ainp:InformAB><ainp:InformABReg><ainp:InformA><iab:Quantity>1.000</iab:Quantity><iab:BottlingDate>2015-12-31</iab:BottlingDate><iab:TTNNumber>1111</iab:TTNNumber><iab:TTNDate>2015-12-31</iab:TTNDate></ainp:InformA></ainp:InformABReg></ainp:InformAB></ainp:Position></ainp:Content></ns:ActChargeOn></ns:Document></ns:Documents>
вот что было в фале
(427) vin1c,
Первое что бросилось в глаза:
<!--номер акта--><ainp:Number></ainp:Number>
<!--дата акта--><ainp:ActDate></ainp:ActDate>
т.е. Пусто...
Согласен по Подбору номер и дата не заполнились...
пока можете сделать заполнение через ШК..
Подправлю...
(432) подправил и через Подбор...
434. knight 23.12.15 11:38 Сейчас в теме
(433) выложена новая версия? я неуспеваю их править под нас)
Abris_d2058; +1 Ответить
438. alenaalenkina 23.12.15 14:19 Сейчас в теме
(433) вы написали, что в версии 1.6 реализована функция сохранения всех запросов и ответов, как через входящие все это загрузить? При нажатии Выбрать приход ничего не дает, хотя в Reply куча Waybill.
Прикрепленные файлы:
439. alenaalenkina 23.12.15 14:23 Сейчас в теме
(433) по вопросу 390(программа просит С++), не могу в сообщениях что либо отправить, прикрепляю здесь
Прикрепленные файлы:
428. vin1c 23.12.15 10:43 Сейчас в теме
у меня кстати нет колонки где ввести количество, прога спросила в даллах сколько при добавлении позиции и все я так понимаю в этом дело
431. vin1c 23.12.15 10:49 Сейчас в теме
(428) vin1c, и еще при добавлении позиции сообщает
Установлена ТЕКУЩАЯ Номенклатура:Жигул 0.5*20 т/у
Параметры АП необходимо адаптировать к Вашей системе!
нужно убирать твои ремы в модуле? куда указывает сообщение
429. vin1c 23.12.15 10:45 Сейчас в теме
и еще может из за этого нет колонок нужных у меня при запуске сообщает
Неудачная попытка загрузить FormEx.dll Некоторые функции будут недоступны !!!
Неудачная попытка загрузить 1cpp.dll Некоторые функции будут недоступны !!!
dll регестрировал было нормально опять начали ругатся сегодня регистрирую их через бат и через авторег все равно не находит
430. vin1c 23.12.15 10:47 Сейчас в теме
перекинул их в базу саму все нормально с dll
435. buka99999 23.12.15 12:03 Сейчас в теме
Добрый день! Вопрос возможно по не знанию. Работаю в последней ТиС. Контрагентов и продукцию получается запросить нормально, но остатки, сколько не пытаюсь сделать запрос, ничего не получаю, каждый раз пишет, что файл "Rests" не найден и далее вылетает ошибка:
"Для ш=1 По DBFRests.КоличествоЗаписей() Цикл
{R:\DEMODB\EXTFORMS\EGAIS\OBMEN_EGAIS.ERT(2857)}: Значение не представляет агрегатный объект (КоличествоЗаписей)"
1) Может я что-то делаю не так?
2) Можно убрать эту ошибку, чтобы осталось только предупреждение!

И еще небольшой вопрос: сделал запрос по продукции и привязал далеко не все позиции, закрыл обработку, открыл потом заново, как продолжить привязку не делая заново запрос. В помощники я вижу не привязанные позиции, но и сделать с ними ничего не могу?

Спасибо, обработка классная!!!
436. knight 23.12.15 12:21 Сейчас в теме
Пытаюсь поставить на баланс остатки(версия 1.6.1). При подборе спрашивает количество(не дает ввести 100 дал только 10) и далее после добавления строки в списке столбцов нет количества(нельзя посмотреть сколько ввел). Не дает добавить еще одну строку с тем же товаром(разные даты розлива, ттн и т д необходимо ввести).
437. vin1c 23.12.15 14:04 Сейчас в теме
14:03:52 - Отправка акта Постановка на Баланс
14:03:55 - Отправка Акта успешно завершена
DBFRests.ЗакрытьФайл();
{E:\1CBASE\DB\EXTFORMS\EGAIS\OBMEN_EGAIS.ERT(5714)}: Значение не представляет агрегатный объект (ЗакрытьФайл)
но на остатки встал
и еще при вводе количества не могу больше 2 разрядов поставить в акте
451. alenaalenkina 23.12.15 17:21 Сейчас в теме
(449) на 438 можете ответить? если есть сохраненные ТТНки, как их вытянуть из Reply в приход? Можно ли через Входящие? Например, сделать кнопочку Выбрать документ/запрос/ответ и возможность выбора и загрузки ТТН из Reply в приход.
440. Brad 23.12.15 15:17 Сейчас в теме
Есть какой-нибудь универсальный способ определить что УТМ рабочая а не тестовая?
441. FogOfJokes 23.12.15 15:23 Сейчас в теме
по 435 попробуйте запросить остатки, тогда сформируется rests (у сегодня так было)
по 439 нужно зарегестрировать 1c++ или (автору) прошу в настройках добавить путь расположения библиотек формекс и 1с++ и тогда все встает на место, т.е. ЗагрузитьВнешнююКомпоненту("D:\EGAIS\Scaner1C.dll") . Я поправил код под себя и заработало. Автор молодец. Спасибо тебе!

Как мне поставить на баланс товар если его нет в справочниках товаров? Получается замкнутый круг: чтоб выгрузить остатки на баланс товар нужен из ЕГАИС, но его еще нет, т.к. нет введеных остатков в ЕГАИС чтоб их загрузить и сопоставить. Наверно есть справочник АП из ЕГАИС который можно загрузить а потом сопоставить при подборе в акт на баланс?
443. alenaalenkina 23.12.15 15:46 Сейчас в теме
(441) FogOfJokes, (441) нужно просто скачать и установить программку С++?
(443) alenaalenkina,
не пакет с++, а 1cpp.dll (все файлы папки dll) представленной в наборе скопировать в каталог Вашей БД Учетной системы (Торговли)
450. alenaalenkina 23.12.15 17:06 Сейчас в теме
(447) 447, я не знаю как наш IT специалист вашу инструкцию читал... Отсутствие данной утилиты? на что то влияет?
442. FogOfJokes 23.12.15 15:27 Сейчас в теме
Почему нужна настройка такая по ЗагрузитьВнешнююКомпоненту("D:\EGAIS\Scaner1C.dll").
Бывает в системе уже есть зарегестрированные эти библиотеки и они другой версии и находятся непонятн где, тогда ЗагрузитьВнешнююКомпоненту грузит не из папки с обработкой а по пути регистрации.
444. alenaalenkina 23.12.15 15:58 Сейчас в теме
Можно еще предложение создателю обработки, при постановке на баланс, ошибки можно увидеть только из вкладки Входящие, если открыть XML файл, что очень не удобно. Можно ли сделать, что то вроде всплывающего окна, где будет либо подтверждение акта (удачная постановка на баланс) либо надпись с указанием ошибки.
445. FogOfJokes 23.12.15 16:18 Сейчас в теме
к 443 это 1с++ или ее боле новая версия iC++
в папке dll автора правильная 3.0.0.0 только что проверил
446. FogOfJokes 23.12.15 16:52 Сейчас в теме
Люди! У кого есть загруженный/заполненный ЕГАИСовским товаром справочник tovar? Мне нужно сопоставить номенклатуру с номенклатурой ЕГАИС для постановки на баланс, а поставщики ничего еще не могут прислать чтоб сопоставить.
(446) FogOfJokes,
Товар можно загрузить по запросам через ИНН производителей/импортеров, но считаю что лучше его получить через работу с ТТН (входящие документы)...
Abris_d2058; +1 Ответить
454. knight 23.12.15 18:20 Сейчас в теме
(446) FogOfJokes, товар можно добавить в форму сопоставления не только из приходов , но и из расходов - выбирая собственные фактуры(продажи), единственное там чтобы расходы нормально работали возможно под себя править придется, приходы то сразу работают
457. FogOfJokes 23.12.15 19:40 Сейчас в теме
(454) из расходов они не добавляются, т.к. их нет в бд Tovar. Уже пробывал, я думаю логика здеь не такая. А вот импорт кнопкой продукция сработал, но при попытк выгрузить ghj,ye. накладную в тестовый УТМ выходит ошибка
- <A>
<error>org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '\S+(.*\S+)*' for type 'NoEmptyString50'.</error>
<ver>2</ver>
</A>
query файл по ссылке https://yadi.sk/d/Uhv3Qnj3mSDSU
Прошу помочь с понимание какое поле не заполнено
(457) FogOfJokes,

<!-- отправитель (обязательно) -->
<wb:Shipper>
<oref:ClientRegId/>
</wb:Shipper>
кто-то уже спрашивал... Заполните поле Код ЕГАИС рядом с Организацией пока по сути это Ваш ID...
Вопрос:
<!-- получатель (обязательно) -->
<oref:KPP>000000000</oref:KPP> <- это загрузился или откуда нули?
472. trofimovalexey 24.12.15 06:23 Сейчас в теме
(446) FogOfJokes,
Процедура НайтиПриход()
ЗаписатьСправочник1("Контрагенты",ФирмыТЗ);
ЗаписатьСправочник1("Производители",ФирмыТЗ);
ЗаписатьСправочник1("ЕгаисНоменклатура",АПТЗ);
	Д0=СоздатьОбъект("Документ.ПоступлениеТМЦ");  
	ДП=СоздатьОбъект("Документ.ПоступлениеТМЦ");  
	
	ПДД=Сред(ПриходДатаДок,9,2)+"."+Сред(ПриходДатаДок,6,2)+"."+Сред(ПриходДатаДок,3,2);
	Сообщить(ПДД);сч=0;                       
	Есть=0;
	Д0.ВыбратьДокументы();
	Пока Д0.ПолучитьДокумент()=1 Цикл          
Если (Д0.ДатаДокВходящий=Дата(ПДД))и(СОКРЛП(Д0.НомерДокВходящий)=СОКРЛП(ПриходНомерДок)) Тогда
Есть=1;	Сообщить(Строка("Найден Документ с такими Условиями (ДатаДокВходящий и НомерДокВходящий соответствуют условиям поиска)")+Строка(Д0));
ДП.НайтиДокумент(Д0.ТекущийДокумент());
//Прервать;
КонецЕсли;
	
КонецЦикла;   

	Если Есть=0 Тогда
		Сообщить("Не Найдено Поступление с ном. "+СОКРЛП(ПриходНомерДок)+" от "+Дата(ПДД)+". Прерываю");
	    Возврат;
	КонецЕсли; 
	
	ДП.ВыбратьСтроки();   
	Если ДП.Егаис=1 Тогда
		Сообщить("В поступлении Галка ЕГАИС. Прерываю");
	//    Возврат;
КонецЕсли;        


	Если Число(ДП.КоличествоСтрок())<>Число(ПриходТЗ.КоличествоСтрок()) Тогда
		Сообщить(Строка("Условия (КоличествоСтрок "+ДП.КоличествоСтрок()+" НЕ соответствуют "+ПриходТЗ.КоличествоСтрок()+" ). Прерываю ")+Строка(ДП)); Возврат; КонецЕсли;
	
	С=СоздатьОбъект("Справочник.ЕгаисНоменклатура");    
	
	
Пока ДП.ПолучитьСтроку()=1 Цикл  
	сч=сч+1;

	
ДП.КодЕгаис=(ПриходТЗ.ПолучитьЗначение(сч,"AlcCode")); 
ДП.КодСправкиА=(ПриходТЗ.ПолучитьЗначение(сч,"InformARegId")); 
ДП.КодСправкиБ=(ПриходТЗ.ПолучитьЗначение(сч,"InformBRegId")); 


Если ДП.Количество<>(ПриходТЗ.ПолучитьЗначение(сч,"Quantity")) Тогда Предупреждение("Поз "+сч+" Разное Количество. Стоп");
ОткрытьФорму(ДП.ТекущийДокумент(),,0);Возврат;КонецЕсли;

Если ДП.Цена<>(ПриходТЗ.ПолучитьЗначение(сч,"Price")) Тогда Предупреждение("Поз "+сч+" Разная Цена. Стоп");
ОткрытьФорму(ДП.ТекущийДокумент(),,0);Возврат;КонецЕсли;  

Если ДП.Номенклатура.Литраж<>(ПриходТЗ.ПолучитьЗначение(сч,"Capacity")) Тогда Предупреждение("Поз "+сч+" Разная Емкость. Стоп");
ОткрытьФорму(ДП.ТекущийДокумент(),,0);Возврат;КонецЕсли;    

ош=0;
ОбработкаСПР(ДП,сч,ош);
Если ош=1 Тогда
    Прервать;
КонецЕсли;
Сообщить((ПриходТЗ.ПолучитьЗначение(сч,"AlcCode")));

КонецЦикла;	

ДП.Егаис=1;

ДП.Записать();  
ОткрытьФорму(ДП.ТекущийДокумент(),,0);
	
		
КонецПроцедуры 
Показать

По сути "автоматически" сопоставляет позиции, при условии что всё по порядку идет в документе поступления
452. vin1c 23.12.15 17:34 Сейчас в теме
сделано в инвинтаризации увеличение разрядности подбора с 10 до 10000? или самому дописать?
455. vin1c 23.12.15 18:22 Сейчас в теме
я смотрю у тебя в модуле есть заремленные строки для базы данных внутри системы, у тебя есть решение без внешних дбф? т.к. у меня урбд 5 филлиалов и мне удобнее что бы все реквизиты были внутри РИБ.
(455) vin1c,
Я думаю сейчас отработаем все технологические процессы и перенесем систему хранения в 1с, для поддержки многопользовательской работы и РИБ ...
461. enter 16 23.12.15 21:50 Сейчас в теме
Подскажите, есть ли возможность сопоставить одной позиции номенклатуры ЕГАИС несколько "наших" позиций?
462. shag008 23.12.15 22:03 Сейчас в теме
Не получается "Проверить УТМ" через РДП
Ситуация: Из магазина подключаемся к 1с по РДП через интернет
Диски и папки локального компьютера доступны на сервере

Куда копать, кто сталкивался?
463. Гость 23.12.15 22:36
(462) shag008,
RDP тут не причем.
Если правильно понимаю:
УТМ на локальном компьютере в магазине, потом с магазина вы подключаетесь к серваку! и на серваке делаете запрос к УТМ (который установлен в магазине).
Если у вас на двух точках один и тот же провайдер и все две точки имеют выход в интернет через одну (ну т.е. я про VLAN говорю) - то тогда просто ip компа с УТМом указываете в 1с.

Ну а если интернет от разных провайдеров, то тогда только проброс портов - гемор конечно))


По закону, конечно требуется что бы УТМ был на каждом обособленном подразделении - это правонарушение может вскрыться только при везите представителей фсрар.
466. shag008 23.12.15 23:13 Сейчас в теме
(463) alanstorm, провайдеры разные, но есть vpn, т.е. локальный комп виден с сервера по айпи 192.168.х.х и в адресеУТМ прописано 192.168.х.х:8080
474. trofimovalexey 24.12.15 06:30 Сейчас в теме
(463) alanstorm, и то они пока приедут, пока ознакомятся, пока документы затребуют.... но 1 июля не за горами.
471. trofimovalexey 24.12.15 06:18 Сейчас в теме
(462) shag008, через VPN с магазина цепляться к сети сервака.
493. andre78 24.12.15 13:00 Сейчас в теме
(462) shag008,

Через RDP не будет виден токен на удаленном пк. Причина скорее всего в этом.
495. andre78 24.12.15 13:16 Сейчас в теме
(462) shag008,
попробуйте использовать VNC
464. Brad 23.12.15 22:44 Сейчас в теме
Насколько я понял из описания, при выгрузке реализации покупателю обработка данные по справкам А и Б подбирает автоматом (в зависимости от режимов "Использовать модуль Заказов" либо "Из текущих остатков ЕГАИС").

А как затем определить какие справки А и Б были зафиксированы в ЕГАИС из документ Реализация ? Это важно, т.к. надо будет собрать копии справок.

(464) Brad,
Ну я думаю что у всех ведется аля-партионный учет, или как кипу нужных документов подбираете..(не вручную же)..
Поэтому тут надо прикрутить Ваш модуль Сборки заказов, который укажет из Партии на нужную Справку Б и т.д....
468. Brad 23.12.15 23:47 Сейчас в теме
(465) Не совсем понял что значит прикрутить? Данные по справкам А и Б теперь получаем из ЕГАИС и при формировании ТТН на отгрузку необходимо использовать именно коды полученных из ЕГАИС справок. Т.е. вопрос - куда эти данные сейчас сохряняются?
467. Brad 23.12.15 23:44 Сейчас в теме
Плюс, как можно убрать ошибочную привязку?
Abris_d2058; +1 Ответить
469. Brad 23.12.15 23:49 Сейчас в теме
Господа, если кто еще не спит - скиньте плиз тестовую ТТН на
ИНН: 7813110500
ФСРАР_ИД: 010000006442
470. trofimovalexey 24.12.15 06:16 Сейчас в теме
Просьба к автору адаптировать форму под разрешение 1024*768
473. trofimovalexey 24.12.15 06:29 Сейчас в теме
Кнопка выбор поступления при нескольких нажатиях список увеличивает. еще кнопку печать туда нужно добавить. кавитации проработать тоже нужно. нужно блокировать реализацию, после отправки, и не давать ее проводить, пока не придёт квитанция.
475. trofimovalexey 24.12.15 06:44 Сейчас в теме
блин, windows 7 тоже недавно в списке был требований...
476. trofimovalexey 24.12.15 06:51 Сейчас в теме
 Процедура ПометитьВсехКонтраген(Таблица)
	Таблица.ВыбратьСтроки() ;
	Пока Таблица.ПолучитьСтроку()=1 Цикл 
		Если ЛЕВ(Таблица.ОтветВид,10)="Контрагент" Тогда
		    
		Таблица.УстановитьЗначение(Таблица.НомерСтроки,"Отметка",МеткаЕсть);
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры   
Показать

Удалить контрагентов из запросов егаис (пометить только их)
4223031592; +1 Ответить
478. trofimovalexey 24.12.15 06:54 Сейчас в теме
Процедура ЗаписатьСправочник1(СпрНазвание,ТЗ)
	Ном=0;

	Если СпрНазвание = "Контрагенты" Тогда							
	ВсегоЭлементов = ТЗ.КоличествоСтрок();
	
	ТЗ.ВыбратьСтроки();	    		
	Пока ТЗ.ПолучитьСтроку() = 1 Цикл
		Если ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,"Отметка")=МеткиНет тогда
			Продолжить;
		КонецЕсли;			
		Ном=Ном+1;Состояние("Обрабатываем "+Ном+"-й элемент из "+ВсегоЭлементов+" ("+Окр(100*Ном/ВсегоЭлементов,2)+" %)");
		Если СпрНазвание = "Контрагенты" Тогда							
		С=Создатьобъект("Справочник.Контрагенты");
		С.ВыбратьЭлементы();
		Пока С.ПолучитьЭлемент()=1 Цикл
		    Если (СОКРЛП(С.ИННЮрЛица)=СОКРЛП(ТЗ.INN))и(СОКРЛП(ТЗ.INN)<>"") Тогда  
		    Сообщить("ИНН нашел");

	Спр = СоздатьОбъект("Справочник.ФактическиеАдреса");
	Спр.ИспользоватьВладельца(С.ТекущийЭлемент());
	Спр.ПорядокКодов();
	Спр.ВыбратьЭлементы();
	Пока Спр.ПолучитьЭлемент() = 1  Цикл
	Если Спр.ПометкаУдаления() = 1 Тогда
	Продолжить;
	КонецЕсли;
	
			Если (СОКРЛП(Спр.КПП)=СОКРЛП(ТЗ.KPP))и(СОКРЛП(ТЗ.KPP)<>"") Тогда
		    Сообщить("КПП нашел");
			
			
		    Если СокрЛП(Спр.КодЕГАИС)="" Тогда
		    Сообщить("для справочника ФактическиеАдреса с кодом:"+Строка(Спр.Код)+" Записываю код Егаис "+ТЗ.ClientRegId);
			Спр.КодЕГАИС=ТЗ.ClientRegId;
			СЗаписать(Спр);
			КонецЕсли;  
		
		  //  Если СокрЛП(Спр.АдресЕГАИС)="" Тогда
		    Сообщить("для справочника ФактическиеАдреса с кодом:"+Строка(Спр.Код)+" Записываю Адрес Егаис "+ТЗ.description);
			Спр.АдресЕГАИС=Лев(ТЗ.description,150);
			Спр.FullName=СокрЛП(ТЗ.FullName);
			Спр.ShortName=СокрЛП(ТЗ.ShortName);
			Спр.ИНН=СокрЛП(ТЗ.INN);
			Спр.Страна=СокрЛП(ТЗ.Country);
			Спр.Регион=СокрЛП(ТЗ.RegionCode);
			Спр.Страна=СокрЛП(ТЗ.Country);
			СЗаписать(Спр);
			//КонецЕсли;
			КонецЕсли;
		
		
		
			КонецЦикла;
	

		  
		    КонецЕсли;
		КонецЦикла;
			
			
			
		КонецЕсли;					
	КонецЦикла;    
	
	
ИначеЕсли СпрНазвание = "Производители" Тогда	
	
		ВсегоЭлементов = ТЗ.КоличествоСтрок();
	
	ТЗ.ВыбратьСтроки();	    		
	Пока ТЗ.ПолучитьСтроку() = 1 Цикл
		Если ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,"Отметка")=МеткиНет тогда
			Продолжить;
		КонецЕсли;			
		Ном=Ном+1;Состояние("Обрабатываем "+Ном+"-й элемент из "+ВсегоЭлементов+" ("+Окр(100*Ном/ВсегоЭлементов,2)+" %)");
		Если СпрНазвание = "Производители" Тогда							
		С=Создатьобъект("Справочник.Производители");
		С.ВыбратьЭлементы();
		Пока С.ПолучитьЭлемент()=1 Цикл   
			Если С.ПометкаУдаления()=1 Тогда Продолжить;	КонецЕсли;
		    Если (СОКРЛП(С.ИНН)=СОКРЛП(ТЗ.INN)) Тогда   
		    Сообщить("ИНН нашел");
		    Если (СОКРЛП(С.КПП)=СОКРЛП(ТЗ.KPP)) Тогда   
		    Сообщить("КПП нашел");
			
			Если С.Импортер.Выбран()=0 Тогда
		
			С.Адрес=Лев(ТЗ.description,150); 
			Сообщить(С.Код);
			Сообщить(ТЗ.ClientRegId);
			С.КодЕГАИС=СОКРЛП(ТЗ.ClientRegId); 
			С.Код=СОКРЛП(ТЗ.ClientRegId); 
			С.АдресЕГАИС=Лев(ТЗ.description,150);
			С.FullName=СокрЛП(ТЗ.FullName);
			С.ShortName=СокрЛП(ТЗ.ShortName);
			С.ИНН=СокрЛП(ТЗ.INN);
			С.Страна=СокрЛП(ТЗ.Country);
			С.Регион=СокрЛП(ТЗ.RegionCode);
			С.Страна=СокрЛП(ТЗ.Country);
		Попытка 	С.Записать();Исключение ОШ("С","Объект заблокирован, либо код не уникален"); КонецПопытки;
		
			КонецЕсли;
		
		КонецЕсли;
		КонецЕсли;
		
		КонецЦикла;
			КонецЕсли;
	КонецЦикла;  
		
	//2      
	
		ВсегоЭлементов = ТЗ.КоличествоСтрок();
	
	ТЗ.ВыбратьСтроки();	    		
	Пока ТЗ.ПолучитьСтроку() = 1 Цикл
		Если ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,"Отметка")=МеткиНет тогда
			Продолжить;
		КонецЕсли;			
		Ном=Ном+1;Состояние("Обрабатываем "+Ном+"-й элемент из "+ВсегоЭлементов+" ("+Окр(100*Ном/ВсегоЭлементов,2)+" %)");
		Если СпрНазвание = "Производители" Тогда							
		С=Создатьобъект("Справочник.Импортеры");
		С.ВыбратьЭлементы();
		Пока С.ПолучитьЭлемент()=1 Цикл
		    Если (СОКРЛП(С.ИНН)=СОКРЛП(ТЗ.INN)) Тогда   
		    Сообщить("ИНН нашел");
		    Если (СОКРЛП(С.КПП)=СОКРЛП(ТЗ.KPP)) Тогда   
		    Сообщить("КПП нашел");
			
		
			С.Адрес=Лев(ТЗ.description,150); 
			С.КодЕГАИС=ТЗ.ClientRegId; 
			С.АдресЕГАИС=Лев(ТЗ.description,150);
			С.FullName=СокрЛП(ТЗ.FullName);
			С.ShortName=СокрЛП(ТЗ.ShortName);
			С.ИНН=СокрЛП(ТЗ.INN);
			С.Страна=СокрЛП(ТЗ.Country);
			С.Регион=СокрЛП(ТЗ.RegionCode);
			С.Страна=СокрЛП(ТЗ.Country);
			Сообщить(С.Код);
			С.Записать();
		
		
		КонецЕсли;
		КонецЕсли;
		
		КонецЦикла;
			КонецЕсли;
	КонецЦикла;

ИначеЕсли СпрНазвание = "ЕгаисНоменклатура" Тогда
	
		ВсегоЭлементов = ТЗ.КоличествоСтрок();
	
	ТЗ.ВыбратьСтроки();	    		
	Пока ТЗ.ПолучитьСтроку() = 1 Цикл
		Если ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,"Отметка")=МеткиНет тогда
			Продолжить;
		КонецЕсли;			
		Ном=Ном+1;Состояние("Обрабатываем "+Ном+"-й элемент из "+ВсегоЭлементов+" ("+Окр(100*Ном/ВсегоЭлементов,2)+" %)");
		Если СпрНазвание = "ЕгаисНоменклатура" Тогда							
		
			
			
			


			
		С=Создатьобъект("Справочник.ЕгаисНоменклатура");
Сообщить(ТЗ.AlcCode);
	Если С.НайтиПоКоду(СОКРЛП(ТЗ.AlcCode))=1 Тогда
Сообщить("нашел");
С.FullName=АПТЗ.FullName;
		С.Литраж=АПТЗ.Capacity;
		С.Крепость=АПТЗ.AlcVolume;
		С.Категория=АПТЗ.ProductVCode;
	Иначе         
Сообщить("новый");
		
		С.Новый();   
		С.Код=АПТЗ.AlcCode;
		С.FullName=АПТЗ.FullName;
		С.Литраж=АПТЗ.Capacity;
		С.Крепость=АПТЗ.AlcVolume;
		С.Категория=АПТЗ.ProductVCode;
		
	КонецЕсли;   
	
	

     Если СОКРЛП(АПТЗ.ImporterRegId)<>"" Тогда  //КодЕГАИС Импортера
  	СИП=Создатьобъект("Справочник.Импортеры");
Сообщить("Код Импортера "+АПТЗ.ProducerRegId);
   		СИП.ВыбратьЭлементы(0);	    		
Пока СИП.ПолучитьЭлемент() = 1 Цикл
			Если СОКРЛП(СИП.КодЕГАИС)=(СОКРЛП(АПТЗ.ImporterRegId)) Тогда
           С.Импортер=СИП.ТекущийЭлемент();
	КонецЕсли; 
КонецЦикла;

	КонецЕсли;
	
   Если СОКРЛП(АПТЗ.ProducerRegId)<>"" Тогда  //КодЕГАИС Производителя  
Сообщить("Код произв. "+АПТЗ.ProducerRegId);
   	
  	СИП=Создатьобъект("Справочник.Производители");
   		СИП.ВыбратьЭлементы(0);	    		
Пока СИП.ПолучитьЭлемент() = 1 Цикл
			Если СОКРЛП(СИП.КодЕГАИС)=(СОКРЛП(АПТЗ.ProducerRegId)) Тогда
           С.Производитель=СИП.ТекущийЭлемент();
		КонецЕсли;  
КонецЦикла;
		КонецЕсли;  
			
		
		

		Сообщить(С);
		С.Записать();
		
		КонецЕсли;
		
	
	КонецЦикла;  
		
Иначе
	Предупреждение("ytn nfrjuj dfhbfynf");
КонецЕсли;

КонецПроцедуры    
Показать


авто обновление реквизитов справочников
Оставьте свое сообщение
Вопросы с вознаграждением