Обмен с ЕГАИС из 1С V7.7

0. Техподдержка 09.11.15 00:39
Дорогие друзья! Предлагаю Вашему вниманию обработку, предназначенную для обмена данными из Вашей учетной системы с ЕГАИС, через универсальный транспортный модуль (УТМ).
В обработке реализован весь функционал обмена:
- загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции;
- загрузка справочных данных по номенклатуре алкогольной продукции;
- загрузка остатков;
- помощник сопоставления справочных данных и запись их в базу данных;
- загрузка приходных ТТН и справок Б от поставщиков, отправка по ним актов всех типов, создание по ним приходных документов;
- выгрузка расходных ТТН покупателям;
- управление Марками и ведение Регистра 3;
Обработку возможно использовать автономно, не внося изменений в Вашу Учетную систему.
Код открыт.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
836. vin1c 13.01.16 00:19 Сейчас в теме
(826) garageinfo, я дописал модуль что у меня контрагент берется из реквизита склада из перемещения. т.е в расходные документы в настройки добавил еще и перемещение.
852. garageinfo 13.01.16 10:16 Сейчас в теме
(836) vin1c, А если не сложно, можете код скинуть, можно в личку, очень нужно....
253. Гость 15.12.15 20:35
Добрый день!
Не могу понять почему не выполняется
АдресУТМ ="192.168.2.201:8080";
ФайлОтвета = "\\192.168.2.200\exchange\egais\vinta\reply.xml";
КомандаСистемыСрипт("curl -X GET http://"+СокрЛП(АдресУТМ)+">"+ФайлОтвета);

1с 7.7 Выполняю на windows 10, а файл хочу сохранить на комп в локальной сети.
На компьютере с ip 192.168.2.201 УТМ и JaCarta.
Сохраняется файл с нулевым размером, т.е. пустой.

Когда эту же строку выполняю в cmd на win 10, то все работает успешно.
255. ivanov_alex 43 15.12.15 21:29 Сейчас в теме
Автору- как сразу кучей отправить 700-1000 реализаций в егаис, ну так, чтобы не сидеть по одной не выбирать из кучи-малы..и как отправить алкогольную и неалькогольную продукцию? упаковка, типа паеты покупателям и прочее? первый вопрос более актуален
(255) ivanov_alex,
а всё с этой 1000 ТТН хорошо? т.е. каждая позиция привязана и имеется на остатках в ЕГАИС достаточное количество?
вообще этот вопрос прорабатывается ... и вывод пока такой, что массовой отправкой должен заниматься Логист при составлении маршрутов доставки...
но к этому моменту они должны быть проверены и подтверждены по остаткам в ЕГАИС (иначе отправить не получится)..
как то так...
262. ivanov_alex 43 16.12.15 06:54 Сейчас в теме
(256) а не обязательно чтоб было прям все хорошо, по каким позициям нет остатков не отправлять ттн и все
но основные остатки заводятся и они буду на балансе в егаис
Друзья! В архив добавлена Инструкция к применению...
Скачивайте надеюсь станет яснее....
271. alenaalenkina 16.12.15 11:57 Сейчас в теме
(263) скажите пожалуйста, я нажала кнопку Удалить все запросы и документы во вкладке Входящие, я что удалила все приходные ТТН, которые еще висели в не принятых (когда нажимаешь Приход была куча ТТН, после удаления ничего не осталось), я вообще думала, что удаляю только текущие запросы, типа контрагенты, номенклатуру. Их как то можно восстановить? Если нет - это БЕДА.
280. Evgen3030 16.12.15 14:55 Сейчас в теме
(263)(263) Здравствуйте. Где находится архив с инструкцией ?
282. alenaalenkina 16.12.15 15:52 Сейчас в теме
(280) Evgen3030, в той ссылке через которую первый раз скачивали архив.
285. Evgen3030 16.12.15 17:34 Сейчас в теме
(282) alenaalenkina, нашел, спасибо.
266. vin1c 16.12.15 10:37 Сейчас в теме
запускаю помощник синхронизации номенклатуры жму "обновить данные егаис" и вылетает ошибка ттСравнений.Подвал.ОбновитьСтроки() значение не представляет агрегатный объект подвал.
(266)
Помощник в доработке..
Выложен для представления и сбора Ваших предложений. .
273. garageinfo 16.12.15 12:13 Сейчас в теме
Коллеги, прошу помощи!!!! Кто знает, как зарегистрировать 1CPP.dll и FormEx.dll под Windows Server 2008 R2 (x64). Пробовал dll кидать и в папку SysWoW64 и в System32 все едино - ошибка "Не удалось загрузить модуль C:\Windows\SysWoW64\1CPP.dll" с FoemEx.dll та же история ((((. Помогите, у кого получилось зарегить их.
277. irkis 16.12.15 13:23 Сейчас в теме
(273) garageinfo,
1. положи DLL в папочку BIN например,
2. скачай Регистрация DLL
3. этой обработкой зарегь DLLки
4. И попробуй 1 раз запустить 1с и воспользоваться обработкой под правами администратора (правой мышкой на ярлык 1с, запустить от админа)
garageinfo; +1 Ответить
278. garageinfo 16.12.15 13:42 Сейчас в теме
(277) irkis, спасибо, большое! Вроде получилось, но все равно нет цветового выделения как описано, когда привязаны номенклатура и контрагенты (зеленое), а когда не привязаны - розовое.
275. Abris_d2058 16.12.15 12:17 Сейчас в теме
Здравствуйте, автор! Помогите настроить. Все сделано как в Инструкции к применению.
Все равно ошибка.
"Ответ от УТМ не получен: Проверьте :
1. Вставлен ключ?..
2. Запущена служба:Transport?..
3. Перезагрузите обработку.."
Прикрепленные файлы:
284. Abris_d2058 16.12.15 17:16 Сейчас в теме
276. viktorn 16.12.15 13:12 Сейчас в теме
Что делается с актом подтверждения, расхождения, отказа?
281. akmaria 16.12.15 15:13 Сейчас в теме
Здравствуйте, нужна удобная программа для оптовой торговли с пивом по ЕГАИС. Учет ведем в Торговле и склад 7.7 релиз 7.70.957. Подойдет ли ваша программа для нас?
283. igor32499 16.12.15 17:08 Сейчас в теме
Привет всем.
Экспериментирую с обработкой, появились вопросы:
1. пришли две, почему то, квитанции на на мое подтверждение приходной накладной, что с ними делать? просто удалить?
2. После того как используешь помощника, где подключаются 1cpp и formex, при выходе из 1с постоянно вылетает ошибка.
Предложение
1. Сделать при выборе реализации отбор по контрагенту.
Друзья в личке (сообщения) возникли проблемы, админы сайта занимаются...
пока сообщения не отправляются...
292. skol 17.12.15 09:01 Сейчас в теме
Использовал авторегистрацию DLL-ек. При вызове Помощника всё равно выдаёт "Не удалось загрузить 1с++ и FormEx".
Господа, крик о помощи. Кто-нибудь может отправить ТТН на ID ФС РАР 020000668273? Никак не доберутся до меня поставщики, а проверить хочется. Заранее благодарен.
300. Abris_d2058 17.12.15 12:23 Сейчас в теме
(292) skol, такая же проблема. и УТМ не определяется
313. Abris_d2058 17.12.15 18:39 Сейчас в теме
(292) skol, решили проблему? у нас получилось так:
длл зарегистрировали под админом
сделали запуск 1с только с админ. правами.
Обработка обмен_егаис, три длл и обработкой хелпегаис - все положили в каталог базы. Только тогда заработало.
324. skol 18.12.15 07:16 Сейчас в теме
(313) Abris_d2058,
Большое спасибо!!!!! Заработало!
295. garageinfo 17.12.15 10:31 Сейчас в теме
rvs-slim, писал Вам в личку, продублирую сюда, может тут ответите.
Помогите с адаптацией вашей обработки к нашей 1С.
1. Хоть я и зарегистрировал 1CPP и FormEX, нет цветовой кодировки как на Ваших картинках, хотя ошибок по незарегистрированным dll нет.
2. Помогите адаптировать этот код:
ТекстПривязкиСтр = "Код: "+Эл.Код+" "+Эл.Наименование+" ИНН/КПП: "+Эл.ЮрФизЛицо.ИНН+ " Адрес: "+Эл.ЮрФизЛицо.АдресАкцизногоСклада;
Нам нужно, что бы адрес брался из контрагент -> алкоголь -> основная лицензия -> область действия -> адрес разгрузки.
3. Невозможно вручную сделать привязку номенклатуры, автоматически не сопоставляет, а если вручную кликаешь по полю КОД БД, то открывает номенклатуру, но не дает выбрать нужную (открываются свойства номенклатуры). Как это исправить?
299. igor32499 17.12.15 11:35 Сейчас в теме
(295) garageinfo,
1. Судя по коду, раскраски там сейчас нет, только в помощнике (или я не туда смотрю)
2. Знать бы, что у вас в этом пути, вдруг это у вас не простые ссылки, а то все просто через точку )))
3. Знать бы опять же вашу конфигурацию, но предполагаю что ТиС или Комплексная, я пока переписал в самой конфигурации Справочник Номенклатура форма для выбора
Процедура ПриОткрытии()
	
	Парам = Форма.Параметр;

	Если ТипЗначенияСтр(Парам) = "СписокЗначений" Тогда

		АктивизироватьОбъект(Парам.Получить("ТекЭлемент"));
		Форма.ОбработкаВыбораСтроки(1); 
// Вот этого не хватало
	ИначеЕсли Форма.Параметр = "Выбор"  Тогда
	    Форма.ОбработкаВыбораСтроки(1);
// Финал
	КонецЕсли;

  	
	Если ПустоеЗначение(Константа.ВидСвойстваНоменклатуры) = 0  Тогда
		Форма.Свойство.Заголовок(Строка(Константа.ВидСвойстваНоменклатуры));
	Иначе
		Форма.Свойство.Видимость(0);
	КонецЕсли;
	
КонецПроцедуры // ПриОткрытии()

Процедура ПриВыбореСтроки()
	
	Если ТипЗначенияСтр(Парам) = "СписокЗначений" Тогда
		Форма.Параметр.Установить("СтатусВозврата", 1);
		Форма.Параметр.Установить("ВыбЗначение", ТекущийЭлемент());
		Форма.Закрыть();    
// Вот этого не хватало
	ИначеЕсли Форма.Параметр = "Выбор"  Тогда
		Форма.Параметр = ТекущийЭлемент();
		Возврат;	
// Финал
	КонецЕсли;

	
КонецПроцедуры // ПриВыбореСтроки()


Показать
garageinfo; +1 Ответить
301. garageinfo 17.12.15 12:34 Сейчас в теме
(299) igor32499, Огромное Вам спасибо! По пункту 3 очень помогли, теперь номенклатуру хотя бы можно выбрать руками. Но это плохой вариант как выяснилось... Кто знает/поможет, как можно сделать сопоставление номенклатуры не по названию а по коду ЕГАИС (который имеет формат 0177402000001390189). Дело в том, что так как мы импортеры, то но всю нашу продукцию в базе 1С имеем коды ЕГАИС, а вот названия в 1С сильно короче чем в ЕГАИС из-за этого при поиске не находит ни одной похожей позиции в номенклатуре.
(301) garageinfo,
Ок. сделаем и по коду давайте только обзовем этот атрибут:AlcCode как в ЕГАИС!!!
296. trofimovalexey 17.12.15 10:39 Сейчас в теме
Вынесите в фору такие данные, как ИНН покупателя, Адрес.... чтоб можно было свою обработку заполнения формы придумать. так проще будет. Вообще я считаю, что это работа Центринформа, создать оболочку.
297. igor32499 17.12.15 10:46 Сейчас в теме
При отправке расходных накладных наименование товара берется из базы справочника номенклатуры, и если забито не так как в ЕГАИС, то потом приходит ответ "Документ обработан c предупреждениями: Наименование продукции отличается от справочника. ", не смертельно, но на будующее
ivanov_alex; +1 Ответить
298. trofimovalexey 17.12.15 11:02 Сейчас в теме
т.е. хотелось бы увидеть все данные в форме перед отправкой. Тогда мы сами сможем прикрутить кнопку для заполнения этой формы, и задача намного упростится как с нашей, так и с вашей стороны. Нужно переработать в данном направлении приходные и расходные накладные, а кнопку заполнить мы уже подправим под себя...
303. ivanov_alex 43 17.12.15 14:01 Сейчас в теме
Вопрос автору:
в документе реализация две строки с одинаковым товаром, егаис такого не хочет и отбил назад накладную
есть ли возможность свернуть такие строки если попались в документе?
308. Union37 17.12.15 15:52 Сейчас в теме
Есть ли возможность проверить соответствие накладным с помощью сканера до подтверждения? (приходуется дорогой алкоголь, покупателя можно ждать годами)
309. alenaalenkina 17.12.15 15:53 Сейчас в теме
Еще одна ошибка. Что она означает?
Прикрепленные файлы:
(309) alenaalenkina,
вместе с сообщением об ошибке должен запуститься браузер с открытым файлом в котором ошибка....
311. kaa100 17.12.15 16:30 Сейчас в теме
Тип контура определяет установленный модуль УТМ, установил realegaissetup.exe - работаешь в продуктивном, установил testEGAISsetup.exe - в тестовом. Чтобы не заморачиваться с именами службы и портами, ставим из на разные машины с разными IP. В обработке соответственно надо указать IP:8080 машины.
312. enter 16 17.12.15 17:51 Сейчас в теме
Не могу найти curl, работающий в Windows Server 2008 R2 Enterprise
(312) enter,
По ссылке в описании нет???
Удивительно. . проверю. ...
317. enter 16 17.12.15 20:02 Сейчас в теме
(314)
По ссылке в описании нет???
Удивительно. . проверю. ...
-- по какой ссылке и в каком описании?
318. SvSoft 80 17.12.15 21:05 Сейчас в теме
(317) По ссылке на curl в описании данной обработки
316. enter 16 17.12.15 19:58 Сейчас в теме
На одном компе с Win7 Ultimate 64 обработка работает с УТМ нормально. На другом Win7 Максимальная 32 все вроде так же настроено и установлено, но при проверке УТМ получаю:
"Ответ от УТМ не получен: Проверьте :
1. Вставлен ключ?..
2. Запущена служба:Transport?..
3. Перезагрузите обработку.."

Если же один раз после открытия обработки перейти по кнопке выбора пути в Каталог БД соответствий, приведенные выше сообщения уже не выходят, при проверке УТМ открывается окно эксплорера с отображением версии УТМ, а рядом с кнопкой "проверить УТМ" появляется надпись "остановлено".

Ключ в Едином клиенте JaCarta виден.
По РЕГИСТРАЦИИ DLL:
Поместите файлы dll в каталог БД (Вашей конфигурации)
с помощью программы Регистрации зарегистрируйте их перегрузите 1с
все лучше все это сделать под Админом...
а то вижу Ваши скрины... у кого-то все белым бело, не поймешь что-привязано, что-нет...
323. skol 18.12.15 07:10 Сейчас в теме
(319)
Всё сделал как Вы написали. Всё равно при вызове Помощника говорит, что не удалось.
Windows Server 2008 R2 Enterprise
Прикрепленные файлы:
(323) skol
Помощника допилю к понедельнику..
Пока к нему только Ваши предложения. .
326. akmaria 18.12.15 09:06 Сейчас в теме
Здравствуйте, нужна удобная программа для оптовой торговли с пивом по ЕГАИС. Учет ведем в Торговле и склад 7.7 релиз 7.70.957. Подойдет ли ваша программа для нас?
(326) akmaria,
Удобство..понятие субъективное. .
Обработка совершенствуется..
Во многом благодаря Вашим предложениям. .
327. vostrikova 18.12.15 13:04 Сейчас в теме
Пришлите, пожалуйста, инструкцию по использованию обработки!!! khrapova@vcbalance.ru
(327) khrapova@vcbalance,
Качайте архив. Она в нем. ..
331. enter 16 18.12.15 13:53 Сейчас в теме
Не могу установить на Windows Server 2008 64. Требует одну DLL за другой. Нельзя выложить набор этих DLL?
335. skol 18.12.15 14:43 Сейчас в теме
(331) enter,
У меня тоже Windows Server 2008 64. Уточните, ЧТО установить? Если Вы про DLL-ки, см. 313 сообщение и ответ на него. Или что Вы имеете ввиду?
337. enter 16 18.12.15 15:11 Сейчас в теме
(335) skol,
нам 313 не помогло. После установки С++ все заработало. Ссылка на дистрибутив С++ в моем комментарии 332.
(332) enter,
Да ладно! Не может быть. ..
334. enter 16 18.12.15 14:34 Сейчас в теме
(333)
мне не смешно. Если Вы считаете, что все об этом знают, то Вы глубоко заблуждаетесь. Если Вы писали об этом в своем руководстве, прошу указать мне это место.
(334) enter,
Да я действительно удивлен!
У нас работает без допов..
338. garageinfo 18.12.15 16:42 Сейчас в теме
Коллеги, у кого работает цветовая раскраска, то что привязано, а что нет? У меня, хоть убей не работает, хотя все библиотеки подключены. Уже не знаю куда копать
339. igor32499 18.12.15 20:37 Сейчас в теме
(338) garageinfo, Где именно не работает в помощнике, в поиске, в самой обработке?
(338) garageinfo,
Про цветоаые схемы:
Накануне Коллега обратился за помощью по этому вопросу. ..
В итоге обнаружено: в глобальном модуле уже была регистрация библиотек...каких то версий и т.п. правда не использовалась...но грузилась.. и требуемой функции не выполняла. .
Подправили заработало. ..
garageinfo; +1 Ответить
374. serg75 21.12.15 19:13 Сейчас в теме
(372) В каких процедурах, какие библиотеки ?
340. viktorn 18.12.15 23:55 Сейчас в теме
Что делается с Акт ТТН (подтверждение накладной)?
Как отслеживаются в программе действия с накладной (подтверждение, расхождение, отказ)?
(340) viktorn,
В описании вкладка Расход вторая половина этому посвящена...
342. sodrk 20.12.15 10:41 Сейчас в теме
Отправьте, пожалуйста, ТТН.
ИНН: 1101016665
ФСРАР_ИД: 030000057193
(342) sodrk,
Давайте писать еще и КОНТУР в котором работаете
-Тестовый...
-Рабочий...
357. sodrk 21.12.15 09:07 Сейчас в теме
343. vostrikova 20.12.15 13:05 Сейчас в теме
Не проходит проверку УТМ((( пишет:
Ответ от УТМ не получен: Проверьте :
1. Вставлен ключ?..
2. Запущена служба:Transport?..
3. Перезагрузите обработку..

ПРоверяю:
1) Единый клиент JaCarta видит ключ, в личный кабинет ЕГАИС зайти могу;
2) служба запущена, по адресу localhost:8080 выдается инф-я по УТМ, т. е. УТМ функционирует;
3) перезугружали много-много раз.

В чем может быть проблема? Может ли играть роль релиз ТИС? У нас просто стоит очень старый релиз. МОжет стоит обновить до последнего?
(343) khrapova@vcbalance,
Нет при подключении роли не играет версии и т.п.
Важно:
Адрес службы: (локальный(localhost) или удаленный(192.168.*.*))
Порт (8080)
Всякого рода Антивирусы (...)
(343)
Ну еще и curl конечно же это самое наверно проблемное место...
1. curl.exe должна находится в каталоге который у вас прописан как временный для обмена...
2. curl.exe должна запускаться т.е. необходимо просто ее запустить! если увидели мелькнувшее черное окошко все ок!, нет качайте версию для своей системы ( ссылка в описании)
344. fotonn 20.12.15 15:02 Сейчас в теме
Не совсем понял как в Акт постановки на баланс попадают коды акцизных марок .MarkCodeInfo (2D кот. надо сканировать)
Поясните пожалуйста.
Сегодня постараюсь выложить версию 1.6 и описание обновленное...
349. vin1c 20.12.15 23:47 Сейчас в теме
Ставлю пиво на остаток, выбрал оприходование, при отправке пишет что нет отсканированых марок, у меня пиво у меня нет марок, ввел вручную штрих код бутылки все равно ругается,что делать?
(349) vin1c,
Скачивайте новую версию, проверьте с пивом должно быть ок..
351. vin1c 21.12.15 00:55 Сейчас в теме
а как программа поймет что это пиво а не водка?
(351) vin1c,
Да сделано многоступенчатое выяснение что товар - пиво...
352. trofimovalexey 21.12.15 06:36 Сейчас в теме
Вобще есть спр категории товара. на пиво коды идут свои. по этим кодам можно идентифицировать товар(пиво/не пиво). как то так
Функция ПроставитьКодыОптовые(к)   

С=СоздатьОбъект("Справочник.ВидПродукции");
С.ВыбратьЭлементы();
Если к=1 Тогда
С.Новый();С.Код=1;С.Наименование="безалкогольное вино";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=200;С.Наименование="Водка";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=229;С.Наименование="Коньяк и арманьяк, реализуемые в бутылках";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=232;С.Наименование="Бренди";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=320;С.Наименование="Виноматериалы";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=340;С.Наименование="Дестилят Винный";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=400;С.Наименование="Вина натуральные";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=401;С.Наименование="Вино (виноградное)";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=403;С.Наименование="Вино (виноградное столовое)";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=410;С.Наименование="Вина (за исключением натуральных, игристых и шампанских)";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=420;С.Наименование="Вина плодовые";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=440;С.Наименование="Вина игристые";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=450;С.Наименование="Вина шампанские";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=300;С.Наименование="Дестилят Коньячный";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=310;С.Наименование="Дестилят Кальвадосный";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=350;С.Наименование="Другая спиртосодержащая пищевая продукция";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=360;С.Наименование="Дестилят Виноградный";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=380;С.Наименование="Дестилят Висковый";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=370;С.Наименование="Дестилят Плодовый";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=460;С.Наименование="Другие вина";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=270;С.Наименование="Другие спиртные напитки с содержанием этилового спирта до 25% включительно";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=402;С.Наименование="Вино с защищенным географическим указанием или с защищенным наименованием места происхождения";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=421;С.Наименование="Фруктовое (плодовое) вино";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=461;С.Наименование="Винный напиток с объемной долей этилового спирта от 1,5% до 22%, произведенный без добавления этилов";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=462;С.Наименование="Винный напиток с объемной долей этилового спирта от 1,5% до 22%, произведенный с добавлением этилово";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=280;С.Наименование="Другие спиртные напитки с содержанием этилового спирта свыше 25%";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=60;С.Наименование="Другие спирты,  исключением денату-рированных (гидролиз-ный,  технический и другое)";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=231;С.Наименование="Коньяки обработанные, предназначенные для отгрузки с целью розлива на других предприятиях или промпе";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=230;С.Наименование="Коньяки, реализуемые в бутылках";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=211;С.Наименование="Ликероводочные изделия с содержанием этилового спирта до 25% включительно";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=212;С.Наименование="Ликероводочные изделия с содержанием этилового спирта свыше 25%";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=250;С.Наименование="Напитки винные с содержанием этилового спирта до 25% включительно";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=251;С.Наименование="Напитки винные с содержанием этилового спирта свыше 25%";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=241;С.Наименование="Напитки коньячные, бренди с содержанием этилового спирта до 25% включительно";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=242;С.Наименование="Напитки коньячные, бренди с содержанием этилового спирта свыше 25%";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=520;С.Наименование="Напитки,  изготавливаемые на  основе пива";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=120;С.Наименование="Пиво";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=500;С.Наименование="Пиво с  содержанием объемной  доли этилового спирта  свыше 0,5 %  и до 8,6%  включительно";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=510;С.Наименование="Пиво с содержанием объемной  доли этилового спирта  свыше 8,6 %";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=92;С.Наименование="Промежуточная фракция этилового спирта из пищевого сырья";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=260;С.Наименование="Слабоалкогольная продукция";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=331;С.Наименование="Соки сброженно-спиртованные";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=330;С.Наименование="Соки спиртованные";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=50;С.Наименование="Спирт этиловый абсолютированный";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=80;С.Наименование="Спирт этиловый денатурированный из непищевого сырья";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=70;С.Наименование="Спирт этиловый денатурированный из пищевого сырья";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=30;С.Наименование="Спирт этиловый из ЭАФ";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=100;С.Наименование="Спирт этиловый по фармакопейным статьям";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=25;С.Наименование="Спирт этиловый ректификованный из непищевого растительного сырья";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=20;С.Наименование="Спирт этиловый ректификованный из пищевого сырья";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=40;С.Наименование="Спирт этиловый синтетический";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=10;С.Наименование="Спирт-сырец этиловый из пищевого сырья";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=90;С.Наименование="Фракция головная этилового спирта";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=91;С.Наименование="Фракция головных и промежуточных примесей этилового спирта";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=998;С.Наименование="ПРОЧЕЕ";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=999;С.Наименование="ПРОЧЕЕ";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=34;С.Наименование="Вина плодовые специальные";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=17;С.Наименование="Коньячные напитки (включая бренди)";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=11;С.Наименование="Водка";Попытка С.Записать(); Исключение КонецПопытки;
С.Новый();С.Код=140;С.Наименование="Спирт этиловый питьевой";Попытка С.Записать(); Исключение КонецПопытки;
Иначе
Пока С.ПолучитьЭлемент()=1 Цикл
С.Удалить();
Сообщить(с);
КонецЦикла;

КонецЕсли;
КонецФункции

Показать
354. vin1c 21.12.15 08:36 Сейчас в теме
я загрузил номенклатуру производителя, сопоставил со своей, отправляю инвинтаризацию и с меня требует марки....
355. vin1c 21.12.15 08:39 Сейчас в теме
Название "Пиво "Жигулевское" пастеризованное фильтрованное светлое" емкость 0.5
356. vin1c 21.12.15 08:59 Сейчас в теме
Код АП 500 т.е он определяет что пиво, но требует марку, обработку вчера скачивал новую
(356) vin1c,
Версия 1.6? Проверю. Спасибо
358. vin1c 21.12.15 09:10 Сейчас в теме
359. vin1c 21.12.15 09:11 Сейчас в теме
и еще как перемещение делать между подразделениями? подразделения со своими ключами
360. Гость 21.12.15 09:29
Добрый день!
В личном кабинете ЕГАИС Контрагентов обязательно заполнять (подгружать из .xml файла) или можно обойтись?
361. basil_m 21.12.15 10:01 Сейчас в теме
По обновлению не понял. Пытался скачать по ссылке, что покупал - уже не действует. У кого-нибудь скачивается обновление по старой ссылке?
363. Гость 21.12.15 10:04
(361) basil_m, Да. Скачивайте через браузер, а не через download manager. У меня проблема была с IDM он видел, что ссылка тоже самая и говорит мне, что этот файл уже скачивал. Выключаю интеграцию с FF и нажимаю по ссылке скачать. Все работает.
371. trofimovalexey 21.12.15 12:55 Сейчас в теме
362. Гость 21.12.15 10:02
Когда в таблицу запросы ЕГАИС добавляем карточку контрагента (ИП) потом нажимаем на кнопку контрагенты.
По логике получается мы отправляем запрос в ЕГАИС по контрагенту (или контрагентах) и получаем сведения о контрагенте.

В функции

Функция ДобавитьФирму(хмл_Фирма,DBFFirms,DBFFirmsInfo,ТолькоНовое = 1)
...
Если хмл_Фирма.getElementsByTagName("oref:INN").length>0 Тогда
ФирмыТЗ.INN = СокрЛП(хмл_Фирма.getElementsByTagName("oref:INN").item(0).Text);
ФирмыТЗ.KPP = СокрЛП(хмл_Фирма.getElementsByTagName("oref:KPP").item(0).Text);
КонецЕсли;
...
КонецФункции

Не может ли быть ошибка в функции. Если выполнять запрос по контрагенту, а это ведь может быть ИП, а у ИП нету КПП ?
(362) alanstorm,
Ок с ИП проверю. Спасибо. .
364. basil_m 21.12.15 10:17 Сейчас в теме
Я и качаю через браузер, пишет "Ошибка! Некорректная ссылка для загрузки."
369. basil_m 21.12.15 12:10 Сейчас в теме
rvs-slim, сбросьте, пожалуйста, обновление на почту basil_m@list.ru. Старая ссылка у меня уже не действует.
370. basil_m 21.12.15 12:32 Сейчас в теме
rvs-slim, сорри, запутался в ссылках, пытался скачать не по той. Все нормально загрузилось.
373. andre78 21.12.15 18:03 Сейчас в теме
Если обработка будет использоваться в организации, и нужна срочно, можно её оплатить как ФЛ через платежную систему ? Никаких Ваших требований не нарушается при этом ?
375. ivanov_alex 43 21.12.15 19:55 Сейчас в теме
опять при поиске контрагента справочник ссылается на сторонние юрлица
как вернуть назад коды контрагентов?
Скачивайте обновленную версию
Исправлена работа с ИП..
Переделана привязка Контрагентов...
Если есть AlcCode номенклатура привяжется по нему...
--По Пиву пока не понятно.. Прошу проверить Акт постановки на баланс..
Спасибо..
380. vin1c 22.12.15 09:31 Сейчас в теме
(378) вы акт постановки на баланс исправляли по пиву в новом обновлении?, требует марку
Оставьте свое сообщение
Вопросы с вознаграждением