Обмен с ЕГАИС из 1С V7.7

0. Техподдержка 09.11.15 00:39
Дорогие друзья! Предлагаю Вашему вниманию обработку, предназначенную для обмена данными из Вашей учетной системы с ЕГАИС, через универсальный транспортный модуль (УТМ).
В обработке реализован весь функционал обмена:
- загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции;
- загрузка справочных данных по номенклатуре алкогольной продукции;
- загрузка остатков;
- помощник сопоставления справочных данных и запись их в базу данных;
- загрузка приходных ТТН и справок Б от поставщиков, отправка по ним актов всех типов, создание по ним приходных документов;
- выгрузка расходных ТТН покупателям;
- управление Марками и ведение Регистра 3;
Обработку возможно использовать автономно, не внося изменений в Вашу Учетную систему.
Код открыт.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
92. garageinfo 27.11.15 10:39 Сейчас в теме
И , прошу прощения за глупый вопрос, но что надо вписывать в поле код ЕГАИС?
93. trofimovalexey 27.11.15 11:47 Сейчас в теме
У меня в настройках пути d:\EG\ в обеих строчках. в эту папку ложим всё что есть без папок. dll, обработки...curl. естественно curl нужен под битность ОС. рекомендую автору закинуть curl64 битный, чтоб не искать. вобще если его запустить, то должно промелькнуть окно черное, значит всё ок. так же регистрация dll под 64 битную систему делается подругому. C:\WINDOWS\SysWOW64\regsvr32.exe c:\atl70.dll (Это пример). Код егаис мы вам и сами можем сказать, если вы скажете инн и кпп, или смотрите сами в JaCarta Monitor-е он же код фсрар, он же KEY.
94. alenaalenkina 27.11.15 12:42 Сейчас в теме
Добрый день, возникла ошибка при запросе в ЕГАИС по контрагенту (рис.). Что она означает?
Ответ:
<?xml version="1.0" encoding="utf-8"?>
<ns:Documents xmlns:tc="http://fsrar.ru/WEGAIS/Ticket" Version="1.0" xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01">
<ns:Owner>
<ns:FSRAR_ID>3463047</ns:FSRAR_ID>
</ns:Owner>
<ns:Document>
<ns:Ticket>
<tc:TicketDate>2015-11-26T15:51:43</tc:TicketDate>
<tc:DocId />
<tc:TransportId>d20f0007-edb3-43e6-ac35-12236a2a224d</tc:TransportId>
<tc:DocHash />
<tc:DocType />
<tc:Result>
<tc:Conclusion>Rejected</tc:Conclusion>
<tc:ConclusionDate>2015-11-26T15:51:43</tc:ConclusionDate>
<tc:Comments>WIN 32 ERROR: Неправильная подпись
</tc:Comments>
</tc:Result>
</ns:Ticket>
</ns:Document>
</ns:Documents>
Прикрепленные файлы:
101. Uncore 1337 27.11.15 16:16 Сейчас в теме
(94) alenaalenkina, ошибка подписи сертификатом PKI на JaCarta. Требуется перезаписать тестовый ключ из ЛК на egais.ru.
95. garageinfo 27.11.15 12:43 Сейчас в теме
trofimovalexey, спасибо за ответ! Мне просто не понятно, отличается чем либо код ФС РАР (FSRAR_ID) (сюда я вписал тот код под которым сертификат из личного кабинета), а для чего тогда соседнее поле КОД ЕГАИС, тоже самое значит?
96. alenaalenkina 27.11.15 12:54 Сейчас в теме
Еще вопрос: при нажатии Создать документ (вкладка Приход), документ создается, но без номенклатуры, все остальные поля заполнены. Это ошибка обработки или нужна связка нашей базы с обработкой? У нас 1С:Предпр.7. 7, Тип.конф. ред.9.2.
Выше спрашивали, что должно быть в поле Код ЕГАИС?
97. anresh 27.11.15 14:25 Сейчас в теме
Добрый день. Что это за модули "Сборка заказов" и "Логистический", которые упоминаются в описании, или какие должны быть реализованы функции этих модулей для работы обработки и где брать эти модули если они нужны?
98. garageinfo 27.11.15 14:35 Сейчас в теме
(97) anresh, Есть подозрение, что логистический - это транспортный раздел из реализации, а вот сборка заказов - сам теряюсь в догадках...
(97) anresh,
Про модули немного напишу:
Логистический: предназначен для привязки накладных к маршрутам доставки, смысл: (если у Вас реализовано подобное) автоматически заполнить раздел Транспорт Расходной ТТН по данным которые указал Логист при доставке товара…
Сборка заказов: предназначен для привязки позиций АП собранной на складе по расходной накладной, к париям АП и соответственно к документам (Сертификатам, справкам и т.п. все эту кипу бумаг представляют), привязка осуществляется по Дате Розлива, ГТД (имп.) или маркам…
99. serg1983 72 27.11.15 15:05 Сейчас в теме
прочитав статью так и не понял есть ли подтверждения факта закупки продукции в ЕГАИС
750. m-serg74 44 07.01.16 11:46 Сейчас в теме
(99) serg1983, а Акт подтверждения это кто?
100. garageinfo 27.11.15 15:53 Сейчас в теме
Конечно есть, на скриншоте же видно, раздел приход, а ниже Отправить акт (подтверждения/отказа/расхождения)
Друзья хотел бы у Вас спросить..
Простановка ОТМЕТОК у наших расходных документах об отправке их в ЕГАИС
где было-бы удобнее и правильнее ее организовать? Предлагайте варианты…
Например:
Завести новый реквизит - (изменения в конфе…)
Комментарий – (но его часто используют для других целей, хотя обработанным определенным типом можно)
Какой то общий реквизит – ( не факт что у всех есть)
106. ivanov_alex 42 28.11.15 19:32 Сейчас в теме
(105) я так понимаю реквизит накладной, без изменения конфы никак, галка где то сбоку-отправлен в егаис, через комментарии еще можно, типа дописки
док.комментарий= "отправлен в егаис "+ТекущаяДата()+" "+ТекущееВремя()+док.комментарий

кому надо-поиск в комментарии типа
если найти(ВРЕГ(док.комментарий),"ОТПРАВЛЕН В ЕГАИС")>0 тогда
107. serg75 29.11.15 10:44 Сейчас в теме
(105) Здравствуйте. Лучше реквизит. Особого труда его добавить нет. Можно будет использовать в запросах.
108. ivanov_alex 42 29.11.15 10:49 Сейчас в теме
нужен модуль для сканирования и загрузки из терминала сбора данных и записи марок в систему
будете делать?
(108) ivanov_alex,
Давайте посмотрим версию 1.4 c вкладками Инвентаризация и Розница со сканированием марок, а дальше посмотрим..
может прикрутим и загрузку из терминала....
109. enter 16 29.11.15 14:33 Сейчас в теме
В который раз сталкиваюсь с нежеланием программистов писать инструкции по работе со своими разработками. Неужели программисты не понимают, что сэкономив пару часов на написание инструкции, они обрекают десятки и сотни пользователей на потери времени, но уже не по 2 часа каждого, а гораздо больше? Наверное, программистам самим нравится постоянно участвовать в решении "увлекательных" ребусов, ну а нам то не до ребусов, нам работать надо и нужен результат.
110. enter 16 29.11.15 14:37 Сейчас в теме
1cpp и formex не удается зарегистрировать. Что делать?
(110) enter,
Писал выше... укажите в личку почту закачки обработки вышлю регистрилку...
ну первоначально была версия 1.1
111. enter 16 29.11.15 14:39 Сейчас в теме
Как обновить до 1.4? По ссылке, которую первоначально прислал Инфостарт, грузится 1.3.
Ок! Выкладываю обновление 1.4 в 21.00, но к сожалению обработку Помощника выложу позже (еще есть моменты над чем подумать)…
115. enter 16 29.11.15 21:05 Сейчас в теме
116. trofimovalexey 30.11.15 04:21 Сейчас в теме
скиньте мне тоже обновление 382784@mail.ru
117. trofimovalexey 30.11.15 04:40 Сейчас в теме
скачал, тут подправить нужно:
ФайлОтвета = Каталог_Темп+ФайлОтвета;                 
	Если ФС.СуществуетФайл(ФайлОтвета) <> 1 Тогда
        Сообщить("Файл """ + ФайлОтвета + """ не найден!");
		Возврат;
	Иначе
		ТекстФайл= СоздатьОбъект( "Текст");
		ТекстФайл.Открыть(ФайлОтвета);
	КонецЕсли;

1 стр. на
ФайлОтвета = СОКРЛП(Каталог_Темп)+ФайлОтвета; 

пишет не найден
118. trofimovalexey 30.11.15 04:42 Сейчас в теме
У себя в страв. номенклатура добавил форму списка ЕГАИС
Перем Литр,Креп,Пр,Имп,КодТов;
Процедура П() 
ИерархическийСписок(0,0);
ИспользоватьСписокЭлементов();
СписОтбора= СоздатьОбъект("СписокЗначений");
    
    СпрТовары= СоздатьОбъект("Справочник.Номенклатура");
    СпрТовары.ВыбратьЭлементы();

	Пока СпрТовары.ПолучитьЭлемент() = 1 Цикл
    Если Число(Литр)<>0 ТОгда
		Ст("есть отбор по Литражу:"+Строка(Литр));
		Если СпрТовары.Литраж<>Литр Тогда Продолжить; КонецЕсли;
	КонецЕсли; 
	
    Если Число(Креп)<>0 ТОгда
		Ст("есть отбор по Крепости:"+Строка(Креп));
		Если СпрТовары.Крепость=Креп Тогда Продолжить; КонецЕсли;
	КонецЕсли;
	  
    Если Число(КодТов)<>0 ТОгда
		Ст("есть отбор по Категории:"+Строка(КодТов));
		Если Число(СпрТовары.Категория.Код)<>Число(КодТов) Тогда Продолжить; КонецЕсли;
	КонецЕсли;
	
    Если СОКРЛП(ПР)<>"" ТОгда
Если (Пр.ИНН=Производитель.ИНН)и(Пр.КПП=Производитель.КПП) Тогда иначе Продолжить; КонецЕсли;
	КонецЕсли;	
	
    Если СОКРЛП(Имп)<>"" ТОгда
Если (Пр.ИНН=Производитель.ИНН)и(Пр.КПП=Производитель.КПП) Тогда иначе Продолжить; КонецЕсли;
	КонецЕсли;	
	
            СписОтбора.ДобавитьЗначение(СпрТовары.ТекущийЭлемент());
    КонецЦикла;
        
    ИспользоватьСписокЭлементов(СписОтбора);
    

КонецПроцедуры 

Процедура ПриОткрытии() 
	Если ТипЗначенияСтр(Форма.Параметр) <> "ТаблицаЗначений" Тогда
	    Возврат;  
	КонецЕсли;

	ТЗИзОтчета = Форма.Параметр;
	Если ТЗИзОтчета.КоличествоСтрок() <> 0 Тогда
		ТЗИзОтчета.ВыбратьСтроки();
		Пока ТЗИзОтчета.ПолучитьСтроку() = 1  Цикл
		
		Литр = 	Число(ТЗИзОтчета.Литраж);   
		Креп = 	Число(ТЗИзОтчета.Крепость);  
		Пр = ТЗИзОтчета.Производитель;   
		Имп = 		ТЗИзОтчета.Импортер;   
		КодТов = 	ТЗИзОтчета.КодТов;    
КонецЦикла;  
	 П() ;
	КонецЕсли;
КонецПроцедуры  


Процедура ПриПовторномОткрытии()
ПриОткрытии() ;
КонецПроцедуры  
Показать
119. trofimovalexey 30.11.15 04:44 Сейчас в теме
а в справочнике ЕГАСНОМЕНКЛАТУРА
Сделал кнопку для поиска ОНК()

Процедура ОНК()
	Параметр=СоздатьОбъект("ТаблицаЗначений");
 	Параметр.УдалитьСтроки();  
	Параметр.НоваяКолонка("Литраж","Литраж");
	Параметр.НоваяКолонка("Крепость","Крепость");
 	Параметр.НоваяКолонка("Производитель","Справочник.Производители");
	Параметр.НоваяКолонка("Импортер","Справочник.Импортеры");
   	Параметр.НоваяКолонка("КодТов","КодТов");

	Параметр.НоваяСтрока();
	Если флЛитраж=1 ТОгда Параметр.Литраж=Литраж; КонецЕсли;
	Если флКрепость=1 ТОгда 	Параметр.Крепость=Крепость; КонецЕсли;
	Если флПроизводитель=1 ТОгда 	Параметр.Производитель=Производитель; КонецЕсли;
	Если флИмпортер=1 ТОгда 	Параметр.Импортер=Импортер; КонецЕсли;
	Если флКатегория=1 ТОгда 	Параметр.КодТов=Категория;КонецЕсли;                                
	Сообщить("Подбор с применением фильтров Литраж:"+Строка(Литраж)+Строка(", Крепость: ")+Строка(Крепость)+Строка(", Категория: ")+Строка(Категория)+Строка(", Производитель ИНН:")+Строка(Производитель.ИНН)+Строка(", Производитель КПП:")+Строка(Производитель.КПП));
  	ОткрытьФорму("Справочник.Номенклатура.ЕГАИС", Параметр);  
  	
  	                      


КонецПроцедуры

Процедура ПриВыбореСтроки()
	
	Форма.Параметр = ТекущийЭлемент();
КонецПроцедуры // ПриВыбореСтроки()       
флЛитраж=1;
флПроизводитель=1;
 флИмпортер=1;
 флКатегория=1;

Показать
151. Phanat0m 02.12.15 08:14 Сейчас в теме
(119)(149)(148)(147) а кому-нибудь оправляли обновление? а то чувство что только меня стороной обходят ;(
152. alexmm3 02.12.15 08:32 Сейчас в теме
(151) Phanat0m, так написали же что можно скачать по той же ссылке с почты когда изначально купили.
166. Phanat0m 03.12.15 05:44 Сейчас в теме
(152) alexmm3, мне менеджер отправлял файл прикрепленный к письму, раза с 3-4 получилось у них... вели переписку.. никак я не мог письмо от них увидеть, и теперь проблема) не складывается что-то с обработкой у меня)
120. trofimovalexey 30.11.15 04:49 Сейчас в теме
Тем самым в ЕГАСНОМЕНКЛАТУРА открывается подбор справочника Номенклатура, в котором отображаются только те позиции, которые нам нужды: т.е. отбор по таким важным параметрам, как Емкости товара, Категория Товара и по ИНН и КПП производителя/импортера.
(120) trofimovalexey,
Алексей все удобство работы со справочниками будет в Помощнике...
Немного допилю и добавлю. .
121. Phanat0m 30.11.15 09:26 Сейчас в теме
Покупал вашу обработку, если можно обновление на почту saint00@mail.ru
122. knight 30.11.15 09:44 Сейчас в теме
в обновлении ошибка синтаксическая КаталогБД = = ?(Прав(Кат,1)="\",Кат,Кат+"\");
одно равно надо удалить.
(122) knight,
Спасибо подправлю...
123. ivanov_alex 42 30.11.15 09:46 Сейчас в теме
не работает запрос контрагентов, добавил 3 штуки в список-даже запроса не уходит-сразу пишет файл ответа пуст и ничего не отправляет, в версии 1.3 работает
124. shkalygin 30.11.15 10:27 Сейчас в теме
Я купил версию 1.3 было написано что доработки бесплатно. Как получить?
У меня версия с недописанной отправкой ТТН
(124) shkalygin,
Обновляйте версия 1.4 доступна для скачивания...
125. knight 30.11.15 10:55 Сейчас в теме
часто выдает ошибку файла egais\rest не существует. запрос остатков предлагает ждать но не грузит.. это нормально? еще вопрос какая версия УТМ должна быть.
(125) knight,
По ошибке про остатки:
Необходимо сделать запрос остатков и загрузить полученный ответ, файл при этом создастся и у Вас будут текущие остатки со справками. ..
128. knight 30.11.15 13:30 Сейчас в теме
(127) сделал запрос весь день жду.. ничего не приходит
129. 1c-vihr 30.11.15 14:22 Сейчас в теме
как связаться с вами? нужна адаптация к нашей 1С ТиС (сильно переделанная)
130. ivanov_alex 42 30.11.15 15:12 Сейчас в теме
первый же запрос по ИП и ошибка
ФирмыТЗ.KPP = СокрЛП(хмл_Фирма.getElementsByTagName("oref:KPP").item(0).Text);
{C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR.SERV\DESKTOP\EGAIS7\EGAIS\OBMEN_EGAIS.ERT(1578)}: Плохой тип переменной
131. 1c-vihr 30.11.15 15:14 Сейчас в теме
при сопоставлении номенклатуры открывается форма для выбора, но выбирать не дает, открывает карточку номенклатуры, если жмешь закрыть возвращает пустой параметр и ошибку про параметр.код
как пофиксить?
146. serg75 02.12.15 05:45 Сейчас в теме
(131) Внесите изменения в справочник Номенклатура-ФормаСписка ДляВыбора-
в процедуру ПриВыбореСтроки() добавьте

Если Парам = "Выбор" Тогда // аналогично как в справочнике Контрагенты
Форма.Параметр = ТекущийЭлемент();
Возврат;
КонецЕсли;

в процедуру ПриОткрытии() добавьте

Если Парам = "Выбор" Тогда // аналогично справочнику Контрагенты
Форма.ОбработкаВыбораСтроки(1);
КонецЕсли;
132. 1c-vihr 30.11.15 16:17 Сейчас в теме


чего-то не хватает?
таблицы например
(132) 1c-vihr,
зарегистрируйте библиотеки .dll.... используется 1CPP.dll...
136. Phanat0m 01.12.15 05:59 Сейчас в теме
rvs-slim, скиньте обновление на почту multimag@kairos.ru или указанную выше в 121 сообщении
137. viktorn 01.12.15 09:22 Сейчас в теме
Не регистрируются DLL Windows 7 32
Вышлите регистрилку DLL nv_velsk@mail.ru
141. anatoliy123 01.12.15 16:47 Сейчас в теме
(137) Используйте Загрузчик ВК и не нужно будет никакие библиотеки регистрировать
138. serg75 01.12.15 11:37 Сейчас в теме
Здравствуйте. Добавил 2 процедуры и 2 кнопки

Процедура ПускУТМ()
Перем Кат;
Кат=Лев(Каталог_Темп, 1+СтрДлина(Каталог_Темп)-Найти(Каталог_Темп, "Temp"));
ЗапуститьПриложение(Кат+"\updater\bin\RunDaemon.bat");
ЗапуститьПриложение(Кат+"\transporter\bin\RunDaemon.bat");
КонецПроцедуры

Процедура СтопУТМ()
Перем Кат;
Кат=Лев(Каталог_Темп, 1+СтрДлина(Каталог_Темп)-Найти(Каталог_Темп, "Temp"));
ЗапуститьПриложение(Кат+"\updater\bin\StopDaemon.bat");
ЗапуститьПриложение(Кат+"\transporter\bin\StopDaemon.bat");
КонецПроцедуры
140. serg75 01.12.15 13:53 Сейчас в теме
(138) Исправить : Кат=Лев(Каталог_Темп, Найти(Каталог_Темп, "Temp") - 1);
139. alexmm3 01.12.15 12:42 Сейчас в теме
Подскажите такой момент - Код егаис и fsrar id - откуда брать? как я понял fsrar id - Это из PKI ключа полученого в ЛК, а код егаис - тогда что и где взять?
142. askv 23 01.12.15 23:56 Сейчас в теме
Все-таки Автору не мешало бы какой-нибудь readme.txt добавить в архив с обработкой, а то тыкаешься, не зная с чего начать.
(142) askv,
В ближайшее время будет создано Описание применения для пользователей, в нем будут описаны основные моменты использования обработки..
Друзья вижу у многих возникают проблемы с регистрацией библиотек...
Поэтому выкладываю программу для их регистрации...
Рекомендация: поместите библиотеки в каталог БД, запустите программу регистрации, выберите библиотеки и регистрируйте....
Друзья многие спрашивают про ВАРИАНТ ПОД КЛЮЧ!
Вы сами посмотрите, сами разработчики ЕГАИС не до конца понимают работоспособность ЕГАИС... иначе не было бы судорожного дописывания версий, документов и схем и т.п....
К сожалению ПОД КЛЮЧ, это не вариант ЕГАИС…тут все приходится проходить опытным путем...
147. sashasasha89 02.12.15 05:54 Сейчас в теме
Кто купил как работает 1С: Предприятие v7.7 Торговля и Склад 9.2?
148. ivanov_alex 42 02.12.15 07:50 Сейчас в теме
при отправке ТТН (getelememntBytag("A")) плохой тип переменной
149. serg75 02.12.15 07:56 Сейчас в теме
Идет задвоение функции ПолучитьИНН(...) в обработке и глобальном модуле (конфиг. ТиС 9.2)
Друзья спасибо за оперативное реагирование на ошибки. . Стараюсь поправлять. .
В описании есть к Вам вопрос ответьте. ..
153. alexmm3 02.12.15 08:34 Сейчас в теме
Сделал запрос по контрагентам и товарам - ответа так и нет уже более 2 часов, код егаис так и не понял что туда ставится.
154. ivanov_alex 42 02.12.15 09:44 Сейчас в теме
в общем чего не хватает при отправке ТТН:
1. разбора логов если ошибка парсера существует, допустим у справки А были два пробела в конце и понять не мог почему не уходит ТТН
открыл лог-parseeroor пробелы не допускаются в названии справки А, кстати поправьте этот момент: REGID справки А нужно избалвять от пробелов спереди и сзади
2.получения квитанции, нужна кнпопка "загрузить квитанции", если нет ошибок парсера пусть проверяет на юрл ТТН(кстати его нет в форме, тоже нужен, там поля пустые) ответ и загружает как только он появился
3.получение отметки о проведении документа и получения квитанции еще и на это
4.сканирование справок при вводе остатков:
отсканировали штрихкод, в ТЗ добавилась строка с номенклатурой, далее сканируем 2Д код он заполняется в нужное поле
сейчас по этому вопросу пустое тз и только надпись что он чтото-то там нашел, без вывода в ТЗ
пока хватит, еще нарою за пару дней
155. ivanov_alex 42 02.12.15 09:59 Сейчас в теме
Ответ на автономность:
не нужно, хранить лучше все в БД
мое ИМХО так как файлы можно потерять стереть может зашифровать вирус и прочее
базу вирус не зашифрует, потому как заблокированы файлы если дбф
и потому как sql хранит базу отдельным файлом и не дает в нее вмешиваться
посему один раз изменить конфу не сильно сложно, если будет МД для объединения
156. sashasasha89 02.12.15 10:05 Сейчас в теме
На крепкие алкогольные напитки она подходит.
157. ivanov_alex 42 02.12.15 10:51 Сейчас в теме
(156) sashasasha89, на любой алкоголь
158. garageinfo 02.12.15 11:34 Сейчас в теме
rvs-slim, подскажите, что можно сделать в следующей ситуации. Есть ряд надежных клиентов которые берут в розницу алк. продукцию. Оплату производят после отгрузки товара, через 3-4 дня. Соответственно стандартное товародвижение описанное ФСРАР для розницы, в данном случае не подходит (отсканировали алко. код. на кассе - он зафиксировался в ЕГАИС - получили деньги - закрыли чек). Нужно, что бы можно было как-либо сохранять код акцизной марки и выгружать эту розничную продажу в УТМ, в момент, когда фактически приходит оплата (в этот момент проданных бутылок уже нет на складе и отсканировать их не получиться). Что можно сделать в таком случае?Можно ли это, реализовать через данную обработку?
159. garageinfo 02.12.15 12:59 Сейчас в теме
Да, и еще вопрос, с 01.01.16 ч/з УТМ, розница должна фиксировать:
1.закупку;
2.перемещение на другое обособленное подразделение;
3.возврат поставщику.

в обработке пункт 1 реализован, а как с пунктом 2 и 3 ?
160. ivanov_alex 42 02.12.15 14:29 Сейчас в теме
(159) garageinfo, реализацию на фсрар ИД другой обособки делайте и все
и сразу же подтверждайте
3.пункт пока неясно будет ли, в момент приемки акт разногласий делайте, так проще чем возврат поставщику выдумывать
вы же товар по факту видите в каком состоянии, ясное дело у вас будет информация о том что ввести в акт разногласий
162. garageinfo 02.12.15 16:03 Сейчас в теме
(160) Слегка не понял по пункту 2. Как сделать реализацию на другой фсрар_ИД, в своей учетной системе? Это же вроде перемещение должно быть?
а по пункту 3. иногда бывает, что брак выявляется не в момент приемки, может товар у нас еще до этого пришел, иногда например возвращают дорогой алкоголь, который не продался, как быть в этом случае?
176. kirlog 87 03.12.15 22:32 Сейчас в теме
(160) ivanov_alex,
Возврат поставщику нужен все же.
Брак браком, но полно возвращается просто не проданного алкоголя.
Договор с поставщиком такой: не продал за 3 месяца - можешь вернуть. Многие так работают.
180. garageinfo 04.12.15 11:12 Сейчас в теме
(176) kirlog, я об этом выше говорил, поддерживаю Вас коллега
161. Пользователь 1С 3 02.12.15 15:40 Сейчас в теме
Можно ли в обработку добавить сервис проверки легальности марки путем сканирования ее сканером?
163. skol 02.12.15 16:14 Сейчас в теме
Здравствуйте! А что делать, когда режешь базу, удаляешь лишние элементы справочников, после этого перекодируешь справочник Номенклатура или Контрагенты? Базе соответствий же трындец наступит. Как быть?
(163) skol,
А Вы прямо так режите базу что Контрагенты и товары с нуля (с новыми кодами)??? Ну тогда Вам все равно .. что добавлять....
177. skol 04.12.15 07:48 Сейчас в теме
168. rvs-slim 03.12.2015 12:17
(163) skol,
А Вы прямо так режите базу что Контрагенты и товары с нуля (с новыми кодами)??? Ну тогда Вам все равно .. что добавлять....
******************************************************
Ну Вы же понимаете, что это не ответ. Обработка должна быть непотопляемой в любом случае. Объясняю свою позицию. У меня в конфигураторе длина кода Номенклатуры равна 5. И каждому менеджеру по закупкам не объяснишь, что не надо тащить какой попало товар, а потом забывать о нём. У меня менеджеры забивают справочник Номенклатура за 2 года до 99999. Поэтому я вынужден резать базу, удалять не нужные элементы и перекодировать справочник с нуля. Поэтому, чтобы база соответствий всегда была актуальна, надо поставить в соответствие уникальному ID ЕГАИСа свои уникальные ID. Это можно сделать 2-мя способами.
1. С помощью менеджера обмена данными компании "ПиБи" (не реклама) присваивать автоматом каждому объекту базы 1С свой уникальный IDD. И писать в Вашу базу соответствий не код Товара, а этот самый IDD. Это актуально и для множества баз данных, которые обмениваются между собой информацией. Но в этом варианте тоже есть подводные камни...
2. Вести базу соответствий, всё-таки, в базе 1С. И использовать не код товара или контрагента, а сами ссылки на них.
Вот тогда "всё" будет жить в гармонии.
(177) skol,
Ок будет 2 версия с хранением данных в 1с..
164. skol 02.12.15 16:18 Сейчас в теме
И ещё не пойму. Контрагентов и Номенклатуру с ЕГАИСа получаю, а посмотреть отгрузку в нашу сторону не могу. На закладке Приход жму "Выбрать Приход", делается запрос, но в ответ ничего нет.
(164) skol,
Договоритесь с кем нибудь из Ваших поставщиков (кто в системе) чтобы отправил на Ваш RegId ...
165. Lev292 34 02.12.15 17:25 Сейчас в теме
Доброго времени суток. У меня такой вопрос: Для компаний оптовиков пива эта обработка подойдет?
169. ilyins 03.12.15 13:17 Сейчас в теме
К вопросу поддерживать автономность?
У нас УРБД, автономность не будет работать.
И еще: если потребуется делать сверку по документам? Документы имеют свойство изменяться, дорабатываться, как и справочники.
Я - за хранения соответствий в конфигурации!
170. garageinfo 03.12.15 14:10 Сейчас в теме
У меня кстати, то же УРБД но я как то не понял с интеграцией справочников, он что то привязывает, но в свей базе я уже имею алкокоды из егаис ()конфигурация КТ-2000), и не понимаю что к чему привязалось ))))
171. 1c-vihr 03.12.15 14:41 Сейчас в теме
Исправьте недоработку с нереагированием на кнопку "выбрать приход" строка 4261

Если Найти(НРег(ТЗ_Документы.Юрл),"waybill/") = 0 Тогда
Продолжить;
КонецЕсли;

пока не понял принципа, но некоторые ТТН то WAYBILL то WayBill
(171) 1c-vihr,
В чем недоработка то? поле адреса переводится в нижний регистр и ищутся входные ТТН....
то что у Вас во входящих их нет... это другой вопрос...
Можете перейти на вкладку Входящие и проверить там наличие вх ТТН (waybill)...
178. 1c-vihr 04.12.15 08:10 Сейчас в теме
(172) так я написал как нужно исправить
в оригинале строка не переводится в нижний регистр
173. ivanov_alex 42 03.12.15 19:34 Сейчас в теме
вот еще что выдумал:
вместо добавления контрагентов по одному в ТЗ сделать при выборе группы контрагентов заполнение тз автоматом.
то есть выбрал папку покупатели, они все запрыгнули в ТЗ
я тут качком стал когда вручную добавлял 1250 контрагентов в список к запросу
и да, при массовом запросе контраентов нещадно тормозит окно с курлом, открывается порой по минуте
(173) ivanov_alex,
согласен... сейчас дорабатываю Помощника думаю будет заметно легче...
175. ivanov_alex 42 03.12.15 21:27 Сейчас в теме
ну и прошу разобраться с партиями товаров в егаис
модель ситуации:
на остатки поставили товар двумя доками:
в 1 документе 1 бутылка во 2-м 10 бутылок
справки а и б одинаковые
ставим в обработке галку брать партии из егаис, пытаемся отправить накладную с 2 бутылками этого товара
подбор партий находит первую партию с кол-вом 1 бутылка и подставляет в таблицу
это неправильно, проверка на кол-во тоже нужно и по сути он должен был перепрыгнуть эту партию и взять ту, в которой есть достаточное кол-во
181. anatoliy123 04.12.15 11:20 Сейчас в теме
Подскажите кто в теме, как заставить работать curl в фоновом режиме, чтобы при запросах команд не мелькали окна? Очень отвлекает и раздражает.
182. anatoliy123 04.12.15 12:11 Сейчас в теме
(181) Всё, сам разобрался. Кому интересно, автор уже реализовал такую возможность, но видимо с целью отладки использует всплывающие окна. Нужно в процедуре КомандаСистемыСрипт(Команда) активировать 2 строки:
WshShell=СоздатьОбъект("WScript.Shell");
WshShell.Run(Команда, 0);//В фоне
И деактивировать строку:
КомандаСистемы(Команда);
183. ivanov_alex 42 04.12.15 19:08 Сейчас в теме
(182) anatoliy123, ага, и сразу
УзелA=DOMDocument.getElementsByTagName("A").item(0);
{C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR.SERV\DESKTOP\EGAIS1.4\EGAIS\OBMEN_EGAIS.ERT(2526)}: Плохой тип переменной

вот как надо
WShell.Run("%COMSPEC% /C "+Команда, 0, 1)
184. 1ckpp 14 05.12.15 07:41 Сейчас в теме
Здравствуйте всем ! Как вы считаете подойдет ли данная обработка для организации (ООО) с оптово-розничной продажей пива?
185. xmxcrew 05.12.15 15:42 Сейчас в теме
Добрый день приобрел вашу обработку при открытии файла Poisk.ert проблем не возникает, когда же пытаюсь открыть файл Obmen_egais.ert возникает ошибка в 1С 7,7 так и в конфигураторе - неправильный формат файла
Прикрепленные файлы:
(185) xmxcrew,
Poisk.ert -вспомогательная обработка для привязки кодов, и запускать ее не нужно..
Obmen_egais.ert основная ... но на скрине не видно, что Вы пытались ее запустить... какая ошибка?
1176. SergBA 03.02.16 15:47 Сейчас в теме
(185) xmxcrew, было ли озвучено решение проблемы? у меня такая же ошибка...
1177. xmxcrew 03.02.16 16:08 Сейчас в теме
(1176) SergBA, нет ждем ответа от автора
1180. SergBA 03.02.16 20:32 Сейчас в теме
(1177) xmxcrew, а эта ошибка на разных версиях обработки? У меня только последняя, на ранних не пробовал... Где можно скачать предыдущую версию?
1198. SergBA 05.02.16 14:13 Сейчас в теме
(1177) xmxcrew, я обновил платформу до 7.70.025 (конфигурацию не трогал) и ошибка открытия обработки исчезла. Теперь можно адаптировать под себя.
2068. user599389_s.trikozin 21.12.16 23:18 Сейчас в теме
Вопрос в догонку, при попытке отправить акт подтверждения на вкладке "Приход" получаю это:
22:59:31 - Отправка акта
БД.ОткрытьФайл(ИмяФайла+".dbf", ИмяФайла+".cdx",ТолькоЧтение);
{D:\1C_BASE\RETAILOLDKISTRUS\EXTFORMS\OBMEN_EGAIS.ERT(1198)}: Неизвестный индекс!
БД.Сжать();
{D:\1C_BASE\RETAILOLDKISTRUS\EXTFORMS\OBMEN_EGAIS.ERT(1202)}: Перед выполнением операции нужно открыть базу!
DBFJurnal.Добавить();
{D:\1C_BASE\RETAILOLDKISTRUS\EXTFORMS\OBMEN_EGAIS.ERT(14763)}: Перед выполнением операции нужно открыть базу!
DBFJurnal.NUMBER = Зн;//В Журнал v1.7
{D:\1C_BASE\RETAILOLDKISTRUS\EXTFORMS\OBMEN_EGAIS.ERT(14764)}: Поле агрегатного объекта не обнаружено (NUMBER)
и соответственно ничего не отправляется...

Про поле с пустым полным наименование - таких позиций около тысячи... Наименование заполнено оказалось только у тех позиций, что пришли в последней накладной, как раз той что сейчас не могу отправить....
(2068)
Сложно сказать без уточнения Версии..
Это ошибки частного характера. .пишите по ним в личку...
По пустым .. а как эти тысячи пришли к Вам на остатки?
Оставьте свое сообщение
Вопросы с вознаграждением