54-ФЗ. Очередь печати для ККМ. Обработки для подключения онлайн-касс к 1С 8 (поддержка маркировки Табака, Обуви, Лекарств, Меховых изделий) + Эмулятор

0. Техподдержка 13.04.15 18:32
Обработка осуществляет обслуживание фискальных регистраторов, поддерживаемых драйвером "АТОЛ: Драйвер ККМ v.8 и v.10" И драйвером "Штрих-М: Драйвер ККТ v.4.Х" для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях.
Для осуществления возможности параллельной работы и пробития чеков на одной ККМ несколькими пользователями, реализован механизм "Очереди печати". Реализована поддержка Веб-сервера Атол для работы с одной ККТ с нескольких рабочих мест. Соответствует требованиям российского законодательства, а именно требованиям закона ФЗ-54 об онлайн-кассах и применении контрольно-кассовой техники. Поддерживает Форматы Фискальных Данных 1.0, 1.05 и 1.1. Включен механизм использования нескольких систем налогообложения в одном документе. Содержит механизмы легкого подключения оборудования по TCP/IP, что упрощает процедуру подключения кассы в сеансах RDP, а так же позволяет подключаться к ККМ через интернет напрямую. Поддерживает работу со ставкой НДС 20%. Поддержка маркировки. Поддержка требований к кассовым чекам с 01.07.2019. Поддерживает режим эмуляции кассовых чеков.

Перейти к публикации

CGV-vlg; Bryuhanov; t79; Rasima.78; +4 Ответить
Лучшие комментарии
1570. alec1490 29.12.18 13:52 Сейчас в теме
Хотел вставить свои "пять копеек" =) Разработчику большое спасибо за проделанную работу и за оперативную поддержку!
Для тех у кого ККТ работает по lan в связке с несколькими ПК и скорость печати нескольких позиций в нём доходит до минут. Вы перепробовали все возможные драйвера и прошивки.А решение банальное, нужно отключить протокол Nagle у сетевого адаптера ПК:
1)Нажмите комбинацию клавиш Win+R и напечатайте в строке regedit.
2)Перейдите к следующей ветке реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\P­arameters\Interfaces.
3)Увидите несколько интерфейсов в следующем формате {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}.
4)Перейдите к ним и найдите подсказки (обычно это значение DhcpIPAddress), которые укажут, какой из них – интерфейс по умолчанию. Альтернативный вариант — выполнить следующие шаги для всех непустых интерфейсов, если вы хотите отключить алгоритм Нейгла на всех сетевых адаптерах.
5)Щелкните правой кнопкой мыши на пустом месте в правом окне и выберите New -> DWORD (32-bit) Value и установите его имя в TcpAckFrequency. Затем дважды щелкните на полученное значение, чтобы изменить его значение на 1.
6)И создать ещё один такой же параметр DWORD (32-разрядное значение), но на этот раз с именем ключа TCPNoDelay со значением 1.
7)Обязательно перезагрузите Windows, задача выполнена.
После этих действий увеличится служебный трафик между ПК и маршрутизатором, но это увеличение будет "каплей в море", по сравнению с остальным трафиком, а зато чеки будут "вылетать" быстрее чем вы подумаете о них! =) По сути мы отключили оптимизацию доставки очень маленьких пакетов tcp-ip.
Может кому поможет! =) С наступающим новым годом!
Drotovsky; mercuriy41311; kochkin.lexa; vis_tmp; gureevks; makcbol1; Sh00rick; +7 Ответить
1357. dmtrpv 01.06.18 08:34 Сейчас в теме
(1356)
Согласен. Разработка качественная и действительно работает, как заявлено. Автор на поддержку отзывается почти мгновенно. Я очень доволен.
CGV-vlg; Rusik; Sh00rick; +3 Ответить
742. user732708 14.05.17 22:50 Сейчас в теме
Обработка и ее автор Александр - это решение проблем по переходу на 54фз и нескольких пользователях 1с по сети.

Наш квест по переходу на 54 фз начался с того, что нужно было подключить Атол 11ф с фискальным накопителем к 1с УТ 10.3.
Сервер Мини на линуксе и три толстых клиента на винде (два на XP и один на 8.1).
Нужно было печатать чеки с любой машины на один фискальник.
Не буду рассказывать про КЭП и прочую камасутру с установкой сертификатов, дополнений браузера и регистрацией на сайте налоговой - это была самая легкая часть - уровень первый, так сказать.

Уровень два - это нужно было уже подключить ККМ компам по сети и скрестить с 1с.
А вот тут нас ждали неожиданности.
Вот такие варианты вырисовывались:
1) Начиная с УТ 11.2 пошла поддержка дров атол 8-й версии, а у нас 10.3 и обновлять не типовой релиз - это много времени на тестирование.
2) Через виртуальные com-порты и прогу ip-to-com - не очень бы хотелось связываться, какое то ПО 2003 года и потом, в многопользовательском режиме не будет возможности работать, придется ждать друг друга, чтоб напечатать - не айс.
3) Терминальный сеанс http://1c-soft.it-terminal.ru/public/544687/ (из коментов) - не наш случай, у нас другая архитектура.
4) Есть еще некоторые обработки, но тут нет инфы про многопользовательский режим, это спасет только от обновления конфы 1с - не годится.
5) Ну и обработка автора - готовое решение, да еще и протестированное - оно и было использовано в итоге.

Связь по сети в ККМ настроена, тесты и верстка чека сделаны, но возникла проблема в фискализации ККМ - Ошибка при обращении к ККТ: неверный номер поля. Александр выяснил по логам, где причина. И виновата была старая прошивка Атола. Пришлось перепрошивать. И это помогло! ККМ фискализировали.

Благодарен Александру за решение проблем и за терпение.
Если вы не хотите обновлять УТ 10.3 и у вас несколько пользователей и один фискальник - эта обработка решает! Это я еще не сказал, что множество внедренцев говорили, что вообще невозможно так подключить. Нужно брать другой фискальник или вообще по фискаьнику на каждый комп. Но оказалось, что все возможно.
Rustig; Sh00rick; +2 Ответить
764. RodionLP 17.05.17 19:51 Сейчас в теме
Да ПОЛНОСТЬЮ солидарен с пользователем user732708! Да и мой опыт дал самые наивысшие результаты как по простоте внедрения так и стабильности работы и совместимости! У нас несколько филиалов и в котором оборудование подключено в локальной сети все РАБОТАЛО НА 100% СРАЗУ ОТЛИЧНО!
А вот при установке в филиале при подключении через RDP РАБОТАЛО ТАКЖЕ, но как и ожидалось возникли задержки при пробросе портов!!!
И ВОТ ОНО ПРОСТО НЕВЕРОЯТНОЕ РЕШЕНИЕ С ГОТОВОЙ ОБРАБОТКОЙ И ТЕХ ПОДДЕРЖКОЙ АЛЕКСАНДРА!!! ВСЕ РАБОТАЕТ ПРОСТО ИЗУМИТЕЛЬНО!!!! ЧЕКИ ДАЖЕ ПРИ (3G ИНТЕРНЕТЕ в филиале) ВЫЛЕТАЮТ МОМЕНТАЛЬНО!!!! СПАСИБО ОГРОМНОЕ АВТОРУ! ОСОБЕННО ЗА КОНСУЛЬТАЦИИ ПРИ НАСТРОЙКЕ ПО РДП!!!
Не потребовались внедрять никаких сторонних программ с дополнительными настройками проброса! ЕЩЕ РАЗ СПАСИБО ОГРОМНОЕ!!!
Uncore; Sh00rick; +2 Ответить
1356. amirselimov 31.05.18 21:24 Сейчас в теме
Спасибо автору за замечательную обработку. Под Атол работает без нареканий. И автор быстро реагирует на вопросы. Реконмедую!!!
Rusik; Sh00rick; +2 Ответить
1398. user616948_sintar 01.07.18 04:30 Сейчас в теме
Данное решение подошло для старой конфигурации Ювелирный салон 1.0, при этом, мне его помогли установить, даже нет, установили за меня, допилили мою конфигурацию, и всё это в 3 часа ночи!!! Я просто в шоке, огромнейшее СПАСИБО!!! Я у Вас в долгу.
Sh00rick; Bambrman1; +2 Ответить
1418. marksheder 05.07.18 12:10 Сейчас в теме
Пользуемся обработкой Атол уже больше года, все отлично. Приобрели обработку Штрих были проблемы с настройкой, Александр оперативно помог. Александр, спасибо за помощь и за Ваши обработки.
scrambleriv; Sh00rick; +2 Ответить
559. RodionLP 19.03.17 16:15 Сейчас в теме
Спасибо Автору! Купил последнею версию под 54 ФЗ Все ОТЛИЧНО РАБОТАЕТ!
Sh00rick; +1 Ответить
1000. byte11 09.07.17 22:01 Сейчас в теме
Добрый вечер всем. Купил обе обработки для Атола и для Штриха. Для Атола встало без нареканий. Для Штриха автор быстро убрал ошибки которые были. Как говориться респект таким людям. По больше бы таких людей которые быстро исправляли и отвечали на вопросы людей которые покупают данную обработку. Короче говоря если еще раздумываешь бери она стоит того что бы купить!!! Автор реально проделал не слабую работу она стоит того!!!
Sh00rick; +1 Ответить
1019. RuLe 14.07.17 14:58 Сейчас в теме
У нас УТ 10.3 в которой три года идет активная разработка(наработка) функционала, т.е. вопрос об обновлении на последний релиз даже не стоит.

После адаптации данной обработки "под себя" могу сказать, что приобретая данный продукт вы получаете:
1. Открытый программный код
2. Все заработало с первого раза
3. Колоссальную экономию времени

Минусов не было замечено.
Sh00rick; +1 Ответить
1239. Bambrman1 27.02.18 18:01 Сейчас в теме
Доброго времени суток, Александр

Хочу поблагодарить Вас за помощь внедрения ККМ в нашей организации от всего коллектива. Все прошло как по маслу в части учета нескольких СНО и печати слип чеков. Так держать. Еще раз спасибо за оперативную помощь.
Sh00rick; +1 Ответить
1361. Rusik 05.06.18 17:45 Сейчас в теме
Александр, спасибо огромное за обработку и оперативную поддержку!!! Всем рекомендую.
Sh00rick; +1 Ответить
1399. Bambrman1 01.07.18 09:13 Сейчас в теме
Всем доброго времени суток.

Хотелось бы выразить огромную благодарность Александру за его неравнодушное отношение к своим клиентам - в выходной день помог интегрировать не только ККт Атол, но и стороннюю ККт Википринт чего в принципе мог и не делать.
С таким подходом к своему делу Александр у Вас всегда будет. что намазать на кусок хлеба.
От меня лично Вам огромный РЕСПЕКТ. Так держать и дальше.
В наше время это большая редкость такое отношение к клиенту.

С уважением Дмитрий.
Sh00rick; +1 Ответить
1467. user949066 13.08.18 12:26 Сейчас в теме
Обработка приобреталась из-за реализованной очереди печати. Все работает! Спасибо Александру за оперативную профессиональную помощь в подключении! Рекомендую!
Sh00rick; +1 Ответить
1481. VitalyKepov 24.09.18 15:19 Сейчас в теме
(1478)
Супер поддержка: подключились на точку и помогли разобраться на месте (была ошибка в конфигурации)
Спасибо
Sh00rick; +1 Ответить
1523. sergeevcorp 14.12.18 13:53 Сейчас в теме
Обработка без проблем встала на нашей Рознице 1.0. Установил и настроил по прилагаемой инструкции.
Спасибо автору за оперативную поддержку!
Sh00rick; +1 Ответить
1597. StormCrow 03.04.19 11:59 Сейчас в теме
Спасибо за разработку, все работает, а что не работает то делают!
Sh00rick; +1 Ответить
1604. user1201748 05.05.19 22:44 Сейчас в теме
Хочется выразить ОГРОМНУЮ благодарность разработчику Александру за помощь во внедрении этой доработки в нашу сильно перелопаченную УТ10.3, теперь быстро печатаются чеки с разных рабочих мест на одну кассу через RDP, параллельно еще и устранил различные недоработки, доставшиеся от предыдущих программистов. Этот человек просто профессионал своего дела, чувствуется высочайший уровень знаний и опыта! По сравнению с другими аналогичными по функционалу обработками, это просто лучшая, тут нет ничего лишнего и никакого обдиралова с лицензиями и т.д., как у некоторых других разработчиков. Рекомендую всем!!! Спасибо еще раз!
dmtrpv; Sh00rick; +2 1 Ответить
1639. ahuram 09.07.19 05:18 Сейчас в теме
Очередное ОГРОМНОЕ спасибо разработчику Александру. Поставили новую кассу, после запуска выдавала аннулированные чеки. И хотя ошибка не была связана с обработкой, помог разобраться с ошибкой даже вне рамок тех поддержки.
Sh00rick; +1 Ответить
1847. ermakov_ivan 29.02.20 13:36 Сейчас в теме
(1844)
Еще раз спасибо за новую версию и исправления - проверили, всё уходит в ОФД и в ЦРПТ тоже выводится из оборота
Sh00rick; +1 Ответить
307. cubic 02.02.17 23:03 Сейчас в теме
Ну и о результатах. Всё прошло успешно. Отработали 1,5 дня, закрыто 2 смены. Данные в ОФД приходят, смс и почта рассылаются (с момента проведения чека, до появления данных в ОФД 12-16 минут). Все довольны. Только некоторых покупателей смущает отсутствие на чеке размера скидки.
ОГРОМНОЕ спасибо автору!
Вышла новая версия обработки 5.0

Список изменений:

1. Объединение отдельных обработок Атол и Штрих в одну единую с поддержкой всех моделей ККТ Атол и ККТ Штрих в едином интерфейсе.
Переключиться между версиями драйверов можно, как и прежде – на закладке «Настройки подключения» параметров обработки.
Важно! При обновлении обработки Штрих на новую единую потребуется перевыбрать используемый драйвер, перепроверить параметры связи с ККТ.
Так же при переходе с предыдущих версий обработок Атол и Штрих потребуется перенастроить/перезаполнить Виды оплат и Налоги на закладке «Таблицы параметров».


2. Все персональные настройки, относящиеся к конкретному оборудования или драйверу вынесены в отдельный раздел дополнительных настроек подключения, которые вызываются по одноименной ссылке на закладке «Настройки подключения». Благодаря этому расширен набор параметров подключения, поддерживаемых в драйверах и отсутствующих в параметрах обработки.
3. Переопределен способ выбора модели ККТ. Теперь модель указывается не через штатный API взаимодействия с фискальными регистраторами, а в дополнительных настройках подключения.
4. Для ККТ Атол, работающих через вариант драйвера 10 «COM-объект» и «JSON через COM-объект» добавлена поддержка установки опции «Канал до ОФД», которая актуальна для ККТ Атол на 5й платформе, передающих чеки через EthernetOverTransport.
5. В тестовом режиме добавлена поддержка ККТ Меркурий производства компании Инкотекс через службу Incotex ECR Manager (INCERMAN).
6. Добавлена поддержка веб-сервера Атол версии 10.7.0.0. Так же сохранена поддержки и предыдущих версий веб-сервера. Переключение между версиями осуществляется в дополнительных параметрах соединения. Так же в доп. настройках подключения добавлен параметр «ИД устройства», позволяющий указать с каким из устройств на веб-сервере будет осуществляться работа.
7. При пробитии чеков из режима РМК или документа ЧекККМ добавлена возможность переопределить ставку НДС из карточки товара, вместо получения значения из конфигурации. Активация данной функции осуществляется в настройках обработки на закладке «Параметры чека».
8. Для ускорения пробития чеков через веб-сервер Атол добавлена опция, позволяющая отключить стандартный механизм получения номера чека и номера смены перед пробитием чека.
Важно! При активации данной опции требуется доработка конфигурации для получения номера чека и номера смены из Объекта драйвера после закрытия чека. Без доработки в документы не будут записываться номера чеков и смены.
9. Добавлена опция, позволяющая активировать механизм получения фискальных признаков из ККТ по завершении пробития чека. Фискальные признаки записываются в структуру, которая в свою очередь записывается в свойство "КАС_СтруктураОтветныхДанных" объекта драйвера. На уровне конфигурации можно реализовать получение из этой структуры таких параметров как: Номер фискального документа, номер смены, фискальный признак документа, дата пробития чека (для некоторых версий драйверов), номер фискального накопителя (для некоторых версий драйверов), регистрационный номер ККТ (для некоторых версий драйверов), ФИО кассира, сумма фискального документа (для некоторый версий драйверов)
10. Переработан механизм получения версии прошивки для ККТ Атол при работе через драйвер версии 10. Благодаря этому устранен вывод ошибки определения версии прошивки, а по ней версии платформы ККТ.
11. Добавлен параметр, позволяющий установить принудительно признак работы с ККТ Атол на 5й платформе, либо признак работы с ККТ Атол на 2й платформе, либо автоопределение платформы ККТ Атол по версии прошивки.
12. Добавлен параметр, позволяющий вручную определить вариант взаимодействия с HTTP сервером при работе с ККТ через веб-сервер Атол или ККТ Меркурий через INCERMAN.
13. Переопределен механизм работы с кодами маркировки в форме Менеджера чека. Теперь если по GTIN из штрихкода маркировки не удалось автоматически определить строку, для которой вводится штрихкод маркировки, то этот штрихкод добавляется для текущей строки, на которой установлен курсор, если это позволит выбранный тип маркировки и предмет расчета в строке. Благодаря этому стало возможным добавление штрихкодов маркировки с заводских марок.
14. В менеджере чека добавлена обработка свойств маркировки, описанных в инструкции к модулю «Маркировка», по которым определяется принадлежность товара к различным типам маркировки. Ранее типы маркировки при пробитии из ордеров или документов отгрузки определялись только из настроек обработки.
15. Доработаны встраиваемые модули для работы в «розничном» режиме работы с маркировкой. В частности, реализован механизм определения типа маркировки товара по настройкам из обработки, а не только по доп. свойствам, что значительно расширяет возможности по привязке товаров к типам маркировки и избавляет от необходимости создавать дополнительные свойства и устанавливать их через групповую обработку и для каждого нового товара. Для активации данного режима необходимо в параметрах конкретного торгового оборудования (в настройках обработки) на закладке «Маркировка» установить текущее торговое оборудование в качестве торгового оборудования для маркировки («ТО для маркировки»).
Важно! Данный параметр сохраняется в параметрах текущего пользователя и для различных пользователей требует отдельной настройки путем нажатия кнопки «Установить текущий» в настройках обработки. После нажатия данной кнопки будет заполнен идентификатор торгового оборудования, по которому будут определяться настройки в модуле маркировки. Если будет определено несколько привязанных карточек торгового оборудования с одной и той же моделью и видом оборудования, то нужно будет выбрать один элемент из выпадающего списка после нажатия кнопки установки текущего ТО.
16. Исправлена ошибка загрузки модуля для работы с JSON, приводящая к невозможности пробивать чеки.
17. Изменен алгоритм определения сделки при пробитии чека из кассовых ордеров, когда происходит сделка по договору, учет взаиморасчетов по которому установлен как «по договору в целом» и без флага «по документам расчетов с контрагентом». Ранее в таких ситуациях при пробитии из ордеров, выписанных на основании реализации с установленным таким договором, пробивалась предоплата вместо передачи предмета расчета. В остальных вариантах ведения взаиморасчетов с контрагентами алгоритм остался прежним.
18. Исправлена ошибка определения ставки НДС, при работе через драйвер Атол версии 10 в режиме COM-объекта, которая в некоторых ситуациях приводила к ошибке синтаксиса из-за неопределенного значения ставки.
19. Исправлена ошибка определения статуса смены, при работе через драйвер Атол версии 10 в режиме COM-объекта, которая в некоторых ситуациях приводила к ошибке синтаксиса из-за неопределенного значения признака превышения 24ч для смены.
Вышла новая версия обработки 5.0.1

Список изменений:

- Добавлен параметр «Символ разделитель слипов платежной системы», позволяющий устанавливать символ, по которому будут разрезаться банковские слипы при печати
- Добавлен параметр «Количество строк промотки перед отрезом слипа», позволяющий установить на сколько протянется чековая лента перед отрезкой банковского слипа.
- Имеющийся параметр «Количество строк промотки перед отрезком чека» теперь отвечает только за промотку чековой ленты на указанное число строк перед отрезом фискального чека.
- Исправлено сохранение/определение параметра «ТО для маркировки». Теперь из карточки оборудования можно перезаписать этот параметр только значением идентификатора оборудования, относящегося к элементу оборудования, для которого открыты параметры, а не любым из списка найденных элементов оборудования.
- Исправлена ошибка определения типа оплаты «Наличные» в форме ввода данных покупателя с таблицей оплат.
- Для ККТ Штрих исправлена ситуация с двойным выводом буквы М для маркированного товара при установке соответствующего флага в настройках обработки.
- Для ККТ Штрих изменен алгоритм промотки строк с метода протяжки на метод печати пустых строк. Использование метода протяжки приводило к смещению чека в сторону, а не промотка ленты.
- Исправлена обработка параметра определения налоговой ставки из номенклатуры для Чека ККМ. Раннее эта опция вовсе не обрабатывалась при наличии в табличной части Товары реквизита «СтавкаНДС». Теперь более высокий приоритет срабатывания установлен для озвученного выше флага определения налога.
- Исправлена ошибка, возникающая при выводе характеристик в чеке при установленном флаге «Выводить характеристику».
- Исправлено сохранение флага «Выводить характеристику». Ранее этот параметр вовсе не сохранялся в настройках.
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
(1991)
Здравствуйте! Все зависит от того какую ошибку выводит и какой версией обработки пользуетесь.
1995. kazakkk 19.08.20 10:17 Сейчас в теме
(1992)
Ошибка регистрации позиции в чеке:
(16) Неверная цена (сумма)

Выходит если есть скидки ручные или авто.
Обработка:
ФЗ-54 АТОЛ: Онлайн кассы и ФР (v.4.09.04)
(1995)
Если у вас прошивка ККТ 5й платформы, то нужно обработку обновить до верси 5
1997. kazakkk 19.08.20 11:15 Сейчас в теме
(1996)
Да, 5я версия. Точно поможет?
(1997)
Да, поможет.
В 4й версии обработки некорректно определялась версия прошивки, когда ККТ Атол была на платформе 5. Из-за этого пробитие чеков происходило по немного иному алгоритму. В 5й версии изменен способ получения версии прошивки.
2002. Rustig 1581 23.08.20 17:48 Сейчас в теме
Добрый день!
Выходит вот такая ошибка
"Ошибка формирования чека ККМ: Cумма всех типов оплаты меньше итога чека"
Использую вашу обработку 5.01
ККМ ШТРИХ-ЛАЙТ-02Ф
параметры обработка определила сама
1с УТ 10.3 доработанная по вашим рекомендациям
(2002)
Добрый день!
Если обновлялись с предыдущих версий на версию 5, то в параметрах обработки необходимо перезаполнить таблицу оплат и таблицу соответствия видов оплат чека ККМ с типов оплат.
2004. Rustig 1581 24.08.20 14:28 Сейчас в теме
(2003) перезаполнял на параметре ФФД 1.05, и повторно перезаполнял на параметре ФФД 1.1 - таблицу оплат и налоги - не помогло.
соответствия видов оплат чека ККМ с типов оплат

А что за таблица "соответствия видов оплат чека ККМ с типов оплат"?
(2004)
А что за таблица "соответствия видов оплат чека ККМ с типов оплат"?

В настройках на закладке "Подарочные карты" находится
2008. Rustig 1581 24.08.20 14:41 Сейчас в теме
2005. Rustig 1581 24.08.20 14:30 Сейчас в теме
(2003)
соответствия видов оплат чека ККМ с типов оплат

И еще - маркированного товара нет, поэтому таблицу для марок я не создавал в УТ, механизмы для маркирвоки дополнительно не переносил в УТ 10.3.
Надеюсь, правильно сделал.
2009. kln 27.08.20 14:36 Сейчас в теме
Александр, добрый день! Подключал вашу обработку к Розница 1, потребовался функционал маркировки табака,, приобрели обновление. По инструкции добавил в конфигурацию. У сигарет в карточке товара свойство КАС_МаркировкаТабак установлено значение Да, в обработке на закладках Признаки расчета и Маркироввка настроено. При продаже сигарет запрашивает марку но в ОФД не передает и в чеке признак расчета - Товар, в чем может быть проблема?
Прикрепленные файлы:
(2009)
Здравствуйте!
Вероятнее всего у вас не подхватывается ссылка на документ печати (на чек ККМ). Сделайте доработку по передаче ссылки из документа в обработку по инструкции из комплекта с обработкой.
2013. kln 28.08.20 08:01 Сейчас в теме
А можно инструкцию для Розницы, процедура печати чека ККМ отличается от инструкции

ОшибкаТО = ПечатьЧекаККМ(ФР, НомерЧекаККМ, НомерСменыККМ,
		                         ТаблицаТоваров, ПолучитьСуммуНаличнойОплаты(),
		                         ПолучитьСуммуБезналичнойОплаты() + ПолучитьСуммуОплатыПодарочнымиСертификатами(),
		                         ВидОперации = Перечисления.ВидыОперацийЧекККМ.Возврат);


Далее функция в модуле чека:
Функция ПечатьЧекаККМ(Идентификатор, НомерЧека, НомерСмены,
                      ОписаниеЧека, СуммаНал, СуммаБезнал, ПризнакВозврата)

	СтруктрураШаблона = КассаККМ.ШаблонЧекККМ.Шаблон.Получить();
	Если СтруктрураШаблона <> Неопределено Тогда
		
		Параметры = Новый Структура();
		Параметры.Вставить("СхемаКомпоновкиДанных", Неопределено);
		Параметры.Вставить("КомпоновщикМакета", Неопределено);
		Параметры.Вставить("КэшМакетов", Неопределено);
		
		СтруктрураШаблона.Вставить("Шаблон", ПроцедурыПечатиФискальныхЧеков.ПолучитьМакетФискальногоЧекаДокументаЧекККМ(Ссылка, СтруктрураШаблона.Шаблон, СтруктрураШаблона.ШиринаЧека, Параметры));
		СтруктрураШаблона.Вставить("СоставнойМассив", Новый Массив);
		СтруктрураШаблона.Вставить("Идентификатор", Идентификатор);
		
	КонецЕсли;
	
	Результат = ПолучитьСерверТО().ОткрытьЧек(Идентификатор, "", ПризнакВозврата, НомерЧека, НомерСмены);
	Если НЕ ЗначениеЗаполнено(Результат) Тогда
		
		Результат = ПроцедурыПечатиФискальныхЧеков.НапечататьСтроки(СтруктрураШаблона, "Шапка");
		Если ЗначениеЗаполнено(Результат) Тогда
			Возврат Результат;
		КонецЕсли;
		
		Позиция = Неопределено;
		Для Каждого Позиция Из ОписаниеЧека Цикл
			
			Результат = ПроцедурыПечатиФискальныхЧеков.НапечататьСтроки(СтруктрураШаблона, "ТелоШапка_"+ОписаниеЧека.Индекс(Позиция));
			Если ЗначениеЗаполнено(Результат) Тогда
				Возврат Результат;
			КонецЕсли;
			
			ЗначениеСкидки = Позиция.Количество * Позиция.Цена * Позиция.Скидка * 0.01;
			СуммаСоСкидкой1С = Окр(Позиция.Количество * Позиция.Цена - ЗначениеСкидки, 2);
			СуммаСоСкидкойФР = Окр(Позиция.Количество * Позиция.Цена - Окр(ЗначениеСкидки, 2), 2);
			
			Если НЕ (СтруктрураШаблона <> Неопределено И СтруктрураШаблона.ОднаФискальнаяСтрока) Тогда
				Если СуммаСоСкидкой1С = СуммаСоСкидкойФР Тогда
					
					СтрокаЧека = Новый Структура("Наименование, Количество, Цена, Скидка, НомерСекции, СтавкаНДС");
					СтрокаЧека.Наименование = ?(СтруктрураШаблона = Неопределено,Позиция.Наименование,"");
					СтрокаЧека.Количество   = Позиция.Количество;
					СтрокаЧека.Цена         = Позиция.Цена;
					СтрокаЧека.Скидка       = Позиция.Скидка;
					СтрокаЧека.НомерСекции  = Позиция.НомерСекции;
					СтрокаЧека.СтавкаНДС    = Позиция.СтавкаНДС;
					Результат = ПолучитьСерверТО().ПечатьСтрокиЧека(Идентификатор, СтрокаЧека);
					
				Иначе
					
					СтрокаЧека = Новый Структура("Наименование, Количество, Цена, Скидка, НомерСекции, СтавкаНДС");
					СтрокаЧека.Наименование = ?(СтруктрураШаблона = Неопределено,Позиция.Наименование,"");
					СтрокаЧека.Количество   = 1;
					СтрокаЧека.Цена         = СуммаСоСкидкой1С;
					СтрокаЧека.Скидка       = 0;
					СтрокаЧека.НомерСекции  = Позиция.НомерСекции;
					СтрокаЧека.СтавкаНДС    = Позиция.СтавкаНДС;
					Результат = ПолучитьСерверТО().ПечатьСтрокиЧека(Идентификатор, СтрокаЧека);
					
				КонецЕсли;
			КонецЕсли;
			
			Если ЗначениеЗаполнено(Результат) Тогда
				Возврат Результат;
			КонецЕсли;
			
			Результат = ПроцедурыПечатиФискальныхЧеков.НапечататьСтроки(СтруктрураШаблона, "ТелоПодвал_"+ОписаниеЧека.Индекс(Позиция));
			Если ЗначениеЗаполнено(Результат) Тогда
				Возврат Результат;
			КонецЕсли;
			
		КонецЦикла;
		
		Результат = ПроцедурыПечатиФискальныхЧеков.НапечататьСтроки(СтруктрураШаблона, "Подвал");
		Если ЗначениеЗаполнено(Результат) Тогда
			Возврат Результат;
		КонецЕсли;
		
		Если НЕ ЗначениеЗаполнено(Результат) Тогда
			Если СтруктрураШаблона <> Неопределено И СтруктрураШаблона.ОднаФискальнаяСтрока Тогда
				
				МассивСтрокДляПечати = ПроцедурыПечатиФискальныхЧеков.ПреобразоватьМассивСоответствийВМассивТекстовыхСтрок(СтруктрураШаблона.СоставнойМассив);
				Результат = ПОлучитьСерверТО().ПечатьТекста(Идентификатор, МассивСтрокДляПечати, СтруктрураШаблона.ШиринаЧека);
				
				Если ЗначениеЗаполнено(Результат) Тогда
					Возврат Результат;
				КонецЕсли;
				
				СтрокаЧека = Новый Структура("Наименование, Количество, Цена, Скидка, НомерСекции, СтавкаНДС");
				СтрокаЧека.Наименование = "Всего:";
				СтрокаЧека.Количество   = 1;
				СтрокаЧека.Цена         = Товары.Итог("Сумма");
				СтрокаЧека.Скидка       = 0;
				СтрокаЧека.СтавкаНДС    = 0;
				СтрокаЧека.НомерСекции  = Позиция.НомерСекции;
				Результат = ПолучитьСерверТО().ПечатьСтрокиЧека(Идентификатор, СтрокаЧека);
				
			КонецЕсли;
		КонецЕсли;
		
		Если НЕ ЗначениеЗаполнено(Результат) Тогда
			Результат = ПолучитьСерверТО().ЗакрытьЧек(Идентификатор, СуммаНал, СуммаБезнал);
		КонецЕсли;
		
	КонецЕсли;

	Возврат Результат;

КонецФункции // ПечатьЧека()
Показать
2014. Timur001 8 28.08.20 10:50 Сейчас в теме
При печати чека из документа Реализации товаров и услуг выдает сообщение "Фискальное устройство не подключено". Это решаемо?
(2014)
Да, решается подключением внешней печатной формы из комплекта с обработкой
2019. kln 02.09.20 07:45 Сейчас в теме
Александр, добрый день!
По Рознице нет инструкции? В Рознице нет обращения к функции ПечатьЧека() в обработке ТОСервер. В Документе ЧекККМ идет обращение к функции ПечатьЧекаККМ(), которая находится в модуле документа ЧекККМ, далее в функции ПечатьЧекаККМ() происходит обращение к обработке ТОСервер к функции ОткрытьЧек() :
Результат = ПолучитьСерверТО().ОткрытьЧек(Идентификатор, "", ПризнакВозврата, НомерЧека, НомерСмены);
Если изменить на Результат = ПолучитьСерверТО().ОткрытьЧек(Идентификатор, "", ПризнакВозврата, НомерЧека, НомерСмены, ДопПараметры) а также в функции ОткрытьЧек
Результат = Обработка.ОткрытьЧек(Объект, Пароль, ПризнакВозврата, НомерЧека, НомерСмены, ФискальныйЧек); изменить на
Результат = Обработка.ОткрытьЧек(Объект, Пароль, ПризнакВозврата, НомерЧека, НомерСмены, ФискальныйЧек,ДопПараметры)

решит проблему по передаче ссылки из документа в обработку?

Функция ОткрытьЧек(Идентификатор, Пароль, ПризнакВозврата, НомерЧека, НомерСмены, ФискальныйЧек = Истина) Экспорт

Обработка = Неопределено;
Объект = Неопределено;
Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);

Если НЕ ЗначениеЗаполнено(Результат) Тогда
Результат = Обработка.ОткрытьЧек(Объект, Пароль, ПризнакВозврата, НомерЧека, НомерСмены, ФискальныйЧек);
мОписаниеОшибки = Объект.ОписаниеОшибки;
Иначе
мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
КонецЕсли;

Возврат Результат;

КонецФункции

Функция ОткрытьЧек() также используется в
ОплатитьПлатежнойКартой(Идентификатор, Сумма, КодRRN, ИдентификаторФР)
ОтменитьПлатежПоПлатежнойКарте(Идентификатор, Сумма, КодRRN, ИдентификаторФР)
ВернутьПлатежПоПлатежнойКарте(Идентификатор, Сумма, КодRRN, ИдентификаторФР)
ИтогиДняПоКартам(Идентификатор, ИдентификаторФР)
ПреавторизацияПоПлатежнойКарте(Идентификатор, Сумма, КодRRN, КодАвторизации, КодОперации, ИдентификаторФР)
ЗавершитьПреавторизацииПоПлатежнойКарте(Идентификатор, Сумма, КодRRN, КодАвторизации, КодОперации, ИдентификаторФР)
ОтменитьПреавторизациюПоПлатежнойКарте(Идентификатор, Сумма, КодRRN, КодАвторизации, КодОперации, ИдентификаторФР)
НапечатьПоследнийСлипЧек(ИдентификаторФР)
ПечатьЧекаПКОРКО(Идентификатор, ЭтоРКО, НомерЧека, НомерСмены,
ОписаниеПлатежа, СуммаНал, СуммаБезнал)

Внесение изменений в эти функции не повлечет проблем с работой интегрированного банковского терминала?
(2019)
изменить на
Результат = Обработка.ОткрытьЧек(Объект, Пароль, ПризнакВозврата, НомерЧека, НомерСмены, ФискальныйЧек,ДопПараметры)

Да, верно. Так и требуется.


Внесение изменений в эти функции не повлечет проблем с работой интегрированного банковского терминала?

Не повлечет, т.к. в обработке есть значение по умолчанию для 7го параметра, если он не передается.
2022. kln 08.09.20 14:13 Сейчас в теме
(2021)
Добрый день!
Изменения внес, проверил ссылка передается, но в ОФД информация о маркированной продукции не уходит.
В обработке ДопПараметры.Свойство("ТаблицаСМарками"",НайденноеЗначение), в чекеККМ табличная часть КАС_ШтрихкодыМаркировки, не в этом проблема?
Прикрепленные файлы:
(2022)
ДопПараметры.Свойство("ТаблицаСМарками"",НайденноеЗначение)

Не в этом причина.
Это используется чтение переданного параметра в функцию "ОткрытьЧек"

У вас в табличной части "Товары" документа "Чек ККМ" заполняется реквизит таблицы "Ключ связи"?
2024. kln 08.09.20 14:28 Сейчас в теме
(2023)
В табличной части "Товары", есть реквизит "КлючСтроки", реквизита "КлючСвязи" нет,
или не там смотрю?
2025. kln 08.09.20 14:33 Сейчас в теме
2026. kln 08.09.20 14:36 Сейчас в теме
(2023)
Посмотрел в УТ 10.3 реквизит "КлючСвязи" и "КлючСтроки" есть, в Рознице только "КлючСтроки"..
(2026)
Дезинформировал вас.
КлючСтроки и нужен.
КлючСтроки строки товара должен совпадать с КлючСтроки строки с маркой, тогда при выборке данных из документа данные подхватятся.

Так же в настройка обработки поставьте флаг "Получать дополнительную информацию из конфигурации при пробитии чеков из документа Чек ККМ (и режима РМК)"
2028. kln 09.09.20 07:48 Сейчас в теме
(2027)
Добрый день!
В настройка обработки поставил флаг "Получать дополнительную информацию из конфигурации при пробитии чеков из документа Чек ККМ (и режима РМК)", проблема решилась.
Спасибо!
2020. kln 02.09.20 07:48 Сейчас в теме
Обновление приобретали, номер заказа - Fwd: Заказ N202541: Доставка товара
2029. leir 10.09.20 15:36 Сейчас в теме
Добрый день, подскажите а реализована у вас, или может планируется, маркировка шин?
(2029)
Добрый день! В текущей версии маркировка шин, духов и фото работает через выбор типа маркировки для товара "Прочая" в настройках обработки.
2031. Rustig 1581 23.09.20 16:24 Сейчас в теме
Добрый день! Для подключения обработки к Атол-30ф на 5й платформе есть какие-нибудь инструкции или нюансы подключения? Надо ли использовать json или веб-сервер Атол?
База находится в терминальной сессии, файловая база.
(2031)
Добрый день!
Есть нюансы для 5й платформы:
1. Необходимо в параметрах ККТ и в настройка обработки указать канал передачи EthernetOverTransport
2. Необходимо всегда держать соединение с ККТ активным (в настройках есть для этого галочки)


При подключении к Веб-Серверу Атол он сам удерживает связь с ККТ и передача чеков будет работать без потери доступа к ККТ для нескольких пользователей.
2033. Rustig 1581 25.09.20 06:12 Сейчас в теме
(2032) Подскажите пож-та, где прочитать как настроить и включить веб-сервер Атол?
И если все-таки без него работать, не лишним будет его устанавливать?
2034. Rustig 1581 26.09.20 08:59 Сейчас в теме
(2032) добрый день!
нам удалось настроить работу вашей обработки через веб-сервер - действительно быстрее чеки стали печататься из терминальной сессии рдп.
На стороне локального компа порты открывал сисадмин, он настроил веб-сервер Атол, сказал, что ай-пи адрес должен быть белым и статическим.
(2034)
Добрый день! Да, все верно. Рад что у вас получилось.
2036. zabaluev 371 04.10.20 20:58 Сейчас в теме
Здравствуйте. Можно ли с данной обработки организовать продажу маркированного товара (обувь) в программе Розница 1.X?
Самой 1с Розница 1.X не поддерживается и не дорабатывается под данный функционал.
2038. zabaluev 371 04.10.20 21:01 Сейчас в теме
(2037) Нужны доработки, если да, то какие?
Платформа 8.2.19.130 поддерживается ?
(2038)
Необходимо будет произвести небольшие доработки по инструкции, в ходящей в комплект с обработкой
2040. zabaluev 371 04.10.20 21:09 Сейчас в теме
(2038) Отлично, обрадую клиента, не придется переходить на новую Розницу 2.Х.
А платформа 8.2 поддерживается?
(2040)
Поддерживаются платформы начиная с 8.1 и выше
2042. zabaluev 371 04.10.20 21:19 Сейчас в теме
2043. Farpost 116 12.10.20 13:52 Сейчас в теме
Александр, вопрос, у нас в товароучётке есть маркированный продукт и точно такой же не маркированный, как его разделить при продаже обоих вариантов в одном чеке? И как подключить (какие настройки надо в 1С сделать, что бы маркировка передавалась в ФР или ККТ?
Товароучетка УТ-10.3
(2043)
Добрый день! О каком типе маркировки ведется речь?
(2043)
Для определенных типов маркировок в моём модуле интеграции зашит запрет продажи без марки с определенной даты и товар немаркированный по такой схеме в чек не добавить. Можно конечно такое ограничение снять и разрешить продавать без марки под свою ответственность. Тогда можно будет в чек добавить товар как маркированный так и не маркированный. Для некоторых типов маркировки такого запрета пока нет, т.к. еще не наступила дата запрета продажи без кода маркировки.
2046. Farpost 116 13.10.20 03:13 Сейчас в теме
Тип маркировки Лекарственные средства (это аптека), проблема в том, что одинаковые лекарства могут быть как маркированы, так и нет, как их разделять в этом случае?
(2046)
При первом добавлении в чек ввести код маркировки, при втором добавлении пропустить ввод, закрыв окно запроса кода маркировки. Вторая позиция при этом в чек добавится без кода маркировки.
2048. Farpost 116 13.10.20 23:50 Сейчас в теме
То есть, если допустим я разделил по каким то признакам товар на маркированный и не маркированный, например при подборе товара по ШК, то все равно мне придётся его ещё раз просканировать при передаче в ФР через Вашу обработку? Я правильно понимаю?
Или можно данные, которые просканированы при подборе товара передать?
(2048)
Если вы разделите товар на маркированный и немаркированный, то ШК марки запросится только для товара с признаком маркировки.
Если же, как вы писали изначально, у вас будет один товар с признаком маркировки, а под ним будет пробиваться как маркированные партии так и немаркированные, то для немаркированных партий этого товара окно маркировки запросит ШК марки, но ввод/сканирование марки в этом окне можно будет пропустить. Данным поведением управляют модули интеграции, встраиваемые в конфигурацию по инструкции к обработке.
2051. Farpost 116 14.10.20 23:14 Сейчас в теме
(2049Так в том то и вопрос: Как мне нужно разделить товар на маркированный и не маркированный, что бы Ваша программа это увидела?
(2051)
Если речь идет о товаре, для которого заведена одна карточка номенклатуры, но имеются как маркированные партии товара так и немаркированные, то после встраивания доработки для маркировки в документе продажи добавляете товар в чек и сканируете или пропускаете сканирование кода маркировки. В случае пропуска ввода/сканирования кода маркировки товар добавится в чек без марки и без кода маркировки пройдет в составе чека.
2050. user735481 14.10.20 17:12 Сейчас в теме
Добрый день! Прошу прощения за повторение вопроса - поддерживает ли обработка бизнес-процессы, связанные с маркировкой автомобильных шин ? Нужно ли для этого дорабатывать конфигурацию ?
(2050)
Здравствуйте!
Поддерживается только выбытие кодов маркировки в составе кассовых чеков.
Для выбытия потребуется доработка конфигурации
2052. Maxilucky 17.10.20 18:27 Сейчас в теме
(2018)
1С:Предприятие 8.3 (8.3.8.2197)
"Управление торговлей", редакция 10.3 (10.3.45.4)
Атол 55Ф
Платформа ККТ 5.0 маркировка
атол драйвер 10.7.0.0

Если в чеке ручная скидка при пробитие ошибка:
Ошибка регистрации позиции в чеке:
(16) Неверная цена (сумма)
Ошибка формирования чека ККМ: Не удалось зарегистрировать позиции в чеке

Обработка 5.0.1
(2052)
Добрый день!
Два варианта решения:
1. Провести тест связи с ККТ в форме настроек обработки и тогда автоматически определится прошивка вашей ККТ и алгоритм пробития чеков для неё будет использован соответствующий.
2. В настройках обработки на закладке ФЗ-54 выбрать принудительно платформу ККТ 5.
2056. brrart 25 19.10.20 10:39 Сейчас в теме
Добрый день. Пытаемся настроить разделение чека по СНО.
Как условие разделения хотим использовать свойство из доработки для маркировки "КАС_МаркировкаОбувь"
Как установить значение это свойства? Ведь оно Булево, а при попытке указать значение проваливаемся в справочник "Значения свойств объектов"?
(2056)
Добрый день! Пока по таким типам значений не разделить, взята в доработку такая возможность.
Поделите по видам, группам номенклатуры или по папкам.
2058. brrart 25 19.10.20 10:46 Сейчас в теме
2059. user878900 22.10.20 17:25 Сейчас в теме
Доброго дня!. Маркировка фотоаппаратов. Розница 1.0 Завел ШК в карточку.
CODE128 или
CODE39 010290000240410421Yv=dAABS6WBefSlJWqZ491EE0692lQDd69asVp8qKz­6S4qd7scBjJ2v5T82me2XEpXjZWXc=

Функция СШКНеизвестныйКод(Штрихкод, ТипКода) Экспорт
Если КАС_ОбработатьНеизвестныйШтрихКодКакШтрихКодМарки(ШтрихКод,ТипКода) тогда
Возврат Истина;
КонецЕсли;

Возврат Ложь;

КонецФункции // СШКНеизвестныйКод()

Ваша функция возвращает Ложь, хотя шк не известный . мб не правильно тип кода или как завести в базу ШК марки? сооветсвенно
получаю типовой вывод ошибки что считанный ШК не может быть обработан
(2059)
Здравствуйте! Не нужно штрихкод маркировки в карточку заводить.
Создайте доп свойство для товара "КАС_МаркировкаПрочая" (тип Булево) и в нужных карточках установите значение Истина.
Далее добавляйте товар в чек и в окне запроса марки сканируйте ШК маркировки
Оставьте свое сообщение
Вопросы с вознаграждением