Интеграция 1С 8.2 и Asterisk (упр. формы)

0. 277 28.10.13 14:16 Сейчас в теме
Пример интеграции на управляемых формах.
Работа с телефонией в тонком клиенте.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. oleg.rizvanov 248 28.10.13 19:03 Сейчас в теме
Вообще-то, я Олег Ризванов, а не Олег Ривзанов :)
2. CeHbKA 277 29.10.13 09:00 Сейчас в теме
(1)упс, очепятался :[
исправил :)
3. CagoBHuK 32 30.10.13 16:09 Сейчас в теме
Управляемые формы подразумевают работы и в Linux-клиенте в том числе. Ваша разработка работает в нем? А в браузере?
4. CeHbKA 277 30.10.13 17:14 Сейчас в теме
(3)
1 - управляемые формы работают в линухе и веб-клиенте
2 - внешняя компонента (она же ROM-Asterisk.dll) написана с помощью COM-технологии
3 - внешняя компонента не работает в веб-клиенте и в линухе тоже, потому что она COM

Надеюсь ответил на все вопросы :)
5. CagoBHuK 32 30.10.13 17:48 Сейчас в теме
(4) В таком случае принципиальных отличий от прочих разработок на эту тему не вижу. Серьезное ограничение - работа только в винде. Плюса не заслуживает.
6. CeHbKA 277 30.10.13 18:01 Сейчас в теме
Вы кажется невнимательно читаете. Причем, очень часто. Внешняя компонента - не моя разработка.

А по поводу плюса - от Вас и не надо ;)
7. Жолтокнижниг 251 31.10.13 09:44 Сейчас в теме
а что нового по сравнению с панелью от simplit, очередная гуёвая переработка?
user718181; +1 1 Ответить
8. CeHbKA 277 04.11.13 13:00 Сейчас в теме
(7) в описании к публикации есть вся необходимая информация. Гуёвая или негуёвая - каждый для себя решает сам. Качайте - смотрите.
9. oleg.rizvanov 248 06.06.14 03:09 Сейчас в теме
Тихо и незаметно Simplit выпустил NativeAPI-версию ROM-Asterisk + новый релиз COM-версии

Из нового:
- Поддерживается сторона сервера
- Можно нарастить глубину очереди событий
- Можно перенаправлять ошибки во внешнее событие

Возможно, стоит пересобрать эту обработку под ROM-Asterisk-Native?
ironn; h00k; +2 Ответить
10. CeHbKA 277 06.06.14 09:12 Сейчас в теме
(9) oleg.rizvanov, ого-го! Нифигасебе :)
Вот это новость :)
Возможно, стоит пересобрать эту обработку под ROM-Asterisk-Native?

Конечно стоит, ща шапку подредактирую и займусь в свободное время

Спасибо!
11. necsoft 3 13.05.16 00:01 Сейчас в теме
Доброй ночи!

Беру демо конфу - все работает. Встраиваю в свою (самописная) через сравнение и объединение и вылетает на Функция Login(Логин,Пароль), а именно при выполнении Если глТелефония.Подключено=1 Тогда

// Авторизация в Asterisk Manager API
//
// Возвращаемое значение: 1-команда отправлена, 0-нет
//
&НаКлиенте
Функция Login(Логин,Пароль)
//    ДокументОбъект = РеквизитФормыВЗначение("Объект"); 
	Если ПустаяСтрока(Логин) Тогда
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Login(). Не указан параметр <Логин>";
		Сообщение.Сообщить(); 
		Возврат 0;
	КонецЕсли; 

	Если ПустаяСтрока(Пароль) Тогда
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Login(). Не указан параметр <Пароль>";
		Сообщение.Сообщить(); 
		Возврат 0;
	КонецЕсли; 

	Если глТелефония.Подключено=1 Тогда
		CRLF = Chars.CR + Chars.LF;
		СтрокаКоманды= "Action: Login"+CRLF+
		"Username: "+Логин+CRLF+
		"Secret: "+Пароль+CRLF+CRLF;
		Возврат ВыполнитьКоманду(СтрокаКоманды);
	КонецЕсли; 

	КонецФункции // Login
Показать


Буду благодарен за помощь!
12. CeHbKA 277 13.05.16 09:51 Сейчас в теме
(11) necsoft, видимо объединили так :)
Посмотрите отладчиком, что из себя представляет значение глТелефония во время ошибки
15. alex_tmn 09.12.16 13:22 Сейчас в теме
(11)Доброго дня, подскажите, не нашли ли вы решение вашей проблемы?
В моей конфигурации аналогичная проблема
21. maksimov1c 6 11.06.19 17:37 Сейчас в теме
(11)Доброго дня удалось решить проблему? тоже самое зависает и все
13. Rustig 1667 14.06.16 17:55 Сейчас в теме
(0) добрый день. где можно скачать внешнюю компоненту ROM-Asterisk.dl ?
14. CeHbKA 277 15.06.16 10:20 Сейчас в теме
(13) Rustig, привет
компонента вшита в конфигурацию + в шапке есть ссылка на сайт разработчика компоненты
16. user718181 26.09.18 10:06 Сейчас в теме
Что за "профессионал" писал эту обработку? Ошибка на ошибке. ПодключитьОбработчикОжидания("вТелефонияКлиент.Автоподключение",30,Ложь); в глобальном модулe не работает.
18. CeHbKA 277 26.09.18 13:39 Сейчас в теме
(16) писал я. 5 лет назад.

Из всех скачавших, ошибка на ошибке, только у вас.
Если не нравится - сделайте сами.
Если можете сами - зачем вам чужое?

P.S. вежливость - залог успеха
P.P.S. не думал, что подобные вещи до сих пор актуальны
P.P.P.S. удачи вам в нелёгкой работе, дальше будет ещё "веселее" :)
19. user718181 26.09.18 14:13 Сейчас в теме
(18) Самому и пришлось писать, потому - что в том виде, как это выложено - это не взлетит
20. Rustig 1667 26.09.18 14:47 Сейчас в теме
(19) возьмите стержень кода, остальное доделаете, будьте Профи!
17. user718181 26.09.18 10:40 Сейчас в теме
ОтключитьОбработчикОжидания("ПереподключитьТелефонию") - в модуле управляемого приложения это что вообще? Даже процедуры такой нет в конфе
22. maksimov1c 6 11.06.19 17:49 Сейчас в теме
Почему он не отрабатывает Если глТелефония.Подключено=1 Тогда изначально глТелефония - это наша dll, после того как отладчиком смотришь "глТелефония.Подключено" , глТелефония стает пустой.
23. maksimov1c 6 11.06.19 20:15 Сейчас в теме
	ТекущийРежим = глТелефония.РежимПрослушивания;
	// корректируем принимаемый параметр
	Режим = ?(Режим<0,0,Режим);
	Режим = ?(Режим>1,1,Режим);
	Если Режим - ТекущийРежим > 0 Тогда
		глТелефония.РежимПрослушивания(Режим);
	КонецЕсли;
	Возврат глТелефония.РежимПрослушивания;
Показать


Зависает dll зарег
24. maipochta 16.10.19 14:26 Сейчас в теме
Библиотека инициализируется на клиенте, т.е. клиент обязательно на Windows, а сервер 1с можно на Linux использовать? Или все только на Windows?
Оставьте свое сообщение
Вопросы с вознаграждением