0. venger 2087 04.01.13 22:26 Сейчас в теме

Бесплатный GPS-трекинг

Современные технологии и возможности становятся все более доступными для широких масс и повсеместно используемыми, как для частного лица, так и для мелкого и среднего бизнеса.
Так и GPS-трекинг (отслеживание в реальном времени на карте местоположения водителей, курьеров, монтажных бригад, торговых представителей, детей, собак и т.п., а также просмотр статистики по их передвижениям и остановкам), становится сейчас все более востребованным сервисом, как для домашних условий, так и для предприятия.
И, если крупные фирмы (например, транспортные предприятия) подписав договора с коммерческими сервисами, оплачивая своевременно счета за устройства и абонплату, эту проблему для себя решили, то это скорее подходит для крупных корпоративных клиентов.
Что делать нам, простым смертным или небольшой фирме с несколькими водителями, например? Какие есть простые, надежные и недорогие решения?

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. gavril 43 05.01.13 12:20 Сейчас в теме
Самый дешевый и доступный как всегда от корпорации добра ;)
Сервис называется latitude.google.com, можно подключать друзей, для того что б смотреть как близко вы друг от друга ;)
2. dyak84 05.01.13 20:32 Сейчас в теме
Спасибо статья получилась очень интересной и увлекательной и водночас полезной. в первые услышал что у нас есть бесплатный трекинг. На праздниках протестирую и отпишусь.автору огромное спасибо за проделаный труд. Так держать.
3. Alex181818 06.01.13 06:31 Сейчас в теме
4. venger 2087 06.01.13 12:30 Сейчас в теме
(3)
...the site shut down on December 13th, 2012.
http://www.instamapper.com

Они закрылись, насколько я понял, что используете сейчас?
5. Alex181818 07.01.13 04:03 Сейчас в теме
(4)
Блиииин, а я и не знал)
НАдо бы другой сервис использовать... Может быть, вы знаете какой-нибудь аналог, но бесплатный?
6. vadimlp77 29 09.01.13 20:16 Сейчас в теме
Купил на фирму таких 200 трекеров TK102-2 (пишет на карту памяти если нету GSM, потом вываливает). Поднял свой TCP сервер на 1с 8.2 ибо нужно не просто показываеть фактическое перемещение агентов, а и плановые точки, где они должны быть и всё это должно синхронизироватсья с базой 1с, всякие там отчеты, внесение координат торговых точек и прочая лабуда. Просто смотреть на то как агенты бегают по городу - не вижу в этом большого смысла. Я сделал, что каждое утро супервайзер получает на почту отчет по своим агентам - расхождения факта от плана, т.е. точки в которых агент должен был побывать, но не дошел, гораздо более полезно, чем пялиться в хитросплетение линий на экране. Плюс к этому отчету он получает маршруты по каждому агенту с точками которые он должен был посетить - если уж очень любопытно посмотреть как он передвигался по городу.
13. venger 2087 09.01.13 23:07 Сейчас в теме
(6) Веб-сервисы тоже функционал наращивают, и гео-зоны есть, если устройства поддерживают, то и индикация батарей т.п., можно сами трекеры на это настроить - отсылка смс в случае разряда батареи. Да и отчеты по точкам и треки за период, как бы тоже показывают. Пробег, соответственно тоже.

API - ( http://forum.gps-tracker.com.ua/viewtopic.php?id=68 ) какой-то есть.

А как точно модель с картой памяти называлась и сколько стоила? Тестировал ТК без функции записи на карту памяти. И какой период отсылки данных с трекеров на сервер ставили?

Для диспетчеров авто - удобно видеть и где сейчас машина, откуда, куда едет и т.п.

Но, конечно, куча хотелок всегда к таким сервисам есть, на 1С реализовать конфу с таким функционалом, "управление траспортом" или "такси", или как подсистема к типовым, диспетчер авто-парка какой-нибудь, не помешало бы... так что давайте поподробнее;-)
14. vadimlp77 29 09.01.13 23:29 Сейчас в теме
(13) Xexun TK102-2 оригинальный, полно не оригинальных, функционально разница есть - товариш сэкономил в итоге девайс работал не стабильно. В Киеве стоит от 1250 гривен, у меня есть поставщик в Китае - брал оптом гораздо дешевле :-)
Этот с СД-картой, позволяет писать на карту если нет сети GSM, при её появлении неотправленные пакеты уходят.
16. venger 2087 09.01.13 23:55 Сейчас в теме
(14) Он видимо досылает с карты пакеты, когда появляется GSM? ПО принимающее это должно учитывать, что стек очереди забьется отсутствующими данными?

(15) К 1С, конечно, лучше в том смысле, что ты сам себе хозяин. А ВК с примерчиком можно? А то на Delphi ( http://forum.shelek.ru/index.php/topic,4107.0.html ) больно смахивает объект)))
17. vadimlp77 29 10.01.13 00:02 Сейчас в теме
(16) в пакете дата-время каждой координаты - проблем не будет, примерчик позже, нужно в терминал лезть - уже отдыхаю
15. vadimlp77 29 09.01.13 23:34 Сейчас в теме
(13) в том то и дело, что лучше это прикручивать к базе 1с, сразу появляется куча доп. возможностей, а смотреть кто где едет онлайн можно и в 1с - не проблема.
7. vadimlp77 29 09.01.13 20:20 Сейчас в теме
Координаты в режиме реального времени пишу в справочник "Состояние трекера", подичненный справочнику "Трекеры" и через периодический регистр сведений задаю соответствие "дата,трекер" - "агент". В состояния трекера так же пишу уровень заряда и еще всякую лабуду на всякий случай. Если уровень заряда падает ниже определенного уровня - система шлёт мыло супервайзеру - он пинает агента, мол не забываем заряжать. Если агент пропадает с радара на больше чем 40 минут (задаётся коснтантой) - супервайзер получает письмо - "Вася не появлсятся 50 минут" - ему звонят и пинают. Как то так.
8. serg_gres 141 09.01.13 20:46 Сейчас в теме
(7) vadimlp77, а как данные попадают в 1С?
9. vadimlp77 29 09.01.13 20:52 Сейчас в теме
(8) serg_gres,
ЗагрузитьВнешнююКомпоненту("TTCPServer.dll");
Сервер = Новый ("Addin.TTCPServer");

подписка на событие:
Процедура ВнешнееСобытие(Источник, Событие, Данные)
Если Источник<>"TTCPServer" Тогда
Возврат;
КонецЕсли;
Если Событие="ПОЛУЧЕНЫ_ДАННЫЕ" Тогда
СтруктураПараметров = Сервер.Результат;
Если не СтруктураПараметров.Свойство("Данные") Тогда
Возврат;
КонецЕсли;
ТекстПредставленияСтрокой = Строка(ТекущаяДата()) + " *** ";
Для каждого Элемент Из СтруктураПараметров.Данные Цикл
ТекстПредставленияСтрокой = ТекстПредставленияСтрокой + Символ(Элемент);
КонецЦикла;
ВывестиСообщение(ТекстПредставленияСтрокой);
ЗаписатьСостояниеGPSТрекера(ТекстПредставленияСтрокой);
КонецЕсли;
Если Событие="ВОЗНИКЛА_ОШИБКА" Тогда
ВывестиСообщение("Параметры подключения:");
СтруктураПараметров = Сервер.Результат;
Если ТипЗнч(СтруктураПараметров)=тип("Структура") Тогда
Для Каждого Элемент ИЗ СтруктураПараметров Цикл
ВывестиСообщение(Элемент.Ключ+": "+Строка(Элемент.Значение));
КонецЦикла;
КонецЕсли;
ВывестиСообщение("Возникла следующая ошибка:"+Сервер.ОписаниеОшибки);
КонецЕсли;

КонецПроцедуры
10. vadimlp77 29 09.01.13 20:54 Сейчас в теме
Просто висит либо регламентное задание, либо просто 1с-ка открыта и на каком то порту (у меня 10000) принимает пакеты.
11. serg_gres 141 09.01.13 21:17 Сейчас в теме
(10) vadimlp77, TTCPServer.dll - а как узнали, что генерирует событие "ПОЛУЧЕНЫ_ДАННЫЕ" ?
В инете описания не нашел.
Или это самописанная dll?
12. vadimlp77 29 09.01.13 22:52 Сейчас в теме
(11) serg_gres, длл-ку скачал, не помню точно где, мне даже кажется что здесь, на инфостарте. Можно прогуглить хорошенько - думаю, что найдётся. Хотя описания то больше никакого и не нужно - всё в коде, который я запостил. Ну или почти всё, не хватает старт, финиш и т.д.
18. serg_gres 141 10.01.13 14:34 Сейчас в теме
19. user1227433 24.05.19 17:03 Сейчас в теме
Отличная связка 1С - Траккар. Траккар позволяет бесплатно отслеживать положение транспорта и поддерживает множество трекеров. Данные можно передавать в 1С и упростить подсчет данных + сделать рутинные процессы автоматизированными.
Здесь подробнее о том, что может 1С + Traccar: http://1c-helper.by/solutions/gps-1c-traccar-tracking.php
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий программист 1С
Санкт-Петербург
зарплата от 130 000 руб.
Полный день

Специалист 1 категории (Программист 1С ФЗД)
Фрязино
зарплата от 110 000 руб.
Полный день

Специалист 1 категории (Программист 1С)
Фрязино
зарплата от 110 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Специалист 1 категории (Методист-аналитик 1С)
Фрязино
зарплата от 100 000 руб.
Полный день