0. SkyLink2012 251 01.01.70 03:00 Сейчас в теме

СТАБИЛЬНАЯ Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel (код открыт скачать можно бесплатно)

В таких случаях многие заказывают соответствующие обработки у собственных штатных программистов, фирм-франчайзи или сторонних разработчиков, но это дополнительные расходы и время.

Как быть, если по различным причинам такой возможности нет?

У каждого пользователя профессиональной версии 1С:Предприятие 8 подобная обработка уже есть! На диске ИТС!

Типовая обработка «ЗагрузкаДанныхИзТабличногоДокумента.epf», находиться в разделе «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Обратите внимание, начиная с Февраля 2010 г. на диске ИТС данная обработка для конфигураций на платформе 8.1 находиться в другом разделе: «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Платформа 1С:Предприятие 8.1» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
100. Bublik2011 9 25.04.14 01:15 Сейчас в теме
(99) Kutnor, Решил проблему так: сравниваю цены (история1), на этом этапе создаются характеристики.

"Я Пойду по другому пути" (с)DJ Ленин :) То есть решил Штрихкоды добавить, а затем характеристики выяснить необходимость добавления характеристики, а потом - добавить штрихкод. Фанатею по EAN13 или Code128 производителя (история2)

Итак, характеристики можно добавить так например, извините на неправильное названия переменных, написанных впопыхах)

		Если (Какое то условие, что цена ОТЛИЧАЕТСЯ и надо вводить характеристику) Тогда
			ЗапросХНА=новый Запрос;
			ЗапросХНА.Текст="
			|     ВЫБРАТЬ
			|	ХарактеристикиНоменклатуры.Ссылка,
			|	ХарактеристикиНоменклатуры.Владелец.Код
			|from
			|	Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры
			|where
			|	ХарактеристикиНоменклатуры.Наименование ПОДОБНО &харнаим
			|	И ХарактеристикиНоменклатуры.Владелец = &харнокод
			|   И НЕ ХарактеристикиНоменклатуры.ПометкаУдаления
			|";
			ЗапросХНА.УстановитьПараметр("харнокод",НоменклЦ);
			ЗапросХНА.УстановитьПараметр("харнаим",ХарактеристикаНаименованиеЕ);
			РезультатПустой1 = ЗапросХНА.Выполнить().Пустой();		
		Если РезультатПустой1 И УстанавливатьХарактеристикиНовые Тогда		
		Характеристика          = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
		Характеристика.Владелец = НоменклЦ;
		Характеристика.Наименование = ХарактеристикаНаименование;	
			Попытка 
				Характеристика.Записать();
				новШк = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи(); 
					  новШк.Владелец         = НоменклЦ; 
					  новШк.ЕдиницаИзмерения = НоменклЦ.ЕдиницаХраненияОстатков; 
					  новШк.ТипШтрихкода     = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13; 
					  новШк.Качество         = Справочники.Качество.Новый; 
					  новШк.Штрихкод         = РаботаСТорговымОборудованием.СформироватьШтрихКод(); 
					  новШк.ХарактеристикаНоменклатуры = Характеристика.Ссылка;
					  новШк.Записать();
				
			Исключение 
				Сообщить(СокрЛП(ОписаниеОшибки())) ;
			КонецПопытки;
		Иначе	
			 Сообщить(СокрЛП(СокрЛП(ТекстыЯчеек[1]))+";"+СокрЛП(ХарактеристикаНаименование)+";"+СокрЛП(ЦенаНоменклатуры)+";"+Формат((Строка(БазоваяЦцена)), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));
		    КонецЕсли;
            Иначе
                  Сообщить(СокрЛП(СокрЛП(ТекстыЯчеек[1]))+";"+СокрЛП("")+";"+СокрЛП(ЦенаНоменклатуры)+";"+Формат((Строка(БазоваяЦцена)), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));
            КонецЕсли;



Показать



Это преступление, давать грязный кусок кода. Не знаю, что поможет тебе Kuthor , приаттаченая настройка или подробнее история1 или история2 ? С утра попробую разобраться в вопросе)) Обратил внимание на рисунок настроек. Как и говорил, предлагаю свой вариант (приаттаченный скрин настроек). ЧЕМ ОН НЕУДОБЕН ?


По крайней мере, ОБРАБОТКА ОШИБКИ - "ХАРАКТЕРИСТИКА НЕ НАЙДЕНА" в ЭТОМ ответе есть. Если честно - один товар - много характеристик - это История3 Какая из историй будет полезна?
Прикрепленные файлы:
102. Kutnor 02.06.14 16:26 Сейчас в теме
Помогите пожалуйста, когда загружаю шрих-коды то вылазит вот такая ошибка:

Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(2,14)}: Переменная не определена (СсылкаНоменклатуры)

как это лечить? или может код не правильный?
103. Kutnor 02.06.14 16:39 Сейчас в теме
весьма странно: поставил свой текст и все заработало, он под номер 1, для сравнения с тем что раньше было ставлю текст который был раньше под номером 2
1)СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
2)CсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;

тесты идентичны, с номером 1 работает, а с номером 2 нет.
darkvampire1991; +1 Ответить
104. Bublik2011 9 02.06.14 19:04 Сейчас в теме
(103) Kutnor, честно сказать? Часто сомневаюсь и жму кнопку "проверить заполнение данных" перед "выполнить".
А иногда до ступора доходит и во внешней обработке проверяю орфографию, начав текст примерно так
ТекстыЯчеек= Новый Массив; 	
СсылкаН=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ТекстыЯчеек[1]));


загружаю шрих-коды то вылазит вот такая ошибка

Да, ошибки будут постоянно. 1С - это тоже ошибка. Исправление старых багов и создание новых )) Но мне для ведения учета вполне, тьфу-тьфу, хватает. АВС и XYZ анализ проводить, например.
Весьма интересно все-таки знать продукт. Например зачастую очень удобно большие данные обрабатывать не внешней обработкой, а применять встроенные отчеты и обработки. Правда, пока не могу "вырасти" до покупки ИТС и подключаемых платных модулей, кроме типовых. Все-таки не внешней обработкой , а этой вот ЗагрузкаДанныхИзТабличногоДокумента.epf, речь о которой идет в этой статье. Мда-а-а, я философ? Нет, так, пару строк написал, чтобы поисковый идекс статья попала и упоминание про УниверсальныеПодборИОбработкаОбъектов.epf
Простите, Kutnor, увлекся... :) Если ближе к делу, стал подгружать ШК из внешнего файлика. Почему? Для загрузки 23000 штрихкодов - это удобнее, чем копипастить в таблицу. Вот пример для УниверсальныеПодборИОбработкаОбъектов.epf
Вот файлик c:\bcode.txt
1709009-4;4620769209832;				
1709009-5;4620769209917;				
1709009-6;4620769209849;

В обработка\настройка - произвольный алгоритм Универсальной Подбора И Обработки Объектов вставил код
	Текст = "";
Запр = Новый Запрос("
 | ВЫБРАТЬ
 | 	Штрихкоды.Штрихкод как Код,
 | 	Штрихкоды.Владелец.Ссылка
 | ИЗ
 | 	РегистрСведений.Штрихкоды КАК Штрихкоды
 | ГДЕ
 | 	Штрихкоды.Владелец.Ссылка = &Товар ");

Запр.УстановитьПараметр("Товар", Объект.Ссылка);
ВыбМ = Запр.Выполнить().Выбрать();
ВыбТ = Запр.Выполнить().Выгрузить();
Индекс = ВыбТ.Количество(); 

Если Индекс=0  Тогда

НазваниеФайла="c:\bcode.txt";
Текст = Новый ЧтениеТекста(НазваниеФайла, КодировкаТекста.ANSI);
Стр=""; Найдено=1; ШКСуществует=1;
СписокНоменклатуры = Новый СписокЗначений;
	Пока Стр<>Неопределено Цикл
	 	Стр = Текст.ПрочитатьСтроку();
			Строк=СокрЛП(Стр);
			Разделитель=Найти(Строк,";");
		Если СтрДлина(Строк)>3 Тогда  
			КонецПервого=Разделитель;
			Первое=СтрЗаменить(Сред(Строк,1,КонецПервого),";","");
			Второе=СтрЗаменить(Сред(Строк,КонецПервого,СтрДлина(Строк)),";","");
						
			Если СокрЛП(Объект.Артикул)=Первое Тогда				
				Если ЗначениеЗаполнено(Второе) Тогда
						Для Каждого ЭлементМассива Из ВыбТ Цикл ШКСуществует=0; 						
							Если СокрЛП(ЭлементМассива[0]) = СокрЛП(Второе) Тогда 
								Сообщить("Для арт.:"+СокрЛП(Объект.Артикул)+" уже существует ШК, предлагаемый для арт:"+СокрЛП(Первое)); ШКСуществует=1;Прервать;
							КонецЕсли; 
						КонецЦикла; 
						Если НЕ ШКСуществует=1 Тогда
                               БуфернаяСтрока=СокрЛП(Второе);
							     Сообщить(Второе);									 
									Если ОбщегоНазначения.ТолькоЦифрыВСтроке(БуфернаяСтрока) Тогда
									Номенкл = Объект.Ссылка;
								Запись                             = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
								Запись.Штрихкод                       = СокрЛП(БуфернаяСтрока);
								Запись.Владелец                       = Номенкл;
								Запись.ТипШтрихкода                 = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
								Запись.ЕдиницаИзмерения                 = Номенкл.ЕдиницаХраненияОстатков;
								Запись.Качество                       = Справочники.Качество.НайтиПоНаименованию("Новый");
								Попытка	Запись.Записать(Истина); Исключение	Сообщить("Не удалось записать ШК: "+СокрЛП(БуфернаяСтрока)+" для элемента: "+Строка(Номенкл)+" "+СокрЛП(Номенкл.Код)+" ||| "+ ОписаниеОшибки());	КонецПопытки;	
										ИначеЕсли НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(БуфернаяСтрока) Тогда	Сообщить("В буфере обмена нет данных формата EAN "+БуфернаяСтрока);	КонецЕсли;
						Иначе		
							 Сообщить("-");	
						КонецЕсли;
						
					Найдено=1;Прервать;
				КонецЕсли;
				
			Иначе
				Найдено=0;
			КонецЕсли;
		КонецЕсли;
	
			
			
	КонецЦикла; 
Если НЕ Найдено=1 Тогда Сообщить("Для "+""+СокрЛП(Объект.Код)+" , арт.:"+СокрЛП(Объект.Артикул)+" не найдено .") ; КонецЕсли;
Текст.Закрыть();
	
КонецЕсли;

Показать


... и ... ЗАРАБОТАЛО !!! :)))
darkvampire1991; +1 Ответить
109. Kutnor 12.08.14 10:20 Сейчас в теме
(103) Kutnor, забыл тут написать что в статье код с английской буквой С. поэтому и ошибку выдавало.
105. SerGan757 07.06.14 01:13 Сейчас в теме
уперся...загружаю такую накладную (см файл) с одинаковыми артикулами!, только в наименовании Товара отличается размером (последние цифры без скобки), в базе у меня есть такой товар тоже артикулы одинаковые, только в Наименовании в конце размер стоит, Нахожу нужный артикул и он ставит самый первый из базы,
а как перебрать и поставить с нужным размером ?
Родитель = Справочники.Номенклатура.НайтиПоНаименованию("ТМ БУМ",Истина);
Результат = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", ТекстЯчейки, Родитель);
????
Прикрепленные файлы:
darkvampire1991; +1 Ответить
106. Bublik2011 9 07.06.14 12:18 Сейчас в теме
(105) SerGan757,

Лучше-бы я не давал совет. Совет: Есть смысл перестроить справочник.

Плохой совет: ввести в Справочник.Номенклатура реквизит Размер (строка,фиксированная,10,индексировать)
         +поиск по реквизиту облегчается
         +очевидный списочный отбор
         -эволюция трудна, при превышении 1000 ценников уже придется модифицировать структуру    

Совет получше: ввести в Справочник.Номенклатура реквизит Размер (создать Справочник.Размеры)
         +преимущество подбора размерного ряда

Идеальный вариант: 1.каждый товар вести учет характеристики
                   2. на каждый штрихкод установить характеристику и размер 
         +будет возможность легко обрабатывать большие объемы, больше 25000 ценников
         +если есть сайт, обратил внимание, выбор по размеру и цвету? Думаю, идеальный вариант лучше
  
Показать


Ответ на вопрос
а как перебрать и поставить с нужным размером ?


Предпочел-бы цифру из строки выбрать с помощью Regexp и построить выбор не по НайтиПоРеквизиту, а запросом. Вот в аттаче РаботаСЗапросами.epf

Вот примерно так,

    стр="Строка с наименование р.599";
	СтрокаАртикул="Артикул-Какой-то"
	
	
    RegExp.IgnoreCase = Истина; //Игнорировать регистр
    RegExp.Global = Истина; //Поиск всех вхождений шаблона
    RegExp.MultiLine = Истина; //Многострочный режим
    RegExp.Pattern = "([^0-9]*)([0-9]+)([^0-9]*)"; 
    стр=RegExp.Replace(стр, "$2"); 
	
	Если (RegExp.Test(стр)) Тогда
		СтрокаЦифраРазмера=Стр;
	Иначе
		СтрокаЦифраРазмера="";
    КонецЕсли;

   Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
|	Номенклатура.Ссылка,
|	Номенклатура.Наименование
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.Артикул = &Артикул
|	И Номенклатура.Наименование ПОДОБНО ""%"" + &ЦифраРазмера + ""%""
|";
Запрос.УстановитьПараметр("Артикул",СтрокаАртикул);
Запрос.УстановитьПараметр("ЦифраРазмера",СтрокаЦифраРазмера);
РезультатЗ = Запрос.Выполнить();
Результат = РезультатЗ.Выгрузить();
Для каждого СтрокаТЗ из РезультатЗ Цикл
КонецЦикла;
РезультатЗапроса = Запрос.Выполнить();
  Если НЕ РезультатЗапроса.Пустой() Тогда
        СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];
		Результат=СтрокаРезультата.Ссылка;
  КонецЕсли;
Показать


возможно ошибки типов, не проверял.
Прикрепленные файлы:
РаботаСЗапросами.epf
SerGan757; +1 Ответить
107. Bublik2011 9 07.06.14 12:35 Сейчас в теме
(105) SerGan757, Вот хороший инструмент для работы с паттернами, в аттаче.
Прикрепленные файлы:
RegExp.exe
darkvampire1991; SerGan757; +2 Ответить
108. SerGan757 07.06.14 20:17 Сейчас в теме
Bublik2011 - спасибо огромное :)
darkvampire1991; +1 Ответить
110. Kutnor 12.08.14 10:30 Сейчас в теме
p.s. данной обработкой загрузил характеристики. Сначала все было хорошо.
Потом у нс расширился ассортимент характеристик и я подгрузил новые, поставил галочку не создавать новые.
Так он что сделал:
допустим есть товар пряжа из шерсти цвет черный 50 уп.
когда я загружал пряжу из хлопка цвет черный, он его не создал а взял и спер у пряжи из шерсти вместе с количеством.
теперь на складе лежит 50 уп. пряжи из шерсти, а в 1С их нет, зато есть пряжа из хлопка 50 уп.

кто подскажет как этого в будущем избежать и как мне теперь все это исправить.
то есть как я понял у характеристики есть 3 параметра:
1)Наименование
2)Номенклатура
3)ХарактеристикаНоменклатуры.Владелец

вот сейчас у меня у некоторых характеристик поля 2 и 3 разные, а должны быть одинаковые.
111. Kutnor 12.08.14 11:05 Сейчас в теме
когда загружаю характеристики поле связь по владельцу в настройках почему то недоступно.
darkvampire1991; +1 Ответить
115. WWWolfy 100 05.02.15 21:48 Сейчас в теме
ЗагрузкаДанныхИзТабличногоДокумента.epf / Единица для хранения остатков / Родитель

1. Легко можно загрузить сразу в первом проходе все Единицы измерения ( Единица для хранения остатков + Единица для отчетов )
Допустим "Базовую единицу" вы прописали откуда брать, тогда добавьте такой код в События (в настройках над таблицей) в заладку "При записи"

текБазоваяЕдиницаИзмерения = Объект.БазоваяЕдиницаИзмерения;
текСсылка = Объект.Ссылка;

Если НЕ ЗначениеЗаполнено(Объект.ЕдиницаХраненияОстатков) Тогда
	ВыборкаЕдиниц = Справочники.ЕдиницыИзмерения.Выбрать(, текСсылка);
	Если ВыборкаЕдиниц.Следующий() Тогда
		НайденнаяЕдиница = ВыборкаЕдиниц.Ссылка;
	Иначе
		НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
		НайденнаяЕдиницаОбъект.Наименование            = СокрЛП(текБазоваяЕдиницаИзмерения);
		НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = текБазоваяЕдиницаИзмерения;
		НайденнаяЕдиницаОбъект.Коэффициент             = 1;
		НайденнаяЕдиницаОбъект.Владелец                = текСсылка;

		Попытка
			НайденнаяЕдиницаОбъект.Записать();
			НайденнаяЕдиница = НайденнаяЕдиницаОбъект.Ссылка;
		Исключение
			//Сообщить("Не удалось записать единицу хранения остатков: " + ОписаниеОшибки(), СтатусСообщения.Важное);
			Отказ = Истина;
		КонецПопытки;
	КонецЕсли;

	Если НЕ Отказ Тогда
		Объект.ЕдиницаХраненияОстатков = НайденнаяЕдиница;
		Объект.ЕдиницаДляОтчетов = НайденнаяЕдиница;
	КонецЕсли;		
КонецЕсли;
Показать

учтите что в этом коде нельзя использовать"Возврат"

2. Чтобы создать группу (родителя) автоматически, добавьте следующий код (в строку Родитель):
ИмяРодителя = ТекстЯчейки;
текГруппа = Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ИмяРодителя),Истина);
Если текГруппа = Справочники.Номенклатура.ПустаяСсылка() Тогда
	ГруппаНоменклатуры = Справочники.Номенклатура.СоздатьГруппу();
	ГруппаНоменклатуры.Наименование = ИмяРодителя;
	ГруппаНоменклатуры.Записать();
	текГруппа = ГруппаНоменклатуры.Ссылка;
КонецЕсли;
Результат = текГруппа;
Показать

Пример для одноуровневых справочников, для многоуровневых доработайте сами
Но учтите! По кнопке [Контроль заполнения] папки сразу создадутся! Можно вынести в "При записи".
116. NE_ZNAIY 07.02.15 23:07 Сейчас в теме
А подскажите, пожалуйста, как из экселя (накладная поставщика) загрузить в документ поступления.
Номенклатура поставщика отличается от нашей. В накладной поставщика есть штрих-коды, которые занесены в нашу номенклатуру.
Можно ли сделать так, чтоб обработка ЗагрузкаДанныхИзтабличногоДокумента искала штрихкод, а в документ поступления подставляла нашы наименования номенклатуры. Раньше, когда поставщик в своих накладных не использовал штрих-код мы выходили из положения так. в карточке номенклатуры наименование - наше наименование, полное наименование - наименование номенклатуры поставщика. и в настройке обработки в строке наименование ставили вычислять и такой код
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.НаименованиеПолное ПОДОБНО &НаименованиеПолное";

Запрос.УстановитьПараметр("НаименованиеПолное", ТекстЯчейки);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Если Выборка.Следующий() Тогда
Результат = Выборка.Ссылка;
Иначе
ОписаниеОшибки = "Не найдена ноиенклатура с полным наименованием " + ТекстЯчейки;
КонецЕсли;

Может его как-нибудь подправить, чтоб обработка брала из регистра штрих-коды?
Может поможет кто-нибудь?
darkvampire1991; +1 Ответить
117. WWWolfy 100 09.02.15 19:56 Сейчас в теме
(116) NE_ZNAIY, так в вашей конфе посмотрите код поиска по штрихкоду и сделайте по аналогии
118. progaoff 03.04.15 10:36 Сейчас в теме
Выбивает ошибку "не удалось записать" захожу в карточку товара единицы пустые, записываю в ручную карточку товара, появляються единицы. В чем проблема?
darkvampire1991; +1 Ответить
119. WWWolfy 100 23.04.15 16:05 Сейчас в теме
120. AlexO 126 23.04.15 16:22 Сейчас в теме
А еще мне заголовок нравится:
"СТАБИЛЬНАЯ Загрузка справочника номенклатуры".
Т.е. остальные - нестабильные, в полураспаде...
darkvampire1991; +1 Ответить
121. KarinaSV 5 12.05.15 23:20 Сейчас в теме
!!!Помогите пожалуйста!!!

При нажатии на кнопку загрузить выдает ошибку:

"Ошибка при вызове метода контекста (Вопрос)"

Нажимаю подробно выходит:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента.МодульОбъекта(946)}: Ошибка при вызове метода контекста (Вопрос)
Если Вопрос("Загрузить "+КоличествоЭлементов + ТекстВопросаИсточника, РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да Тогда
по причине:
Использование модальных окон в данном режиме запрещено!

Заранее огромное спасибо!
darkvampire1991; +1 Ответить
122. micha76 29.05.15 13:43 Сейчас в теме
В принципе, грузится и с группами (только группы первого уровня отдельно завести). А серийные номера в УТ никто не пробовал переносить?
darkvampire1991; +1 Ответить
123. tihokir 04.06.15 16:50 Сейчас в теме
Помогите, пожалуйста, новичку. Есть две характеристики номенклатуры Размер и Цвет, у каждого по три значения, то есть, всего 9 характеристик получается. Как их загрузить в 1С УТ стандартными программными средствами ЗагрузкаДанныхИзТабличногоДокумента?
darkvampire1991; +1 Ответить
124. xavikz 25.08.15 11:23 Сейчас в теме
Подскажите пожалуйста, есть база в управлении торговлей 1 8.2 (Штрих-М).
В номенклатуре есть много свойств, и на половине товаров вбиты значения этих свойств, в другой нет.
Как то можно из ексель импортировать значения свойств объектов для номенклатуры?
Наименований очень много, десятки тысяч
aRaBest; darkvampire1991; +2 Ответить
125. vsomova 17.05.16 19:26 Сейчас в теме
Добрый день! Подскажите, пожалуйста, с помощью этой обработки можно изменить уже существующие артикулы? Наименование и все прочие данные остаются без изменений.
darkvampire1991; +1 Ответить
126. Online-Ufa 17.05.16 20:15 Сейчас в теме
ха... увидеть свою статью через столько лет под чужим именем - это забавно :-)
http://www.online-ufa.ru/content/articles/loading_data_into_1c_from_excel_part_3/
источник чтоли хотя бы указал
darkvampire1991; +1 Ответить
127. Online-Ufa 17.05.16 20:23 Сейчас в теме
наврал,
предыдущая ссылка на статью про загрузку накладной
оригинал вот
http://www.online-ufa.ru/content/articles/loading_data_into_1c_from_excel_part_2/
128. vsomova 18.05.16 11:21 Сейчас в теме
(127) Online-Ufa,
Добрый день!
Спасибо огромное за подробную инструкцию, но у меня проблем а в том, что по этой инструкции удается только создать новые артикулы, а как быть со старыми - нужно изменить артикулы, которые уже есть в 1С. Номенклатуры много, сейчас вот решили изменить полностью все кодировки артикульные. Если руками обрабатывать, то даже месяца времени не хватит. Может есть какие-то другие обработки групповые? Спасибо заранее!
darkvampire1991; +1 Ответить
129. Online-Ufa 18.05.16 17:46 Сейчас в теме
какая проблема? с помощью этой же обработки можете менять артикулы, только тогда идиентификация будет производится по названию? товаров с одинаковыми названими нет? названия в вашей базе и екселе сходятся на 100% с точностью до каждого знака?
если на все вопросы ответ "да", то пожалуйста, загружайте свои артикулы
darkvampire1991; +1 Ответить
130. vsomova 18.05.16 20:21 Сейчас в теме
(129) Online-Ufa,
Это просто чудо! Немного потыкалась в настройках и все получилось - и артикулы изменить и цены новые подтянуть!!! Я даже не знаю как Вас благодарить! Спасибо ОГРОМНОЕ!!!!
darkvampire1991; +1 Ответить
131. darkvampire1991 23.05.16 06:43 Сейчас в теме
Здравствуйте подскажите используя обработку необходимо добавить в Номенклатуру Производителей чтобы они записывались сразу в Номенклатуру, просто если ставишь Режим загрузки: Устанавливать то не записываются производители, если же Искать то не находит соответственно их. Приходится в ручную идти в Номенклатуру и создавать производителя. Думаю вопрос правильно изложил, код какой-то написать в обработку по автоматическому добавлению производителей из файла Excel? Спасибо за ответ заранее)
132. manager16 28.09.16 10:28 Сейчас в теме
добрый день. как с помощью обработки данной загрузить еще аналоги. То есть в карточке номенклатуры есть вкладка аналог. Вот туда и надо мне загрузить практически под каждый артикул загрузить от 1-15 аналогов.
133. Bublik2011 9 02.03.12 14:55 Сейчас в теме
Необходимо загрузить в справочник Номенклатура данные из файла Excel с помощью обработки "Универсальный загрузчик табличного документа" , что с диска ИТС (конфигурация 1С:Управление Торговлей). Нашел инструкцию как это делается для УТ 10.3, но с теми же настройками обработки не получается загрузить. Ошибки возникают на пунктах: Единица хранения остатков и Единица для отчетов. Не загружается единица для штрихкода. Как исправить для моей конфигурации?
134. SkyLink2012 251 02.03.12 17:15 Сейчас в теме
Bublik2011! Для коррекции единиц хранения измерения номенклатуры в справочнике штрих-коды или штрихкоды создайте в конфигураторе - "Новая" - "Обработка" и вставьте код по действию "Выполнить".

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ВыборкаШК = РегистрыСведений.Штрихкоды.Выбрать();
	Пока ВыборкаШК.Следующий() Цикл
		Если ВыборкаШК.Владелец = ВыборкаШК.ЕдиницаИзмерения.Владелец Тогда
			Продолжить;
		КонецЕсли;
		Если ВыборкаШК.Владелец.ЭтоГруппа Тогда
			Продолжить;
		КонецЕсли;
		Состояние("Обрабатывается: "  + ВыборкаШК.Владелец);
		Запись = ВыборкаШК.ПолучитьМенеджерЗаписи(); 
		Запись.Прочитать();
		
		Запись.ЕдиницаИзмерения = Запись.Владелец.ЕдиницаХраненияОстатков;
		Попытка
			Запись.Записать()
		Исключение
			ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки())
		КонецПопытки;
		Состояние("Обрабатывается: ......");
		
	КонецЦикла;
	Сообщить("Обработка завершена!");
КонецПроцедуры


Показать



Прикрепленные файлы:
CorrectEAN-13.epf
135. helsik 06.10.17 11:02 Сейчас в теме
все получилось, но только с этой обработкой https://infostart.ru/public/81468/
136. seregapplk 30.08.18 19:40 Сейчас в теме
не ставит единицы

"сылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Наименование"]);
БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);"

это я так понимаю код по классификатору "НайтиПоКоду(796)" у мея другой код конфиг для украины, ошибок не выдает но не ставит хотя код я изменил не пойму что не так
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Москва
зарплата от 140 000 руб. до 200 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Консультант 1С (Бухгалтерия)
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Программист 1С
Тюмень
зарплата от 70 000 руб.
Полный день