0. Diamante 87 05.05.10 06:31 Сейчас в теме

Расчетная ведомость с детализацией по месяцам

Стандартная расчетная ведомость с возможностью формирования за произвольный период. С детализацией по месяцам.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Kapitan911 340 05.05.10 06:31 Сейчас в теме
ВсегоУдержано_1 = ВсегоУдержано_1 + Таб2.ПолучитьЗначение(Таб2.НомерСтроки,Значение_ВР);
{D:\РАСЧЕТНАЯ ЗА ПЕРИОД\РАСЧЕТНАЯ ВЕДОМОСТЬ_ПО МЕСЯЦАМ.ERT(3114)}: Номер за пределами значения!
2. Diamante 87 05.05.10 07:59 Сейчас в теме
Да косяк нашел, косяк происходил при наличии удержаний. Прошу прошения.
Косяк исправлен, можно пользоваться.
gutentag; +1 Ответить
3. gutentag 254 06.05.10 00:10 Сейчас в теме
Почему данные в обработке "Вдомость0 от 1С" и "Ведомость по месяцам" показывают разные результаты ?
4. Diamante 87 06.05.10 06:06 Сейчас в теме
Исправлен косяк в строке "Итого по ведомости" и в последней строке "Итого по сотруднику" по колонкам "Итого натуральных доходов" и "Итого удержано".

>gutentag
Где именно разнятся данные?
Для решения твоей проблемы необходимо знать строки и колонки по которым разные результаты или можешь прислать скриншоты!.
5. gutentag 254 06.05.10 13:48 Сейчас в теме
(4) см.картинку
Прикрепленные файлы:
6. gutentag 254 13.05.10 16:23 Сейчас в теме
Замечание: Если в программу вводить документ "накопленная задолженность", то суммируются данные в колонках Сальдо начальное и Сальдо конечное.
Имхо это ошибка, т.к. если задолженность возникла и погашена в середине года, то Сальдо начальное и Сальдо конечное должны по Сотруднику быть равны нулю.
7. maxchaos 22 23.08.10 19:19 Сейчас в теме
А что за оригинальная проверка в процедуре "Детализация" (в строке 40):
Процедура Детализация()
	Если ВыводПоМес = 1 Тогда
		Если ПериодСтр(д1, ДатаАктуальности) = 1 Тогда
			ВыводПоМес = 0;
			Предупреждение("Не корректно выбран Период!",30);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
Показать

Это как же ПериодСтр(д1, ДатаАктуальности), т.е. строка, может быть равна числу 1? :o :D
8. harutyunb 27.10.10 14:53 Сейчас в теме
есть недоработка!
Кода выберешь период с детализацией по месяцам а потом форму отчета
"не" - "Расч. вед. в разрезе по месяцам", то обработка зацикливается !!!
Исправьте!
9. Pitot 28.10.11 06:15 Сейчас в теме
10. hanio 49 03.11.11 10:46 Сейчас в теме
а зачем ты убрал отработано дней? первый же в лоб вопрос бухгалтера - "В расчетной старой это было а сейчас почему нет??" верни пожалуйста.
11. Мать Тереза 24.01.12 15:41 Сейчас в теме
Что то с итоговым сальдо-выходит минус, хотя в штатной ведомости-норм, но меня устраивает-распечатать одну-и сверять и НДФЛ и базу по страховым взносам.
12. vovkakursk 15.02.12 13:21 Сейчас в теме
13. NOVOPRO 13.04.12 07:39 Сейчас в теме
ВсегоУдержано_1 = ВсегоУдержано_1 + Таб2.ПолучитьЗначение(Таб2.НомерСтроки,Значение_ВР);
{с:\РАСЧЕТНАЯ ЗА ПЕРИОД\РАСЧЕТНАЯ ВЕДОМОСТЬ_ПО МЕСЯЦАМ.ERT(3114)}: Номер за пределами значения! У меня такаяже проблема.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист стажер 1С
Нижний Новгород
зарплата от 30 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программисты 1С УТ / БУЗ/ЗУП / БИТ ФИНАНС
Москва
зарплата от 100 000 руб. до 180 000 руб.
Полный день