КД 2 Как заменить подрзделение при загрузке?

1. Death_eye 10.07.24 11:15 Сейчас в теме
Используются типовые правила обмена ЗУП - БП. Нужно, чтобы при выгрузке или загрузке вместо подразделения вставало подразделение-родитель. В правилах есть алгоритм ЗаполнитьТЧИзПараметровОбъекта
Код такой:

НачисленнаяЗарплатаИВзносы = ПараметрыОбъекта.Получить("НачисленнаяЗарплатаИВзносыТабличнаяЧасть");
Если НачисленнаяЗарплатаИВзносы <> Неопределено Тогда
Для Каждого СтрокаТЧ Из Объект.НачисленнаяЗарплатаИВзносы Цикл
ЗаполнитьЗначенияСвойств(СтрокаТЧ, НачисленнаяЗарплатаИВзносы[СтрокаТЧ.НомерСтроки - 1]);
Подразделение = СтрокаТЧ.Подразделение;
СтрокаТЧ.Подразделение = Подразделение.Родитель;
КонецЦикла;
КонецЕсли;

Не работает.
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. user-z99999 70 10.07.24 13:32 Сейчас в теме
(1)
Значение = Подразделение.Родитель;

если это ПКО и мы на строке Подразделение
3. starjevschik 10.07.24 14:38 Сейчас в теме
(2)
Значение = Подразделение.Родитель

Источник.Подразделение.Родитель... и то при соблюдении некоторых условий, о которых мы ничего не знаем.
4. tusv 212 10.07.24 14:51 Сейчас в теме
Тогда уж в ПКО Подразделение сразу переопределить
Если ТипЗнч(Источник) = Тип("СправочникОбъект.ПодразделенияОрганизаций") Тогда
	//Выгрузка с помощью  КонвертацияОбъектовИнформационныхБаз
	Источник = Источник.Родитель.ПолучитьОбъект();
Иначе
	//Универсальная выгрузка
	Источник = Источник.Родитель;
КонецЕсли;
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот