Запись в регистр накопления в Операции Бух

1. OlegAr 22 25.09.23 22:41 Сейчас в теме
В моем случае есть необходимость при синхронизации из УТ 10.4 передать реквизиты документа и в БП 3.0 произвести запись в Операции Бух, по Регстру Бухгалтерии всезаписывается и проводится, но одновременно надо сделать запись в регистре накопления ИП МПЗ, а тут как раз и не получается, приходится открывать форму Операции выполнять действия Записать Закрыть, в первом случае добавляется табличная часть с регистром ИП МПЗ, во второй раз производиться запись в регистр.
Нужны советы какисправить, чтобы запись в регистр совершалась при записи в Регистр Бухгалтерии, понимаю, что пока нет записи, то и в Регистр ничего не записать.
может возможно програмно выполнить запись, и второй раз отурыть и выполнить запись в регистр ИП МПЗ по данным табличной части Регистра бухгалтерии.
Процедура Расш1_ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
	
	Если РежимЗаписи = РежимЗаписиДокумента.Запись Тогда	
		ХарактерДеятельности = Неопределено;
		Выб = Справочники.ВидыДеятельностиПредпринимателей.Выбрать();
		Пока Выб.Следующий() Цикл
			ХарактерДеятельности = Выб.ХарактерДеятельности;
			Прервать;
		КонецЦикла;
		ВидМПЗ = Перечисления.ВидыМПЗ.Материалы;
		Движения.ИПМПЗ.Очистить();
		ДобавленыДвижения = Ложь;
		Для Каждого Стр ИЗ Движения.Хозрасчетный Цикл
			Если Стр.СчетДт.Код = "10.07" Тогда          
				НоменклатураСчетДт = Стр.СубконтоДт.Номенклатура;
				Если ЗначениеЗаполнено(НоменклатураСчетДт) Тогда
					СтрДоб = Движения.ИПМПЗ.ДобавитьПриход();
					СтрДоб.Период = Дата;
					СтрДоб.Активность = Истина;
					СтрДоб.Организация = Стр.Организация;
					СтрДоб.НоменклатурнаяГруппа = НоменклатураСчетДт.НоменклатурнаяГруппа;
					СтрДоб.ХарактерДеятельности = ХарактерДеятельности;
					СтрДоб.ВидМПЗ = ВидМПЗ;
					СтрДоб.Номенклатура = НоменклатураСчетДт;
					СтрДоб.Партия = Стр.СубконтоДт.Партии;
					СтрДоб.Количество = Стр.КоличествоДт;
					СтрДоб.Сумма = Стр.Сумма;
					ДобавленыДвижения = Истина;
				КонецЕсли;	                                    
			КонецЕсли;
		КонецЦикла;
		Если ДобавленыДвижения Тогда
			СтрНайти = ТаблицаРегистровНакопления.Найти("ИПМПЗ","Имя");
			Если СтрНайти = Неопределено Тогда
				СтрДоб = ТаблицаРегистровНакопления.Добавить();
				СтрДоб.Имя = "ИПМПЗ";
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
Показать
По теме из базы знаний
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. VZyryanov 26.09.23 08:40 Сейчас в теме
	Об=Документы.ОперацияБух.СоздатьДокумент();
	Об.Организация=Организация;
	//...
	Регистр1=Об.ТаблицаРегистровНакопления.Добавить();
	Регистр1.Имя="НДСПоПриобретеннымЦенностям";
	Регистр1.Представление="НДС по приобретенным ценностям";
	//...
	Об.Записать();
	Опреация=Об.Ссылка;

	Хозрасчетный=РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
	Хозрасчетный.Отбор.Регистратор.Значение=Операция;
	НДСПоПриобретеннымЦенностям=РегистрыНакопления.НДСПоПриобретеннымЦенностям.СоздатьНаборЗаписей();
	НДСПоПриобретеннымЦенностям.Отбор.Регистратор.Значение=Операция;
	//...
	Запись=Хозрасчетный.Добавить();
	Запись.Регистратор=Операция;
	Запись.Организация=Организация;
	Запись.Период=Операция.Дата;
	//...
	Запись=НДСПоПриобретеннымЦенностям.Добавить();
	Запись.Регистратор=Операция;
	Запись.Организация=Организация;
	Запись.Период=Операция.Дата;
	//...
	Хозрасчетный.Записать();
	НДСПоПриобретеннымЦенностям.Записать();
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот