1. olgita_n 10.07.19 08:47 Сейчас в теме

Конвертация данных 2.0 поиск ссылки в приемнике

Здравствуйте!
Я выполняю обмен через конвертацию данных между Бухгалтерией 8.2 и БИТ.ФИНАНС 8.3.
Подскажите пожалуйста как в ПКО прописать поиск?
Мне нужно выгрузить справочник Банковские счета. В нем есть поле группа-договоров (ссылка на справочник Договоры).
Вроде ничего сложного, но мне не нужно выгружать сами эти договоры. Нужно выгрузить ссылку этого договора и поиском найти в приемнике его и записать его в этом поле.
Найденные решения
7. maks_20 60 10.07.19 10:11 Сейчас в теме
(6) Вы можете в пкс проверять тип договора и в зависимости от типа вызывать нужное пко. примерно так:
Если Источник.Договор.Тип = ВашТипДоговора Тогда
ИмяПКО = "ДоговорыПоиск";
Иначе
ИмяПКО = "ДоговорыПолныйПеренос";
КонецЕсли;


Либо можно при загрузке проверять так:
Если ОбъектНайден И Объект.ТипДоговора= ВашТип Тогда
НеЗамещатьОбъект  = Истина;
ОбъектМодифицирован  = Ложь;
КонецЕсли;
9. tusv 159 10.07.19 11:01 Сейчас в теме
(8)Источника при Загрузке не существует. Потому и ругается.
Переносите бит_ТипДоговора, как параметр и сравнивайте. Приблизительно
Если ПараметрыОбъекта["Бит_ТипДоговора"] = Бла бла бла Тогда
   Бла бла бла
КоенцЕсли;
24. olgita_n 11.07.19 10:47 Сейчас в теме
Создала два ПКО для справочника Договоры. В одном необходимы поля и при выгрузке прописала запрет на выгрузку с определенным типом. А в другом ПКО при выгрузки прописала только нужный тип договоров и выбрала только одно поле для выгрузки и это правило указала в ПКО банковского счета у поля Договоры.
Остальные ответы
Избранное Подписка Сортировка: Древо
2. platonov.e 3 10.07.19 08:57 Сейчас в теме
А как они появились в приемнике?
3. olgita_n 10.07.19 09:02 Сейчас в теме
(2) я сначала из бухгалтерии в бит перегружаю эти договора, а обратно уже не нужно перегружать договора с определенным типом. И я прописала условие при выгрузки у договоров, чтобы они не выгружались. И дело в том что если я из бита не выгружаю эти договора, то они в бухгалтерии в справочнике банковские счета в поле группы договоров не отображаются
4. platonov.e 3 10.07.19 09:19 Сейчас в теме
Ну по идеи ссылка на него выгружается, и если он находит по ссылке его то подставляет.
5. maks_20 60 10.07.19 09:19 Сейчас в теме
Вариантов решения несколько. Например можно для договоров создать ПКО с поиском по ГУИД и флагами "Не создавать если не найден" и "Не замещать существующие объекты в приемнике" , без пкс, в ПКО Банковские счета для свойства группа договоров указать созданное ПКО.
6. olgita_n 10.07.19 09:39 Сейчас в теме
(5) так тогда это для всех типов договоров будет, а у меня есть типы договоров которые изменяются и их нужно изменять, а некоторые типы не нужно изменять
7. maks_20 60 10.07.19 10:11 Сейчас в теме
(6) Вы можете в пкс проверять тип договора и в зависимости от типа вызывать нужное пко. примерно так:
Если Источник.Договор.Тип = ВашТипДоговора Тогда
ИмяПКО = "ДоговорыПоиск";
Иначе
ИмяПКО = "ДоговорыПолныйПеренос";
КонецЕсли;


Либо можно при загрузке проверять так:
Если ОбъектНайден И Объект.ТипДоговора= ВашТип Тогда
НеЗамещатьОбъект  = Истина;
ОбъектМодифицирован  = Ложь;
КонецЕсли;
8. olgita_n 10.07.19 10:41 Сейчас в теме
(7) Выдает ошибку при загрузки
ОписаниеОшибки = Поле объекта не обнаружено (бит_ТипДоговора)
ПозицияМодуля = (1)
КодСообщения = 20
Прикрепленные файлы:
9. tusv 159 10.07.19 11:01 Сейчас в теме
(8)Источника при Загрузке не существует. Потому и ругается.
Переносите бит_ТипДоговора, как параметр и сравнивайте. Приблизительно
Если ПараметрыОбъекта["Бит_ТипДоговора"] = Бла бла бла Тогда
   Бла бла бла
КоенцЕсли;
10. olgita_n 10.07.19 11:05 Сейчас в теме
(9) источник заменила на объект, такая же ошибка
11. tusv 159 10.07.19 11:08 Сейчас в теме
(10)Разумеется. В бухгалтерии 2.0 таких реквизитов нет
В правилах Добавьте ПКС Бит_ТипДоговора. Передавать в Параметр и далее, как в 9
12. olgita_n 10.07.19 11:15 Сейчас в теме
(11) все равно выдает ошибку

Обработчик = ПриЗагрузкеОбъекта
ОписаниеОшибки = Получение элемента по индексу для значения не определено
ПозицияМодуля = (1)
КодСообщения = 20
Прикрепленные файлы:
13. tusv 159 10.07.19 11:24 Сейчас в теме
(12)Для начала создайте ПКС с Передавать данные в параметр
Прикрепленные файлы:
14. olgita_n 10.07.19 11:25 Сейчас в теме
(13) он у меня созданный
Прикрепленные файлы:
15. tusv 159 10.07.19 11:35 Сейчас в теме
(14)Сорри. Не обратил внимание. Вы пишите код в обработчике При загрузке. ПараметрыОбъекта еще нет. Надо в После загрузки
16. tusv 159 10.07.19 11:37 Сейчас в теме
(15)И написать Отказ = Истина
17. olgita_n 10.07.19 11:43 Сейчас в теме
(15) тогда он у меня выгружает и изменяет эти договоры
18. tusv 159 10.07.19 12:12 Сейчас в теме
19. olgita_n 10.07.19 12:52 Сейчас в теме
20. olgita_n 10.07.19 13:15 Сейчас в теме
(18)Отказ = Истина сработал, то тогда он не загружает в справочнике это поле
21. tusv 159 10.07.19 13:35 Сейчас в теме
(20)Так Вам поле не надо менять?
Тогда
Это так
Если Условие выполняется Тогда
  //Возвращаем старое значение
   Объект.Нужное поле = Объект.Ссылка.Нужное поле;
КонецЕсли;
22. olgita_n 10.07.19 13:55 Сейчас в теме
(21) А это где прописывать, а то я уже запуталась
23. dakork 14 10.07.19 18:36 Сейчас в теме
24. olgita_n 11.07.19 10:47 Сейчас в теме
Создала два ПКО для справочника Договоры. В одном необходимы поля и при выгрузке прописала запрет на выгрузку с определенным типом. А в другом ПКО при выгрузки прописала только нужный тип договоров и выбрала только одно поле для выгрузки и это правило указала в ПКО банковского счета у поля Договоры.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Москва
Полный день

Консультант-аналитик 1С
Москва
Полный день

Консультант ERP-систем
Москва
Временный (на проект)

Бизнес-аналитик 1С
Москва
зарплата от 90 000 руб. до 150 000 руб.
Полный день