обмен данным с сайтом через xml файлы комерсмл 2

1. vse-puchcom 10.04.19 08:09 Сейчас в теме
бяда бядова народ нужен хелп
вообщем соорудили мы сайт с которым идет обмен через xml файлы
сразу говорю не на битриксе а на сайте мегагрупп вообщем они говорят что у них все норм
а вот на стороне 1с косяк мол типо либо в форме либо еще где кояк

в самом узле обмена есть выбор ставиться две галочки иерархия по
1 видам номенклатуры
2 группам номенклатуры
и вообщем то что когда выбрано по видам все выгружается ровно там товар услуги все норм папки создаются автоматом
а когда выбираешь по группам он либо выкидывает по видам либо без каких либо групп..
хелп ми плиз скажи че надо выложу)))
1с розница 2.2 ут 11
Вознаграждение за ответ
Показать полностью
Найденные решения
14. vse-puchcom 19.04.19 10:10 Сейчас в теме +0.5 $m
все парни решил))
просто заменил все везде на номенклатура родитель и это группа и все за фужильмировало как мне надо
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. platonov.e 159 10.04.19 08:13 Сейчас в теме
Ошибка в коде, не иначе)
3. vse-puchcom 10.04.19 08:14 Сейчас в теме
(2) хех логишно))) кто бы подсказал куда смотреть))
4. SedovSU@mail.ru 298 10.04.19 08:22 Сейчас в теме
(3) вы приложите фрагмент кода может явно ошибку можно будет увидить
6. vse-puchcom 10.04.19 08:25 Сейчас в теме
(4)
может явно ошибку можно будет увидить
а чего именно я могу из модуля дернуть или из плана обена
(5) тааак минууутку
7. platonov.e 159 10.04.19 08:27 Сейчас в теме
(6) выгрузка из 1с и загрузка на сайт самописная? Посмотрите xml, может там все нормально выгружается, а дело в загрузке на сайт?
5. platonov.e 159 10.04.19 08:23 Сейчас в теме
(3) в код, где условия разделяется на выгрузку по видам или группам) там должно быть что то типа
Если ПоВидам Тогда
Иначе
КонецЕсли;

))
8. vse-puchcom 10.04.19 08:41 Сейчас в теме
(5)
Процедура ТаблицаКаталоговПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
	
	Если Копирование Тогда
		
		Элемент.ТекущиеДанные.ИдентификаторКаталога = "";
		
	КонецЕсли;
	
	Если (Элемент.ТекущиеДанные.Группы.Количество() = 1
		И НЕ ЗначениеЗаполнено(Элемент.ТекущиеДанные.Группы[0].Значение))
		ИЛИ Элемент.ТекущиеДанные.Группы.Количество() = 0 Тогда
		
		НовыйСписокГрупп = Новый СписокЗначений;
		Если Объект.ОтборГруппыКатегорииНоменклатуры = ПредопределенноеЗначение("Перечисление.ВидыОтборовНоменклатуры.ГруппыНоменклатуры") Тогда
			ТипЗначений = ПолучитьТипСправочника("Номенклатура");
			Элементы.ТаблицаКаталоговГруппы.ВыборГруппИЭлементов = ГруппыИЭлементы.Группы;
		Иначе
			ТипЗначений = ПолучитьТипСправочника("ВидыНоменклатуры");
			Элементы.ТаблицаКаталоговГруппы.ВыборГруппИЭлементов = ГруппыИЭлементы.ГруппыИЭлементы;
		КонецЕсли;
		
		НовыйСписокГрупп.ТипЗначения = ТипЗначений;
		НовыйСписокГрупп.Добавить(Неопределено, НадписьВсеЭлементыСписка);
		Элемент.ТекущиеДанные.Группы = НовыйСписокГрупп;
		
	КонецЕсли;
Показать
9. vse-puchcom 10.04.19 08:44 Сейчас в теме
(5) // Добавляем отбор по каталогу.

Если СписокГруппКаталога <> Неопределено И СписокГруппКаталога.Количество() > 0 Тогда
		
		НовыйЭлемент = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
		НовыйЭлемент.ИдентификаторПользовательскойНастройки = ОтборПоКаталогу;
		
		Если КлассифицироватьПоВиду = Истина Тогда
			НовыйЭлемент.ЛевоеЗначение =  Новый ПолеКомпоновкиДанных("НоменклатураВидНоменклатуры");
		Иначе
			НовыйЭлемент.ЛевоеЗначение =  Новый ПолеКомпоновкиДанных("Номенклатура");
		КонецЕсли;
Показать


это общий модуль
10. platonov.e 159 10.04.19 08:46 Сейчас в теме
(9) Я думаю нужно пригласить специалиста. По кускам кода ничего не понятно. Либо обратится к разработчикам выгрузки.
11. пользователь 10.04.19 08:52
Сообщение было скрыто модератором.
...
12. vse-puchcom 10.04.19 10:14 Сейчас в теме
ИдГруппы = "";
	ВыгружатьВид = Ложь;
	Если Параметры.ПрикладныеПараметры.Свойство("КлассифицироватьПоВидамНоменклатуры")
		И Параметры.ПрикладныеПараметры.КлассифицироватьПоВидамНоменклатуры <> Неопределено Тогда
		Попытка
			ВыгружатьВид = Параметры.ПрикладныеПараметры.КлассифицироватьПоВидамНоменклатуры;
		Исключение
			СтрокаОшибки = ОписаниеОшибки();
		КонецПопытки;
	КонецЕсли;
	Если ВыгружатьВид Тогда
		Если ЗначениеЗаполнено(ДанныеНоменклатуры.НоменклатураВидНоменклатуры) Тогда
			ИдГруппы = УникальныйИдентификаторОбъекта(ДанныеНоменклатуры.НоменклатураВидНоменклатуры);
		КонецЕсли;
	Иначе
		Если ЗначениеЗаполнено(ДанныеНоменклатуры.НоменклатураРодитель) Тогда
			ИдГруппы = УникальныйИдентификаторОбъекта(ДанныеНоменклатуры.НоменклатураРодитель);
		КонецЕсли;
	КонецЕсли;
Показать
13. user1194547 10.04.19 10:38 Сейчас в теме
Может проблема именно в xml файле?
14. vse-puchcom 19.04.19 10:10 Сейчас в теме +0.5 $m
все парни решил))
просто заменил все везде на номенклатура родитель и это группа и все за фужильмировало как мне надо
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот