Перенос пользователей ИБ с помощью 1С:Конвертации данных

1. Jhormungand_1C 03.04.19 14:25 Сейчас в теме
Добрый день, товарищи программисты.

На днях прочитал статью Перенос пользователей ИБ с помощью 1С:Конвертации данных

Сделал все, как описано в статье ( только учел "Важно:
Если для выборки данных ПВД используется произвольный алгоритм и в обработчике ПВД "Перед обработкой" инициируется параметр ВыборкаДанных, то для ПКО следует установить признак "Не запоминать выгруженные объекты"." из справки по обработчикам в КД 2.1). Но при загрузке в базу приемник вылетает ошибка "Значение не является значением объектного типа (Метаданные)". В отладчике нашел место возникновения ошибки:

 // Выполняет проверку на наличие запрета загрузки по дате.
//
// Параметры:
//   ЭлементДанных	  - СправочникОбъект, ДокументОбъект, РегистрСведенийНаборЗаписей и др. данные.
//                      Данные, которые были зачитаны из сообщения обмена, но еще не были записаны в ИБ.
//   ПолучениеЭлемента - ПолучениеЭлементаДанных.
//
// Возвращаемое значение:
//   Булево - Истина - установлена дата запрета изменения и загружаемый объект имеет дату меньше установленной, иначе Ложь.
//
Функция ЗапретИзмененияДанныхПоДате(ЭлементДанных)
	
	ИзменениеЗапрещено = Ложь;
	
	Если МодульДатыЗапретаИзменения <> Неопределено
		И Не Метаданные.Константы.Содержит(ЭлементДанных.Метаданные()) Тогда
		Попытка
			Если МодульДатыЗапретаИзменения.ИзменениеЗапрещено(ЭлементДанных) Тогда
				ИзменениеЗапрещено = Истина;
			КонецЕсли;
		Исключение
			ИзменениеЗапрещено = Ложь;
		КонецПопытки;
	КонецЕсли;
	
	ЭлементДанных.ДополнительныеСвойства.Вставить("ПропуститьПроверкуЗапретаИзменения");
	
	Возврат ИзменениеЗапрещено;
	
КонецФункции
 
Показать


Параметр ЭлементДанных = Неопределено, соответственно возникает ошибка.

При чем первый пользователь записывается в БД, значит обработчик ПередЗагрузкой отрабатывает исправно, а вот далее вылетает ошибка.

Кто переносил пользователей ИБ путем, описанным в статье?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. idw 343 20.02.23 11:41 Сейчас в теме
Аналогичная проблема. Только переношу документы.

Ошибка при загрузке данных: Значение не является значением объектного типа (Метаданные)
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(9291)}:Если МодульДатыЗапретаИзменения <> Неопределено
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(9010)}:Отказ = Отказ Или ЗапретИзмененияДанныхПоДате(Объект);
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(12793)}:ПоследнийОбъектЗагрузки = ПрочитатьОбъект();
{Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(13132)}:ПроизвестиЧтениеДанных();
{Обработка.УниверсальныйОбменДаннымиXML.Форма.УправляемаяФорма.Форма(1421)}:ОбъектДляСервера.ВыполнитьЗагрузку();


Никто не разобрался?
Оставьте свое сообщение
Вакансии
Аналитик-консультант 1C:ERP
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день

Консультант 1С
Москва
зарплата от 80 000 руб. до 150 000 руб.
Полный день

Программист 1С (ERP, УХ, КА 2, УТ 11), удаленно
Москва
зарплата от 160 000 руб.
Полный день

Аналитик 1С
Москва
зарплата от 200 000 руб.
Полный день

Консультант 1С / Специалист поддержки 1C
Екатеринбург
зарплата от 70 000 руб.
Полный день