Шаблон внешней печатной формы для БСП с универсальной формой тестирования

0. 224 23.03.19 23:45 Сейчас в теме
Данный шаблон содержит форму тестирования печати для конфигураций, разработанных на базе БСП. Форма универсальная - сама определяет команды печати и поддерживаемые объекты. Не требует доработок. Скопируйте ее в ваши обработки печатных форм и назначьте основной. Далее тестируйте через файл-открыть.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. JohnConnor 43 17.06.20 11:29 Сейчас в теме
НЕ РАБОТАЕТ !

КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(КомандыПечати[НомерСтрокиКомандПечати-1].Идентификатор);
Прикрепленные файлы:
2. JohnConnor 43 17.06.20 11:39 Сейчас в теме
(1)ЗАКОМЕНТИЛ И ДОБАВИЛ ВОТ ТАК

//КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(КомандыПечати[НомерСтрокиКомандПечати-1].Идентификатор);
КоллекцияПечатныхФорм = ПодготовитьКоллекциюПечатныхФорм(КомандыПечати[НомерСтрокиКомандПечати-1].Идентификатор);


Функция ПодготовитьКоллекциюПечатныхФорм(Знач ИменаМакетов)

Макеты = Новый ТаблицаЗначений;
Макеты.Колонки.Добавить("ИмяМакета");
Макеты.Колонки.Добавить("ИмяВРЕГ");
Макеты.Колонки.Добавить("СинонимМакета");
Макеты.Колонки.Добавить("ТабличныйДокумент");
Макеты.Колонки.Добавить("Экземпляров");
Макеты.Колонки.Добавить("Картинка");
Макеты.Колонки.Добавить("ПолныйПутьКМакету");
Макеты.Колонки.Добавить("ИмяФайлаПечатнойФормы");
Макеты.Колонки.Добавить("ОфисныеДокументы");

Если ТипЗнч(ИменаМакетов) = Тип("Строка") Тогда
ИменаМакетов = СтрРазделить(ИменаМакетов, ",");
КонецЕсли;

Для Каждого ИмяМакета Из ИменаМакетов Цикл
Макет = Макеты.Найти(ИмяМакета, "ИмяМакета");
Если Макет = Неопределено Тогда
Макет = Макеты.Добавить();
Макет.ИмяМакета = ИмяМакета;
Макет.ИмяВРЕГ = ВРег(ИмяМакета);
Макет.Экземпляров = 1;
Иначе
Макет.Экземпляров = Макет.Экземпляров + 1;
КонецЕсли;
КонецЦикла;

Возврат Макеты;

КонецФункции
Показать
Оставьте свое сообщение
Вопросы с вознаграждением