Выгрузка из УТ 10.3 в БП2.0 базовая

1. Александр Ключников (Ксалекс) 12.01.18 13:42 Сейчас в теме
Выгрузка из УТ 10.3 в БП2.0 базовая, после обновлений БП сломалась. Была настройка "Возможность подключения к информационной базе-приёмнику Не требуется продолжение настройки обменов на стороне инф базе приёмнике"
После обновления 1С Бухгалтерия 8 базовая, редакция 2.0 и технологической платформы , выгрузка из торговли стала невозможной, и выдаёт следующие ошибки, что делать ?

Ошибка при выгрузке данных: {Обработка.ОбменДаннымиXML.МодульОбъекта(14466)}: Ошибка при вызове метода контекста (ВыполнитьДействияПередЧтениемДанных): Произошла исключительная ситуация (1C:Enterprise 8.2.19.130): {Перечисление.СтавкиНДС.МодульМенеджера(3,2)}: Ожидается оператор препроцессора
Ошибка при вызове метода контекста (ВыполнитьДействияПослеЗавершенияЧтенияДанных): Произошла исключительная ситуация (1C:Enterprise 8.2.19.130): {Обработка.ОбменДаннымиXML.МодульОбъекта(14293)}: Значение не является значением объектного типа (Закрыть)

Начат обмен данными по настройке "Обмен с "Бухгалтерия предприятия, редакция 2.0"" (22:47:14).

Начало выгрузки: 09.01.2018 22:47:28

Ошибка при выгрузке данных: {Обработка.ОбменДаннымиXML.МодульОбъекта(14466)}: Ошибка при вызове метода контекста (ВыполнитьДействияПередЧтениемДанных): Произошла исключительная ситуация (1C:Enterprise 8.2.19.130): {Перечисление.СтавкиНДС.МодульМенеджера(3,2)}: Ожидается оператор препроцессора
Ошибка при вызове метода контекста (ВыполнитьДействияПослеЗавершенияЧтенияДанных): Произошла исключительная ситуация (1C:Enterprise 8.2.19.130): {Обработка.ОбменДаннымиXML.МодульОбъекта(14293)}: Значение не является значением объектного типа (Закрыть)



{ОбщийМодуль.ПроцедурыОбменаДанными.Модуль(4019)}: {Обработка.ОбменДаннымиXML.МодульОбъекта(14489)}: Ошибка при вызове метода контекста (ВыполнитьДействияПослеЗавершенияЧтенияДанных): Произошла исключительная ситуация (1C:Enterprise 8.2.19.130): {Обработка.ОбменДаннымиXML.МодульОбъекта(14293)}: Значение не является значением объектного типа (Закрыть)
ВызватьИсключение СтрокаОписанияОшибки;
Прикрепленные файлы:
Ответы
2. Борис (buriZa) 25 12.01.18 14:12 Сейчас в теме
Добрый день!
Частенько после обновления БП надо в базу УТ подкреплять новые правила конвертации из релиза бухгалтерии. Если вы это не делали, могу замудриться - описать процесс (если вы этого ещё не делали).
3. Александр Ключников (Ксалекс) 12.01.18 14:24 Сейчас в теме
(2) подкреплял но не из бухгалтерии а из УТ... в УТ более новее правила, в БП они рассчитаны на УТ более ранней версии
4. Борис (buriZa) 25 12.01.18 17:51 Сейчас в теме
(3) на сколько я помню в релизе БП лежат правила для УТ,
когда в релизе УТ лежат правила для БП.
Но вам виднее. Давно эту схему не юзал.
5. Александр Ключников (Ксалекс) 12.01.18 18:57 Сейчас в теме
(4) и в УТ и в БП лежат оба правила выгрузки, но в БП для ранних релизов, в УТ более актуально, Сейчас в БП вышло новое обновления, буду пробовать опять, хотя в 1С уже выслал базы для их проверок
6. Дмитрий Х (ХДС) 19.01.18 09:24 Сейчас в теме
(5)Вам удалось решить проблему или получить разъяснение от 1С?
7. Александр Ключников (Ксалекс) 19.01.18 20:34 Сейчас в теме
(6) Нет, было ещё 2 обновления, результаты остались теме же, в 1С базы выслал и они исчезли.. неделя прошла и не одного ответа
8. Алла Малеева (allunka) 20.01.18 21:57 Сейчас в теме
Добрый день!

Столкнулась с той же проблемой. УТ 10.3.46.2, БП 2.0.66.46, Платформа 8.3.9.1818, обмен прямым подключением из УТ к БП, правила обмена актуальные.

В БП 2.0.66.46 по сравнению с 66.39, с которой обновлялась, и в которой обмен проходил без ошибок, в Модуле менеджера Перечисления СтавкиНДС (на что "ругается" обмен) появился следующий код:
--------------------------------------------------------------------
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область ПрограммныйИнтерфейс

// Определяет ставки НДС, операции, отраженные по которым, подлежат регистрации в книге продаж.
//
// Параметры:
// Параметры - Структура - параметры для определения ставок
// * ВерсияПостановленияНДС1137 - Число - см. УчетНДСПереопределяемый.ВерсияПостановленияНДС1137.
//
// Возвращаемое значение:
// Массив - ставки НДС
Функция СтавкиПоОперациямОтражаемымВКнигеПродаж(ВерсияПостановленияНДС1137) Экспорт

МассивСтавок = Новый Массив;

МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС0);
МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС10);
МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС10_110);
МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС18);
МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС18_118);
Если ВерсияПостановленияНДС1137 < 3 Тогда
МассивСтавок.Добавить(Перечисления.СтавкиНДС.БезНДС);
КонецЕсли;

Возврат МассивСтавок;

КонецФункции

#КонецОбласти

#КонецЕсли
----------------------------------------------------------

Ошибка возникает в строке #Область ПрограммныйИнтерфейс

На просторах инета прочитала, что такую конструкцию не понимает платформа 8.2, но это вроде не наш случай....

В общем, не знаю, поможет ли это кому-то прийти к какой-нибудь умной мысли, но очень на вас всех надеюсь и жду новостей в теме ))
Оставьте свое сообщение