ЭВОТОР: выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ (54ФЗ). 1С: 7.7 ТиС

0. Техподдержка 19.06.17 15:29
Выгрузка из 1C версии 7.7 ТиС (Торговля и Склад) в EXCEL для дальнейшей загрузки в кассы ЭВОТОР, с помощью обработки обмен через EXCEL ( которая выбирается на сайте ЭВОТОР в магазине приложений).
Полная версия без ограничений.
Демоверсия позволяет выгружать только 5 строк номенклатуры(группы товаров).
Демоверсия обладает такими же характеристиками что и полная за исключением того, что выгружает 5 строк неважно чего группы или номенклатуры (текст обработки зашифрован).
Если у вас одна позиция номенклатуры или 5 позиций без групп, тогда Демоверсия для Вас.
Если вдруг выскакивает ошибка по запуску обработки попробуйте запустить 1с с правами администратора

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Техподдержка 19.06.17 17:11
Качаем выгрузку в excel файл для кассы Эвотор из 1с 7.7 , она также является полноценной для организаций с небольшим количеством номенклатуры ( до 5 позиций если в корне справочника номенклатуры)
2. Sergant 50 20.06.17 11:13 Сейчас в теме
В Эвоторе есть возможность локальной загрузки файла формата АТОЛ. (Формат простой, выгрузка пишется быстро)
3. Техподдержка 20.06.17 12:06
(2) Для 8ки возможно, никто не спорит, попробуйте для 7.7 и для номенклатуры с 30 тыс позиций
5. 00tv 23.06.17 15:38 Сейчас в теме
Можно ссылку на документацию эвотора ? Искал решение в свое время.
У них ни слова о локальном обмене. Только через облако, REST API. Для 7-ки вообще нету.
Сергей если не трудно, подскажите ? Конкретный пруф можно, а то до дыр их доки зачитал.
Пока данной обработкой пользуемся. Если есть локальный вариант, это сильно выручило бы.
Но даже Эвоторовская Техподдержка сказала, что нет такой возможности. Обманывают наверное.
4. 00tv 23.06.17 15:34 Сейчас в теме
Выручила, 45000 в семерке в торговле. Пара точек. Руками не вариант.
6. Техподдержка 28.06.17 14:38
ВАЖНО . ПЕРЕД ТЕМ КАК СТАРТОВАТЬ ОБРАБОТКУ НЕОБХОДИМО ДОБАВИТЬ В ПРОЦЕДУРУ ГЛОБАЛЬНОГО МОДУЛЯ

Процедура ПриНачалеРаботыСистемы()

СЛЕДУЩИЕ СТРОКИ (выделены жирным и курсивом)

Процедура ПриНачалеРаботыСистемы()
Перем Спр;
// Выполняется при старте
// При старте проверяем наличие компоненты "Оперативный учет" 1С:Предприятия

//Добавляемые строки

Если ЗагрузитьВнешнююКомпоненту(каталогиб()+"decoder.dll") = 0 Тогда
Предупреждение("Недоступна компонента ""decoder.dll"".");
Иначе

КонецЕсли;


//КонецДобавляемыхстрок
7. Oblomovo 12.09.17 10:22 Сейчас в теме
Доброго! Не могу с сайта скачать бесплатно демку. Поддержка сказала звонить на горячую линию, они типа соединят с Вами. Если оффлайн не случиться... Вопросов 2. Как всё таки заполучить демку? Какая обработка из магазина ЭВОТОР работает с Вашей обработкой? У меня 7.7 самописка(((

По обработке ЭВОТОР разобрался, недосмотрел в описании. Вопрос остался по демке, и если всё будет нормально, по покупке
9. Техподдержка 12.09.17 12:40
Добрый день Олег , теперь демо- версия бесплатна, можете ее скачать , если будут вопросы по работе пишите , обработка может работать в любых конфигурациях где есть справочники номенклатуры и типы цен
10. Oblomovo 12.09.17 12:41 Сейчас в теме
Спасибо за оперативность, увидел
12. Oblomovo 12.09.17 13:27 Сейчас в теме
Ну вот где-то так получилось. Куда идти?
Далее, у меня нет мелкооптовых и розничных. Есть только учётная в номенклатуре. На всякий переименовал ее в розничную
Прикрепленные файлы:
13. Техподдержка 12.09.17 18:07
Олег скорее всего у вас нет глобальных функций которые есть в типовой конфигурации ТиС (Торговли и Склад) необходимо их внести в глобальный модуль вашей конфигурации, пишите мне в личку я помогу их внедрить по удаленке , либо поправлю под вашу конфу свою выгрузку

вот что нужно ставить в глобальный модуль

//
//******************************************************************************
//  глПересчет(Сумма,ВалютаНач,ПоКурсуВалютыНач,ВалютаКон,ПоКурсуВалютыКон,ПоКратностиВалютыНач,ПоКратностиВалютыКон)
//
// Параметры:      
//	Сумма                - сумма, которую следует пересчитать
// 	ВалютаНач            - валюта (элемент справочника "Валюты"), из которой считаем
// 	ВалютаКон            - валюта (элемент справочника "Валюты"), в которую считаем
// 	ПоКурсуВалютыНач     - курс или дата курса валюты нач
// 	ПоКурсуВалютыКон     - курс или дата курса валюты кон
// 	ПоКратностиВалютыНач - кратность валюты нач
// 	ПоКратностиВалютыКон - кратность валюты кон
//
// Возвращаемое значение: 
//  Сумма, пересчитанная в другую валюту
//
// Описание: 
// 	Эта функция пересчитывает сумму из ВалютаНач и возвращает значение Сумма в 
// 	ВалютаКон в параметрах ПоКурсуВалютыНач и ПоКурсуВалютыКон могут передаваться
// 	либо сами курсы либо даты
//
Функция глПересчет(Сумма,ВалютаНач,ПоКурсуВалютыНач,ВалютаКон,ПоКурсуВалютыКон,ПоКратностиВалютыНач = 1,ПоКратностиВалютыКон = 1) Экспорт
	
	Если ВалютаНач = ВалютаКон Тогда
		// ну, тут и считать нечего...
		Возврат Сумма;
	КонецЕсли;

	ТипЗн=ТипЗначенияСтр(ПоКурсуВалютыНач);
	
	Если ТипЗн = "Число" Тогда
		КурсВалютыНач      = ПоКурсуВалютыНач;
		КратностьВалютыНач = ПоКратностиВалютыНач;
		КратностьВалютыНач = ?(КратностьВалютыНач = 0,1,КратностьВалютыНач);
		
	ИначеЕсли ТипЗн = "Дата" Тогда
		КурсВалютыНач      = глКурсДляВалюты(ВалютаНач,ПоКурсуВалютыНач);
		КратностьВалютыНач = глКратностьДляВалюты(ВалютаНач,ПоКурсуВалютыНач);
		
	Иначе
		Сообщить("глПересчет():Неверный тип параметра ПоКурсуВалютыНач!");
		Возврат Сумма;
		
	КонецЕсли;

	ТипЗн = ТипЗначенияСтр(ПоКурсуВалютыКон);
	
	Если ТипЗн = "Число" Тогда
		КурсВалютыКон      = ПоКурсуВалютыКон;
		КратностьВалютыКон = ПоКратностиВалютыКон;
		КратностьВалютыКон = ?(КратностьВалютыКон = 0,1,КратностьВалютыКон);
		
	ИначеЕсли ТипЗн = "Дата" Тогда
		КурсВалютыКон      = глКурсДляВалюты(ВалютаКон,ПоКурсуВалютыКон);
		КратностьВалютыКон = глКратностьДляВалюты(ВалютаКон,ПоКурсуВалютыКон);
		
	Иначе
		Сообщить("глПересчет():Неверный тип параметра ПоКурсуВалютыКон!");
		Возврат Сумма;
		
	КонецЕсли;

	Если (КурсВалютыНач = 0) 
	 ИЛИ (КурсВалютыКон = 0) Тогда
		Сообщить("При пересчете валюты обнаружен нулевой курс валюты "
		+?(КурсВалютыНач = 0,ВалютаНач,ВалютаКон));
		Возврат Сумма;
	КонецЕсли;

	Возврат Сумма * ((КурсВалютыНач / КратностьВалютыНач) / (КурсВалютыКон / КратностьВалютыКон));
	
КонецФункции // глПересчет()

//2 фунция

//******************************************************************************
// глОкруглить(Числ, ПорядокОкругления)
//
// Параметры:
//  Числ              - исходное число
//  ПорядокОкругления - элемент перечисления Порядки окгугления: 
//  "шаг" округления (0.01 (арифметическое), 0.01, 0.05, 0.1, 0.5, 1, 5, 10, 50, 100)
//
// Возвращаемое значение:
//  Округленное по заданному порядку значение
//
// Описание:
//  Округляет число вверх по заданному порядку. Т.е число 123.37 при порядке
//  округление 0.5 превратиться в 123.50, а число 0.1 при порядке округления
//  5 станет равным 5.
//  Если значение перечисления ОкрТочно, то округляет арифметически до 0.01
//
Функция глОкруглить(Числ, ПорядокОкругления) Экспорт
	Перем Рез;
	
	Если ПорядокОкругления = Перечисление.ПорядкиОкругления.ОкрТочно Тогда
		
		// арифметическое округление до 2-х знаков после запятой
		Рез = Окр(Числ, 2);
	Иначе
		// округление к верхней границе по заданному порядку
		
		// преобразуем порядок округления число
		Порядок			= Число(Строка(ПорядокОкругления));
		
		// вычислим количество интервалов, входящих в число
		КолвоИнтервал	= Числ / Порядок;
		
		// вычислим целое количество интервалов.
		КолвоИнтервалЦел= Цел(КолвоИнтервал);
		
		Если КолвоИнтервал = КолвоИнтервалЦел Тогда
			// Числа поделились нацело. Округлять не нужно.
			Рез	= Числ;
		Иначе
			Рез	= Порядок * (КолвоИнтервалЦел + 1);
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глОкруглить()

//3 функция


// глВернутьЦену1(Номенклатура, ТипЦены, ДатаЦены, ЦенаЦены, ЕдЦены, ВалЦены, НаценкаЦены, НайденнаяЦена) 
//
// Параметры: 
//  Номенклатура  - элемент справочника "Номенклатура"
//  ТипЦены       - элемент справочника "ТипыЦен"
//  ДатаЦены      - дата, на которую надо получить цену
//  ЦенаЦены      - переменная, которую надо заполнитиь значением (число) полученной цены
//  ЕдЦены        - переменная, которую надо заполнитиь значением 
//                  (элемент справочника Единицы) единицы, за которую дается цена
//  ВалЦены       - переменная, которую надо заполнитиь значением валюты, в которой выражена цена 
//  НайденнаяЦена - переменная, которую надо заполнить найденным элементом справочника цен
//
// Возвращаемое значение:
//  1 - если есть такая цена, пераметры цены заполнены
//  0 - нет такой цены
// -1 - есть только цены, помеченные на удаление
//
// Описание:
//  Формирует ценовые характеристики номенклатурной единицы по заданному типу цен. 
//
Функция глВернутьЦену(Номенклатура, ТипЦены, ДатаЦены = 0, ЦенаЦены = 0, ЕдЦены = 0, ВалЦены = 0, НаценкаЦены = 0, НайденнаяЦена = 0) Экспорт
	Перем ЦеныНоменклатуры;
	Перем Рассчетная;
	Перем НужныйТипЦен;
	Перем ЕстьУдаленные;
	
	
	Рез = 1;
	НайденнаяЦена = ПолучитьПустоеЗначение("Справочник.Цены");
	
	Если ПустоеЗначение(ДатаЦены) = 1 Тогда
		ДатаЦены = РабочаяДата();
	КонецЕсли;
	
	// Найдет или нужную цену в справочнике
	// если она рассчитывается, то найдем базовую цену 
	Рассчетная		= ТипЦены.Рассчитывается;
	НужныйТипЦен	= ?(ПустоеЗначение(Рассчетная) = 1, ТипЦены, ТипЦены.БазовыйТипЦен);
	
	ЦеныНоменклатуры= СоздатьОбъект("Справочник.Цены");
	ЦеныНоменклатуры.ИспользоватьВладельца(Номенклатура); 
	ЦеныНоменклатуры.ВыбратьЭлементы();
	
	Пока ЦеныНоменклатуры.ПолучитьЭлемент()  = 1 Цикл    
		Если ЦеныНоменклатуры.ТипЦен <> НужныйТипЦен Тогда
			Продолжить;
		КонецЕсли;
		
		НайденнаяЦена = ЦеныНоменклатуры.ТекущийЭлемент();
		
		Если ЦеныНоменклатуры.ПометкаУдаления() = 1 Тогда
			Рез = - 1; // Цена есть, но помечена на удаление
			Продолжить;
		Иначе
			Прервать;
		КонецЕсли;
		
	КонецЦикла;       
	
	Если ПустоеЗначение(НайденнаяЦена) = 1 Тогда
		
		// Нет такой цены
		Возврат 0;
	КонецЕсли;
	
	// Заполним все ценовые характериситики 
	
	// если не задана единица цены на эту дату, то потом придется обрабатывать случай нулевого коэффициента у  пустой единицы
	ЕдЦены		= НайденнаяЦена.Единица.Получить(ДатаЦены); 
	
	Если ПустоеЗначение(Рассчетная) = 1 Тогда 
		
		//Если цена не рассчитывается
		ЦенаЦены	= НайденнаяЦена.Цена.Получить(ДатаЦены);
	    //Рез=ЦенаЦены;
		// элемент справочника существует Валюту и Наценку возьмем из него
		ВалЦены		= НайденнаяЦена.Валюта;
		НаценкаЦены	= НайденнаяЦена.Процент;
	Иначе
		//Если цена рассчитывается
		БазоваяЦена 	= НайденнаяЦена.Цена.Получить(ДатаЦены);
		БазоваяВалюта	= НайденнаяЦена.Валюта;
		
		// Цены у базового типа могут отличаться
		ЦенаЦены    = глПересчет(БазоваяЦена, БазоваяВалюта, ДатаЦены, ТипЦены.Валюта, ДатаЦены);
		ЦенаЦены    = глОкруглить(ЦенаЦены * (100 + ТипЦены.Процент) / 100, ТипЦены.ПорядокОкругления);
	    
		// элемент справочника Цены не существует (расчетный). Валюту и Наценку возьмем из типа цены
		ВалЦены		= ТипЦены.Валюта;
		НаценкаЦены	= ТипЦены.Процент;
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глВернутьЦену()
Показать
Oblomovo; +1 Ответить
14. Oblomovo 25.09.17 09:27 Сейчас в теме
Спасибо огромное!!! За сутки адаптировать свою обработку к нашей "самописке" - громадный респект. Выгрузили уже несколько раз, всё прекрасно работает. Но.. есть и пожелания - выдать дерево номенклатуры, хотя бы первого уровня, есть группы, которые не участвуют в рознице, приходится удалять их вручную из Excel файла
15. Техподдержка 25.09.17 09:43
(14) Олег обращайтесь, рад что вам помог, в следующем релизе выпущу с деревом номенклатуры
16. user943592 27.03.18 09:13 Сейчас в теме
Добрый день! Выгрузка справочника номенклатура из 1С в Эвотор есть, это понятно. Непонятно есть ли загрузка продаж за день в 1С: ТиС 7.7 9.2 ?
17. user945894 29.03.18 23:34 Сейчас в теме
Добрый день! Насколько я понял информация из 1с переносится в эвотор. а именно? Количество и наименование товара по каждому складу и фирме? Справочник контрагенты ? И можно ли потом автоматически залить продажи с эвотора в 1с при наличии 2 фирм и 3 магазинов?
18. Техподдержка 18.04.18 09:21
(17)
я понял информация из 1с переносится в эвотор. а именно? Количество и наименование товара по каждому складу и фирме? Справочник контрагенты ? И можно ли потом автоматически залить продажи с эвотора в 1с при наличии 2 фирм и 3 магазинов?

Добрый день , в данный момент , реализована только выгрузка справочника номенклатуры с ценой , без учета складов и фирмы, если нужен такой функционал то добавим в следующей версии, загрузка будет реализована в другой обработке.
19. oops! 18.05.18 12:46 Сейчас в теме
(18) На счет необходимости складов и фирмы в самом Эвоторе - вопрос спорный. А вот есть ли возможность выгрузить туда остатки по конкретному складу/фирме, и осуществлять реализацию с контролем остатков? Кроме того, безусловно, без загрузки продаж из Эвотора в 1С в конце дня вся эта автоматизация не имеет никакого смысла, и в связи с этим, вопрос: когда ждать? По срокам - запуститься надо не позже 01.07.2018...
20. Техподдержка 19.05.18 00:13
(19) Егор , следущий релиз планирую выпустить после 25 мая , с учетом выгрузки остатков по складам, вы конечно понимаете что формируется файл эксель с готовыми остатками а затем его подгружаем через обмен через эксель в облаке эвотора, загружать продажи так же, выгрузка из облака в файл эксель и дальше уже загрузка реализаций в 1с, но тут встает вопрос грузить реализацию одну за 1 день или создавать множество в зависимости от количества продаж

Также планирую выпустить выгрузку под 8ку , конфигурации 1с Розница версия 1.0 ( уже опробована на 1 магазине выгружено более 140 тыс номенклатурных позиций) если кому интересно. ( постараюсь выпустить побыстрее) и по Управление торговлей 10.3 ( опробована также на предприятии)
21. oops! 20.05.18 01:08 Сейчас в теме
(20) Что ж, тогда ждём 25 мая. Я со 2-го июня в отпуске, до 29-го июня, - надеюсь, мне хватит времени на обкатку ;). Здесь сразу же вопрос - повлияют ли доработки функционала на стоимость решения?
На счёт в каком варианте грузить реализацию - тут ответ, на мой взгляд, вполне очевиден - загрузка реализации происходит в конце смены, и, по сути, грузится "Отчет ККМ", который в случае режима работы типа "фискальный регистратор" формируется с помощью обработки "Закрытие смены", которая все "чеки ККМ" удаляет, перенося данные из них в "Отчет ККМ".
Единственный здесь нюанс я вижу, так это то, что стандартная версия ТиС 9.2 не поддерживает работу с эквайринговыми терминалами, но сейчас практически не осталось розничных точек, где бы не было этих терминалов, и, к Эвотору, pin-pad также подключается. К примеру, Сбербанк сейчас вообще продаёт свои комплекты - касса Эвотор 7.3 + их pin-pad, и на обоих устройствах логотипы Сбербанка. В связи с этим очень бы хотелось хотелось, чтобы все продажи за наличный расчёт собирались в документ "Отчет ККМ", а все остальные продажи (варианты оплаты по платежной карте, кредиту) отдельно собирались в один документ "Реализация (розница)".
22. user1006119 29.06.18 08:37 Сейчас в теме
Доброе утро, ситуация следующая: работаем в унф облачной, продажи оптом но физ лицам, оплачивают по банку по счетам, но обязали на эти продажи пробивать чеки, ассортимент огромный в счете может быть и 100 позиций, есть ли возможность не дублировать продажу из 1с в эвотор, а выгрузить только ее в эвотор и пробить чек? Спасибо заранее за ответ.
23. Техподдержка 02.07.18 16:23
(22)
плачивают по банку по счетам, но обязали на эти продажи пробивать чеки, ассортимент огромный в счете может быть и 100 позиций, есть ли возможность не дублировать продажу из 1с в эвотор, а выгрузить только ее в эвотор и пробить чек? Спасибо заранее за ответ.

Людмила читайте внимательно, что делает обработка, она делает выгрузку из 1с товаров с ценами в эксель для того чтобы вы загрузив этот файл, работали с эвотором отдельно, выгрузить можно продажи из 1с , но вот загрузить в кассу)) вряд ли , смысл онлайн кассы тогда в чем
24. CheBurator 3452 29.05.20 00:06 Сейчас в теме
Еще бы в самом Эвоторе чтобы была возможность как-нибудь сканером прощелкать-проверить поступление товара на точку...
Попробовал с Эвотором поработать - как автономная касса на автономном месте где ничего более как 1.загрузить товары в кассу. 2. пробивать товар по кассе - норм. Чуть более расширенный вариант - надо искать приложения, они все мутные... без головняка на базе Эвотор вменяемой автоматизации мелкой торговой точки не сделать. ну, может Эвотор для этого и не предназначен... ва вот.. если мобильное приложение бы...
25. user1041091 04.02.21 10:57 Сейчас в теме
Ошибка при создании объекта из компоненты C:\1С_Bases\ComplexKIT\mxl_doctor.dll (отсутствует CLSID)

Отстутствует ВК (внешняя компонента) <MXL_DOCTOR>, необходимая для работы программы!
ВК <MXL_DOCTOR> можно скачать здесь: http://www.infostart.ru/projects/323/download.php?file=808

библиотека в корне базы есть!
26. user1041091 04.02.21 11:13 Сейчас в теме
Ошибка при создании объекта из компоненты C:\1С_Bases\ComplexKIT\mxl_doctor.dll (отсутствует CLSID)

Отстутствует ВК (внешняя компонента) <MXL_DOCTOR>, необходимая для работы программы!
ВК <MXL_DOCTOR> можно скачать здесь: http://www.infostart.ru/projects/323/download.php?file=808
Оставьте свое сообщение
Вопросы с вознаграждением