IE 2018
0. forseil 153 26.04.17 14:17 Сейчас в теме

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
98. forseil 153 09.04.18 09:32 Сейчас в теме
(97)у меня пока работают ЗУП 3.1.6 БП 2,0,66,53
99. ciklauri 139 11.04.18 13:43 Сейчас в теме
Спасибо огромное, мне ваша выгрузка понравилась, протестировала на БИТ.Строительство 2.0.8.108 и ЗУП 3.1.5.126. Пока полет нормальный, если что-то обнаружится, обязательно напишу.
100. dtybr 15 12.04.18 10:27 Сейчас в теме
Добрый день.
Неправильно ставит статью налогового учета на 70 счете - везде пп.1, ст.255 НК РФ, а отпуск, например, проходит по другому пункту(пп.7, ст.255 НК РФ). В ЗуП стоит правильно, а выгружает некорректно.
Эта информация есть в исходном документе в последней колонке. http://prntscr.com/j45o4b
Как-то можно исправить?
101. forseil 153 12.04.18 10:49 Сейчас в теме
114. *Zed* 277 19.04.18 17:32 Сейчас в теме
(101) Скажите пожалуйста, это уже исправлено?

Эти правила работают для ЗуП 3.1.5 и 3.1.6?
102. m_rose 1 12.04.18 14:48 Сейчас в теме
Здравствуйте. Комментарии прочитала, но так и не смогла разобраться, как разделить, чтобы в субконто затрат вместо "Оплата труда" разделял на "Оплата труда" и "страховые взносы"
103. forseil 153 12.04.18 14:49 Сейчас в теме
104. m_rose 1 12.04.18 14:52 Сейчас в теме
(103) Комплексная (я так понимаю идентична упп)
105. forseil 153 12.04.18 14:55 Сейчас в теме
(104)Тогда в справочнике Способы отражения зп надо завести два элемента
Зарплата 26
Зарплата 26 (страховые)
В первом указать статью Оплата Труда, а во втором "Страховые взносы"
106. m_rose 1 12.04.18 14:58 Сейчас в теме
(105) получается будет два элемента с разными наименованиями? А разве в правилах не по наименованию синхронизируется? В зуп получается ведь один способ отражения заводится
107. forseil 153 12.04.18 15:02 Сейчас в теме
(106)В ЗУПе один элемент, а в УПП два. в этих правилах способы не синхронизируются, я в ЗУПе и в УПП руками их заводил и настраивал
108. m_rose 1 12.04.18 15:08 Сейчас в теме
109. lenamol 16.04.18 15:14 Сейчас в теме
Добрый день! Подскажите данная обработка подойдет для выгрузки зарплатных документов из ЗУП 3.1 в БП 2.0?
110. forseil 153 16.04.18 17:06 Сейчас в теме
(109)выгружает только документ "отражение зп в рег учете"
111. mikl79 103 18.04.18 20:00 Сейчас в теме
Спасибо за правила, для БП 2.0 все загрузилось правильно по физ.лицам, но подразделения не проставились!
Наименование подразделений в ЗУП 3 и БП 2.0 совпадают, подскажите как сделать, чтобы подразделения подгружались?
113. Alex_3189 19.04.18 12:54 Сейчас в теме
(111)
се загрузилось п
Добрый день. С подразделениями получилось решить проблему?
115. mikl79 103 19.04.18 19:59 Сейчас в теме
(113), нет пока не решал.
У вас та же проблема?
Надо в конвертацию лезть.
Знатоки подскажите пожалуйста - я правильно понимаю, что нужно в конвертацию 2.1 загрузить правила обмена? тут 3.0 не подойдет?
116. Alex_3189 20.04.18 09:35 Сейчас в теме
112. Alex_3189 19.04.18 12:53 Сейчас в теме
Добрый день. Подскажите на последних релизах ЗУП и БП проверял кто-нибудь? Все корректно работает?
117. forseil 153 20.04.18 09:46 Сейчас в теме
(112)На последних релизах все работает
118. forseil 153 20.04.18 09:47 Сейчас в теме
(112)По подразделениям: в параметрах надо поставить галочку разворачивать по подразделениям
119. Alex_3189 20.04.18 10:01 Сейчас в теме
120. mikl79 103 20.04.18 11:54 Сейчас в теме
(118), в параметрах поставил "Выгружать в разрезе подразделений", но загружается с пустыми подразделениями.
У меня релиз БП 2.0.66.42 (вернее ВДГБ: Ломбард 3.3.41.10), ЗУП 3.1.5.129
121. forseil 153 20.04.18 12:48 Сейчас в теме
(120)Надо смотреть, поиск идет по названию и владельцу
122. Alex_3189 23.04.18 16:38 Сейчас в теме
Добрый день!
Справочники "Способы отражения.." я сопоставил. Но у меня не переносится Аренда транспорта. Вернее сумма переносится, а остальные поля не заполняются. И аналогично с НДФЛ с дивидентов.

Подскажите, в чем может быть проблема?
Прикрепленные файлы:
123. forseil 153 23.04.18 16:44 Сейчас в теме
(122) Эти виды операций не прописаны в моих правилах, соответственно и результат(
124. Alex_3189 23.04.18 17:20 Сейчас в теме
(123) Это надо в конвертацию лезть? Подойдет конвертацию 2.1 или нужна 3.0?
125. forseil 153 23.04.18 18:39 Сейчас в теме
126. mikl79 103 26.04.18 13:41 Сейчас в теме
Добрый день, я разобрался почему не встает подразделение.
У меня для 44.01 счета не прописывалось подразделение, т.к. у данного счета Не стоит флаг "Учет по подразделениям".

Это явно прописано в правилах в ПКО "ОтражениеЗарплатыВРеглУчете" в обработчике "После загрузки".

...
Если НЕ СтрокаОтражениеВУчете.СчетДт.УчетПоПодразделениям Тогда
СтрокаОтражениеВУчете.ПодразделениеДт = Справочники.ПодразделенияОрганизаций.ПустаяСсылка();
КонецЕсли;
...
127. mikl79 103 27.04.18 07:11 Сейчас в теме
Спасибо автору, использую для переноса ЗУП 3 в БП 2.0.66.42 (вернее ВДГБ: Ломбард 3.3.41.10), немного доработал под свои нюансы.
С помощью данных правил немного разобрался в конвертации 2.1 )
128. BlizD 550 27.04.18 10:31 Сейчас в теме
Добрый день.

Спасибо за правила, очень помогли.
Правда напрямую использовать в нашем случае не получилось (много своих особенностей), но подсматривая в Ваши правила сделали свои.

Возможно в этом участке кода ошибка: где указывается РегистрацияВИФНС в субконто, похоже надо СубконтоДт2 заменить на СубконтоКт2:


ИначеЕсли ВидОперации = "НДФЛ" Тогда
	СтрокаОтражениеВУчете.СчетДт      = мСчет_70; 
	Если СтрокаОтражениеВУчете.СчетДт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РаботникиОрганизаций) = Неопределено Тогда 
		СтрокаОтражениеВУчете.СубконтоДт1 = Перечисления.ВидыНачисленийОплатыТрудаПоСт255НК.пп1ст255;
		СтрокаОтражениеВУчете.СубконтоДт2 = Неопределено;
		СтрокаОтражениеВУчете.СубконтоДт3 = Неопределено;
	Иначе
		СтрокаОтражениеВУчете.СубконтоДт1 = СтрокаОтражениеВУчете.ФизЛицо;
		СтрокаОтражениеВУчете.СубконтоДт2 = Перечисления.ВидыНачисленийОплатыТрудаПоСт255НК.пп1ст255;
		СтрокаОтражениеВУчете.СубконтоДт3 = Неопределено;
	КонецЕсли;	
	СтрокаОтражениеВУчете.СчетКт      = мСчет_6801; //ПланыСчетов.Хозрасчетный.НайтиПоКоду("68.01"); 
	СтрокаОтражениеВУчете.СубконтоКт1 = Перечисления.ВидыПлатежейВГосБюджет.Налог;
	СтрокаОтражениеВУчете.СубконтоКт2 = Неопределено;
	СтрокаОтражениеВУчете.СубконтоКт3 = Неопределено;
	Если Найти(Метаданные.Имя, "КОРП") <> 0 Тогда
		Если СтрокаОтражениеВУчете.СчетКт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РегистрацияВИФНС) <> Неопределено Тогда 
			РегистрацияВИФНС = Справочники.РегистрацияВИФНС.ПустаяСсылка();
			Выполнить(Алгоритмы.ПолучитьРегистрациюВИФНС);
			//+ #2005 Иванов А.Б. 2018-04-27
			//СтрокаОтражениеВУчете.СубконтоДт2 = РегистрацияВИФНС;
			СтрокаОтражениеВУчете.СубконтоКт2 = РегистрацияВИФНС;
			//- #2005 Иванов А.Б. 2018-04-27
		КонецЕсли;
	КонецЕсли;	
Показать
user705522_constantin_h; +1 Ответить
129. forseil 153 27.04.18 17:37 Сейчас в теме
130. BlizD 550 28.04.18 12:05 Сейчас в теме
Добрый день, Евгений.

На стороне ЗУП 3 не учитываются при выгрузке следующие реквизиты:

* ПФРЗаЗанятыхНаПодземныхИВредныхРаботахБезСпецОценки
* ПФРЗаЗанятыхНаПодземныхИВредныхРаботахСпецОценка
* ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахБезСпецОценки
* ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахСпецОценка

Добавил в запрос выгрузке следующий код:

//+ #2005 Иванов А.Б. 2018-04-27
|//Взносы в ПФР (вредные работы, без спец. оценки) (с резерва)
|ВЫБРАТЬ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ФизическоеЛицо,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Подразделение,
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) ТОГДА
| ""ПФР (вредные работы, без спец. оценки) (с резерва)""
| ИНАЧЕ
| ЗНАЧЕНИЕ(Перечисление.ВидыОперацийПоЗарплате.ПФРЗаЗанятыхНаПодземныхИВредныхРаботахБезСпецОценки) КОНЕЦ,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.СпособОтраженияЗарплатыВБухучете, ЗНАЧЕНИЕ(Справочник.СпособыОтраженияЗарплатыВБухУчете.ПустаяСсылка)),
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ОблагаетсяЕНВД,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботахБезСпецОценки, 0),
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) И НЕ &ФормироватьРезервОтпусковНУ ТОГДА
| 0
| ИНАЧЕ
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботах, 0)
| КОНЕЦ,
| 0,
| 0,
| """",
| """",
| ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
|ИЗ
| Документ.ОтражениеЗарплатыВБухучете.НачисленнаяЗарплатаИВзносы КАК ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы
|ГДЕ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Организация = &Организация
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Дата МЕЖДУ &НачалоПериода И &ОкончаниеПериода
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Проведен
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботахБезСпецОценки <> 0
|ОБЪЕДИНИТЬ ВСЕ
//- #2005 Иванов А.Б. 2018-04-27
//+ #2005 Иванов А.Б. 2018-04-27
|//Взносы в ПФР (вредные работы, спец. оценка) (с резерва)
|ВЫБРАТЬ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ФизическоеЛицо,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Подразделение,
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) ТОГДА
| ""ПФР (вредные работы, спец. оценка) (с резерва)""
| ИНАЧЕ
| ЗНАЧЕНИЕ(Перечисление.ВидыОперацийПоЗарплате.ПФРЗаЗанятыхНаПодземныхИВредныхРаботахСпецОценка) КОНЕЦ,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.СпособОтраженияЗарплатыВБухучете, ЗНАЧЕНИЕ(Справочник.СпособыОтраженияЗарплатыВБухУчете.ПустаяСсылка)),
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ОблагаетсяЕНВД,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботахСпецОценка, 0),
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) И НЕ &ФормироватьРезервОтпусковНУ ТОГДА
| 0
| ИНАЧЕ
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботах, 0)
| КОНЕЦ,
| 0,
| 0,
| """",
| """",
| ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
|ИЗ
| Документ.ОтражениеЗарплатыВБухучете.НачисленнаяЗарплатаИВзносы КАК ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы
|ГДЕ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Организация = &Организация
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Дата МЕЖДУ &НачалоПериода И &ОкончаниеПериода
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Проведен
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботахСпецОценка <> 0
|ОБЪЕДИНИТЬ ВСЕ
//- #2005 Иванов А.Б. 2018-04-27
//+ #2005 Иванов А.Б. 2018-04-27
|//Взносы в ПФР (тяжелые работы, без спец. оценки) (с резерва)
|ВЫБРАТЬ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ФизическоеЛицо,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Подразделение,
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) ТОГДА
| ""ПФР (тяжелые работы, без спец. оценки) (с резерва)""
| ИНАЧЕ
| ЗНАЧЕНИЕ(Перечисление.ВидыОперацийПоЗарплате.ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахБезСпецОценки) КОНЕЦ,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.СпособОтраженияЗарплатыВБухучете, ЗНАЧЕНИЕ(Справочник.СпособыОтраженияЗарплатыВБухУчете.ПустаяСсылка)),
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ОблагаетсяЕНВД,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахБезСпецОценки, 0),
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) И НЕ &ФормироватьРезервОтпусковНУ ТОГДА
| 0
| ИНАЧЕ
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботах, 0)
| КОНЕЦ,
| 0,
| 0,
| """",
| """",
| ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
|ИЗ
| Документ.ОтражениеЗарплатыВБухучете.НачисленнаяЗарплатаИВзносы КАК ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы
|ГДЕ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Организация = &Организация
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Дата МЕЖДУ &НачалоПериода И &ОкончаниеПериода
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Проведен
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахБезСпецОценки <> 0
|ОБЪЕДИНИТЬ ВСЕ
//- #2005 Иванов А.Б. 2018-04-27
//+ #2005 Иванов А.Б. 2018-04-27
|//Взносы в ПФР (тяжелые работы, спец. оценка) (с резерва)
|ВЫБРАТЬ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ФизическоеЛицо,
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Подразделение,
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) ТОГДА
| ""ПФР (тяжелые работы, спец. оценка) (с резерва)""
| ИНАЧЕ
| ЗНАЧЕНИЕ(Перечисление.ВидыОперацийПоЗарплате.ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахСпецОценка) КОНЕЦ,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.СпособОтраженияЗарплатыВБухучете, ЗНАЧЕНИЕ(Справочник.СпособыОтраженияЗарплатыВБухУчете.ПустаяСсылка)),
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ОблагаетсяЕНВД,
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахСпецОценка, 0),
| ВЫБОР КОГДА ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ВидОперации В (&СписокОперацийЗаСчетРезерва) И НЕ &ФормироватьРезервОтпусковНУ ТОГДА
| 0
| ИНАЧЕ
| ЕСТЬNULL(ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаПодземныхИВредныхРаботах, 0)
| КОНЕЦ,
| 0,
| 0,
| """",
| """",
| ЗНАЧЕНИЕ(Справочник.Контрагенты.ПустаяСсылка)
|ИЗ
| Документ.ОтражениеЗарплатыВБухучете.НачисленнаяЗарплатаИВзносы КАК ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы
|ГДЕ
| ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Организация = &Организация
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Дата МЕЖДУ &НачалоПериода И &ОкончаниеПериода
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.Ссылка.Проведен
| И ОтражениеЗарплатыВБухучетеНачисленнаяЗарплатаИВзносы.ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахСпецОценка <> 0
|ОБЪЕДИНИТЬ ВСЕ
//- #2005 Иванов А.Б. 2018-04-27
Показать
user705522_constantin_h; +1 Ответить
131. forseil 153 28.04.18 12:13 Сейчас в теме
(130) и после загрузки добавили установку счетов?
132. BlizD 550 28.04.18 12:17 Сейчас в теме
(131)
Евгений,

в процессе, ща протестирую и скину код.
133. BlizD 550 28.04.18 12:21 Сейчас в теме
(131)
Вот такой код вставил:
//+ #2005 Иванов А.Б. 2018-04-27
//ИначеЕсли Найти(ВидОперации,"Взносы в ПФР (дополнительный тариф за занятых на работах с вредными условиями труда)") <> 0 Тогда                              
ИначеЕсли Найти(ВРЕГ(ВидОперации),ВРЕГ("Взносы в ПФР (дополнительный тариф за занятых на работах с вредными условиями труда)")) <> 0
	ИЛИ Найти(ВРЕГ(ВидОперации),ВРЕГ(СокрЛП("ПФР (вредные работы, без спец. оценки)"))) <> 0
	ИЛИ Найти(ВРЕГ(ВидОперации),ВРЕГ(СокрЛП("ПФР (вредные работы, спец. оценка)"))) <> 0
	Тогда
//- #2005 Иванов А.Б. 2018-04-27
	Если Найти(ВидОперации,"(с резерва)") <> 0 Тогда
		СтрокаОтражениеВУчете.СчетДт      = мСчет_96; //ПланыСчетов.Хозрасчетный.НайтиПоКоду("96");; 
		СтрокаОтражениеВУчете.СубконтоДт1 = Параметры.ОценочноеОбязательствоИРезервДля96;
		СтрокаОтражениеВУчете.СубконтоДт2 = Неопределено;
		СтрокаОтражениеВУчете.СубконтоДт3 = Неопределено;
	Иначе
		СтрокаОтражениеВУчете.СчетДт      = СчетЗатрат; 
		СтрокаОтражениеВУчете.СубконтоДт1 = СубконтоЗатратДт1;
		СтрокаОтражениеВУчете.СубконтоДт2 = СубконтоЗатратДт2;
		СтрокаОтражениеВУчете.СубконтоДт3 = СубконтоЗатратДт3;
		СтрокаСубконтоПоСтатьямЗатрат     = СтрокаОтражениеВУчете.СчетДт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиЗатрат);
		Если СтрокаСубконтоПоСтатьямЗатрат <> Неопределено 
			И ЗначениеЗаполнено(Параметры.СтатьяЗатратДляНалоговСОплатыТруда) Тогда
			СтрокаОтражениеВУчете["СубконтоДт" + Строка(СтрокаОтражениеВУчете.СчетДт.ВидыСубконто.Индекс(СтрокаСубконтоПоСтатьямЗатрат) + 1)] = Параметры.СтатьяЗатратДляНалоговСОплатыТруда;
		КонецЕсли;	
	КонецЕсли;	
	СтрокаОтражениеВУчете.СчетКт      = мСчет_69025; //ПланыСчетов.Хозрасчетный.НайтиПоКоду("69.02.5"); 
	СтрокаОтражениеВУчете.СубконтоКт1 = Перечисления.ВидыПлатежейВГосБюджет.Налог;                              
	//+ #2005 Иванов А.Б. 2018-04-27
	Если Найти(ВРЕГ(ВидОперации),ВРЕГ(СокрЛП("без спец. оценки"))) <> 0 Тогда
		СтрокаОтражениеВУчете.СубконтоКт1 = Перечисления.ВидыПлатежейВГосБюджет.ВзносыБезСпецоценки;
	Конецесли;
	//- #2005 Иванов А.Б. 2018-04-27
	СтрокаОтражениеВУчете.СубконтоКт2 = Неопределено;
	СтрокаОтражениеВУчете.СубконтоКт3 = Неопределено;
//+ #2005 Иванов А.Б. 2018-04-27
//ИначеЕсли Найти(ВидОперации,"Взносы в ПФР (дополнительный тариф за занятых на работах с тяжелыми условиями труда)") <> 0 Тогда                              
ИначеЕсли Найти(ВРЕГ(ВидОперации),ВРЕГ("Взносы в ПФР (дополнительный тариф за занятых на работах с тяжелыми условиями труда)")) <> 0
	ИЛИ Найти(ВРЕГ(ВидОперации),ВРЕГ(СокрЛП("ПФР (тяжелые работы, без спец. оценки)"))) <> 0
	ИЛИ Найти(ВРЕГ(ВидОперации),ВРЕГ(СокрЛП("ПФР (тяжелые работы, спец. оценка)"))) <> 0 Тогда		
//- #2005 Иванов А.Б. 2018-04-27
	Если Найти(ВидОперации,"(с резерва)") <> 0 Тогда
		СтрокаОтражениеВУчете.СчетДт      = мСчет_96; //ПланыСчетов.Хозрасчетный.НайтиПоКоду("96");; 
		СтрокаОтражениеВУчете.СубконтоДт1 = Параметры.ОценочноеОбязательствоИРезервДля96;
		СтрокаОтражениеВУчете.СубконтоДт2 = Неопределено;
		СтрокаОтражениеВУчете.СубконтоДт3 = Неопределено;
	Иначе
		СтрокаОтражениеВУчете.СчетДт      = СчетЗатрат; 
		СтрокаОтражениеВУчете.СубконтоДт1 = СубконтоЗатратДт1;
		СтрокаОтражениеВУчете.СубконтоДт2 = СубконтоЗатратДт2;
		СтрокаОтражениеВУчете.СубконтоДт3 = СубконтоЗатратДт3;
		СтрокаСубконтоПоСтатьямЗатрат     = СтрокаОтражениеВУчете.СчетДт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.СтатьиЗатрат);
		Если СтрокаСубконтоПоСтатьямЗатрат <> Неопределено 
			И ЗначениеЗаполнено(Параметры.СтатьяЗатратДляНалоговСОплатыТруда) Тогда
			СтрокаОтражениеВУчете["СубконтоДт" + Строка(СтрокаОтражениеВУчете.СчетДт.ВидыСубконто.Индекс(СтрокаСубконтоПоСтатьямЗатрат) + 1)] = Параметры.СтатьяЗатратДляНалоговСОплатыТруда;
		КонецЕсли;	
	КонецЕсли;	
	СтрокаОтражениеВУчете.СчетКт      = мСчет_69026; //ПланыСчетов.Хозрасчетный.НайтиПоКоду("69.02.6") 
	СтрокаОтражениеВУчете.СубконтоКт1 = Перечисления.ВидыПлатежейВГосБюджет.Налог;
	//+ #2005 Иванов А.Б. 2018-04-27
	Если Найти(ВРЕГ(ВидОперации),ВРЕГ(СокрЛП("без спец. оценки"))) <> 0 Тогда
		СтрокаОтражениеВУчете.СубконтоКт1 = Перечисления.ВидыПлатежейВГосБюджет.ВзносыБезСпецоценки;
	Конецесли;
	//- #2005 Иванов А.Б. 2018-04-27			
	СтрокаОтражениеВУчете.СубконтоКт2 = Неопределено;
	СтрокаОтражениеВУчете.СубконтоКт3 = Неопределено;
Показать
user705522_constantin_h; +1 Ответить
134. VasiliX1 03.05.18 09:39 Сейчас в теме
Евгений, подскажите, в архиве три файла, но файла ЗУП31-БП20 нет.
ЗУП30-БП20 грузит только выписки
ЗУП31-БП30 не загружает выписки

Есть ли возможность выложить обновленные правила с учетом предложенных доработок в обсуждениях?
Или доработать самому?

Спасибо!
Прикрепленные файлы:
135. forseil 153 03.05.18 09:45 Сейчас в теме
(134)Постараюсь выложить в ближайшее время)
VasiliX1; +1 Ответить
136. KeyMaster 84 03.05.18 17:59 Сейчас в теме
(135)Здравствуйте, Евгений.
На данный момент в архиве нет правил, грузящих отражение из ЗУП 3.1 в БП 2.0?
137. forseil 153 03.05.18 18:29 Сейчас в теме
(136)Все на месте, самый первый файл, то что в скобочках написано "(исходная)" это я для себя писал
138. KeyMaster 84 03.05.18 19:02 Сейчас в теме
(137)Спасибо.
Смутило сообщение (134), где написано:
файла ЗУП31-БП20 нет.
ЗУП30-БП20 грузит только выписки
139. VasiliX1 04.05.18 17:13 Сейчас в теме
(138)
ЗУП30-БП20 Грузит и отражение. Но у же не помню - до или после смены данных о конфигурациях в правилах.
Сейчас настроил правила на выгрузку с возможностью
указать на кого грузить зарплату, если в параметрах учета БП в разделе учета зарплаты указано "сводно по сотрудникам"
грузить по сотрудникам, даже если в параметрах учета БП указано "сводно по сотрудникам" (Субконто1 счета 70 прописываются физлица)
грузить по сотрудникам если в параметрах учета БП указано по сотрудникам (как и было прописано автором)

все обновления, предложенные в обсуждении прописал.

Спасибо автору за правила!
140. forseil 153 04.05.18 17:36 Сейчас в теме
(139) Оформите отдельную публикацию, мне кажется так будет корректнее.
141. Eddy 1 11.05.18 10:58 Сейчас в теме
ЗУП30-БП20 не выгружает субконто по дебету 26 счета, несмотря на то, что "Способ отражения" в документе "Отражение зарплаты в бухучете" совпадает по наименованию в бухгалтерии. Также проводку Дт 26 Кт 70 не выгружает в разрезе видов начисления для налогового учета.
143. forseil 153 11.05.18 11:26 Сейчас в теме
(141) надо смотреть, субконто заполняются точно, а вот вид начисления не прописан
142. Eddy 1 11.05.18 11:04 Сейчас в теме
Тестировал обработка на следующих релизах: ЗУП 3.1.6.6, БП 2.0.66.37 (к предыдущему сообщению)
146. Диван 08.06.18 10:36 Сейчас в теме
Подскажите, что не так делаю?

Начало выгрузки: 08.06.2018 10:34:44

Окончание выгрузки: 08.06.2018 10:34:44

Выгружено объектов: 0
Выгрузка данных завершена.
147. forseil 153 08.06.18 10:55 Сейчас в теме
(146)Документ отражение есть? от какого числа?
Диван; +1 Ответить
148. VladC# 61 14.06.18 09:41 Сейчас в теме
Очень пригодились, с минимальными доработками, спасибо.
149. TODD22 17 14.06.18 11:15 Сейчас в теме
Подскажите как ваши правила выгружают налоги с дополнительных дней по уходу за ребёнком инвалидом ?
Скачал какую то разработку, в ней правила, и ссылка на вашу публикацию. Написано что правила взяли из вашей публикации.

При переносе отражения ЗП суммы налогов с дополнительных дней по уходу за ребёнком инвалидом почему то попадают на 26 счёт. Видимо берут способ указанный по умолчанию.
150. forseil 153 14.06.18 11:49 Сейчас в теме
(149) Если у вас в отражении стоит операция "Расходы по страхованию ФСС" то должно выгружаться на 69
151. sapravka 23.06.18 11:23 Сейчас в теме
При загрузке в бухгалтерию 2.0 документа отражения зарплаты в регламентированном учете выходит ошибка:

Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(6991)}: Тип не определен (СправочникСсылка.СпособыОтраженияЗарплатыВБухУчете)
152. serg85 30 04.07.18 14:41 Сейчас в теме
У меня все работает, спасибо за сэкономленное время.
153. Krimskiy_xan 13.07.18 16:16 Сейчас в теме
Автору респектище огромное!!!
154. MillerOmsk 20.07.18 08:01 Сейчас в теме
Доброе время суток.
Скажите а расширили правила для операции?

ПФРЗаЗанятыхНаПодземныхИВредныхРаботахБезСпецОценки,
ПФРЗаЗанятыхНаПодземныхИВредныхРаботахСпецОценка,
ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахБезСпецОценки,
ПФРЗаЗанятыхНаТяжелыхИПрочихРаботахСпецОценка
155. Mx00 157 17.08.18 05:28 Сейчас в теме
Тестирую обработку,очень вовремя её нашел, буду умничать по ходу настройки :-)
в модуле "После загрузки правил обмена" для поиска организации лучше написать так:
ВыборкаОрганизации = Справочники.Организации.Выбрать(); ВыборкаОрганизации.Следующий();
Параметры.Организация = ВыборкаОрганизации.Ссылка;


Даты можно тоже проставлять по "текущей"
Параметры.НачалоПериодаВыгрузки = НачалоМесяца(ТекущаяДата());
Параметры.ОкончаниеПериодаВыгрузки = КонецМесяца(ТекущаяДата());


НО лучше даты брать из самой обработки ("Период выгрузки"), для этого в модулях заменить
Запрос.УстановитьПараметр("НачалоПериода", НачалоДня(Параметры.НачалоПериодаВыгрузки));
Запрос.УстановитьПараметр("ОкончаниеПериода", КонецДня(Параметры.ОкончаниеПериодаВыгрузки));

на
Запрос.УстановитьПараметр("НачалоПериода", НачалоДня(ДатаНачала));
Запрос.УстановитьПараметр("ОкончаниеПериода", КонецДня(ДатаОкончания));


При этом блок
НастройкиРезервовОтпусков   = РезервОтпусков.НастройкиРезервовОтпусков(Параметры.Организация, ДатаНачала);
Параметры.ФормироватьРезервОтпусковБУ = НастройкиРезервовОтпусков.ФормироватьРезервОтпусковБУ;
Параметры.ФормироватьРезервОтпусковНУ = НастройкиРезервовОтпусков.ФормироватьРезервОтпусковНУ;

нужно перенести в модуль "Перед выгрузкой данных", т.к. эти параметры зависят от даты
156. Winlin 11.09.18 10:44 Сейчас в теме
Подскажите что делаю не так? Паспортные данные переносятся, только по физлицу, выбранному в параметрах. По физлицам в документах не переносит паспортные данные.
157. forseil 153 11.09.18 11:49 Сейчас в теме
(156)Да наверное все правильно делаете, надо проверить, может я чего забыл прописать
158. koshak84 8 26.09.18 09:30 Сейчас в теме
Аналогичный вопрос. Правила работают с актуальными релизами ЗУП 3.1 и БП 2.0 ?
159. forseil 153 26.09.18 10:11 Сейчас в теме
(158)Да, пока особых изменений в документе "отражение зарплаты" не было
160. researcher01 05.10.18 09:19 Сейчас в теме
На связке типовых конфигураций 3.1.7.144 - 2.0.66.62 отработало без ошибок. У контрагента буду на следующей неделе проверять в бою.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата от 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Системный аналитик
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Программист 1С
Казань
Полный день