РИБ Розница: В подчиненные узлы не загружаются данные

1. Александр Доровских (Requiem) 17.12.16 09:42 Сейчас в теме
Добрый день

Столкнулись с такой проблемой. Из Центральной базы данные выгружаются, и в файле обмена они присутствуют. При этом в подчиненный узел не загружаются. И ошибок никаких не показывает.

Пробовал создавать новую номенклатуру, в подчиненную базу она не уходит. Так же пробовал переименовывать сегмент номенклатуры. До этого создавал новую группу доступа. Тоже в подчиненные узлы она не загрузилась. Хотя в выгрузке была.

Проблема воспроизводится во всех подчиненных ИБ.

Из подчиненного узла в ЦУ данные выгружаются и загружаются.

Версия 2.2.4.25

Что пробовал предпринять:
- тестирование-исправление центрального и подчиненных узлов
- пересоздание настройки обмена в ЦУ
- совет из этой темы http://forum.infostart.ru/forum15/topic163951/
- пробовал разные версии платформы

Пробовал через отладчик отловить проблему. Дошел до того, что в событии ПриПолученииДанныхОтГлавного плана обмена видно что загруженный объект создается (ЭлементДанных содержит объект), но в базу в итоге не записывается.

Что еще предпринять даже не представляю.
Ответы
2. Alx Alx (alxarz) 29 17.12.16 09:52 Сейчас в теме
посмотреть номера принятых-отправленных, может эти номера уже загружались, он их и не принимает... Как вариант - изменить номер принятых в приемнике чтобы был меньше чем отправленные в центральной.
3. борян петров (TODD22) 15 17.12.16 10:09 Сейчас в теме
Ещё бывало помогало просто обнуление номеров. В ЦБ и Узле номера сбрасывал в ноль, перерегистрировал объекты для обмена и обмен пошёл.
4. борян петров (TODD22) 15 17.12.16 10:10 Сейчас в теме
А из подчинённого узла в ЦБ данные передаются?
5. Александр Доровских (Requiem) 27 17.12.16 10:10 Сейчас в теме
(2) Если проблема с номерами, то ошибку видно. У меня никаких ошибок. В т.ч. в журнале регистрации. Да и я удалял настройку обмена в ЦБ и потом в подчиненной выставлял номер полученного. Иначе не грузилось.
6. Александр Доровских (Requiem) 27 17.12.16 10:10 Сейчас в теме
7. Александр Доровских (Requiem) 27 17.12.16 10:11 Сейчас в теме
(3) попробую. Но что то подозрительно. Я бы еще понял если в одном подчиненном была проблема. А у меня вообще ни в одну не грузятся данные.
8. борян петров (TODD22) 15 17.12.16 10:12 Сейчас в теме
У меня было пару раз так. Но я сильно не вникал почему так происходит. Обнулял номера в базах.

З.Ы да кстати у меня не грузились только в один узел.
9. борян петров (TODD22) 15 17.12.16 10:13 Сейчас в теме
Проверьте у планов обмена в узлах магазин в табличной части не слетел? С настройками плана обмена всё нормально. Лучше консолью запросов посмотреть. Мало ли....
10. борян петров (TODD22) 15 17.12.16 10:15 Сейчас в теме
И в ЦБ проверьте план обмена. Может в нём настройки какие нибудь слетели.
А зарегистрированные объекты в ЦБ копятся? Для передачи в узел.
11. Александр Доровских (Requiem) 27 19.12.16 11:08 Сейчас в теме
(10) нет, не копятся, при получения ответа от базы регистрация снимается
12. Александр Доровских (Requiem) 27 20.12.16 14:59 Сейчас в теме
Всплыла новая информация по проблеме.

Решил я поэкспериментировать на копиях. Сделал копию центрального узла. Из центрального узла заново сделал начальный образ одной из починенных баз.

Смотрю, в подчиненной базе код узла в плане обмена правильный стоит. А в константе ПрефиксУзлаРаспределеннойИнформационнойБазы совсем другой.

Полез смотреть что в других константах и нашел константу НастройкиПодчиненногоУзлаРИБ
В ней хранится xml-ка.

<?xml version="1.0" encoding="UTF-8"?>
<ПараметрыНастройки xmlns:v8="http://v8.1c.ru/data" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" ВерсияФормата="1.1">
	<ОсновныеПараметрыОбмена>
		<ИмяПланаОбмена xsi:type="xsd:string">ПоМагазину</ИмяПланаОбмена>
		<НаименованиеВторойБазы xsi:type="xsd:string">хххххххххх</НаименованиеВторойБазы>
		<НаименованиеЭтойБазы xsi:type="xsd:string">РИБ по магазину (2)</НаименованиеЭтойБазы>
		<КодНовогоУзлаВторойБазы xsi:type="xsd:string">82 </КодНовогоУзлаВторойБазы>
		<ПрефиксИнформационнойБазыИсточника xsi:type="xsd:string">03</ПрефиксИнформационнойБазыИсточника>
		<ВидТранспортаСообщенийОбмена xmlns="" xsi:type="EnumRef.ВидыТранспортаСообщенийОбмена">FILE</ВидТранспортаСообщенийО­бмена>
		<ПарольАрхиваСообщенияОбмена xsi:type="xsd:string"/>
		<FILEКаталогОбменаИнформацией xsi:type="xsd:string">C:\Файлы 1с</FILEКаталогОбменаИнформацией>
		<FILEСжиматьФайлИсходящегоСообщения xsi:type="xsd:boolean">true</FILEСжиматьФайлИсходящегоСообщения>
		<ИспользоватьПараметрыТранспортаEMAIL xsi:type="xsd:boolean">false</ИспользоватьПараметрыТранспортаEMAIL>
		<ИспользоватьПараметрыТранспортаFILE xsi:type="xsd:boolean">true</ИспользоватьПараметрыТранспортаFILE>
		<ИспользоватьПараметрыТранспортаFTP xsi:type="xsd:boolean">false</ИспользоватьПараметрыТранспортаFTP>
		<НаименованиеНастройкиВыполненияОбмена xsi:type="xsd:string">хххххххххххххх</НаименованиеНастройкиВыполненияОбмен­а>
		<КодНовогоУзла xsi:type="xsd:string">82 </КодНовогоУзла>
		<КодПредопределенногоУзла xsi:type="xsd:string">03 </КодПредопределенногоУзла>
	</ОсновныеПараметрыОбмена>
</ПараметрыНастройки>
...Показать Скрыть


И есть у меня подозрение, что с ней что то не то. Как раз код 03 и присвоился подчиненной базе при создании. Хотя должен был быть 89. Пробовал менять ПрефиксУзлаРаспределеннойИнформационнойБазы на правильный. Все равно обмен не идет. Т.е. идет только из подчиненного в центральный узел.

И еще. Константа НастройкиПодчиненногоУзлаРИБ в центральном узле содержит точно такую же xml-ку.
13. Вадим Михайлюк (vmyhailiuk) 20.12.16 15:05 Сейчас в теме
После создания нового узла разгоните всех пользователей ЦБ или перезагрузите агент сервера.
14. Александр Доровских (Requiem) 27 20.12.16 15:13 Сейчас в теме
(13) всмысле перед созданием образа базы?
15. Вадим Михайлюк (vmyhailiuk) 20.12.16 15:22 Сейчас в теме
после создания начального образа базы с ЦБ
16. борян петров (TODD22) 15 20.12.16 15:37 Сейчас в теме
(12) Вряд ли дело в xml-ке.
Посмотрите с каким номером у вас с последним выгружался объект. Например элемент справочника Номенклатура "Вилка декоративная" выгружалась с номером 325. Тогда в базе источнике поставьте номер отправляемого сообщения 350, а в базе приёмнике номер принятого 349. И сделайте обмен.
17. борян петров (TODD22) 15 20.12.16 15:38 Сейчас в теме
Вы проверили табличную часть у плана обмена в узле? Там магазин случайно не слетел?
Настройки самого плана обмена консолью смотрели? В узле и в ЦБ?
18. Александр Доровских (Requiem) 27 21.12.16 07:59 Сейчас в теме
(16)
Посмотрите с каким номером у вас с последним выгружался объект. Например элемент справочника Номенклатура "Вилка декоративная" выгружалась с номером 325. Тогда в базе источнике поставьте номер отправляемого сообщения 350, а в базе приёмнике номер принятого 349. И сделайте обмен.

Пробовал. Вообще если номера не совпадают, то не будет сниматься регистрация. Но для проверки попробовал, поставил 10000 в обоих базах. Эффекта нет. Вообще проблема воспроизводится сразу же после создания нового образа, когда еще вообще никаких обменов не было. И сразу из ЦБ ничего не грузится.

(17)
Вы проверили табличную часть у плана обмена в узле? Там магазин случайно не слетел?
Настройки самого плана обмена консолью смотрели? В узле и в ЦБ?

Да, посмотрел. Магазин указан.
19. борян петров (TODD22) 15 21.12.16 08:19 Сейчас в теме
Тогда даже не знаю что ещё можно по ванговать.... тут уже смотреть надо.
Оставьте свое сообщение