Статистика аккаунтов Instagram

0. 52 14.12.16 11:11 Сейчас в теме
Конфигурация для сбора статистики по Instagram аккаунтам

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Akuji 17 19.04.18 21:06 Сейчас в теме
что то не хочет обновлять нынче(
{ОбщийМодуль.ПроцедурыРаботыСИнстаграммом.Модуль(38)}: Ошибка при вызове метода контекста (ПрочитатьJSON)
Инст = ПрочитатьJSON(ЧтениеJSON);
по причине:
Недопустимое имя свойства: 'acct:ntb' для чтения JSON в объект Структура
MsDjuice; dance000; +2 Ответить
2. MsDjuice 104 17.10.18 20:10 Сейчас в теме
Публикация актуальная? У кого работает? Скачал и ошибка {ОбщийМодуль.ПроцедурыРаботыСИнстаграммом.Модуль(17)}: Ошибка при вызове метода контекста (ПрочитатьJSON)
Инст = ПрочитатьJSON(ЧтениеJSON);
по причине:
Недопустимое имя свойства: 'acct:ntb' для чтения JSON в объект Структура
3. MsDjuice 104 18.10.18 11:55 Сейчас в теме
(2) Может кому нужно, я сделал так:
&НаСервере
Процедура СобратьИОбновитьПоказатели(ПользовательИнстаграмма) Экспорт
	
	Результат = ПолучитьСодержимоеВебАдреса("https://www.instagram.com/" + ПользовательИнстаграмма.Наименование);
		
	Результат = Прав(Результат, СтрДлина(Результат) - Найти(Результат, "<script type=""text/javascript"">window._sharedData =")-51);
	Результат = Лев(Результат, Найти(Результат, ";</script>")-1);
	Результат = "{" + Прав(Результат, СтрДлина(Результат) - Найти(Результат, "edge_followed_by") + 2);
	СтрокаДляДж = Лев(Результат, Найти(Результат, "page_info") - 3) + "}}";
	
	ЧтениеJSON = Новый ЧтениеJSON();
	ЧтениеJSON.УстановитьСтроку(СтрокаДляДЖ);
	Инст = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();
	
	ЗаписатьПоказателиСервер(ПользовательИнстаграмма, Инст.edge_follow.count, Инст.edge_followed_by.count, Инст.edge_owner_to_timeline_media.count)
	
КонецПроцедуры
Показать
4. djolejek 21.04.19 04:33 Сейчас в теме
&НаСервере
Процедура СобратьИОбновитьПоказатели(ПользовательИнстаграмма) Экспорт
	
	// Тут нам нужно взять название Пользователя
	// И добавить к https://www.instagram.com/kevin/
	// в получившемся ответе будет json в котором есть все параметры
	// эти параметры записываем в 
	

	Результат = ПолучитьСодержимоеВебАдреса("https://www.instagram.com/" + ПользовательИнстаграмма.Наименование);
		
//	СтрокаДляДЖ = Сред(Результат, Найти(Результат, "<script type=""text/javascript"">window._sharedData =")+ 52);


	Результат = Прав(Результат, СтрДлина(Результат) - Найти(Результат, "<script type=""text/javascript"">window._sharedData =")-51);
	СтрокаДляДж = Лев(Результат, Найти(Результат, ",""to_cache"":")-1);
	СтрокаДляДж = СтрЗаменить(СтрокаДляДж,"acct:ntb","acct_ntb");
	//Результат = "{" + Прав(Результат, СтрДлина(Результат) - Найти(Результат, "edge_followed_by") + 2);
	//СтрокаДляДж = Лев(Результат, Найти(Результат, "page_info") - 3) + "}}";
	//СтрНачинаетсяС(СтрокаДляДж,"to_cache":);
     СтрокаДляДж = СтрокаДляДж + "};";


	ЧтениеJSON = Новый ЧтениеJSON();
	ЧтениеJSON.УстановитьСтроку(СтрокаДляДЖ);
	Инст = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();
	
	ЗаписатьПоказателиСервер(ПользовательИнстаграмма, Инст.entry_data.ProfilePage[0].graphql.user.edge_follow.count, Инст.entry_data.ProfilePage[0].graphql.user.edge_followed_by.count, Инст.entry_data.ProfilePage[0].graphql.user.edge_owner_to_timeline_media.count);
	
КонецПроцедуры

Функция СобратьСвойстваАккаунта(Наименование) Экспорт
	
	Результат = ПолучитьСодержимоеВебАдреса("https://www.instagram.com/" + Наименование);
		
	//СтрокаДляДЖ = Сред(Результат, Найти(Результат, "<script type=""text/javascript"">window._sharedData =")+ 52);
	Результат = Прав(Результат, СтрДлина(Результат) - Найти(Результат, "<script type=""text/javascript"">window._sharedData =")-51);
	СтрокаДляДж = Лев(Результат, Найти(Результат, ",""to_cache"":")-1);
	СтрокаДляДж = СтрЗаменить(СтрокаДляДж,"acct:ntb","acct_ntb");
	//Результат = "{" + Прав(Результат, СтрДлина(Результат) - Найти(Результат, "edge_followed_by") + 2);
	//СтрокаДляДж = Лев(Результат, Найти(Результат, "page_info") - 3) + "}}";
	//СтрНачинаетсяС(СтрокаДляДж,"to_cache":);
     СтрокаДляДж = СтрокаДляДж + "};";
	
	ЧтениеJSON = Новый ЧтениеJSON();
	ЧтениеJSON.УстановитьСтроку(СтрокаДляДЖ);
	Инст = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();
	
	
	Стр = Новый Структура();
	Стр.Вставить("Ид", Инст.entry_data.ProfilePage[0].graphql.user.id);
	Стр.Вставить("ПолноеИмя", Инст.entry_data.ProfilePage[0].graphql.user.full_name);
	Стр.Вставить("Описание",  Инст.entry_data.ProfilePage[0].graphql.user.biography);
	Стр.Вставить("Закрытый", Инст.entry_data.ProfilePage[0].graphql.user.is_private);
	Стр.Вставить("Знаменитость", Инст.entry_data.ProfilePage[0].graphql.user.is_verified);
	
	Возврат Стр;
	
КонецФункции

Показать
Оставьте свое сообщение
Вопросы с вознаграждением