Ошибки при синхронизации РИБ розница 2.2

1. user655644_a.slepcov 14.12.16 10:19 Сейчас в теме
У нас есть две розницы 2.2 одна у нас главный узел, другая подчиненный. Периодически стали возникать ошибки такого рода, что при синхронизации данные из подчиненого узла иногда теряются, это происходит не всегда, и не понятна причина этого. При этом данные из основного узла в подчиненный доходят без сбоев. Подскажите в чем может быть проблема, создавать новый РИБ мы не можем, так как филиал находиться далеко и не понятно какие данные попали в основной узел, какие нет.
Найденные решения
4. lenochka-semicova 14.12.16 15:28 Сейчас в теме
Попробуйте проверить - есть ли у Вас в конфе такое изменение

в модуле ОбменДаннымиСервер заменить строки кода


Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
Иначе
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоЗарегистрированныхОбъектов(Получатель);
КонецЕсли;

на


КоличествоОбъектовКВыгрузке = 0;
Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
КонецЕсли

Прогресс-бар при этом будет показывать 0 во время выгрузки, но данные теряться не будут.

Подробнее можно почитать тут
https://partners.v8.1c.ru/forum/topic/1508697
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. TODD22 18 14.12.16 14:41 Сейчас в теме
(1)Та же проблема. В ЦБ из регистра сведений часть записей не выгружается в узел.....
2. alxarz 31 14.12.16 14:21 Сейчас в теме
проблема может быть из-за "проблемной" базы. ТиИ в помощь.
4. lenochka-semicova 14.12.16 15:28 Сейчас в теме
Попробуйте проверить - есть ли у Вас в конфе такое изменение

в модуле ОбменДаннымиСервер заменить строки кода


Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
Иначе
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоЗарегистрированныхОбъектов(Получатель);
КонецЕсли;

на


КоличествоОбъектовКВыгрузке = 0;
Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
КонецЕсли

Прогресс-бар при этом будет показывать 0 во время выгрузки, но данные теряться не будут.

Подробнее можно почитать тут
https://partners.v8.1c.ru/forum/topic/1508697
5. gsvserg 24.06.20 18:35 Сейчас в теме
Оставьте свое сообщение
Вакансии
Консультант-аналитик 1С
Нижний Новгород
зарплата от 100 000 руб.
Полный день

Разработчик 1С
Нижний Новгород
зарплата от 100 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата до 150 000 руб.
Полный день

Разработчик 1С
Санкт-Петербург
зарплата от 130 000 руб. до 170 000 руб.
Временный (на проект)

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству