1. user655644_a.slepcov 14.12.16 10:19 Сейчас в теме

Ошибки при синхронизации РИБ розница 2.2

У нас есть две розницы 2.2 одна у нас главный узел, другая подчиненный. Периодически стали возникать ошибки такого рода, что при синхронизации данные из подчиненого узла иногда теряются, это происходит не всегда, и не понятна причина этого. При этом данные из основного узла в подчиненный доходят без сбоев. Подскажите в чем может быть проблема, создавать новый РИБ мы не можем, так как филиал находиться далеко и не понятно какие данные попали в основной узел, какие нет.
Найденные решения
4. lenochka-semicova 14.12.16 15:28 Сейчас в теме
Попробуйте проверить - есть ли у Вас в конфе такое изменение

в модуле ОбменДаннымиСервер заменить строки кода


Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
Иначе
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоЗарегистрированныхОбъектов(Получатель);
КонецЕсли;

на


КоличествоОбъектовКВыгрузке = 0;
Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
КонецЕсли

Прогресс-бар при этом будет показывать 0 во время выгрузки, но данные теряться не будут.

Подробнее можно почитать тут
https://partners.v8.1c.ru/forum/topic/1508697
Остальные ответы
Избранное Подписка Сортировка: Древо
3. TODD22 17 14.12.16 14:41 Сейчас в теме
(1)Та же проблема. В ЦБ из регистра сведений часть записей не выгружается в узел.....
2. alxarz 29 14.12.16 14:21 Сейчас в теме
проблема может быть из-за "проблемной" базы. ТиИ в помощь.
4. lenochka-semicova 14.12.16 15:28 Сейчас в теме
Попробуйте проверить - есть ли у Вас в конфе такое изменение

в модуле ОбменДаннымиСервер заменить строки кода


Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
Иначе
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоЗарегистрированныхОбъектов(Получатель);
КонецЕсли;

на


КоличествоОбъектовКВыгрузке = 0;
Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
КонецЕсли

Прогресс-бар при этом будет показывать 0 во время выгрузки, но данные теряться не будут.

Подробнее можно почитать тут
https://partners.v8.1c.ru/forum/topic/1508697
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Благовещенск (Амурская область)
зарплата от 40 000 руб. до 70 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 110 000 руб.
Полный день

Ведущий программист 1С
Ставрополь
зарплата от 80 000 руб.
Полный день