0. Alex_E 1854 23.11.15 17:18 Сейчас в теме

[COM] Перенос данных через COMConnector

Обработка обмена между двумя информационными базами схожей (не обязательно совпадающей) структуры. Изначально была заточена под бухгалтерию предприятия, сейчас используется для для обменов через COM любых конфигураций.
Ближайший аналог - выгрузка-загрузка XML, но здесь нет промежуточных файлов выгрузки/загрузки, и обмен не прекращается в случае, когда состав реквизитов источника и приёмника различен!!!

07.09.2018 Версия 5.2.2.9 Исправлены функция получения списка организаций базы источника, если в справочнике "Организации" нет кода (например в УТ 11).

Перейти к публикации

Комментарии
Сортировка: Древо
101. Alex_E 1854 10.08.17 07:36 Сейчас в теме
(99) Напишите почту в личку, пришлю изменённый вариант, по одной строке муторно очень
102. citkhv 10.08.17 07:38 Сейчас в теме
(101) отправил в личку. Жду по почте измененный вариант
113. Alex_E 1854 16.10.17 12:45 Сейчас в теме
(99) Про общий модуль, обслуживающий подписки на события уже было - подключался по амми админу - косяк был именно там.Здесь тоже ошибка в самописном модуле, я её предусмотреть или обойти не смогу при всём желании))))))))))
{ОбщийМодуль._Подписки.Модуль(26,8)}: Переменная не определена (КОМ) 
-
переменная КОМ не моя......
100. Alex_E 1854 10.08.17 07:35 Сейчас в теме
строка модуля 1727 заменить на

Если НовОбъект.Метаданные().СтандартныеРеквизиты.Найти(стрCOM.Name) = Неопределено Тогда Продолжить КонецЕсли;
103. citkhv 11.08.17 00:43 Сейчас в теме
Обработка останавливалась с ошибкой из за того что у меня была доработанная конфигурация а не типовая. автор помог мне обойти мою ошибку и у меня все перенеслось. Благодарю автора.
104. sp1nfun 08.10.17 18:36 Сейчас в теме
В последнем обновлении с какого на какой релиз идет перенос данных?
105. Alex_E 1854 09.10.17 04:38 Сейчас в теме
(104)
19.09.2017 Версия 4.4.5.7 Исправлена проверка подключения для 3.0.52.*
- делалось на 3.0.52.32
106. Zexes 16.10.17 10:44 Сейчас в теме
Добрый день.
Пользуюсь регулярно спасибо.
А можно перенести данные из 3 корп в 3 бп? Там нужно переносить только документы поступления.

Разумеется данные о подразделении можно выкинуть, там перенос в техническую базу, для каких-то аналитических исследований :)
107. Alex_E 1854 16.10.17 11:44 Сейчас в теме
(106) Можно, почему нет? Если КОРП в КОРП, то, наверное, и подразделения перенесутся - для одинаковых конфигураций перенос идёт реквизит в реквизит, если только эти реквизиты не включены в список исключаемых из обмена...
108. Zexes 16.10.17 12:01 Сейчас в теме
Да нет, проблема видимо в другом, даже не переносит из бп в бп (последний релиз)
При нажатии кнопки перенести ссылки, вылетает недостаточно фактических параметров.
Прикрепленные файлы:
109. Alex_E 1854 16.10.17 12:22 Сейчас в теме
(108) У Вас не последняя версия обработки
110. Zexes 16.10.17 12:26 Сейчас в теме
(109)Согласен, клоун, скачал самую верхную а она ПереносДанныхЧерезCOM_v4.0.5.5 =( понедельник, блин.
111. Alex_E 1854 16.10.17 12:28 Сейчас в теме
(110) Дайте в личку почту, пришлю последнюю...
112. Zexes 16.10.17 12:36 Сейчас в теме
(111)да я уже скачал новую 4,0,5,7 но все равно что-то ошибка недостаточно параметров =( Хотя подключение устанавливает нормально. А вот что интересно, старый вариант 4,0,1,0 переносит хорошо, но только по одному документу. Если несколько указать, перенесет только первый и зависнет, если выгрузить 1с и загрузить, можно будет перенести следующий =)
114. Alex_E 1854 16.10.17 12:46 Сейчас в теме
(112) давайте на досуге я подключусь и посмотрим - у меня таких проблем не наблюдается...
115. Zexes 18.10.17 01:21 Сейчас в теме
(114) кстати проблема решилась, когда убрал галочку Перезап. в принципе, в моем случае она в 99% не нужна! Большое Вам спасибо за труд!
117. smile2009 18.10.17 11:21 Сейчас в теме
(115)
Гляньте мое сообщение ниже. Похоже у Вас схожая проблема.
116. smile2009 18.10.17 11:19 Сейчас в теме
Спасибо за обработку!
Версия 4.0.5.7.

Ошибка возникла при переносе документа ОперацияБух в процедуре _ПереносДвижений().

Процедура _ПереносДвижений(_СтрокаXML, Док, ИдДок, ИдДокCOM = "") Экспорт
	Если Док.Дата < НачалоПериода и ПереноситьДвижения Тогда Сообщить("Дата документа " + Док + " меньше даты начала переноса! Движения перенесены не будут."); Возврат; КонецЕсли;


// ИСКЛЮЧЕНИЕ ЗДЕСЬ!!!
	ДокCom = ПолучитьЗначениеСсылкиПоГУИД(?(ТипЗнч(_СтрокаXML) = Тип("Строка"), Коннект.NewObject("UUID", _СтрокаXML), _СтрокаXML), Коннект.Documents[?(ИдДокCOM = "", ИдДок, ИдДокCOM)]);
...


ЛЕЧИТСЯ ТАК:
Вставляем обработчик исключения, и в случае исключения, присваиваем ДокCom = _СтрокаXML.
Дело в том, что в строке _СтрокаXML уже находится COM-ссылка на операцию. Почему не отрабатывает ПолучитьЗначениеСсылкиПоГУИД() разбираться не стал. В итоге, выгрузка операций прошла на ура (кидал из БП3 в БП3)

Попытка
		ДокCom = ПолучитьЗначениеСсылкиПоГУИД(?(ТипЗнч(_СтрокаXML) = Тип("Строка"), Коннект.NewObject("UUID", _СтрокаXML), _СтрокаXML), Коннект.Documents[?(ИдДокCOM = "", ИдДок, ИдДокCOM)]);
	Исключение
		ДокCom = _СтрокаXML;
	КонецПопытки;
118. Alex_E 1854 18.10.17 11:48 Сейчас в теме
119. 26178_mail.ru 57 23.10.17 04:25 Сейчас в теме
при переносе такая ошибка {ВнешняяОбработка.ПереносДанныхБП_БП30.МодульОбъекта(2961)}: Получение элемента по индексу для значения не определено
СсылкаCOM = ПолучитьЗначениеСсылкиПоГУИД(Коннект.NewObject("UUID", СокрЛП(ГУИД)), Коннект[?(ТипCOM = "Документ", "Documents", "Catalogs")][ИдентификаторCOM]);

Что это может быть?7 Заранее спасибо
120. 26178_mail.ru 57 23.10.17 04:31 Сейчас в теме
и еще такая ошибка
{ВнешняяОбработка.ПереносДанныхБП_БП30.Форма.Форма.Форма(768)}: Недостаточно фактических параметров
Возврат РеквизитФормыВЗначение("Объект").ПереносЛюбойСсылкиCOM(ГУИД);

действительно в самой процедуре 3 параметра а передается один параметр как такое может быть??
121. Alex_E 1854 23.10.17 08:31 Сейчас в теме
(120) Какая версия обработки? Пришлите почту в личку - пришлю последнюю.
122. killer8-00 28.11.17 16:53 Сейчас в теме
Добрый вечер. Скачал последнюю версию обработки. Пытаюсь создать подключение к базе 8.2 корп и получаю такую ошибку. Подскажите как исправить?
Прикрепленные файлы:
124. Alex_E 1854 28.11.17 17:08 Сейчас в теме
(122) Уже много раз отвечал на подобный вопрос - скопипастите ошибку в гугл - получите тучу ссылок.... Начините с поста (4) к этой публикации...
(123) Не стоит плодить сущности, заполните существующие документы в источнике - там этот документ из 2.0 в 3.0 он переносится по своему алгоритму (ну должен, как я помню), у Вас исходная база КОРП?, проверьте ИмяКонфигурацииИсточника, возможно там стоит "БП30" , поскольку КОРП не прописан (нет базы под руками, проверьте и просто допишите в список конфигураций КОРП - должно быть "БП20").
123. killer8-00 28.11.17 17:02 Сейчас в теме
С этой проблемой разобрался. Теперь вылезла другая.
Прикрепленные файлы:
125. killer8-00 28.11.17 18:53 Сейчас в теме
Прописал версию корп. Мне необходимо перенести всего 2 вида документа. Подскажите где подправить, чтоб заработало.Спасибо.
Прикрепленные файлы:
126. Alex_E 1854 28.11.17 18:57 Сейчас в теме
(125) Пишите в личку, решим вопрос
127. Alex_E 1854 06.12.17 09:01 Сейчас в теме
Выложил новую версию 5.2.0.4 Переработан алгоритм поиска ссылок. Добавлены процедуры переноса из БП 1.6, жёсткой привязки к БП больше нет - спокойно можно использовать для переноса данных "почти" одинаковых конфигураций. Все замечания постараюсь оперативно исправить.
128. irbis-auto 05.02.18 18:47 Сейчас в теме
1) А где версия 5.2.2.3 о которой вы пишите?
2) Почему вы добавили изменения в версию 5.2.0.4 "Поиск по реквизитам", а не в более поздние версии, например в 5.2.2.2 (которая на сайте выложена) или 5.2.2.3 (которая нет, но вы пишите что сделана-вопрос №1) ?
3) Учитывая вопрос №2: увеличение версии релиза обработки не означает, что всё что есть в старой обработки есть либо улучшено в новой обработке, т.е. например: релиз 5.2.2.2 - это доработанная (улучшенная) версия релиза 5.2.0.4 или это совсем разные обработки, каждая с определенной своей доработкой ?
129. Alex_E 1854 05.02.18 18:56 Сейчас в теме
(128) Спасибо, что сказали, всё написал, а файл не прикрепил...почему-то.........
Сейчас файл на месте.
130. irbis-auto 06.02.18 13:09 Сейчас в теме
(128)
На первый вопрос вы ответили
После того как вы выложили релиз 5.2.2.3, то второй и третий вопрос снимаются. Увидел что там всё есть.
131. Alex_E 1854 06.02.18 13:18 Сейчас в теме
(130) Вчера отвечал не на первый вопрос, а на один, остального просто не было (ну, или я не заметил)...
А так, каждая новая версии - это развитие предыдущей...иногда , случается, что делается * до более "стабильной" версии, на которой делаются доработки...
Бывает, что исправляя одно, могу поломать что-то другое, и это не сразу может быть замечено...
Обработка существует уже не один год, постоянно что-то дописывается, как в плане найденных ошибок, так и в связи с изменениями в платформе, и конфигурациях...

Так что, прошу прощения за доставленные неудобства, и отнеситесь с пониманием: косячу я не со зла, просто так получается )))))))))))
132. v.zagorodniy 13.02.18 19:46 Сейчас в теме
Здравствуйте! Обработка хороша! Вот только учетная политика к сожалению не переноситься ни за какие периоды, а также настройки налогов по организациям. Я так думаю из-за регистров сведений. БП 3.0.57.17. Платформа 1С:Предприятие 8.3 (8.3.11.2899)
133. Alex_E 1854 13.02.18 20:00 Сейчас в теме
(132) С учетной политикой, честно говоря, мне воевать уже надоело - от релиза к релизу практически, вылезают разные нежданчики... В принципе, установить вручную её реально, а вот какого то вменяемого переноса сделать так и не удалось - работает, фактически, только пока пишешь))))

Про за различные периоды - специально убрал - были случаи лет по за 10 переносилось, что не нужно совершенно, но можно вернуть тот вариант. Кстати, возможно стало хуже после попытки "отвязки" от БП. Для той же, ИМХО, БП более актуально переносить настройки Плана счетов, в смысле аналитики учета ТМЦ, сотрудников в зарплате и пр. - всё это работало, но, рано я радовался, в какой-то момент, нежданно, перестало)))
134. Glagoleva 07.09.18 15:22 Сейчас в теме
купил
Перенос данных через COMConnector v 5.2.2.8, думал переносить УТ11 - Ут11, в первых сразу ошибка, в спр "организации" нет кода, во вторых список докумекнтов не заполняется совсем, что делать?
135. Alex_E 1854 07.09.18 15:26 Сейчас в теме
(134) Переносите по ГУИД а не по реквизитам, или в макете уберите поиск по коду. Если сложно - пишите в личку - покажу через АА...
136. Glagoleva 07.09.18 15:27 Сейчас в теме
Оки по разбираюсь сам, может напишу
137. Alex_E 1854 07.09.18 15:34 Сейчас в теме
(136) Поиск по ГУИД писать не нужно - кнопка на форме, а вот если по реквизитам - то макет в обработке, вроде в описании это было...
138. Alex_E 1854 07.09.18 15:53 Сейчас в теме
(136) Ошибка поиска организации - заменить функцию ЗаполнитьСписокОрганизацийCOM в моделе обработки на
Функция ЗаполнитьСписокОрганизацийCOM(тз) Экспорт
	Если Коннект = Неопределено Тогда Если Не ПодключитьИБ() Тогда	Сообщить("Не удалось установить подключение к ИБ!!!");	Возврат Новый ТаблицаЗначений; КонецЕсли; КонецЕсли;
	Запрос = Коннект.NewObject("Query");	
	ЗапросТекст = 
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	Организации.Код,
	|	Организации.Наименование,
	|	Организации.Ссылка
	|ИЗ
	|	Справочник.Организации КАК Организации";
	Если Не ЕстьРеквизитИлиСвойствоОбъекта(Коннект.Catalogs.Организации.CreateItem(), "Код") Тогда
		ЗапросТекст = СтрЗаменить(ЗапросТекст, "Организации.Код,", """"" КАК Код,");
	КонецЕсли;
	Запрос.Текст = ЗапросТекст;
	Результат = Запрос.Выполнить().Выгрузить();
	Для Каждого стр Из Результат Цикл
		НовСтр = тз.Добавить();
		ЗаполнитьЗначенияСвойств(НовСтр, стр);
		НовСтр.ГУИД = "" + Коннект.XMLСтрока(стр.Ссылка);
	КонецЦикла;
	Возврат тз;
КонецФункции
Показать

Сейчас выложу новую версию (остальное не проверял правда).
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Салехард
зарплата от 80 000 руб. до 200 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день


Программист 1С
Санкт-Петербург
Полный день

Программист 1С
Санкт-Петербург
Полный день