Обмен с ЕГАИС из 1С V7.7

Дорогие друзья! Предлагаю Вашему вниманию обработку, предназначенную для обмена данными из Вашей учетной системы с ЕГАИС, через универсальный транспортный модуль (УТМ).
В обработке реализован весь функционал обмена:
- загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции;
- загрузка справочных данных по номенклатуре алкогольной продукции;
- загрузка остатков;
- помощник сопоставления справочных данных и запись их в базу данных;
- загрузка приходных ТТН и справок Б от поставщиков, отправка по ним актов всех типов, создание по ним приходных документов;
- выгрузка расходных ТТН покупателям;
Обработку возможно использовать автономно, не внося изменений в Вашу Учетную систему.
Код открыт.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Лучшие комментарии
После/перед обновлением/переустановкой УТМ (все случаи когда нумерация входящий документов в УТМ начинается заново) необходимо:
все файлы каталога архива входящих (Reply) переместить в подпапку (любое название .. напр: utm_230 или 20161214)....
В след версии сделаю кнопку:Переустановка УТМ...
Остальные комментарии
1. 1 2 (1ckpp) 5 14.11.15 09:11 Сейчас в теме
Очень нужная обработка. Сейчас присматриваюсь какую купить в каталоге инфостарта и на просторах интернета. Эта наиболее приглянулась для типовой ТИС 77. Подожду еще с недельку, наверное остановлюсь на этой.
221. Алексей Трофимов (trofimovalexey) 14.12.15 04:36 Сейчас в теме
Подправил:Спр. НоменклатураЕГАИС
Функция ИННКПП(Конт,реж) 
Если Реж=1 Тогда
Возврат Производитель.ИНН;
Иначе
Возврат Производитель.КПП;	
КонецЕсли;
	
КонецФункции 

 Процедура ОбработкаПодбора(ВыбЗнач, КонтФормыПодбора)
	
Сообщить(ВыбЗнач);	
КонецПроцедуры // ОбработкаПодбора()           

Процедура ПриНачалеРедактированияСтроки()
        // ТМЦ=СоздатьОбъект("Справочник.Номенклатура");
		Параметр	= СоздатьОбъект("СписокЗначений");
	Если флЛитраж=1 Тогда  Параметр.ДобавитьЗначение(Литраж			, "Литраж");иначе Параметр.ДобавитьЗначение(, "Литраж");	КонецЕсли;	
 	Если флПроизводитель=1 Тогда  	Параметр.ДобавитьЗначение(Производитель	, "Производитель");	КонецЕсли;
	Если флИмпортер=1 Тогда  	Параметр.ДобавитьЗначение(Импортер		, "Импортер");КонецЕсли;	
	Если флКатегория=1 Тогда  	Параметр.ДобавитьЗначение(Категория	, "КодТов");иначе Параметр.ДобавитьЗначение(, "КодТов");КонецЕсли;	
   	Параметр.ДобавитьЗначение(НашаНоменклатура	, "НашаНоменклатура");	
	Параметр.ДобавитьЗначение(глВзятьКонтекст(Контекст)	, "Контекст");	

		// открываем форму 
 	ОткрытьФормуМодально("Справочник.Номенклатура.ЕГАИС", Параметр);  
	
	
	
		Сообщить( Параметр.Получить("НашаНоменклатура").ТекущийЭлемент());
		НашаНоменклатура= Параметр.Получить("НашаНоменклатура").ТекущийЭлемент();



КонецПроцедуры

Процедура ПриВыбореСтроки()
	
	// Форма может быть открыта для выбора из процедур ПриНачалеВыбораЗначения()
	// в модальном режиме. В этом случае результат выбора передается передается
	// через параметр формы.
	
	Форма.Параметр = ТекущийЭлемент();
КонецПроцедуры // ПриВыбореСтроки()       
флЛитраж=1;
флПроизводитель=0;
флИмпортер=0;
флКатегория=1;

Показать

Спр.Номенклатура Форма Списка ЕГАИС
Перем Парам;
Перем Литр,Креп,Пр,Имп,КодТов;
Процедура П() 
ИерархическийСписок(0,0);
ИспользоватьСписокЭлементов();
СписОтбора= СоздатьОбъект("СписокЗначений");
    
    СпрТовары= СоздатьОбъект("Справочник.Номенклатура");
    СпрТовары.ВыбратьЭлементы();

	Пока СпрТовары.ПолучитьЭлемент() = 1 Цикл
    Если Число(Литр)<>0 ТОгда
		Ст("есть отбор по Литражу:"+Строка(Литр));
		Если СпрТовары.Литраж<>Литр Тогда Продолжить; КонецЕсли;
	КонецЕсли; 
	
    Если Число(Креп)<>0 ТОгда
		Ст("есть отбор по Крепости:"+Строка(Креп));
		Если СпрТовары.Крепость=Креп Тогда Продолжить; КонецЕсли;
	КонецЕсли;
	  
    Если Число(КодТов)<>0 ТОгда
		Ст("есть отбор по Категории:"+Строка(КодТов));
		Если Число(СпрТовары.Категория.Код)<>Число(КодТов) Тогда Продолжить; КонецЕсли;
	КонецЕсли;
	
    Если СОКРЛП(ПР)<>"" ТОгда
		Ст("есть отбор по ПР:"+Строка(Производитель));
Если (Пр.ИНН=Производитель.ИНН)и(Пр.КПП=Производитель.КПП) Тогда иначе Продолжить; КонецЕсли;
	КонецЕсли;	
	
    Если СОКРЛП(Имп)<>"" ТОгда
		Ст("есть отбор по Имп:"+Строка(Производитель));
Если (Пр.ИНН=Производитель.ИНН)и(Пр.КПП=Производитель.КПП) Тогда иначе Продолжить; КонецЕсли;
	КонецЕсли;	
	
            СписОтбора.ДобавитьЗначение(СпрТовары.ТекущийЭлемент());
    КонецЦикла;
                                     
    ИспользоватьСписокЭлементов(СписОтбора);
    

КонецПроцедуры  

Процедура ПриНачалеРедактированияСтроки()            
		Параметр = "Выбор";

	КонецПроцедуры  
	
		
	
	
Процедура ПриВыбореСтроки()
Сообщить(1);             

	Форма.Параметр.Установить("НашаНоменклатура",ТекущийЭлемент());
	Форма.Параметр.Установить("СтатусВозврата", 1);
	Форма.Закрыть();
	 	Возврат;
    
	
КонецПроцедуры // ПриВыбореСтроки()



Функция ИННКПП(Конт,реж) 
Если Реж=1 Тогда
Возврат Производитель.ИНН;
Иначе
Возврат Производитель.КПП;	
КонецЕсли;
	
КонецФункции 






Процедура ПриОткрытии()    
	
		Если ТипЗначенияСтр(Форма.Параметр) <> "СписокЗначений" Тогда
		Предупреждение("Форма вызывается только для целей подбора партий в документе!", 60);
		СтатусВозврата(0);
		Возврат;
	КонецЕсли;
	 
	Литр	= Форма.Параметр.Получить("Литраж");   
	Сообщить(Литр);
	Креп		= Форма.Параметр.Получить("Крепость");
	Пр= Форма.Параметр.Получить("Производитель");
	Имп		= Форма.Параметр.Получить("Импортер");
	КодТов		= Форма.Параметр.Получить("КодТов");
 	НашаНоменклатура		= Форма.Параметр.Получить("НашаНоменклатура");
 	Сообщить("Подбор с применением фильтров Литраж:"+Строка(Литр)+Строка(", Крепость: ")+Строка(Креп)+Строка(", Пр:")+Строка(Производитель.ИНН)+Строка(", Производитель КПП:")+Строка(Производитель.КПП));

	 П() ;   
//	Форма.Параметр.Установить("СтатусВозврата"	, 0);
	
	
	 
  
	 
		Форма.ОбработкаВыбораСтроки(1);

		
КонецПроцедуры  


Процедура ПриПовторномОткрытии()
ПриОткрытии() ;
КонецПроцедуры  



Показать
477. Алексей Трофимов (trofimovalexey) 24.12.15 06:54 Сейчас в теме
Процедура ДобавитьВсехКонтеров(ЗначПод) 
	СООБЩИТЬ(ЗначПод);
		Если ЗначПод = "Контрагенты" Тогда							
		С=Создатьобъект("Справочник.Контрагенты");
		С.ВыбратьЭлементы();   
		сч=0; 
		Пока С.ПолучитьЭлемент()=1 Цикл
		  Стр = 0; 
		  	Если (СТРДЛИНА(сокрлп(С.ИННЮрЛица))<>10) Тогда   пРОДОЛЖИТЬ;		КонецЕсли;
 	 		Если	(ИННТЗ.НайтиЗначение(С.ИННЮрЛица,Стр,"INN")=1) Тогда  пРОДОЛЖИТЬ;		КонецЕсли;			
					
	//дубли
д=0;
ИННТЗ.ВыбратьСтроки();
стр=0;
Пока ИННТЗ.ПолучитьСтроку()=1 Цикл
стр=стр+1;
Если ИННТЗ.НайтиЗначение(СокрЛП(С.ИННЮрЛица),Стр,"INN")=1 Тогда Сообщить(С.ИННЮрЛица); д=1; Прервать;		КонецЕсли;			
КонецЦикла;

		    Сообщить(С);
Если д=0 ТОгда
			
            сч=сч+1;

//			Если сч>10 Тогда
//			    прервать;
//			КонецЕсли;    
			
			
	      	
				
		
			ИННТЗ.НоваяСтрока();					
			ИННТЗ.УстановитьЗначение(сч,1,2);
			//Сообщить(ShortName);
			ИННТЗ.ShortName = С.Наименование; 	
			ИННТЗ.INN = СОКРЛП(С.ИННЮрЛица); 
				КонецЕсли;
				КонецЦикла;
				КонецЕсли;

КонецПроцедуры
Процедура ДобавитьВсехПР(ЗначПод) 
	СООБЩИТЬ(ЗначПод);
		Если ЗначПод = "Производители" Тогда							
		С=Создатьобъект("Справочник.Производители");
		С.ВыбратьЭлементы();   
		сч=0;
		Пока С.ПолучитьЭлемент()=1 Цикл
				  Стр = 0; 
    Если (СТРДЛИНА(сокрлп(С.ИНН))<>10) Тогда   пРОДОЛЖИТЬ;		КонецЕсли;
 		
	//дубли
д=0;
ИННТЗ.ВыбратьСтроки();
стр=0;
Пока ИННТЗ.ПолучитьСтроку()=1 Цикл
стр=стр+1;
Если ИННТЗ.НайтиЗначение(СокрЛП(С.ИНН),Стр,"INN")=1 Тогда  д=1;Сообщить(С.ИНН); Прервать;		КонецЕсли;			
КонецЦикла;

		    Сообщить(С);
Если д=0 ТОгда
            сч=сч+1;
//			Если сч>10 Тогда   прервать;КонецЕсли;    
			
			ИННТЗ.НоваяСтрока();					
			ИННТЗ.УстановитьЗначение(сч,1,2);
			//Сообщить(ShortName);
			ИННТЗ.ShortName = С.Наименование; 	
			ИННТЗ.INN = СОКРЛП(С.ИНН); 
			КонецЕсли;
				КонецЦикла;
				КонецЕсли;

КонецПроцедуры

Процедура РаботаСоСписком(Режим,Таблица,ТипСправочника)
	Перем ТекПоз;
	Перем ТекЭлемент;
	Перем Фрм;

	ТекПоз = Таблица.ТекущаяСтрока();

	Если Режим="Добавить" Тогда		// добавляем в список один элемент
		СписокПодбора = Таблица;
		СправочникПодбора = ВРег(ТипСправочника);
		// открываем окно подбора
		ОткрытьПодбор("Справочник."+ТипСправочника,,Фрм,0,ТекЭлемент);
		Фрм.ВыборГруппы(1);		

	ИначеЕсли Режим="ДобавитьНесколько" Тогда  // добавляем в список несколько элементов
		СписокПодбора = Таблица;
		СправочникПодбора = ВРег(ТипСправочника);
		// открываем окно подбора
		ОткрытьПодбор("Справочник."+ТипСправочника,,Фрм,1,ТекЭлемент);
		Фрм.ВыборГруппы(1);
	ИначеЕсли Режим="ДобавитьВсе" Тогда  // добавляем в список несколько элементов
ДобавитьВсехКонтеров(ТипСправочника);

	ИначеЕсли Режим="ДобавитьВсеПР" Тогда  // добавляем в список несколько элементов
ДобавитьВсехПР(ТипСправочника);

 	ИначеЕсли Режим="УдалитьВсе" Тогда	// удаляем все элементы из списка
		Таблица.УдалитьСтроки();

	ИначеЕсли Режим="Удалить" Тогда	// удаляем из списка один элемент
		Если ТекПоз>0 Тогда
			Таблица.УдалитьСтроку(ТекПоз);
		КонецЕсли;
	КонецЕсли;

КонецПроцедуры		// работа со списком
Показать

Кнопки глобальных запросов
957. Sergey Б (serg63) 1 19.01.16 00:18 Сейчас в теме
Возникла небольшая проблема, если меняем УТМ, то проверка УТМ выдает номер версии первой УТМ, при которой заходили в обработку. Нужно выйти из обработки,
оставив вторую УТМ и снова зайти в обработку, тогда будет работать правильная проверка УТМ для второй УТМ. Увидел это,т.к. стояли разные УТМ рабочая и тестовая на разных фирмах. Вызов проверки УТМ "ПолучитьFSRAR_ID(1)", здесь стоит цифра 1. Берет только текущую строку УТМ.
1169. 1 1 (xmxcrew) 02.02.16 17:29 Сейчас в теме
Добрый день!

При приеме накладных от нескольких поставщиков вываливается

АПТЗ.AlcVolume = СокрЛП(ПолучитьЭлемент(хмл_Товар,"AlcVolume";).Text);
{C:\2.0\EGAIS (1)\EGAIS\OBMEN_EGAIS.ERT(3508)}: Значение не представляет агрегатный объект (Text)

понятно что они что-то намудрили с типом переменной, но что с этим делать если они наотрез отказываются у себя что-то менять, аргументируя это тем что с другими контрагентами никаких проблем нет.
1910. Victor Nespyatin (victuan) 1570 05.10.16 19:58 Сейчас в теме
rvs-slim, небольшие замечания по загрузке внешних компонент (1с++, FormEx):
1) 1с++ рекомендуется загружать перед FormEx, а не наоборот
2) перез загрузкой внешних компонент предлагаю делать проверку, не были ли они загружены ДО запуска обработки Obmen_egais.ert. Иначе Формекс будет недоступна у вас для использования, а 1с++ загрузиться дважды.

Предлагаю следующее изменение кода:
		ПлюсыЗагужены = 1;
		Попытка
			Модуль = СоздатьОбъект("ВыполняемыйМодуль"); //проверка того, что 1С++ была уже загружена
		Исключение
			//Компонента Отображения сетки
			Если ЗагрузитьВнешнююКомпоненту("1cpp.dll")=0 Тогда
				СообщитьПр("Неудачная попытка загрузить  1cpp.dll Некоторые функции будут недоступны !!!");
				ПлюсыЗагужены = 0;
			КонецЕсли;
		КонецПопытки;  
		
		Если ПлюсыЗагужены = 1 Тогда
			Попытка
				МетаИнфо = СоздатьОбъект("MetaInfoClasses");
				Версия = МетаИнфо.ПолучитьВерсиюФайла();
			Исключение
				СообщитьПр("Для корректной работы необходимо использовать 1с++ версии не ниже 3.0.0.0");
				ПлюсыЗагужены = 0
			КонецПопытки;
		     
			Если (Число(Версия) < 3) и (ПлюсыЗагужены=1) Тогда
				СообщитьПр("Для корректной работы необходимо использовать 1с++ версии не ниже 3.0.0.0");
				ПлюсыЗагужены = 0
			КонецЕсли;
			
			Если ПлюсыЗагужены = 0 Тогда
				СообщитьПр("Неудачная попытка загрузить  1cpp.dll Некоторые функции будут недоступны !!!");
			КонецЕсли;   
		КонецЕсли;   

		Попытка
			//Компонента расскраски строк
			глСервис_FormEx = СоздатьОбъект("Сервис");
		Исключение
			Если ЗагрузитьВнешнююКомпоненту("FormEx.dll") = 0 Тогда //
				//СообщитьПр("Неудачная попытка загрузить FormEx.dll Некоторые функции будут недоступны !!!");
			КонецЕсли;
		КонецПопытки;

		Попытка
			Если ПустоеЗначение(глСервис_FormEx)=1 Тогда
				глСервис_FormEx = СоздатьОбъект("Сервис");
			КонецЕсли;
			глСервис_FormEx = СоздатьОбъект("Сервис");
			//разрешаем использование раскраски таблиц
			глСервис_FormEx.ВключитьРаскраскуТаблиц();
			//добавляем индикатор клавиатуры и часы в статус бар
			глСервис_FormEx.ПоказыватьИндикаторКлавиатуры(1);
			//глСервис_FormEx.УстановитьОбои("Logo",5,0);
			глДопМодуль = 0;
		Исключение
			СообщитьПр("Неудачная попытка загрузить FormEx.dll Некоторые функции будут недоступны !!!");
		КонецПопытки;
Показать
(1910) victuan,
спс, так и сделаем.. :)
2. Alexandr Mal (zaoproxy) 29 14.11.15 20:29 Сейчас в теме
К обработке прилагается инструкция по подключению и использованию?
Основные шаги и содержание архива (что для чего нужно) есть в описании.. Если будет этого недостаточно, добавлю инструкцию к применению... Напишите...
4. Александр Колпаков (kerrik249) 16.11.15 02:59 Сейчас в теме
Здравствуйте, возможно ли в планах : ведение электронного журнала продаж.
Работа с УТМ на кассе.
5. Иван Демидов (ivanov_alex) 3 16.11.15 07:13 Сейчас в теме
купил обработку, вопрос в следующем: как с обновлениями? каждый раз покупку делать? или есть какой то период на бесплатное обновление?
Далее по самой обработке
вот этот участок в функции записатьфирму() пишет неверный код соответствия.
			Справочник=СоздатьОбъект("Справочник.Контрагенты");
			Если Справочник.НайтиПоКоду(Зн) = 1 Тогда
				Эл = Справочник.ТекущийЭлемент();
				ТекстПривязкиСтр = "Код: "+Эл.Код+" "+Эл.Наименование+" ИНН/КПП: "+Эл.ИННКПП+" Адрес: "+Эл.АдресАкцизногоСклада;
				Если Справочник.НайтиПоКоду(Code) = 1 Тогда
					Эл = Справочник.ТекущийЭлемент();
					ТекстПривязкиНов = "Код: "+Эл.Код+" "+Эл.Наименование+" ИНН/КПП: "+Эл.ИННКПП+" Адрес: "+Эл.АдресАкцизногоСклада;
					Если Вопрос("В БД обнаружена привязка кодов!!!("+СокрЛП(ClientRegId)+")"+РазделительСтрок+"Найдена:"+ТекстПривязкиСтр+РазделительСтрок+"Новая:"+ТекстПривязкиНов+РазделительСтрок+"Заменить на новую?","Да+Нет",60)  <> "Да"  Тогда
						Возврат 0;
					КонецЕсли;	  						
				КонецЕсли;	  							
			КонецЕсли;	  		        	
Показать

делаю запрос по производителю при записи в БД сначала ошибка, ругается на отстутсвие поля иннкпп, когда руками прописываешь .юрфизлицо.ИНН делает запись о контрагенте-производителе,но код берет из юрфизлица а не из контрагента-в торговле спрачоник юрлиц и контрагентов разный
как быть в этой ситуации?
korsar2001; Ovrfox; LVA1; +3 Ответить
(5) ivanov_alex, Друзья для тех кто купил обработку, обновления как писал выше, полностью бесплатны...
Текущая версия 1.2 (на 16.11.2015)
по процессу обновления: предлагаю, кому необходимо, выслать в личку свою почту или логин, (я знаю, что некоторым нужна только "рыба"...)
6. Alexandr Mal (zaoproxy) 29 16.11.15 09:13 Сейчас в теме
Вопрос к тем кто уже приобрел обработку: насколько легко интегрируется?

Предложение к создателю: думаю что инструкция, хоть в самом минимальном варианте, для конечных пользователей нужна. Типа интеграцию провел, дал инструкцию пользователям и пусть учатся пользоваться.
7. Иван Демидов (ivanov_alex) 3 16.11.15 09:44 Сейчас в теме
(6) zaoproxy, распаковал архив, посомтрел подключены ли 1cpp и formex если нет, отдельная папка там бантик нужно запустить один раз
потом открываешь обработку в базе, заполняешь фсрарИД и пользуешься
если поля по другому называются адаптируй под себя
8. Андрей Тарлыков (Tarlich) 72 16.11.15 10:34 Сейчас в теме
Поступление и сопоставление - ГУД!!! а планируется допиливание для розницы (ЧЕК ККМ)?
(8) Tarlich,
а планируется допиливание для розницы (ЧЕК ККМ)?
Да, по Чеку если требуется сделаю вкладку для розницы...
9. Иван Демидов (ivanov_alex) 3 16.11.15 15:21 Сейчас в теме
при сопоставлении номенклатуры открывается форма для выбора, но выбирать не дает, открывает карточку номенклатуры, если жмешь закрыть возвращает пустой параметр и ошибку про параметр.код
как пофиксить?
10. Anatol (askv) 23 16.11.15 22:21 Сейчас в теме
Есть вопросы к автору:
Через какие объекты сделано чтение, запись XML и отправка XML к УТМ?
Используется ли curl?
На каких по размеру XML тестировалась обработка?
(10) askv,
Код полностью открыт, размер XML? Сколько АП разных производителей не грузил, занимает не более 3 сек.
14. Николай Двоелучинских (dvoinik) 10 17.11.15 07:35 Сейчас в теме
Добрый день. Есть конфигурация "Бизнес-Логика: Винно-водочная Торговля. Стандартная версия, ред. 9.291 (Торговля+Склад)" Пойдет эта обработка для нее? Где хранятся справочники соответствия? Данные о товаре и контрагенте ЕГАИС? (Алко код, ID контрагента и тд.) Возможно будет доработать ее самостоятельно ? (между структурными подразделениями делается документ перемещение)
(14) dvoinik,
Добрый день. Есть конфигурация "Бизнес-Логика: Винно-водочная Торговля. Стандартная версия, ред. 9.291 (Торговля+Склад)" Пойдет эта обработка для нее?
Подойдет, на ней и пишется…
Где хранятся справочники соответствия? Данные о товаре и контрагенте ЕГАИС? Данные о товаре и контрагенте ЕГАИС?
Локально в указанном Вами месте, при первом запуске обработки (задаем каталог хранения и жмем кнопку Инициализация) Несложно доработать и хранить где угодно механизм одинаковый, код открыт…, но мне кажется это лишним, так как всего позиций .. ну не более 10 тыс. а это в поиске соответствий доли сек. И накоплений здесь не происходит… Таблица соответствий максимально облегчена… и т.п.
Возможно будет доработать ее самостоятельно ? см. выше…
15. Сергей Попов (s_v_p) 17.11.15 16:45 Сейчас в теме
Добрый день! В этой обработке есть или будет добавлен механизм ввода начальных остатков АП для оптовиков пива?
(15) s_v_p, (467) Brad,
В помощнике..удалить привязку
16. viktorn 1 (viktorn) 17.11.15 18:56 Сейчас в теме
Если приобретаю сейчас, есть ли возможность и как получить последующие изменения?
(16) viktorn,
Обработка приобретается один раз!
Обновление:
1 вариант: Вы получаете ссылку на скачивание, она действительна для Вас бесконечно долго (так объяснил представитель инфостарта), при обновлении версии, по той же ссылке Вы еще раз скачиваете уже обновленный архив.
2 вариант: Вы делаете запрос с указанием почтового адреса покупки программы, далее обновления Вы получаете на почту по запросу (Здесь я постараюсь оперативно указывать новую версию…)
Друзья поступают однотипные вопросы, отвечу здесь:
1.Насколько рабочая и проверенная в работе с реальнымы накладными?
Сейчас идет тестовый режим работы с ЕГАИС, все накладные отправленные Поставщиками (производители/Импортеры/Оптовики) в системе видны и загружаются..на основе их создаются приходные накладные в учетной системе… Все обработанные поступления (составлен какой либо из Актов) видны в остатках… Выбрав Расходный документ формируется ТТН .. и т.п. а вот насколько данные циркулирующие в системе сейчас Реальны? Сомневаюсь, данные тестовые (в этом легко убедится загрузив АП от производителей… видны явные ляпы…)
2.Много ли придется переделывать? Думаю, что нет.. тем более от помощи и техподдержки я не отказываюсь, а с учетом Ваших предложений доработаем до хорошего уровня, кроме того эта обработка работает в реально существующей организации, где имеет место и опт и розница...
20. mootriskoff (mootriskoff) 18.11.15 08:50 Сейчас в теме
Цитата:
"В обработке реализован весь функционал обмена:
- загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции;"

Вы работаете на людей, которые торгуют алкоголем?

Адольф Шикельгрубер (Гитлер): «Население должно быть сокращено наполовину. Никакой гигиены. Только водка и табак».

Парижская Хартия ещѐ 1975 года определила: «К 2025 году население России не должно превышать 20-25 миллионов человек».

Работаете на нацистов?

Помогаете уничтожать население России?
25. Иван Демидов (ivanov_alex) 3 18.11.15 18:01 Сейчас в теме
(20) mootriskoff, мы помогаем правительству избавить и без того пьющих людей от паленки и контрафакта, торгуя качественным продуктом, вспомните 90-е годы и засилие контрафакта на алкорынке и как следствие черезмерный рост смертности от этого контрафакта
запретите людям пить и они вам свернут за это голову. проверено неоднократно
21. ООО Энтер (enter) 12 18.11.15 09:07 Сейчас в теме
Хорошо было бы еще сделать формирование Журнала розничных продаж - фиктивного, конечно же, но с максимальным приближением к реальности (т.е. с учетом приходов, рандомным списанием в течение заданного пользователем периода). Ведь это одна из основных проблем розничных продавцов, у которых не автоматизирован товарный учет - закупку подтвердить то подтвердим через Вашу обработку, а вот вести Журнал предстоит вручную.
22. Гость 18.11.15 09:10 Сейчас в теме
Нельзя ли выложить пробную версию?
23. sodrk Пунегова (sodrk) 18.11.15 09:42 Сейчас в теме
Будет работать на 1С 7.7 Бухгалтерский учет, ред.4.5(один из последних релизов)?
24. viktorn 1 (viktorn) 18.11.15 15:26 Сейчас в теме
Инструкция по работе есть?
Если есть то можно выслать nv_velsk@mail.ru
26. Сергей Попов (s_v_p) 18.11.15 21:44 Сейчас в теме
Добрый день. Купил обработку. Указал код ФС РАР.
1) Важно ли расположение каталогов с данной обработкой (локально или на сервере)?
2) Каким образом проверить подключены ли DLL? при запуске файла с регистрацией, выходит сообщение "Не удалось загрузить модуль ..."
3) Делаю запрос по организации - "21:39:19 - Запрос справочника по ИНН ... Файл "reply.xml" не найден!"
4) Делаю запрос по контрагенту - "21:39:49 - Запрос справочника по ИНН 7726260234
Файл "reply.xml" не найден!"

Во входящих ничего нет, при обновлении "Файл "\\...\Torg\EGAIS\Temp\reply.xml" не найден!"
Что делаю не так? Как проверить работает ли обработка?

При запросе через cmd:
Microsoft Windows [Version 6.1.7601]
© Корпорация Майкрософт (Microsoft Corp.), 2009. Все права защищены.

C:\Users\Администратор>curl -X GET http://localhost:8080/opt/out
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<A>
<url>http://localhost:8080/opt/out/FORMBREGINFO/1</url>;
<url>http://localhost:8080/opt/out/WAYBILL/2</url>;
<url>http://localhost:8080/opt/out/WAYBILL/3</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/4</url>;
<url>http://localhost:8080/opt/out/WAYBILL/5</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/6</url>;
<url>http://localhost:8080/opt/out/WAYBILL/7</url>;
<url>http://localhost:8080/opt/out/WAYBILL/8</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/9</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/10</url>;
<url>http://localhost:8080/opt/out/WAYBILL/11</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/12</url>;
<url>http://localhost:8080/opt/out/WAYBILL/13</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/14</url>;
<url>http://localhost:8080/opt/out/WAYBILL/15</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/16</url>;
<ver>1</ver>
</A>
27. Сергей Попов (s_v_p) 18.11.15 23:37 Сейчас в теме
Поискал файл reply.xml , нашел в папке "C:\Windows\".
мне кажется проблема в строке определения ФайлОтвета , в нем нет явного указания пути:

Процедура ПолучитьСписокДокументов(ДопИнфо =0)
ФайлОтвета = "reply.xml";
КомандаСистемыСрипт("curl.exe -X GET http://"+СокрЛП(АдресУТМ)+"/opt/out?refresh=true"+">"+ФайлОтвета);
(27) s_v_p,
Посмотрите вкладку Настройки
Должно быть примерно так:
Каталог хранения файлов обмена: C:\TT\Temp\
Каталог БД соответствий:C:\DemoDB\ExtForms\EGAIS\
Если у Вас не так исправьте...
По dll: система вероятно Win7 x64? тогда используйте regsvr32, из каталога syswow64
38. Сергей Попов (s_v_p) 19.11.15 14:27 Сейчас в теме
(28)

Поменял каталог хранения файлов обмена на C:\TT\Temp\.
Каталог БД соответствий оставил в сетевой папке.
Заработало только после того, как я скинул в C:\TT\Temp\ ранее скаченный curl для своей системы.
По dll: у меня система W7x32, так их и не зарегистрировал, хотя брал regsvr32 из системы, скопировал dll везде где можно и вот чудо, при работе с запросами 1Cpp сама зарегистрировалась ""1С++ Загружен. Требуется открыть обработку еще раз!"".

В итоге запросы приходят, разбираюсь с соответствиями: пока не понятно, почему не доступны кнопки "Отвязать контрагента" и "Отвязать номенклатуру", что если не так привязали?
39. Иван Демидов (ivanov_alex) 3 19.11.15 17:28 Сейчас в теме
(38) s_v_p, думается модуль в разработке, поэтому
Указанные в настройках каталоги должны СУЩЕСТВОВАТЬ!!!
И еще, попробуйте запросить остатки...
и посмотреть http://localhost:8080/opt/in/
Текущая версия обработки 1.3 (добавлена вкладка Розница)
30. Иван Демидов (ivanov_alex) 3 19.11.15 06:50 Сейчас в теме
(29) акты постановки на баланс будут? и когда ждать?
Следующим обновлением (30) ivanov_alex,
32. Сергей Иванов (serg75) 19.11.15 07:35 Сейчас в теме
У меня при запуске curl.exe сообщение, что версия C://TT/Temp/curl.exe не совместима с версией Win 7. У меня 32 разрядная Максимальная. При запуске Установить.bat регистрируется только OcvitaBarcode.ocx, библиотеки 1CPP.dll и FormEx.dll не регистрируются (пишет не удалось загрузить модуль)
33. Сергей Иванов (serg75) 19.11.15 11:27 Сейчас в теме
Наконец заработало после того как скачал пакет curl http://curl.haxx.se/dlwiz/?type=bin и кинул curl.exe в папку C:/TT/Temp. Остается только вопрос с регистрацией модулей из папки DLL
34. Сергей Иванов (serg75) 19.11.15 12:19 Сейчас в теме
Не долго музыка играла... Запросы формируются (На вкладке Справочники в таблице Запросы в ЕГАИС по нашей организации появляется ЗапросИД). Выскакивает окно ожидания или отмены. Делаю отмену. Жду 10 мин. Нажимаю кнопку Проверить/Загрузить ответы. Перехожу на вкладку Входящие. Жму кнопку Обновить и Загрузить ответы. Все таблицы пустые. Новую версию обработки 1.3 скачал и переустановил. В чем проблема.
35. Сергей Иванов (serg75) 19.11.15 12:42 Сейчас в теме
Еще такой вопрос. Почему нигде не указывается КПП подразделения, ведь сертификаты и ключи на JaCarta привязаны к нему.
Правильно я понял: по Вашему ИНН ответ системы пуст. Т.е. фирм с таким инн в ЕГАИС не зарегистрировано? Обычно ситуация обратная на один инн есть множество подразделений среди которых по кпп надо выбрать свою...
41. Сергей Иванов (serg75) 20.11.15 06:06 Сейчас в теме
(36) Здравствуйте. Как таких фирм не зарегистрировано, если я получил из ЕГАИС сертификат RSA на КПП обособленного подразделения. Проверил также в сводном реестре лицензий на fsrar.ru . По нашему ИНН указано 3 разных КПП и 3 разных адреса деятельности. Один КПП по месту регистрации организации и 2 КПП по обособленным подразделениям. При входе в личный кабинет ЕГАИС тоже показывает 3 адреса деятельности и 3 КПП. По одному из них и получил RSA сертификат. И снова тот же вопрос почему не регистрируются модули из DLL ? Объясните подробней куда их кидать и как запускать регистрацию ?
И на вкдадку Входящие переходить не обязательно. На той же вкладке есть кнопка Загрузить ответы...
40. Сергей Попов (s_v_p) 19.11.15 21:58 Сейчас в теме
Ошибка: после привязке номенклатуры во многих позициях повторяются кодБД (на закладке приход и справочники).
Предложение по улучшению: при привязке (синзронизации) номенклатуры, сделать поиск по производителю/крепости/емкость/кодАП
48. Сергей Попов (s_v_p) 20.11.15 13:56 Сейчас в теме
(40) s_v_p,

Снимаю вопрос по дублям - это один товар с разными справками А и Б, но появились новые:
1) делаю "Акт подтверждения" , как понять прошло все или нет?
2) что будет, если я удалю все запросы и документы без подтверждения прихода, они так и будут висеть неподтвержденные где-то в недрах ЕГАИСа?

И все-таки хотелось бы получить подробную инструкцию, чтобы не задавать глупых вопросов

Еще одно предложение: при поиске товаров не показывать те из них, которые уже привязаны
(48) s_v_p,
1) делаю "Акт подтверждения" , как понять прошло все или нет?
У Вас во Входящих должны появиться квитанции…
Сейчас работаю на тем, чтобы все Входящие документы выстраивались в Дерево, т.е. Вы получили ТТН (+ справки Б), подтвердили ее Актом, получили квитанции…
все эти документы должны объединиться в ветку, посмотрим должно получиться нагляднее…
Ну и конечно результат Вашего Акта должен отразиться на Остатках.

2) что будет, если я удалю все запросы и документы без подтверждения прихода, они так и будут висеть неподтвержденные где-то в недрах ЕГАИСа?
Думаю если Вы НЕ будете реагировать на Входящие документы (не подтверждать прием товара), то больше отгрузок от Вашего Дорогого Поставщика Вы не дождетесь…
Поставщик в свою очередь приобрел право за Вас отправить Акт отказа….
52. Сергей Попов (s_v_p) 21.11.15 13:28 Сейчас в теме
(50)

1) делаю "Акт подтверждения" , как понять прошло все или нет?
У Вас во Входящих должны появиться квитанции…
Сейчас работаю на тем, чтобы все Входящие документы выстраивались в Дерево, т.е. Вы получили ТТН (+ справки Б), подтвердили ее Актом, получили квитанции…
все эти документы должны объединиться в ветку, посмотрим должно получиться нагляднее…
Ну и конечно результат Вашего Акта должен отразиться на Остатках.

Я бы предложил: при удачном подтверждении акта удалять приход со справками из входящих (с вопросом), может быть при этом на всякий случай сохранить во временную базу на какой-то период , но и там ее удалять по прошествию например 7 дней.

2) что будет, если я удалю все запросы и документы без подтверждения прихода, они так и будут висеть неподтвержденные где-то в недрах ЕГАИСа?
Думаю если Вы НЕ будете реагировать на Входящие документы (не подтверждать прием товара), то больше отгрузок от Вашего Дорогого Поставщика Вы не дождетесь…
Поставщик в свою очередь приобрел право за Вас отправить Акт отказа….

я немного про другое спрашивал, про опасность того, что пользователь случайно удалит из входящих приход, этот вопрос перекликается с первым, если приходы будут удаляться автоматом после актов, то и пользователю незачем ползать во входящих и удалять все вручную
(52) s_v_p,
Ок! Давайте вместе над этим подумаем (обсудим предлагайте)...
А пока сделаем:
-Акт постановки на баланс;
-Акт о списании товара;
-Проверку любых исходящих движений товара на соответствие остаткам в ЕГАИС;
-Продвинутого Помощника управлением связями кодов ЕГАИС и нашей УС;
-Архивные каталоги, куда будем сохранять все полученные/сформированные документы…
42. Сергей Иванов (serg75) 20.11.15 07:27 Сейчас в теме
Проверил в браузере http://localhost:8080/opt/in/ свои запросы. XML cписок запросов показывает, их уже стоит 18 такого вида <url replyId="222b3c2c-0010-43fc-ab57-36e17d830221">http://localhost:8080/opt/in/QueryPartner/18</url>; Набираю адрес ответов http://localhost:8080/opt/out/ - пустая страница
По dll: у кого какие-то проблемы с регистрацией модулей пишите в личку. Вышлю регистрилку..
При отправке запроса по орг проверьте файл запроса в части корректности ИНН
УТМ это служба на Вашем компе и судя по аходной очереди все запросы от обработки она получает. Проверьте связь с серверами ЕГАИС. ..
46. Сергей Иванов (serg75) 20.11.15 08:38 Сейчас в теме
По каким адресам проверить связь
47. Алексей Трофимов (trofimovalexey) 20.11.15 11:26 Сейчас в теме
<A>
<error>org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '[0-9]{9}' for type 'KPPType'.</error>
<ver>2</ver>
</A>

я понял, что 'KPPType' нет в обработке. в описании утм тоже нет. а в схемах есть.
Дорогие друзья! Писать инструкцию, к сожалению, абсолютно нет времени.
Пытаюсь все сделать дружелюбно и понятно, цена обработки считаю вполне адекватна, для того чтобы самим немного вникнуть…
А небольшая «Помощь» создается Здесь при обсуждении с Вами ее работы…
Спасибо за понимание..
Жду Ваших предложений...
54. Алексей Трофимов (trofimovalexey) 22.11.15 09:37 Сейчас в теме
Будет ли реализован Акт постановки на баланс, как у опта? Тут примеры есть. http://egais2016.ru/forum/viewtopic.php?f=2&t=377
55. Алексей Трофимов (trofimovalexey) 22.11.15 09:45 Сейчас в теме
Напишите свой электронный адрес. есть пару вопросов.
56. Алексей Трофимов (trofimovalexey) 23.11.15 03:57 Сейчас в теме
https://www.youtube.com/watch?v=93H80Or5-RY&feature=youtu.be
Тут грамотно сделан справочник НоменклатураЕГАИС. К нему уже подцепляется штатная номенклатура. Я бы сделал по аналогии.
57. Алексей Трофимов (trofimovalexey) 23.11.15 03:59 Сейчас в теме
Если у вас есть распределенная база данных, каким образом будут передаватся дбф? по мне так-этот подход не совсем правильный.
(57) trofimovalexey
При работе с ЕГАИС распределннности не нужно. Работа со справочником в последней версии оптимизирована Вы скоро это увидите. ..используется Помощник.
83. Сергей Ильин (ilyins) 27.11.15 06:01 Сейчас в теме
(57) trofimovalexey,
У нас распределенная база. Сомнения о возможности работать с одной папкой синхронизации не покидают и меня.
В версии 1.4 решена эта задача?
(83) ilyins,
Алексей, для решения задачи по распределенности необходимо таблицы хранения соответствий реализовать в конфигурации и вкл в раср. обмен, но здесь об автономности обработки тогда можно забыть. .
Если многим это нужно, пишите здесь..
Будут желающие сделаем.. или сделаем второй вариант с изменением конфы..
Хотя Код открыт можете сами это сделать. .
85. Владимир Владимир (knight) 27.11.15 07:38 Сейчас в теме
(84) заказал обработку отдал счет в бухгалтерию, думаю сегодня оплатят. в идеале бы обращения к хранимым данным локализовать в отдельных процедурах/функциях.
Чтобы люди с распределенками или теми кому просто удобнее хранить соотвествия, коды и тд в самой 1с подправили бы один раз эти места под себя и при обновлениях обработки просто копировали пару процедур,а не лопатили весь код. Еще вопрос судя по скриншотам ттн-ки покупателям отправляются по одной. А какой-то пакетный режим планируется?
P. S. спасибо вам от всех семерочников, помогаете многим людям неоценимо!
88. Сергей Ильин (ilyins) 27.11.15 08:07 Сейчас в теме
(85) knight, Еще одна проблема может возникнуть из-за дублей номенклатуры и контрагентов в ЕГАИС - 1 позиция в 1с должна включать в себя несколько позиций из ЕГАИС.
59. Taras Dneprovskij (Phanat0m) 23.11.15 07:50 Сейчас в теме
Добрый день, в вашей обработке определение "справки Б" прихода ТТН определяется по полю
<wb:InformB>
<!--Раздел Б - ид записи предыдущей отгрузки (по которому продукция поступила на склад)-->
<pref:InformBItem>
<pref:BRegId>000000000000008</pref:BRegId>
</pref:InformBItem>

из самой ТТН, что, вроде, в корне не корректно, ибо это справка-б прихода товара к нашему поставщику.

У нас же данные по справке Б надо получать из файла FORMBREGINFO, где в поле
<wbr:InformBRegId>TEST-FB-000000000668534</wbr:InformBRegId>
хранятся нужный нам номер справки Б.

или я не правильно понимаю?
60. Taras Dneprovskij (Phanat0m) 23.11.15 07:59 Сейчас в теме
Либо уж вводить 2 свойства для номенклатуры - это справка б входящая и поставщика
61. sodrk Пунегова (sodrk) 23.11.15 10:36 Сейчас в теме
Будет работать на 1С 7.7 Бухгалтерский учет, ред.4.5(один из последних релизов)?
62. Алексей Трофимов (trofimovalexey) 24.11.15 04:37 Сейчас в теме
Еще столкнулся спроблемой, в Егаим адреса выглядят так РОССИЯ,,ТВЕРСКАЯ ОБЛ,Конаковский р-н,,Новозавидовский пгт,Первомайский пер,д. 1,, , однако страну и регион нужно отправлять кодом.
63. Алексей Трофимов (trofimovalexey) 24.11.15 04:38 Сейчас в теме
Еще столкнулся спроблемой, в Егаисе адреса выглядят так: РОССИЯ,,ТВЕРСКАЯ ОБЛ,Конаковский р-н,,Новозавидовский пгт,Первомайский пер,д. 1,, , однако страну и регион нужно отправлять кодами.
(63) trofimovalexey,
Алексей, а какая здесь проблема-то? Или в формировании адресов у Вас получается что-то некорректное?
64. Сергей Иванов (serg75) 24.11.15 10:18 Сейчас в теме
Здравствуйте. Если при запросе остатков прервать ожидание ответа, то как позже результат ответа получить в таблицу остатков ?
(64) serg75,
Во вкладке Водящие (после кнопки Обновить) загружаются все входящие Документы, в текущей версии они отсортированы по типу и дате прихода,
соответственно самый последний Документ Остатки содержит самые актуальные данные, ставим на нем Отметку и жмем Загрузить ответы….
Переходим на вкладку Остатки, там все должно уже быть…
65. Евгений (Пользователь 1С) 2 24.11.15 15:42 Сейчас в теме
Добрый день! Обработку уже приобрели. Спасибо! А как получить новую версию? И неплохо бы описание, хотя бы краткое. Например не понятно, нажали "Акт подтверждения", в сообщении написала "отправка акта". Как понять, отправилось (добралось) до ЕГАИС наше подтверждение?
(65) Пользователь 1С
Новая версия проверятся и дорабатывается (что-бы у Вас возникало меньше трудностей, думаю на этой неделе выйдет)…
А как получить новую версию? См. выше…
Например не понятно, нажали "Акт подтверждения", в сообщении написала "отправка акта". Как понять, отправилось (добралось) до ЕГАИС наше подтверждение?
В ответ должны прийти две квитанции… и Товар (подтвержденный) появиться в Остатках… Кстати, этот вопрос поднимался чуть выше…
Далее, планируется сделать Архив входящих документов, после этого успешно подтвержденные документы можно будет автоматически удалять…
70. Евгений (Пользователь 1С) 2 25.11.15 10:28 Сейчас в теме
(67) Вы имеете по "см выше" в виду перечитать ветку или это написано в описании? Я так понял, появится ссылка для скачивания? И всё же, краткая инструкции не помешала бы. Я, к примеру, минут 10 прокопался, пока понял, как каталоги задать) впрочем, как программист, Вас понимаю, в нашей работе самое нудное и грустное, это писать инструкции, которые потом никто не читает (я про пользователей - бухгалтеров) :)
(70) Пользователь 1С,
Ссылку на скачивание Вы уже получили при первом скачивании обработки...
74. Сергей Иванов (serg75) 26.11.15 06:50 Сейчас в теме
(72) Здравствуйте. Версия 1.4 доступна для скачивания или нет ?
69. Алексей Трофимов (trofimovalexey) 25.11.15 09:17 Сейчас в теме
разобрался. тут вот еще нашел интересное http://egais2016.ru/forum/viewtopic.php?f=3&t=427
а свой вопрос я тут разместил. http://egais2016.ru/forum/viewtopic.php?f=2&t=379&start=10 что-то не уходят ттн. квитанция с ошибкой возвращается.(
(69) trofimovalexey,
Да Алексей спасибо, в версии 1.4 уже изменен тип идентификаторов в таблицах на строковые (кнопка Модернизировать БД)
(действительно проблема в "отсутствии" организации в ЕГАИС, вероятно кроется в потери нулей слева при преобразовании строки в число)..
73. Древницкий Сергей (nico2) 26.11.15 02:51 Сейчас в теме
Здравствуйте, подскажите пожалуйста, есть ли версия данной обработки под 1С. Бухгалтерия УСН 1.3 Если есть отпишите с удовольствием приобретем.
75. Сергей Иванов (serg75) 26.11.15 07:19 Сейчас в теме
Каким образом поставить на баланс в ЕГАИС конечные остатки из декларации ?
(75) serg75,
Как заявлено: ТОЛЬКО ПОМАРОЧНО!
но посмотрим...
77. Сергей Иванов (serg75) 26.11.15 08:39 Сейчас в теме
(76) Я имел ввиду через обработку остатки в ЕГАИС можно или нет. И все таки версия 1.4 доступна или нет ?
79. Алексей Трофимов (trofimovalexey) 26.11.15 15:28 Сейчас в теме
(76) 2 числа в Москве будет совещание по опту. мне непонятна позиция фирмы 1с. есть к примеру утап 195-последний релиз. там учет ведется по сериям. ждать новое обновление придётся если они примут помарочное сканирование, а время на исходе. как-то у них все про розницу и про розницу. я очень благодарен данному автору, что он вселяет надежду для решения общей проблемы- пережить 1января+получить неплохой набросок для опта. пока я только со справочниками работаю+ документы попытался отправить. в утап не работает ничего. выводы:
78. Алена A (alenaalenkina) 26.11.15 12:13 Сейчас в теме
Добрый день, вчера приобрели вашу обработку, только в версии 1.3, как нам можно скачать либо получить 1.4. Спасибо.
80. Алексей (al-greka) 26.11.15 15:49 Сейчас в теме
Добрый день! Можно электронный адрес. Есть работа по адаптации ТиС, измененной под торговлю пивом.
81. Кирилл Логинов (kirlog) 42 26.11.15 18:21 Сейчас в теме
Купил. Плюсую.
Однако - ошибка имеет место при отправке акта расхождений.
В запросе два раза повторяется wa:Content
Это потому, что в процедуре ОтправитьАкт()
Дважды встречается:
...
Content = WayBillAct.appendChild(DOMDocument.createElement("wa:Content"));
...
ИначеЕсли Вид=3 Тогда
...
Content = WayBillAct.appendChild(DOMDocument.createElement("wa:Content"));
...

УТМ это не ест. Давится ошибкой.

И ЕЩЕ:
Ошибка в в логике этой же процедуре:
В строке: ПриходТЗ.RealQuantity<ПриходТЗ.Quantity нужно бы поствить знак <=
А то ругань идет по каждой строке, где факт равен кол-ву поставщика.

Друзья поступает типовой вопрос про версию 1.4!
К концу недели будет доступна для обновления и скачивания, хочется реализовать большинство Ваших предложений указанных и в форуме и в личке, по удобству, ясности, и минимизации ошибок… Спасибо..
86. Николай Двоелучинских (dvoinik) 10 27.11.15 07:50 Сейчас в теме
При запросе справочников пишет ошибки.
УзелA=DOMDocument.getElementsByTagName("A").item(0);
{D:\ALCOP\EGAIS\OBMEN_EGAIS.ERT(2021)}: Плохой тип переменной
87. Николай Двоелучинских (dvoinik) 10 27.11.15 08:00 Сейчас в теме
10:59:48 - Запрос отстаков
Создаем Msxml2.DOMDocument.6.0
Удачно создали Msxml2.DOMDocument.6.0
Создаем Msxml2.DOMDocument.6.0
Удачно создали Msxml2.DOMDocument.6.0
УзелA=DOMDocument.getElementsByTagName("A").item(0);
{D:\BASA1C_2015\ALCOP\EGAIS\OBMEN_EGAIS.ERT(2208)}: Плохой тип переменной
(87) dvoinik,
Посмотрите сам ответ (reply.xml) когда происходит ошибка «Плохой тип переменной».
Скорее всего с ним что то не в порядке, в личку файл-ответ скиньте… будет яснее...
89. Алексей Трофимов (trofimovalexey) 27.11.15 09:03 Сейчас в теме
Сделайте кнопку, чтоб можно было посмотреть "в глаза" утм-у
WSShel = СоздатьОбъект("WScript.Shell");
WSShel.Run("explorer.exe http://"+АдресУТМ);

еще вот пару интересных ссылок:
http://egais2016.ru/forum/viewtopic.php?f=2&t=576
http://www.gazeta.ru/business/news/2015/11/26/n_7936241.shtml
90. viktorn 1 (viktorn) 27.11.15 10:02 Сейчас в теме
Не регистрируются 1CPP.dll FormEx.dll
Windows 7 32
(90) viktorn,
Регистрилку .dll вышлю по запросу (с указанной почтой)...
91. Александр Доронин (garageinfo) 27.11.15 10:33 Сейчас в теме
Коллеги, кто уже пользуется обработкой, подскажите как ее правильно установить? Куда закинуть папки дополнительные, в EXTFORMS?
Оставьте свое сообщение