0. StepByStep 3272 29.12.11 22:13 Сейчас в теме

Универсальный редактор реквизитов объектов. Мультиобработчик

Объекты: Справочник, Документ, ПланОбмена, ПВХ, Бизнес-процесс, Задача, ПланСчетов, ПВР.
Мультиобработчик:
-Проведение, перенумерация, движения, копирование, создание на основании, подчиненность, статистика, удаление документов.
-Регистрация изменений объекта(ов) в планах обмена.
-Установка/Отключение ГлавногоУзла РИБ.
-Поиск и восстановление "Битых" ссылок.
-Недопустимые символы XML/Дерево XML.
-Поиск и замена ссылок.
-Ошибки ИБ, в т.ч XML.
-Множество обработок справочников.
-GUID. Дата и время создания объектов ссылочного типа.
-Аналитика предопределенных, блокируемых реквизитов, ХранилищаЗначений.
-История изменений объекта.
-Активные пользователи.
-Подписки на события, функциональные опции.
-Загрузка пользователей ИБ из Windows, Active Directory.
-Выгрузка/Загрузка пользователей ИБ в/из внешний XML-файл.
-Поддержка различных режимов модальности.
Файловый, Клиент-Серверный варианты.
Обычная и Управляемая формы.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
315. StepByStep 3272 30.06.16 23:45 Сейчас в теме
ВЕРСИЯ 9.0
- Добавлены параметры регистрации обработки в справочнике "Дополнительные отчеты и обработки" 1С:Предприятия для текущих версий БСП.
- Добавлено "Недопустимые символы XL/Ошибка преобразования данных XML".
- Изменения, предложенные yuraos (см. комментарии).
- Прочие изменения.
316. Master5550 26.07.16 09:55 Сейчас в теме
Спасибо! обработка работает как надо!
317. krv2k 368 28.07.16 18:24 Сейчас в теме
Версия 9.0 не работает в конфигурации, в которой переопределено стандартное хранилище данных форм (точнее, может не работать). Предлагаю сохранять значения каким-нибудь другим способом.
319. StepByStep 3272 06.08.16 13:33 Сейчас в теме
(317) krv2k,
Смоделировал ситуацию - ошибок не возникло.
Какая у Вас конфигурация ?
Может следует провести "Тестирование и исправление" ?
321. krv2k 368 12.08.16 06:47 Сейчас в теме
(319) у меня в хранилище в качестве идентификаторы используется не строка, а ссылка. В общем, всё зависит от написанного кода. Вечером выложу конфу.
322. krv2k 368 20.08.16 18:54 Сейчас в теме
(319) попробуйте открыть обработку в этой конфе, сразу будет видно в чём причина.
Прикрепленные файлы:
2016-08-20.cf
327. StepByStep 3272 14.09.16 11:05 Сейчас в теме
(322) krv2k,
Посмотреть - посмотрю, но в этой части изменения не планируются.
332. krv2k 368 15.09.16 06:06 Сейчас в теме
318. AllexSoft 01.08.16 11:00 Сейчас в теме
Все отлично, не достает главного: Редактирование набора движений документа в ручную... ибо просто информационная закладка "Движения" без возможности редактирования практически бесполезна ( Будет ли такой функционал в обработке ?
320. StepByStep 3272 06.08.16 13:34 Сейчас в теме
(318) AllexSoft,
Это уже есть (СПАСИБО YURAOS) см. контекстное меню таблицы движений.
323. yaguarrr 71 24.08.16 10:39 Сейчас в теме
Розница 2,2,4,22
1) Хорошо бы добавить возможность редактирования ТТН ЕГАИС по которым уже отправлен акт принятия/отказа (в данный момент такие накладные просто не видно в списке подбора)
2) возможность редактирования пробитых чеков ККМ
324. krv2k 368 25.08.16 05:12 Сейчас в теме
(323) yaguarrr, да, точно, очень не хватает простой формы выбора как в http://infostart.ru/public/14747/
329. StepByStep 3272 14.09.16 11:08 Сейчас в теме
(324) krv2k,
Если Вы имеете в виду форму выбора объекта без фильтров - то это возможно.
333. krv2k 368 15.09.16 06:09 Сейчас в теме
(329) не только без фильтров, она должна быть как генерируемая по умолчанию платформой (если бы в конфигураторе формы вообще не было).
334. StepByStep 3272 21.09.16 10:53 Сейчас в теме
(333) krv2k,
В принципе получилось.
Исключение - использование дополнительных окон обработки.
Посмотрите ...
328. StepByStep 3272 14.09.16 11:07 Сейчас в теме
(323) yaguarrr,
При Записи/Проведении используются процедуры конфигурации.
325. krv2k 368 06.09.16 16:41 Сейчас в теме
А ещё обработка не показывает общие реквизиты.
330. StepByStep 3272 14.09.16 11:09 Сейчас в теме
(325) krv2k,
Общие реквизиты в следующей версии будут.
326. krv2k 368 12.09.16 10:44 Сейчас в теме
Ещё не хватает функционала открытия по навигационной ссылке и открытия по УИД. Например, в документообороте почти нигде не выведены номер и код, а найти объект в форме выбора просто нереально.
331. StepByStep 3272 14.09.16 11:09 Сейчас в теме
(326) krv2k,
Возможно в следующей версии обработки.
335. StepByStep 3272 21.09.16 10:54 Сейчас в теме
9.1 (09.2016)
- Добавлена возможность редактирования общих реквизитов объектов.
- Добавлена нестандартная форма выбора объекта информационной базы (см. "Настройка").
- Добавлен выбор объекта по GUID/Навигационной ссылке.
- Прочие изменения.
336. krv2k 368 04.10.16 07:47 Сейчас в теме
(335) большое спасибо, теперь работать с обработкой намного удобнее.
337. krv2k 368 04.10.16 07:49 Сейчас в теме
Ещё не хватает редактирования реквизита "Пометка удаления". Есть кнопка установки/снятия пометки, но это немного не то.
339. StepByStep 3272 05.10.16 15:00 Сейчас в теме
341. krv2k 368 06.10.16 07:33 Сейчас в теме
(339) чтобы платформой не выполнялись действия, которые происходят при пометке на удаление, например, пометка подчинённых элементов в иерархическом справочнике. Ну и чтобы можно было изменить пометку в режиме "ОбменДанными.Загрузка".
344. StepByStep 3272 30.10.16 17:46 Сейчас в теме
(341) krv2k, (342) krv2k, (343) krv2k,
- ПометкаУдаления - хорошо
- УникальныйИдентификатор - хорошо.
- Оптимизация. Отмените в обработке сохранение/восстановление "ОбъектБД" - будет быстрее, а иначе открывается (восстанавливается) последний редактировавшийся объект со всеми табличными частями.
aipnnov; krv2k; +2 Ответить
345. krv2k 368 31.10.16 11:16 Сейчас в теме
(344)
Отмените в обработке сохранение/восстановление "ОбъектБД"

Как это сделать? Не нашёл такой настройки.
346. StepByStep 3272 02.11.16 13:00 Сейчас в теме
(345) krv2k,
Форма - Реквизиты - Объект раскрыть - Найти реквизит "ОбъектБД" - Снять галочку "Сохранение".
В результате последний редактировавшийся объект не будет восстанавливаться при повторном открытии обработки.
347. krv2k 368 03.11.16 06:21 Сейчас в теме
(346) это, конечно, можно, но хотелось бы не править обработку самому, а иметь настройку в пользовательском режиме.
338. krv2k 368 04.10.16 10:43 Сейчас в теме
Если редактировать бизнес-процесс, то не указывается его тип, только надпись "БизнесПроцесс:" рядом с полем ввода.
340. StepByStep 3272 05.10.16 15:01 Сейчас в теме
342. krv2k 368 06.10.16 07:35 Сейчас в теме
Также нужна возможность редактирования реквизитов с типом "УникальныйИдентификатор". Это можно реализовать через текстовое поле ввода, при записи введённый текст преобразовывать обратно в идентификатор.
343. krv2k 368 06.10.16 07:37 Сейчас в теме
В больших конфигурациях обработка открывается очень долго, можно ли оптимизировать эту часть? Считывание объекта тоже выполняется довольно долго.
348. StepByStep 3272 08.11.16 23:49 Сейчас в теме
9.2 (11.2016)
- Добавлена возможность редактирования реквизитов "ПометкаУдаления" и реквизита типа "Уникальный идентификатор".
- Прочие изменения.
351. Kyrales 134 11.11.16 09:05 Сейчас в теме
(348) StepByStep, пометку удаления только справочников можно редактировать. Просьба добавить поддержку других объектов метаданных.

Просьба убрать информационные надписи о правильности использовать пометки удаления и GUID. Пользователи этой обработки явно понимают сей риск.
363. StepByStep 3272 19.12.16 22:03 Сейчас в теме
(351)
Пометку удаления - проверю, если так - подправлю.
Спасибо.
349. erinsergey 10.11.16 15:59 Сейчас в теме
Здравствуйте!
Какую из выложенных обработок надо скачать, чтобы отредактировать реквизиты банковского счета в УТ 11.2.3.200?

Я скачал "РедакторСиД 2.1".
Но ее не получается запустить, выдается ошибка "Проверка мутабельных значений на заполненность не поддерживается".
Как ее запустить?
361. StepByStep 3272 19.12.16 21:58 Сейчас в теме
(349)
Здравствуйте.
Рекомендую скачать последнюю версию.
350. Kyrales 134 10.11.16 19:04 Сейчас в теме
Все классно, но если "Объект БД" будет битой ссылкой, а мы до этого его смотрели в обработке, то обработка больше не запустится.
362. StepByStep 3272 19.12.16 22:00 Сейчас в теме
(350)
Неоднократно открывал обработку с объектом - битой ссылкой - проблем не было.
Уточните, пожалуйста, какая платформа, конфигурация, объект.
352. Kyrales 134 11.11.16 09:20 Сейчас в теме
Просьба рассмотреть для реализации возможность редактирования и отображения типа ХранилищеЗначения.

В списке свойств всегда можно определять что хранится в хранилище значения: таблица значений, структура, файл. Можно добавить возможность сохранения и загрузки файла.
353. krv2k 368 11.11.16 09:23 Сейчас в теме
Скачал последнюю версию, с уникальным идентификатором очень удобно получается, но всё ещё не хватает пары моментов:
1) Не указывается имя типа для бизнес-процессов и для задач.
2) Нет настройки, чтобы при открытии не загружался последний выбранный объект.
364. StepByStep 3272 19.12.16 22:05 Сейчас в теме
(353)
Тип бизнес-процесса посмотрю.
Настройки по последнему объекту не будет. При необходимости доработайте.
354. krv2k 368 14.11.16 08:08 Сейчас в теме
Сегодня столкнулся с проблемой, что нумератор у справочника сбился - новые элементы не записываются из-за уникальности кода.
Добавьте, пожалуйста, функционал обновления нумерации объектов (для конкретного объекта или всех объектов сразу):
ОбновитьНумерациюОбъектов(Метаданные.Справочники.АдреснаяКнига)
ОбновитьНумерациюОбъектов()
365. StepByStep 3272 19.12.16 22:07 Сейчас в теме
(354)
Такой функционал не планируется.
355. krv2k 368 18.11.16 10:33 Сейчас в теме
При нажатии на кнопку "GUID/НС" нужно активировать соответствующее поле ввода.
356. Kabz 76 30.11.16 21:29 Сейчас в теме
В статистике словил такую ошибку

{ВнешняяОбработка.Администратор1С.МодульОбъекта(8608)}: Ошибка при вызове метода контекста (Выполнить)
Результат = Запрос.Выполнить().Выгрузить();
по причине:
{(4, 48)}: Синтаксическая ошибка "о"
"(не используется) Пачка документов "Сведения <<?>>о страховом стаже застрахованного лица СПВ-2"" КАК Синоним,
366. StepByStep 3272 19.12.16 22:10 Сейчас в теме
(356)
Статистика документов. Посмотрю.
370. zoomzd1234 26.01.17 18:13 Сейчас в теме
(356)"Обойти программные ограничения, существующие в форме объекта типовой конфигурации." - как? Неужели процедуры модуля объекта не будут вызываться?

Естественно, будут вызываться.

Имелось в виду обойти ограничения, существующие в конфигурации, определяемые в форме(модуле формы) объекта типа:

1. Форма: Определенные реквизиты вообще не высвечиваются в форме объекта типовой конфигурации.

2. Модуль формы: Блокировка редактирования отдельных реквизитов.
Например: во время создания нового элемента справочника доступны для редактирования 10 реквизитов, а после записи, при повторном редактировании объекта доступно лишь 8, 2 оставшихся высвечиваются серым цветом - недоступны для редактирования - это зависит от проектной логики конкретной конфигурации. Причем не всегда есть так называемое "Разблокирование реквизитов", т.е средствами стандартного диалога до этих реквизитов не добраться ...

Здесь подобные ограничения не накладываются.
357. krv2k 368 04.12.16 15:09 Сейчас в теме
В дополнение к настройке открытия последнего выбранного объекта. Если открытие отключено, то при на форму добавить кнопку "Открыть последний объект".
358. PavelZnaikin 157 16.12.16 13:55 Сейчас в теме
Скажите а можно ли данной обработкой откорректировать регистр "Сведений или Накоплений" подчиненный регистратору. Или частично удалить движения документа по регистрам?
359. yuraos 956 16.12.16 17:18 Сейчас в теме
(358) начиная с версии 9.0 (06.2016)
можно из контекстного меню.включить редактирование таблицы набора движений документа по любому регистру.
отредактировать произвольно таблицу движений (включая добавление и удаление строк)
и перезаписать набор движений документа по регистру этой отредактированной таблицей.
360. PavelZnaikin 157 17.12.16 23:07 Сейчас в теме
Скачал последнюю версию, что то не получается. Можете скрин приложить как удалить движение частично
367. StepByStep 3272 19.12.16 22:13 Сейчас в теме
(360)
Флажок "Показать т.движений" - далее в таблице движений контекстное меню пункт "Включить изменение набора"
368. StepByStep 3272 25.01.17 22:32 Сейчас в теме
9.2.1 (01.2017)
- Добавлена возможность редактирования реквизитов "ПометкаУдаления" объектов-несправочников.
- Прочие изменения недочетов.
369. mkostya 26 26.01.17 15:09 Сейчас в теме
9.2.1

{ВнешняяОбработка.Администратор1С.МодульОбъекта(9453)}: Ошибка при вызове метода контекста (Выполнить)
Результат = Запрос.Выполнить();
по причине:
{(3, 1)}: Ожидается выражение "ВЫБРАТЬ"
<<?>>УПОРЯДОЧИТЬ ПО
371. StepByStep 3272 02.02.17 13:15 Сейчас в теме
372. coolseo 53 07.02.17 12:38 Сейчас в теме
Здравствуйте, а консоль запросов есть встроенная?
373. StepByStep 3272 18.02.17 16:59 Сейчас в теме
375. coolseo 53 19.02.17 01:50 Сейчас в теме
(373) Андрей, подумайте насчет консоли, это единственный инструмент которого не хватает для полного счастья.
Спасибо.
376. StepByStep 3272 23.02.17 10:14 Сейчас в теме
(375)
Скорее всего в этой обработке консоли запросов не будет.
426. AlexO 127 21.09.19 12:31 Сейчас в теме
(375) вы хоть представляете, сколько возникнет проблем и ошибок только в модуле консоли запросов? А там еще и конструктор есть.
Вы еще на уровне 8.1 все видите, а тут уже давно все в уэф-ном 8.3 варятся.
Не случайно даже 1С разделила консоль выполнения и редактор запросов - очень много проблем и ошибок. Не говоря о том, что в тонком не работает конструктор (хотя пытаются обойти это ограничение, и даже успешно иногда)
И посмотрите, как дорабатываются, и с каким трудом, уже существующие консоли, которые в подавляющем большинстве - и так все основаны на типовой консоли с ИТС.
374. StepByStep 3272 18.02.17 17:21 Сейчас в теме
9.3 (02.2017)
- Добавлена новая редакция удаления документов.
- Прочие изменения.
377. user597811_loki111 01.03.17 10:32 Сейчас в теме
здравствуйте а артикула совсем редактировать нельзя?
379. StepByStep 3272 01.04.17 15:45 Сейчас в теме
(377)
Запрета на редактирование артикула нет.
378. grachev1c 23.03.17 16:48 Сейчас в теме
Автор, ты крут! Продолжай, пожалуйста!
380. user597811_loki111 01.04.17 16:17 Сейчас в теме
обработка пишет что артикул находится в заблокированных реквизитах
382. StepByStep 3272 01.04.17 16:26 Сейчас в теме
(380)
(381)
Только что попробовал - позволяет изменять.
А сообщение о блокируемом реквизите - предупреждающее.
Т.к. эти реквизиты нельзя или не рекомендуется изменять после того, как они используются где-либо.
381. user597811_loki111 01.04.17 16:18 Сейчас в теме
розница 2.2.5 не дает убрать из артикула нечитаемые символы
383. user597811_loki111 01.04.17 21:07 Сейчас в теме
пишет
МО: Реквизит: "Артикул" не включен в редактирование, т.к. не соответствует отбору: Реквизит - это "Группа", а Реквизит используется для: "ДляЭлемента".
Прикрепленные файлы:
385. StepByStep 3272 11.04.17 00:02 Сейчас в теме
(383)
(384)
По всей видимости у Вас артикул в виде числа записан в строковый реквизит "Артикул".
Число разделено неразрывными пробелами - это нормально для 1С и в данном случае не удаляется, если Вы не измените обработку.
Рекомендую Вам изменять артикул в свойствах элемента номенклатуры.
384. user597811_loki111 01.04.17 21:31 Сейчас в теме
пробелами оказались невидимые знаки градусов не пойму как их удалить
386. user597811_loki111 11.04.17 08:53 Сейчас в теме
через доп свойства? или как?
если есть желание растолкуйте как это можно сделать
387. StepByStep 3272 05.05.17 14:54 Сейчас в теме
(386)
На вкладке "Свойства объекта" в таблице "Реквизиты" корректируете значение "Артикула".
388. vasyak319 132 17.05.17 14:34 Сейчас в теме
Спасибо за мину в Редакторе СиД 2.1. Прибегает бухгалтер: "А почему у меня текущая оборотка за первый квартал с сохранённой не сходится?"
А всё потому, что автор обработки решил, что реквизиты бывают только целочисленными. Зато смотрите, какой теперь курс в документах красивый - без копеек.
390. StepByStep 3272 07.06.17 13:11 Сейчас в теме
(388)
Редактор СиД 2.1 - это что-то древнее.
Сейчас выходит версия 9.4.
Между ними - "пропасть" по возможностям.
Желательно подобные обработки использовать сначала на тестовых базах.
В помощи к обработке сказано:
ВНИМАНИЕ:

ПРИ НЕСТАНДАРТНОМ ИЗМЕНЕНИИ ДАННЫХ ПРОЕКТНАЯ ЛОГИКА КОНФИГУРАЦИИ НЕ ОТСЛЕЖИВАЕТСЯ!

РЕКОМЕНДАЦИЯ:

ПЕРЕД ПРИМЕНЕНИЕМ НА «РАБОЧЕЙ» БАЗЕ ПРИМЕНИТЬ ОБРАБОТКУ НА «ТЕСТОВОЙ»!
389. Andre_ultra 29.05.17 13:46 Сейчас в теме
Ценный редактор. Жду, когда к объектам добавят Роли (инструмент для анализа ошибок RLS, шаблонов ограничений и средства отладки)
391. StepByStep 3272 07.06.17 13:14 Сейчас в теме
(389)
Работа с ролями пользователей - в обработке
Настройка прав пользователей. БСП. Профиль доступа. Три клика.:
http://infostart.ru/public/174375/
427. AlexO 127 21.09.19 12:38 Сейчас в теме
(389)отвечу за автора:
инструмент для анализа ошибок RLS, шаблонов ограничений и средства отладки НЕ БУДЕТ НИКОГДА.
Вы вообще как себе представляете работу такого "инструмента"? Как ограничения ловить будете, или шаблоны читать, которые по объектам конфигурации раскиданы, и в принципе не поддаются какому-либо автоматическому анализу и поиску?
Это RLS, а не ограничения в ролях, которые можно получить, запросив в коде таблицы прав.
392. StepByStep 3272 07.06.17 14:08 Сейчас в теме
9.4 (06.2017)
- Добавлено: Информация по регистрам сведений ИБ (вкладка "Дополнительно").
- Прочие изменения.
393. b-dm 169 07.08.17 12:55 Сейчас в теме
Так и не понял, будет ли обработка работать, например, в УП 1.3 ? или в 8.2 корректно будет отрабатывать. что для этого необходимо ?
394. b-dm 169 07.08.17 14:21 Сейчас в теме
395. IgorXml 610 30.08.17 12:46 Сейчас в теме
Версия 9.4. Не нашел как изменять Уникальный идентификатор. GUID/
396. webester 29 30.08.17 16:50 Сейчас в теме
(395)Я что-то пропустил? В какой момент это стало возможным?
397. IgorXml 610 30.08.17 17:02 Сейчас в теме
(396) "9.2 (11.2016)
- Добавлена возможность редактирования реквизитов "ПометкаУдаления" и реквизита типа "Уникальный идентификатор".
- Прочие изменения."
398. webester 29 30.08.17 17:42 Сейчас в теме
(397)Это юмор или очепятка. Не может же редактироваться уникальный идентификатор, без прямого доступа к БД
399. yuraos 956 30.08.17 18:42 Сейчас в теме
(398)
Здесь скорее всего имеется ввиду создание дубля объекта с указанным GUIDом
с одновременным непосредственным удалением исходного объекта.
400. IgorXml 610 31.08.17 09:31 Сейчас в теме
(399) Ок. Как надо сделать в обработке?
401. hopter 36 01.09.17 08:25 Сейчас в теме
(400) Никто не читает похоже, что написано.
9.2 (11.2016)
- Добавлена возможность редактирования реквизитов "ПометкаУдаления" и реквизита типа "Уникальный идентификатор".

Речь не о GUID объектов базы, естественно система не даст этого, а о реквизитах типа "Уникальный идентификатор" вроде же по русски написано.


Реквизиты такого типа используются во многих типовых.
корум; yuraos; IgorXml; +3 Ответить
402. yuraos 956 03.09.17 17:36 Сейчас в теме
(401) Вернее читает, так как ему хочется (о своем, девичьем, что болит) ;)

А вообще 1С также неисчерпаема, как электрон...
Возможность хранения в реквизитах объектов значения типа "УникальныйИдентификатор"
появилась начиная с платформы 8.2, но по причине своей мало-нужности как-то осталась незаметной.

Я не встречал ни одного примера ни в типовых конфигурациях, нп в самописных
где бы это использовалось.

Было бы любопытно взглянуть, где это понадобилось.
403. hopter 36 04.09.17 00:35 Сейчас в теме
(402) Например ЗУП 3, Документооборот 2

в БСП их очень много
404. AllexSoft 04.09.17 13:31 Сейчас в теме
Добрый день!

Предлагаю изменения которые многим будут полезны, сделайте таб часть где можно будет вставлять в структуру ДополнительныеСвойства в обработчике проведения и записи. Зачем это нужно? эта структура хранит в себе параметры проведения, всякие временные таблицы, а что важнее состояния констант, например можно будет выключать контроль по каким то регистрам типа ДополнительныеСвойства.Вставить("ОтключитьКонтрольТоварыОрганизаций", Истина);
Тогда не придется снимать константу контроля остатков на момент записи документов (которые зачастую оказываются проведенными "в минус" по контролируемым регистрам)
gortol; Erne100; +2 Ответить
406. Erne100 247 17.10.17 18:04 Сейчас в теме
(404) Вы правы, в последнее время это часто необходимо. Особенно в типовых.
405. Erne100 247 17.10.17 16:36 Сейчас в теме
Нашёл пару "опечаток":
1. Замена ссылок валится на константах (Например: Валюта регламентированного учета).
2. Некорректно формируюстя заголовки подменю "Настройка". См. исправление ниже.
&НаСервере
Процедура ОМСоздатьЭлементыМенюСервисНаСервере(ИмяПанели, ИмяПанелиИсключения, ГруппаПанели)
	Перем Обработка, ТаблицаПанели, НоваяСтрока;
	Перем Подменю;
	
	ТаблицаПанели = Новый ТаблицаЗначений;
	ТаблицаПанели.Колонки.Добавить("ИмяОбработки");
	ТаблицаПанели.Колонки.Добавить("СинонимОбработки");
	ТаблицаПанели.Колонки.Добавить("КомментарийОбработки");
	ТаблицаПанели.Колонки.Добавить("Префикс");
	
	Для Каждого Обработка ИЗ Метаданные.Обработки Цикл
		Если ЗначениеЗаполнено(ИмяПанелиИсключения) И Найти(Обработка.Имя, ИмяПанелиИсключения) > 0 Тогда
			Продолжить;
		КонецЕсли;
		Если Найти(Обработка.Имя, ИмяПанели) > 0 Тогда
			НоваяСтрока = ТаблицаПанели.Добавить();
			НоваяСтрока.ИмяОбработки = Обработка.Имя;
			НоваяСтрока.СинонимОбработки = Обработка.Синоним;
			НоваяСтрока.КомментарийОбработки = Обработка.Комментарий;
			НоваяСтрока.Префикс = СтрЗаменить(Обработка.Имя, ИмяПанели, "");
			НоваяСтрока.Префикс = ?(Найти(НоваяСтрока.Префикс, "БСП") > 0, "БСП", НоваяСтрока.Префикс);
			НоваяСтрока.Префикс = ?(Найти(НоваяСтрока.Префикс, "1СДокументооборот") > 0, "1СД", НоваяСтрока.Префикс);
			НоваяСтрока.Префикс = ?(Найти(НоваяСтрока.Префикс, "Справочник") > 0, "СПР", НоваяСтрока.Префикс);
			НоваяСтрока.Префикс = ?(СтрДлина(НоваяСтрока.Префикс) > 3, "КФГ", НоваяСтрока.Префикс);
		КонецЕсли;
	КонецЦикла;
	
	Если ТаблицаПанели.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	Для Каждого Обработка ИЗ ТаблицаПанели Цикл
		Подменю = Элементы.Вставить(Обработка.ИмяОбработки, Тип("ГруппаФормы"), ГруппаПанели);
              //Подменю.Заголовок = ?(ЗначениеЗаполнено(НоваяСтрока.КомментарийОбработки), НоваяСтрока.КомментарийОбработки, Обработка.СинонимОбработки);
		Подменю.Заголовок = ?(ЗначениеЗаполнено(Обработка.КомментарийОбработки), Обработка.КомментарийОбработки, Обработка.СинонимОбработки);
		Подменю.Вид = ВидГруппыФормы.Подменю;
		Подменю.Картинка = БиблиотекаКартинок.УстановитьФлажки;
		Подменю.Отображение = ОтображениеКнопки.КартинкаИТекст;
		ОМНастройкиКонфигурацииНаСервере(Подменю, Обработка.ИмяОбработки, Обработка.Префикс);
	КонецЦикла;
	
КонецПроцедуры
Показать
eeeio; gortol; +2 Ответить
407. acsent 1141 18.12.17 15:53 Сейчас в теме
Ускоряем открытие формы констант путем кэширования ФО
Ускорение раз в 10
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Перем Константа, НоваяСтрока, СтруктураФОпция;
	
	РежимИспользованияМодальностиБулево = Параметры.Настройки.РежимИспользованияМодальностиБулево;
	
	УстановитьПривилегированныйРежим(Истина);
	
	//++Кэшируем ФО
	КэшФОКонстант = Новый Соответствие;
	Для Каждого ФОпция ИЗ Метаданные.ФункциональныеОпции Цикл
			
		Для Каждого ЭлементСостава ИЗ ФОпция.Состав Цикл
			
			Если ЭлементСостава.Объект = Неопределено Тогда
				Продолжить;
			КонецЕсли;
			
			ПолноеИмя = ФОпция.Хранение.ПолноеИмя();
			Если Найти(ПолноеИмя, "Константа.") = 1 Тогда
				СтруктураВозврат = Новый Структура("ИмяФОпции,ПривилегированныйРежимПриПолучении");
				СтруктураВозврат.ИмяФОпции = ФОпция.Имя;
				СтруктураВозврат.ПривилегированныйРежимПриПолучении = ФОпция.ПривилегированныйРежимПриПолучении;
				КэшФОКонстант.Вставить(ФОпция.Хранение.Имя, СтруктураВозврат);
				Прервать;
			КонецЕсли;	
		
		КонецЦикла;
		
	КонецЦикла;
	//--
	
	Для Каждого Константа ИЗ Метаданные.Константы Цикл
		
		НоваяСтрока = ЭтаФорма.ТаблицаКонстант.Добавить();
		НоваяСтрока.нПП = ЭтаФорма.ТаблицаКонстант.Количество();
		НоваяСтрока.ИмяКонстанты = Константа.Имя;
		НоваяСтрока.СинонимКонстанты = Константа.Синоним;
		НоваяСтрока.ОписаниеТипов = Константа.Тип;
		//++
		//СтруктураФОпция = ПолучитьФункциональнуюОпциюКонстанты(Константа.Имя);
		СтруктураФОпция = КэшФОКонстант[Константа.Имя];
		Если СтруктураФОпция <> Неопределено Тогда
		//--
			НоваяСтрока.ФОпция = СтруктураФОпция.ИмяФОпции;
			НоваяСтрока.ПривилегированныйРежимПриПолучении = СтруктураФОпция.ПривилегированныйРежимПриПолучении;
		КонецЕсли;
		
		НоваяСтрока.ЗначениеКонстанты = Константы[Константа.Имя].Получить();
		
	КонецЦикла;

КонецПроцедуры
Показать
eeeio; корум; gortol; +3 Ответить
408. acsent 1141 18.12.17 16:23 Сейчас в теме
Чтобы хотя бы зрительно ускорить открытие формы лучше заполнять объект через обработчик ожидания
	
	СтрокаРавно = "===========================================================­==";
	
	Если НЕ Объект.ОбъектБД = Неопределено Тогда
		// ++
		ПодключитьОбработчикОжидания("ОтложенноеЗаполениеОбъектаПриОткрытии", 0.1, Истина);
		//ОбъектБДПриИзменении("ПриОткрытии");
		//--
	Иначе
		ФормаОпределитьДоступнность(Неопределено);
	КонецЕсли;
		
КонецПроцедуры

&НаКлиенте
Процедура ОтложенноеЗаполениеОбъектаПриОткрытии()
	ОбъектБДПриИзменении("ПриОткрытии");
КонецПроцедуры
Показать
eeeio; корум; gortol; +3 Ответить
409. gortol 183 31.01.18 14:04 Сейчас в теме
огромная благодарность комментаторам, улучшающим код обработки!!!
(Константы действительно стали мгновенно открываться))
410. turatam 3 12.02.18 12:27 Сейчас в теме
очень нравится , только "бухгалтерия предприятия базовая"

ошибка при открытии

параметр номер "1" (Нельзя получить навигационную ссылку от значения типа Начисление)
Прикрепленные файлы:
412. webester 29 27.03.18 05:32 Сейчас в теме
(410)ЗУП проф, та же проблема, я конечно закинул эту строку в обработку исключением. Но как бы непонятно, чем это грозит.
411. VodoleyPlus 21.03.18 13:34 Сейчас в теме
А эта обработка поможет восстановить остатки с РИБом. Т.е. какие-то документы по тем или иным причинам не передавались
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Технический лидер, архитектор 1С, руководитель проектов
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Екатеринбург
зарплата до 120 000 руб.
Полный день

Консультант-аналитик 1С
Рязань
зарплата до 80 000 руб.
Полный день

Программист 1С
Калининград
зарплата от 60 000 руб. до 80 000 руб.
Полный день