Повелитель регламентных заданий

0. 374 22.11.16 14:52 Сейчас в теме
Обработка позволяет комфортно и быстро работать с регламентными и фоновыми заданиями, не требует наличия БСП.
Незаменимый инструмент, если в ИБ активно используются регламентные задания.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Kyrales 142 22.11.16 18:53 Сейчас в теме
Отличная штука.
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?
2. krv2k 374 22.11.16 19:26 Сейчас в теме
(1) Kyrales,
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Спасибо, исправлю.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?

Это может пригодиться при исправлении ошибок механизмов конфигурации. Например, несколько лет назад в типовой УТ11 некорректно заполнялись параметры одного из заданий (не хватало одного параметра), из-за чего запуск регламентного задания завершался с ошибкой.
3. alfa_1969 24.11.16 04:33 Сейчас в теме
работает на обычных формах?
4. krv2k 374 24.11.16 09:33 Сейчас в теме
5. ZLENKO 395 06.01.17 11:17 Сейчас в теме
Порадовала культура написания и оформления кода обработки.
6. krv2k 374 06.01.17 20:42 Сейчас в теме
(5) Приятно удивляет, что в наше время ещё есть те, кто смотрит на код. Спасибо!
8. fixin 4128 26.04.17 10:31 Сейчас в теме
(6) мы, профи, всегда смотрим на код... ггггг...
7. fixin 4128 26.04.17 10:23 Сейчас в теме
Скачал обработку тупо, чтобы отключить все регламентные задания, т.к. доступа к консоли не было, а на копии базы они мешали.

и что же?

Она отключает только одно задание...

Надо переписать примерно так:

&НаКлиенте
Процедура ВключитьВыключитьРегламентноеЗадание(Команда)
	
	//Если Не ЭтоРегламентноеЗадание() Тогда
	//	
	//	Возврат;
	//	
	//КонецЕсли;
	Для Каждого Строка ИЗ Элементы.ДеревоРегламентныхЗаданий.ВыделенныеСтроки Цикл
		ТекущиеДанные = Элементы.ДеревоРегламентныхЗаданий.ДанныеСтроки(Строка);
		ВключитьВыключитьРегламентноеЗаданиеНаСервере(ТекущиеДанные.УникальныйИдентификатор);
	КонецЦикла;
	
	ОбновитьСписокРегламентныхЗаданий();
	
КонецПроцедуры
Показать



Единственно, я выключал группировку и отбирал только включенные задания, чтобы они нормально инвертировались.

Автору, короче, есть еще над чем поработать. Действия должны выполняться не над текущей задачей, а над выделенными.
9. krv2k 374 07.05.17 20:07 Сейчас в теме
(7)
Действия должны выполняться не над текущей задачей, а над выделенными.

Забавно, сегодня у меня появилась такая же необходимость ещё до того, как открыл Ваш комментарий. В следующей версии будет.
10. fixin 4128 07.05.17 23:44 Сейчас в теме
(9) и добавь кнопки Выкл и Вкл активности заданий, а не инверсии их состояния, плиз
13. krv2k 374 29.06.20 09:21 Сейчас в теме
(10) Добавил кнопки вкл/выкл.
17. fixin 4128 29.06.20 18:42 Сейчас в теме
12. krv2k 374 29.06.20 09:21 Сейчас в теме
(7) Добавил обработку выделенных.
11. Dzenn 737 02.10.17 13:57 Сейчас в теме
Добрый день! Хорошая, годная обработка, но есть одно "но" — использование модальных окон нынче не фэншуйно, хорошо бы избавиться от них.
14. krv2k 374 29.06.20 09:22 Сейчас в теме
(11) Пока нужна версия для 8.2, так что не получится избавиться.
15. Kyrales 142 29.06.20 12:37 Сейчас в теме
"Повелитель регламентных заданий" можно ли подключать как внешнюю обработку в конфигурации БСП?
16. krv2k 374 29.06.20 14:40 Сейчас в теме
(15) Да.
Прикрепленные файлы:
18. Kyrales 142 10.07.20 16:32 Сейчас в теме
Если добавить как обработку, потом открыть и далее закрывать, то возникает сообщение о модальности.
Прикрепленные файлы:
21. krv2k 374 14.07.20 20:27 Сейчас в теме
(18) Особенность совместимости с 8.2. В настройках можно отключить этот вопрос.
19. Kyrales 142 10.07.20 16:33 Сейчас в теме
Нельзя свернуть по умолчанию раздел доп.отборы и общие отборы? Очень много места занимает.
20. krv2k 374 14.07.20 20:24 Сейчас в теме
(19) Так как обработка под 8.2, то проблематично. К тому же, доп. отборы часто используются при администрировании заданий, зачем их скрывать?
22. чингачгук 14 03.02.21 20:55 Сейчас в теме
Спасибо за разработку!
Столкнулся с ситуацией, что база самописная, с нуля, соответственно стандартных общих модулей нет. Не мог найти ни одну рабочую обработку по регламентным заданиям, что работала бы в моей ситуации. Ваша заработала!
Оставьте свое сообщение
Вакансии
Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Рязань
зарплата от 150 000 руб. до 250 000 руб.
Полный день

Архитектор 1С
Обнинск
зарплата от 150 000 руб. до 350 000 руб.
Полный день

Программист 1С
Обнинск
зарплата от 200 000 руб.
Полный день

Консультант-аналитик 1С
Нижний Новгород
зарплата от 100 000 руб.
Полный день