0. krv2k 366 22.11.16 14:52 Сейчас в теме

Регламентные и фоновые задания (ТУРБО)

Обработка позволяет комфортно и быстро работать с регламентными и фоновыми заданиями, даже если у Вас нет БСП.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Kyrales 128 22.11.16 18:53 Сейчас в теме
Отличная штука.
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?
2. krv2k 366 22.11.16 19:26 Сейчас в теме
(1) Kyrales,
Просьба поправить заголовок при редактировании регламентного задания: там опечатка.

Спасибо, исправлю.

Объясните как может пригодится возможность добавлять свои параметры при редактировании?

Это может пригодиться при исправлении ошибок механизмов конфигурации. Например, несколько лет назад в типовой УТ11 некорректно заполнялись параметры одного из заданий (не хватало одного параметра), из-за чего запуск регламентного задания завершался с ошибкой.
3. alfa_1969 24.11.16 04:33 Сейчас в теме
работает на обычных формах?
4. krv2k 366 24.11.16 09:33 Сейчас в теме
5. ZLENKO 381 06.01.17 11:17 Сейчас в теме
Порадовала культура написания и оформления кода обработки.
6. krv2k 366 06.01.17 20:42 Сейчас в теме
(5) Приятно удивляет, что в наше время ещё есть те, кто смотрит на код. Спасибо!
8. fixin 3802 26.04.17 10:31 Сейчас в теме
(6) мы, профи, всегда смотрим на код... ггггг...
7. fixin 3802 26.04.17 10:23 Сейчас в теме
Скачал обработку тупо, чтобы отключить все регламентные задания, т.к. доступа к консоли не было, а на копии базы они мешали.

и что же?

Она отключает только одно задание...

Надо переписать примерно так:

&НаКлиенте
Процедура ВключитьВыключитьРегламентноеЗадание(Команда)
	
	//Если Не ЭтоРегламентноеЗадание() Тогда
	//	
	//	Возврат;
	//	
	//КонецЕсли;
	Для Каждого Строка ИЗ Элементы.ДеревоРегламентныхЗаданий.ВыделенныеСтроки Цикл
		ТекущиеДанные = Элементы.ДеревоРегламентныхЗаданий.ДанныеСтроки(Строка);
		ВключитьВыключитьРегламентноеЗаданиеНаСервере(ТекущиеДанные.УникальныйИдентификатор);
	КонецЦикла;
	
	ОбновитьСписокРегламентныхЗаданий();
	
КонецПроцедуры
Показать



Единственно, я выключал группировку и отбирал только включенные задания, чтобы они нормально инвертировались.

Автору, короче, есть еще над чем поработать. Действия должны выполняться не над текущей задачей, а над выделенными.
9. krv2k 366 07.05.17 20:07 Сейчас в теме
(7)
Действия должны выполняться не над текущей задачей, а над выделенными.

Забавно, сегодня у меня появилась такая же необходимость ещё до того, как открыл Ваш комментарий. В следующей версии будет.
10. fixin 3802 07.05.17 23:44 Сейчас в теме
(9) и добавь кнопки Выкл и Вкл активности заданий, а не инверсии их состояния, плиз
11. Dzenn 287 02.10.17 13:57 Сейчас в теме
Добрый день! Хорошая, годная обработка, но есть одно "но" — использование модальных окон нынче не фэншуйно, хорошо бы избавиться от них.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Бизнес-аналитик 1С ERP
Пермь
зарплата от 80 000 руб.
Полный день

Программист 1С УТ 11
Омск
зарплата от 60 000 руб.
Полный день

Бизнес-аналитик 1С УТ 11
Омск
зарплата от 60 000 руб.
Полный день

Программист 1С
Воронеж
Полный день