0. kompas-dm 761 26.02.10 12:42 Сейчас в теме

Обновления 2012 . Для пользователя, бухгалтера (пакет отчетов и обработок)

Пакет обработок и отчетов для бухгалтера построен по технологии регламентированных отчетов.
Технология ранее публиковалась в составе конфигурации. По просьбе пользователей ИС сделал самостоятельное приложение. В составе пакета представлены ряд обработок и отчетов для ежедневной работы ( стандартные, собственные и очень интересный, профессиональный отчет от http://infostart.ru/public/14467/).
Обработка "ВнешниеОтчеты.ert" будет работать в любой бухгалтерской конфигурации 7.7.
Обновлено 3 января 2012 г.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Доня 273 26.02.10 12:42 Сейчас в теме
Собрать готовые отчеты в один флакон - тоже нужная работа!
2. Agema 26.02.10 19:51 Сейчас в теме
Извините, а для бюджетки 6.1 подойдет?
3. kompas-dm 761 27.02.10 11:06 Сейчас в теме
(2) Управление отчетами - да, а сами отчеты нужно пробовать. Все-таки Бюджет, там совсем другие субконто...
12. dobraleks 137 12.01.11 16:34 Сейчас в теме
отчеты понравились, вроде иду, но пока проверяю еще..
Отчет Необоротные активы не захотел на моей конфе работать, не давал выбирать план счетов, пришлось маленько подправить под себя. Может кому то пригодится:
Если ((сч.Забалансовый = 0) И ((сч.видсубконто(2) = ВидыСубконто.НеоборотныеАктивы) или (сч.видсубконто(3) = ВидыСубконто.НеоборотныеАктивы)))
//Если (сч.Забалансовый = 0)и ((строка(сч.видсубконто(2)) = ВидыСубконто.НеоборотныеАктивы) или (строка(сч.видсубконто(3)) = "Необоротные активы") )
4. Berrimor 196 28.02.10 20:32 Сейчас в теме
Посмотрите http://infostart.ru/public/14474/ и не изобретайте велосипед с квадратными колесами
5. kompas-dm 761 01.03.10 10:16 Сейчас в теме
(4)
На ИС обработок по управлению внешними отчетами несколько. Хорошие, профессиональные. Этот вариант позволяет редактировать отчеты, обработки , добавлять новые и т.д. не притрагиваясь к 1С на компьютере пользователя.
.
У azernot другая заточка.
6. CheBurator 3566 01.03.10 14:52 Сейчас в теме
беглый осмотр показал - что у Зернятко инструмент более предпочтительный.
7. kompas-dm 761 01.03.10 17:01 Сейчас в теме
(6) "Нас уже 103060". Простых пользователей - 98 %. Для запуска серьезных работ нужен специалист, время и контакт с клиентом.
Работу регламентированных отчетов знают все. Просто и надежно.
С уважением отношусь к механизму azernot'а . Его обработка без доработок, с сохранением авторства использована мною в трех проектах.
Ориентировался на бухгалтеров, пользователей, находящихся без поддержки 1С-ника . Фишка не в управлении отчетами, а в составе пакета...

8. artbear 1091 01.03.10 18:45 Сейчас в теме
(7) Пока минусую из-за цитаты "Фишка не в управлении отчетами, а в составе пакета..."
Где состав пакета? где хотя бы краткое описание каждого отчета?

Поправишь, минус уберу.
9. kompas-dm 761 02.03.10 10:12 Сейчас в теме
(8)
В составе пакета представлены ряд обработок и отчетов для ежедневной работы ( стандартные, собственные и очень интересный, профессиональный отчет от http://infostart.ru/public/14467/).

См СкринШоты, рис 3,4,5.
Да и размер скачивания 321 кб
10. artbear 1091 02.03.10 15:17 Сейчас в теме
11. sema-5263 25.12.10 19:45 Сейчас в теме
Отчеты понравились.Очень.Только вот, самый нужный для меня..Налоги. Есть пару вопросов. Ну тот же Пенсионный. Вначислении идет разбивка сумми по фондам (32,2%,4%,2%), а вот с "Оплочено" у меня идет одной суммой,попадая ПФ с з/п с банковской выписки.Хотя...платежек было 3(32,2%,4%,2%),и в банковской выписке проходит тоже три суммы, а не одна общая, как показано в отчете. В итоге, остатки к начислению в отчете,не совпадают сфактическими по бух учету. Может кто-то объяснит в чем проблема???
14. kompas-dm 761 11.12.11 14:06 Сейчас в теме
15. Фред 04.01.12 09:40 Сейчас в теме
В публикации упомянута Украина...
Вопрос- данный продукт будет работать в российских конфигурациях?
16. kompas-dm 761 04.01.12 10:39 Сейчас в теме
(15) Управление внешними отчетами - да, сами же отчеты затачивайте под себя. В России другой план счетов и субконто.
17. Фред 04.01.12 11:39 Сейчас в теме
(16) Спасибо!
То есть это навигатор по отчетам? Комплектовать самостоятельно или есть набор по умолчанию?
18. kompas-dm 761 04.01.12 12:11 Сейчас в теме
(17) По умолчанию - в пакете много отчетов и обработок. Прочитайте описание настройки и ВПЕРЕД самостоятельно. Навигатор - для любой конфигурации 7.7.
19. Фред 04.01.12 12:47 Сейчас в теме
(18)
Загрузил...Попробовал.
Сам инструмент нормально загрузился, работает.
Первые три папки с отчетами (Налоги,денежные счета и ТМЦ), судя по
всему, не от моей семерки.
При загрузке ругаются. Остальное (ОСВ и Технологические обработки)
работает.
По моему мнению, сложноват процесс добавления новых отчетов.
Хотелось бы указанием пути прямо из меню.
+ за проведенную работу.
Спасибо.
20. rus128 2 04.01.12 13:17 Сейчас в теме
"В публикации упомянута Украина... "
А я наоборот нигде (в шапке и кратком описании) не увидел этих упоминаний - только в разделе обновлений от 9 августа 2011 года (по новому налоговому кодексу).
21. AlexTorin 06.01.12 15:46 Сейчас в теме
Благодарю за проделанную работу! Очень нужно и своевременно!
22. Mika-Marinka 25.01.12 20:38 Сейчас в теме
Реально пригодилась) Очень круто) Большое спасибо
23. z5515 3 21.02.13 09:43 Сейчас в теме
на типовой бух. 537 не пашет...

ВыбраннаяФирма = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","Фирма");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(24)}: Функция не обнаружена (глВосстановитьЗначение)
датаС = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаС");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(25)}: Функция не обнаружена (глВосстановитьЗначение)
датаПо = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаПо_");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(26)}: Функция не обнаружена (глВосстановитьЗначение)
фСчет = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСчет");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(27)}: Функция не обнаружена (глВосстановитьЗначение)
фСклад = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСклад");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(28)}: Функция не обнаружена (глВосстановитьЗначение)
фПартия = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фПартия");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(29)}: Функция не обнаружена (глВосстановитьЗначение)
фДокументы = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фДокументы");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(30)}: Функция не обнаружена (глВосстановитьЗначение)
СписокСохр = глВосстановитьЗначение<<?>>("Отчеты_пакет_2012_тмц","СписокСохр");
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(31)}: Функция не обнаружена (глВосстановитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","СписокСохр",СписокСохр);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(64)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСчет",фСчет);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(65)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фДокументы",фДокументы);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(66)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фПартия",фПартия);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(67)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","фСклад",фСклад);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(68)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","Фирма",ВыбраннаяФирма);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(69)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаС",ДатаС);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(70)}: Процедура не обнаружена (глСохранитьЗначение)
глСохранитьЗначение<<?>>("Отчеты_пакет_2012_тмц","ДатаПо",ДатаПо);
{C:\USERS\ИННА\DOWNLOADS\ОБНОВЛЕНИЕ_2012\1C_3_БУХ.REP\ДВИЖЕНИЕТМЦ.ERT(71)}: Процедура не обнаружена (глСохранитьЗначение)
24. kompas-dm 761 21.02.13 09:55 Сейчас в теме
В типовой для Украины (тек.релиз 296) есть две процедуры в гл.модуле:
// Локально сохраняет значение по ключу
// ===============================
// Конт - или контекст документа, или строка (для совместимости)
// сИдентификатор - идентификатор значения
// Значение - значение для сохранения
Процедура глСохранитьЗначение(Конт="", сИдентификатор="", Значение="") Экспорт
Если ТипЗначенияСтр(Конт) = "ГрупповойКонтекст" Тогда
сГруппа = Конт.Вид();
Иначе
// строка или что-то другое, преобразуем все к строке
сГруппа = СокрЛП(Строка(Конт));
КонецЕсли;
сКлюч = ?(ПустаяСтрока(сГруппа) = 0, сГруппа+"_", "")+СокрЛП(сИдентификатор);
СохранитьЗначение(сКлюч, Значение);
КонецПроцедуры

// В зависимости от значения глОбщиеУстановки или восстанавливает локально
// сохраненное значение или берет значение константы (реквизита справочника)
// Используется для присвоения значений по умолчанию
// ===============================
// Конт - или контекст документа, или строка (для совместимости)
// сИдентификатор - идентификатор значения
// ЗначПоУмолчанию - значение по умолчанию, если ничего не "восстановили"
Функция глВосстановитьЗначение(Конт="", сИдентификатор="", ЗначПоУмолчанию=0) Экспорт
Перем сГруппа, Фирма, ДатаЗнач;
Если ТипЗначенияСтр(Конт) = "ГрупповойКонтекст" Тогда
сГруппа = Конт.Вид();
Фирма = Конт.Фирма;
ДатаЗнач = Конт.ДатаДок;
Иначе
// строка или что-то другое, преобразуем все к строке
сГруппа = СокрЛП(Строка(Конт));
Фирма = 0;
ДатаЗнач = РабочаяДата();
КонецЕсли;
// сразу попытаемся восстановить значение по ключу
сКлюч = ?(ПустаяСтрока(сГруппа) = 0, сГруппа+"_", "")+СокрЛП(сИдентификатор);
Значение = ВосстановитьЗначение(сКлюч);
Если (глОбщиеУстановки = 2) и (ТипЗначенияСтр(Значение) <> "") Тогда
// оставляем то, что уже получили
ИначеЕсли Метаданные.Константа(сИдентификатор).Выбран() = 1 Тогда
// берем из константы...
Если Метаданные.Константа(сИдентификатор).Периодический = 1 Тогда
// ...периодической
Значение = Константа.ПолучитьАтрибут(сИдентификатор).Получить(ДатаЗнач);
Иначе
// ...обычной
Значение = Константа.ПолучитьАтрибут(сИдентификатор);
КонецЕсли;
ИначеЕсли ПустоеЗначение(Фирма) = 0 Тогда
// из реквизита объекта (справочника)
Попытка
// прочитаем реквизит
Реквизит = Метаданные.Справочник("Фирмы").Реквизит(сИдентификатор);
Если Реквизит.Выбран() = 1 Тогда
// есть такой реквизит...
Если Реквизит.Периодический = 1 Тогда
//... периодический
Значение = Фирма.ПолучитьАтрибут(сИдентификатор).Получить(ДатаЗнач);
Иначе
//... обычный
Значение = Фирма.ПолучитьАтрибут(сИдентификатор);
КонецЕсли;
КонецЕсли;
Исключение
КонецПопытки;
КонецЕсли;
// если все-таки ничего не получили, то используем значение по умолчанию
Если ТипЗначенияСтр(Значение) = "" Тогда
Значение = ЗначПоУмолчанию;
КонецЕсли;
Возврат Значение;
КонецФункции

-----------------------------------------------------------------
Поправьте или отчеты, или свой релиз ...
25. miramak 04.04.13 15:00 Сейчас в теме
Очень нравится пакет обработок, но, две работают у меня почему-то не правильно.
В обработке "Основные средства 2012г" пишет:
Ти.Загрузить(т_);
{D:\БО СБФДБТ\1SBUKR\EXTFORMS\ОСНОВНЫЕСРЕДСТВА2012.ERT(593)}: Значение не представляет агрегатный объект (Загрузить)
Что это такое не знаю?
И в обработке " Расчет_налогов":
не правильно считает налоги к уплате,в расчет попадает итоговая сумма (выделенная цветом) по сч.651 (в частности). Можно ли это исправить?
Прикрепленные файлы:
Ведомость расчетов по налогам.xls
26. kompas-dm 761 04.04.13 16:02 Сейчас в теме
(25) Проверю "Расчет налогов" и отпишу. А "Загрузить" - у Вас нет компоненты 1СPP.
Положите ее в каталог ИБ.
Прикрепленные файлы:
1CPP.dll
27. miramak 04.04.13 17:04 Сейчас в теме
Спасибо за быстрый ответ и 1СРР, буду ждать Ваших результатов
28. miramak 04.04.13 17:46 Сейчас в теме
Посмотрела обработку "Основные средства 2012г"- на опции "бухгалтерский учет" в наличие ОС показывает не корректно период. Выбираю квартал, показывает данные на последний день квартала, а это искажение данных (т.к. остатков на начало периода не было). И в шапке не помещается название предприятия.
Прикрепленные файлы:
ведомость наличия ОС_.xls
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С
Санкт-Петербург
Полный день

Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 120 000 руб.
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день