0. venger 2086 01.01.70 03:00 Сейчас в теме

Игра "Пятнадцать спичек" (разновидность игры "Ним")

Правила: 15-ть спичек выкладываются в три ряда, по 3, 5, 7 спички в ряду. Противники ходят по очереди. За один ход можно взять любое количество спичек из произвольного ряда (но только из одного ряда). Тот, кто взял последнюю спичку — проиграл.
Количество спичек, которые разрешается брать, — неограниченно. Можно первым же ходом "смести" весь первый ряд, забрав из него все 7 спичек. Но нельзя, например, взять одну спичку из первого ряда и еще одну — из второго.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. salexdv 26.08.09 13:57 Сейчас в теме
В обед погонять - самое то! :) +
3. Tatitutu 3816 26.08.09 14:38 Сейчас в теме
чуть не убил компьютер. А чего он все время побеждает )))
(1) коротковат у тебя обед
4. salexdv 26.08.09 14:42 Сейчас в теме
(3) Ну эт смотря как гонять :))))
5. Tatitutu 3816 26.08.09 14:47 Сейчас в теме
(4) Согласен. Не поспоришь.

" - А ты кто ?
- Говорящий пес Артемон. Гав !
- Так говорите у Вас нет коробка - боробка ?!?!!!" (с) КВН
2. venger 2086 26.08.09 13:58 Сейчас в теме
(0) Буду благодарен за тестирование алгоритма игры компа, писал на скорую руку, мог что-то и не учесть... Выиграть реально, если ходишь первым...
6. Ёпрст 1036 26.08.09 15:27 Сейчас в теме
Да... убери ты к едрени фени Это:
"Примечание: отчет/обработка всегда должен быть внешним."

И встроенный отчет можно открывать модально.
7. venger 2086 26.08.09 16:10 Сейчас в теме
(6) Как узнать "свое" имя во встроенном отчете/обработке? Я не в курсе просто... Подскажи, в общем, чего уж там...
9. Ёпрст 1036 26.08.09 16:44 Сейчас в теме
(7) Если нет ВК, то тупо прописать его в самом отчете.
А дальше проверять на Форма.МодальныйРежим()
15. venger 2086 26.08.09 16:52 Сейчас в теме
(9) Вот и я к тому, что если вставили в конфу с другим именем - то привет...
16. Ёпрст 1036 26.08.09 16:53 Сейчас в теме
(15) ну дык с умом нужно вставлять..
17. venger 2086 26.08.09 17:02 Сейчас в теме
(16) Со знанием, скорее:-) А кто просто чуток пользователь или админ, и особо не в курсе тонкостей 1С и конфигуратора, тому не лишне будет и написать, чтоб не парился, а тот, кто знает, тому оно не помешает.... ИМХО, конечно. Но все-равно спасибо, ибо не оскуднеет источник мастерства твоего, чтоб было всегда чему поучиться у тебя!
22. Tatitutu 3816 26.08.09 17:35 Сейчас в теме
(6) Сань конечно у тебя самомнение - Высший класс !!!
Или на лоха расчитано.
Я бы хотел посмотреть тому в глаза, кто бы твои "спички" прикрутил бы к конфигурации ЗИК или ПУБ.Я бы ему их в глаза бы и вставил )))
23. venger 2086 26.08.09 20:27 Сейчас в теме
(22) Грубоватая провокация:-)))) Но мож кто и клюнет:-))))
8. seven77782 52 26.08.09 16:16 Сейчас в теме
Все время выигрывает компьютер
11. Ёпрст 1036 26.08.09 16:45 Сейчас в теме
(8) я пока тоже не выиграл..
лень смотреть...
13. Арчибальд 2708 26.08.09 16:46 Сейчас в теме
14. Ёпрст 1036 26.08.09 16:48 Сейчас в теме
10. Ёпрст 1036 26.08.09 16:44 Сейчас в теме
+9 аналогично работают все кнопки "Обновить" и "Настройка" во всех типовых отчетах - тупо передается имя отчета, как из метаданных.
12. Ёпрст 1036 26.08.09 16:45 Сейчас в теме
+11 но чуствую - глобальное наипалово на всех уровнях общества :))
18. Tatitutu 3816 26.08.09 17:16 Сейчас в теме
Шурик на как вариант ))))

Процедура ПриОткрытии()
Если Форма.МодальныйРежим()=0 Тогда
Для Сч=1 По Метаданные.Отчет() Цикл
Если Прав(Метаданные.Отчет(Сч).Комментарий,6)="Венгер" Тогда
ОткрытьФормуМодально("Отчет."+Метаданные.Отчет(Сч).Идентификатор);
СтатусВозврата(0);
Прервать;
КонецЕсли;
КонецЦикла;
Для Сч=1 По Метаданные.Обработка() Цикл
Если Прав(Метаданные.Отчет(Сч).Комментарий,6)="Венгер" Тогда
ОткрытьФормуМодально("Обработка."+Метаданные.Отчет(Сч).Идентификатор);
СтатусВозврата(0);
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
19. Ёпрст 1036 26.08.09 17:23 Сейчас в теме
(18) И откуда Комментарий брать во внешнем отчете ?...
21. Tatitutu 3816 26.08.09 17:29 Сейчас в теме
(19) )))) молодца - быстро мышей ловишь. Как вариант )))
20. venger 2086 26.08.09 17:28 Сейчас в теме
(18) Комментарий и синоним во внешнем не остается... Если его вставить в конфу, то комментарий будет пуст.... только что пробовал... Но юмор заценил...:-)))
24. venger 2086 26.08.09 20:39 Сейчас в теме
+23, или я не догнал, короче не важно, кто куда чего вставит:-)))
25. venger 2086 26.08.09 20:39 Сейчас в теме
+24, главное наперед предусмотреть все возможные действия пользователя - это и есть мастерство:-))
26. СССР 26.08.09 21:08 Сейчас в теме
Молодец ! А я пока "лузер"...до по следующей среды. Проект сдаю - времени нет на "игрушечки",хотя пару интересных идей есть в голове.Моего ПЕРЕВЕРТЫША осилил или несмотрел даже ?
27. venger 2086 26.08.09 21:49 Сейчас в теме
(26) > Проект сдаю - времени нет на "игрушечки"

Без проблем, понятно, что время не резиновое, да и помимо работы еще куча всего есть, так что тут без напрягов.

> хотя пару интересных идей есть в голове

Как-нибудь, как появится время, в фоновом режиме, и главное желание, то будет классно, если чего еще релизуете в удовольствие.

> Моего ПЕРЕВЕРТЫША осилил или несмотрел даже ?

У меня боролись два желания (тоже из-за ограниченности по времени) - погонять в Ваши или сваять свои, вот разрываюсь надвое:-)

Да и все-равно было приятно, а победила дружба, что самое главное!
28. Lexus 27.08.09 17:50 Сейчас в теме
я знаю другую версию, там нет разбивки по рядам и ограничения в количестве спичек.
в таком варианте чтобы выиграть надо всегда оставлять противнику количество спичек равное степени двойки за вычетом единицы, т.е. (2^2-1), (2^3-1), (2^4-1) и т.п.
34. venger 2086 28.08.09 11:35 Сейчас в теме
(28),(32) Можно усложнить, добавить еще ряд с 11-й спичками, т.е. 4 ряда - 3,5,7,11 и т.д. Простые числа в рядах должны быть, вроде как, т.е. 5-й ряд если добавлять, то 13 спичек и т.д. Можно поменять условие - побеждает тот, кто последний взял. В общем, как-нибудь, надо будет развить идею...
35. Shaman100M 1191 28.08.09 11:43 Сейчас в теме
(34) без разницы, сколько рядов, какое количество, главное, правильно выбрать, кому первым ходить.
29. Abadonna 3834 27.08.09 18:55 Сейчас в теме
ХЗ, как работает движок? Плюс, чтобв не пакостили
30. CheBurator 3400 28.08.09 01:49 Сейчас в теме
плохо.. выбор количества снимаемых спичек должен делаться выделением области мышью... низачот, короче...
31. CheBurator 3400 28.08.09 01:50 Сейчас в теме
а вот еще раньше без всяких компов, на спичечных коробках была самообучаемая машина по игре в крестики-нулики...
33. venger 2086 28.08.09 11:35 Сейчас в теме
(31) Ух-ты, где бы поподробнее об этом узнать? Про такую самообучаемую машину, да еще на спичечных коробках.....
32. Shaman100M 1191 28.08.09 11:01 Сейчас в теме
на пальцах можно выйграть если знать секрет
36. lilly 12.01.12 20:41 Сейчас в теме
Забавная игра))) Раньше такую не встречала)))
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Краснодар
зарплата от 80 000 руб. до 160 000 руб.
Полный день

Консультант 1 С
Краснодар
зарплата от 50 000 руб. до 150 000 руб.
Полный день

Консультант-методолог 1С
Краснодар
зарплата от 110 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 120 000 руб.
Полный день