план обмена

Внимание! Тема закрыта. Добавлять сообщения в закрытую тему запрещено.
1. Роман Силаев (silai89) 26.07.13 12:15
в состав плана обмена помещены документы. надо создать сообщение обмена изменениярегистраций только для проведенных документов.как это организовать?в чем ошибка
Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза) Экспорт

ОбъектМетаданных=ЭлементДанных.Метаданные();

Если Метаданные.Документы.Содержит(ОбъектМетаданных) Тогда
Если ЭлементДанных.Проведен Тогда
ОтправкаЭлемента=ОтправкаЭлементаДанных.Авто;
КонецЕсли;
КонецЕсли;
//.....................................
КонецПроцедуры
Вознаграждение за ответ
Сумма: 0 $m
Добавили:
Роман Силаев (silai89) (0.70 $m)
Подписаться Добавить вознаграждение

Ответы

2. Роман Силаев (silai89) 26.07.13 16:04
как запросом обратится к результатуРегистрации
3. Сергей Сторожев (ssa) 26.07.13 16:12
По идее, нужно устанавливать не Авто для проведенных документов (Авто и так установлено у каждого элемента, который обрабатывается в этом обработчике), а Игнорировать - для не проведенных.
4. Роман Силаев (silai89) 26.07.13 16:27
5. Роман Силаев (silai89) 26.07.13 16:33
(4) silai89, а можно как нибудь обратится запросом к результату регистраций и выбрать изменения только проведенных документов и их записать в файл
6. Сергей Сторожев (ssa) 26.07.13 17:52
(5) Обратиться то можно, только зачем такие сложности. По-моему, оптимально решить этот вопрос при формировании файла выгрузки.
7. Роман Силаев (silai89) 26.07.13 17:54
8. Роман Силаев (silai89) 26.07.13 17:54
ни в выбратьИзменения() ни в ЗарегистрироватьИзменения()
9. Сергей Сторожев (ssa) 29.07.13 11:57
(8) silai89,
"ни в выбратьИзменения() ни в ЗарегистрироватьИзменения()" - ?
Имел в виду, что в ПриОтправкеДанныхПодчиненному() нужно сделать то, что написано в (3), т.е. анализировать текущий ЭлементДанных и если это документ и он не проведен - установить ОтравкаЭлемента = Игнорировать. Либо, если нужно удалить в периферийной базе: ОтравкаЭлемента = Удалить.