Запретить ПриАктивизацииСтроки при обращении к элементу формы

1. Анатолий Радонежский (TOlikRx) 07.07.12 22:05 Сейчас в теме
Для динамического списка создан обработчик ПриАктивизацииСтроки. В обработчике вызываю процедуру "СоздатьДанныеПараметров":

&НаСервере
Процедура СоздатьДанныеПараметров()
ДанныеИмя = "Поле_1";
ДанныеТип = Новый ОписаниеТипов("Строка");
ДанныеПуть = "";
ДанныеЗаголовок = "Тип";
ПолеДанных = Новый РеквизитФормы(ДанныеИмя, ДанныеТип, ДанныеПуть, ДанныеЗаголовок);
ДанныеМассив = Новый Массив;
ДанныеМассив.Добавить(ПолеДанных);
ИзменитьРеквизиты(ДанныеМассив);
КонецПроцедуры

После выполнения данной процедуры, почему то обработчик возвращается к ПриАктивизацииСтроки и все зацикливается и соответственно вылетает. Почему так происходит и как решить проблему правильно ?
Ответы
2. Анатолий Радонежский (TOlikRx) 07.07.12 23:21 Сейчас в теме
Сделал так:

&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
ПодключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента", 0.1, Истина);
КонецПроцедуры

&НаКлиенте
Процедура ВывестиДанныеТекущегоЭлемента()
<Вызов_Процедуры_Создания_Элементов>
ОтключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента")
КонецПроцедуры

Все работает, но только в ПодключитьОбработчикОжидания указал в 3м параметре Истина, а она повторяется. Хотя в минуале написано, что 3й параметр если истина, то повторяется однократно. Пришлось по окончании действий прописать ОтключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента")
3. Басир Мухамедкулов (basicm) 08.07.12 21:51 Сейчас в теме
Зачем может понадобиться пересоздавать реквизиты формы при активизации строки?)
4. Николай (Chameleon1980) 25.09.16 07:08 Сейчас в теме
вот еще на подобную тему от Гилева
Прикрепленные файлы:
Warning-2011-02-24-OnActivateRow.avi
levante90; Дмитрий Рудаков; morbus; +3 Ответить 2
5. Николай (Chameleon1980) 25.09.16 07:19 Сейчас в теме
СП говорит жеж:

ТаблицаФормы.ПриАктивизацииСтроки (FormTable.OnActivateRow)
ТаблицаФормы (FormTable)
ПриАктивизацииСтроки (OnActivateRow)
Синтаксис:

ПриАктивизацииСтроки()
Описание:

Вызывается при активизации строки таблицы.
Примечание:

В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
levante90; sommid; morbus; +3 Ответить
6. Sasha Antipov (morbus) 21.12.16 17:53 Сейчас в теме
(4) Спасибо огромное, сразу на несколько вопросов получил ответ!
И избавился от зацикливания!
7. Анатолий Глушков (levante90) 19.05.17 12:53 Сейчас в теме
(4) Спс, очень помогло видео)
Оставьте свое сообщение