Актуальность "Обособленный учёт себестоимости товаров по видам запасов"

1. MGMGA Фымилие (MGMGA) 11.12.16 16:09 Сейчас в теме
Управление торговлей 11.3.1.142, партионный учёт 2.2
Подскажите, кто знает. В современных релизах УТ галки "обособленный учёт себестоимости товаров по видам запасов" с сопутствующими "По поставщикам" и "По подразделениям и менеджерам" остаются актуальны или информацию в разрезе менеджеров/поставщиков/подразделений и без них имеем? Почему спрашиваю. Много документов перепроводить нужно. Если включить галки, постоянно ругается на наличие развёрнутого сальдо по видам запасов на конец месяца - приходится исправлять. К тому же совсем не понятно как этот учёт по видам запасов ведётся. В 90% случаев значением регистра "себестоимость-вид запасов" является "собственный товар" и только в оставшихся 10% добавляется поставщик..
Ответы
2. Виталий Клим (v_clim) 31 30.12.16 00:21 Сейчас в теме
Я поставил чистую базу Ут 11.3. Так и не получилось добиться получение аналитики по поставщикам
3. Vladimir Glumov (Vovan58) 5 30.12.16 00:45 Сейчас в теме
А что такое
партионный учет 2.2
?
4. MGMGA Фымилие (MGMGA) 30.12.16 14:16 Сейчас в теме
(2) То же самое. Аналитика по поставщикам похоже переехала в "Аналитика финансового учета" регистра "Себестоимость товаров", а отчёты пользуют "Вид запасов". И вообще половина отчётов по продажам теперь не работают корректно.
(3) В УТ11.2 появилась возможность использовать партионный учет 2.2. Там все регистры по себестоимости, партиям в один сведены.
5. Виталий Клим (v_clim) 31 31.12.16 00:21 Сейчас в теме
Обновил сегодня на Ут 11.3.2 ничего не поменялось. Так и не получилось хоть как-то получить аналитику.
6. Никита Сапунов (clcru) 06.01.17 10:01 Сейчас в теме
УТ 11.3.2.157 (учет 2.2) - попробовал вручную при поступлении указать вид запасов, чтобы был прописан поставщик. В итоге в отчетах по продажам аналитика подцепилась, но в РН Себестоимость товаров не списалась стоимость товара (только количество).
Также обратил внимание, что формат записи вида запасов в УТ 11.3 изменился (по сравнению с УТ 11.2) - теперь помимо записи "собствнный товар" и "поставщик" - стала автоматом проставляться Налогообложение и валюта.
7. Никита Сапунов (clcru) 06.01.17 12:56 Сейчас в теме
Таки поборол - но это конечно костыли. Виды запасов можно проставить вручную при поступлении (имею ввиду совсем в ручную - написать его в документе, нажать "создать новый" - затем отредактировать Наименование и сохранить изменения ...) - в этом случае при продаже подцепляется, и при закрытии месяца себестоимость списывается. Собственно это то, что писал в предыдущем посте, но забыл про закрытие месяца.
8. MGMGA Фымилие (MGMGA) 06.01.17 13:55 Сейчас в теме
Ещё несуразность. Если в документе относишь расход на дату отличную от даты документа, он всё равно принимается датой документа. Похоже топик можно переименовывать в "косяки релиза УТ 11.3".
9. Алексей Станиславович (Drizer2000) 13 13.01.17 10:28 Сейчас в теме
Возникла та же задача, нужно было вести учет себестоимости в разрезе поставщиков. В типовой 11.3.2.157, нормально вести не получится, придется использовать совет, который дали выше в (7) для документа Поступление товаров, если же вам нужно вести начальные остатки документом "Ввод начальных остатков", то и это не получится. Для исправления ситуации придется править типовую. Код где решается будет поставщик или нет для видов запасов находится
в модуле менеджера справочника "виды запасов" в функции: СтруктураВидаЗапасов. Обрезанный код примерно такой.
СтруктураВидЗапасов.Поставщик = Неопределено;
Если ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПриемНаКомиссию
         ИЛИ ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ВозвратТоваровКомитенту
         ИЛИ ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПередачаНаКомиссиюВДругуюОрганизацию
         ИЛИ РеквизитыДокумента.ТипЗапасов = Перечисления.ТипыЗапасов.КомиссионныйТовар Тогда
            СтруктураВидЗапасов.Поставщик = РеквизитыДокумента.Поставщик;
Иначе
КонецЕсли;
...Показать Скрыть

Сами видете,что поставщик появится только при комиссионной торговли. Даже в справочнике "виды запасов" в комментарии для реквизита поставщик написано:
"Комитент, от которого получен товар. Заполняется только для типа запасов "Комиссионный товар". "
Так что пока не понятно, ошибка это разрабов или целенаправленный уход от ведения учета себестоимости по поставщикам для собственных товаров. Я надеюсь,что все-таки ошибка. Для себе я код подправил, теперь работает как раньше,перевыбираешь Поставщика или организацию, вид запасов обнуляется и после проведения подставляется "Собственный товар\Поставщик".
10. Никита Сапунов (clcru) 14.02.17 18:11 Сейчас в теме
(9) можно попросить Вас скинуть код, чтобы вставить и поправить конфигурацию. Собственных знаний, к сожалению, не хватает.

Также заметил, что с моими костылями - не проводится документа "Возврат товаров поставщику" - даже если проставлять виды запасов вручную. У Вас проводится?
11. Никита Сапунов (clcru) 14.02.17 18:24 Сейчас в теме
Прошу прощения за беспокойство - вот код, на место указанного в (9)
Если РеквизитыДокумента <> Неопределено Тогда
		
		Если ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПриемНаКомиссию
		 ИЛИ ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ВозвратТоваровКомитенту
		 ИЛИ ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПередачаНаКомиссиюВДругуюОрганизацию
		 ИЛИ РеквизитыДокумента.ТипЗапасов = Перечисления.ТипыЗапасов.КомиссионныйТовар Тогда
			СтруктураВидЗапасов.ТипЗапасов = Перечисления.ТипыЗапасов.КомиссионныйТовар;
			СтруктураВидЗапасов.Комитент = РеквизитыДокумента.Поставщик;
			СтруктураВидЗапасов.Контрагент = ?(ЗначениеЗаполнено(РеквизитыДокумента.Контрагент), РеквизитыДокумента.Контрагент, Неопределено);
			СтруктураВидЗапасов.Соглашение = ?(ЗначениеЗаполнено(РеквизитыДокумента.Соглашение), РеквизитыДокумента.Соглашение, Справочники.СоглашенияСПоставщиками.ПустаяСсылка());
			СтруктураВидЗапасов.Договор = ?(ЗначениеЗаполнено(РеквизитыДокумента.Договор), РеквизитыДокумента.Договор, Справочники.ДоговорыКонтрагентов.ПустаяСсылка());
			СтруктураВидЗапасов.Валюта = РеквизитыДокумента.Валюта;
			СтруктураВидЗапасов.НалогообложениеНДС = РеквизитыДокумента.НалогообложениеНДС;
			СтруктураВидЗапасов.Поставщик = РеквизитыДокумента.Поставщик;
		Иначе
			Если ЗначениеЗаполнено(РеквизитыДокумента.ТипЗапасов) Тогда
				СтруктураВидЗапасов.ТипЗапасов = РеквизитыДокумента.ТипЗапасов;
			Иначе
				СтруктураВидЗапасов.ТипЗапасов = Перечисления.ТипыЗапасов.Товар;
			КонецЕсли;
			Если ПолучитьФункциональнуюОпцию("ФормироватьВидыЗапасовПоПоставщикам") Тогда
				СтруктураВидЗапасов.Поставщик = ?(ЗначениеЗаполнено(РеквизитыДокумента.Поставщик), РеквизитыДокумента.Поставщик, Неопределено);
			КонецЕсли;
			Если РеквизитыДокумента.НалогообложениеНДС = РеквизитыДокумента.НалогообложениеОрганизации
			 ИЛИ Не ПолучитьФункциональнуюОпцию("ИспользоватьРаздельныйУчетПоНалогообложению") Тогда
				СтруктураВидЗапасов.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПустаяСсылка();
			Иначе
				СтруктураВидЗапасов.НалогообложениеНДС = РеквизитыДокумента.НалогообложениеНДС;
			КонецЕсли;
		КонецЕсли;
		
		СтруктураВидЗапасов.ГруппаФинансовогоУчета = РеквизитыДокумента.ГруппаФинансовогоУчета;
		
		Если ЗначениеЗаполнено(РеквизитыДокумента.Назначение) Тогда
			СтруктураВидЗапасов.Назначение = РеквизитыДокумента.Назначение;
			СтруктураВидЗапасов.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляЗаказа;
			СтруктураВидЗапасов.АналитикаПредназначения = РеквизитыДокумента.Назначение;
			
		ИначеЕсли (РеквизитыДокумента.ОбособленныйУчетТоваровПоСделке
		 И ПолучитьФункциональнуюОпцию("ФормироватьВидыЗапасовПоСделкам"))
		 ИЛИ РеквизитыДокумента.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляСделки Тогда
			СтруктураВидЗапасов.Сделка = РеквизитыДокумента.Сделка;
			СтруктураВидЗапасов.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляСделки;
			СтруктураВидЗапасов.АналитикаПредназначения = РеквизитыДокумента.Сделка;
			
		ИначеЕсли (РеквизитыДокумента.ВариантОбособленногоУчетаТоваров = Перечисления.ВариантыОбособленногоУчетаТоваров.ПоМенеджерамПодразделения
		 И ПолучитьФункциональнуюОпцию("ФормироватьВидыЗапасовПоПодразделениямМенеджерам"))
		 ИЛИ РеквизитыДокумента.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляМенеджера Тогда
			СтруктураВидЗапасов.Менеджер = РеквизитыДокумента.Менеджер;
			СтруктураВидЗапасов.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляМенеджера;
			СтруктураВидЗапасов.АналитикаПредназначения = РеквизитыДокумента.Менеджер;
			
		ИначеЕсли (РеквизитыДокумента.ВариантОбособленногоУчетаТоваров = Перечисления.ВариантыОбособленногоУчетаТоваров.ПоПодразделению
		 И ПолучитьФункциональнуюОпцию("ФормироватьВидыЗапасовПоПодразделениямМенеджерам"))
		 ИЛИ РеквизитыДокумента.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляПодразделения Тогда
			СтруктураВидЗапасов.Подразделение = РеквизитыДокумента.Подразделение;
			СтруктураВидЗапасов.Предназначение = Перечисления.ТипыПредназначенияВидовЗапасов.ПредназначенДляПодразделения;
			СтруктураВидЗапасов.АналитикаПредназначения = РеквизитыДокумента.Подразделение;
		
		КонецЕсли;
				
	КонецЕсли;
	
	Возврат СтруктураВидЗапасов;
...Показать Скрыть


С такой правкой возврат поставщику проводится как должно.
12. MGMGA Фымилие (MGMGA) 14.02.17 19:06 Сейчас в теме
(11) Вы б этот код в техподдержку одинэс сбросили, а то у них ни получаеца.
13. Алексей Станиславович (Drizer2000) 13 14.02.17 23:09 Сейчас в теме
(11) Ну вот зря прибеднялись, вам вполне хватило знаний разобраться. Смотрел новые обновления, в описании которых, было написано,что исправлено много очевидных ошибок, к сожалению, эту ошибку они не посчитали очевидной, так и не исправили. Может они вообще не считают это ошибкой. Может кто напишет в поддержку 1с, интересно что они ответят.
14. MGMGA Фымилие (MGMGA) 14.02.17 23:40 Сейчас в теме
(13) + Присоединяюсь. Сам бы написал, но у меня ИТС Техно. Больше 1 обращения в месяц не принимают, что и выдаю. Ещё года на три обращений в запасе :)
15. MiB (MiB) 01.03.17 12:21 Сейчас в теме
Ваще шляпа какая то. Рентабельность вообще не считается. Перепровел доки стало подставляться туда же еще и 18% ндс...
16. Дмитрий Долгополов (strannik.dj) 17.04.17 09:22 Сейчас в теме
(11) А ошибка 00-00102096 (https://bugboard.v8.1c.ru/error/000024582.html) это не про данную проблему? или предложенное там исправление годиться только для ERP ?
17. MGMGA Фымилие (MGMGA) 17.04.17 12:44 Сейчас в теме
(16) Возможно.
Зарегистрирована: 06.12.2016
Оставьте свое сообщение