Загрузка данных из табличного документа в справочники, документы, в движения документов, поточная загрузка документов (EXCEL, управляемые формы, универсальная)

0. Павел Алексеенко (qwinter) 505 29.05.14 13:32 Сейчас в теме
Обладает уникальным функционалом. Позволяет загружать в справочники, табличные части, регистры сведения, движения документа, поточно загружать документы, а также одновременно загружать в справочники, являющиеся реквизитами загружаемых объектов, с полноценной настройкой. Обработка на управляемых формах, работает на всех версиях 1С предприятия 8.2 и 8.3

Перейти к публикации

Комментарии
1. Артём Рогов (ben_art) 12 30.05.14 13:15 Сейчас в теме
Зачем же плодить одно и тоже , хоть бы кто сделал возможность сохранения и восстановления настроек настроек ?
2. Артём Рогов (ben_art) 12 30.05.14 13:36 Сейчас в теме
Хотя то что получает ссылку на документ сама . уже хорошо. Но придётся допиливать.
3. Павел Алексеенко (qwinter) 505 30.05.14 13:38 Сейчас в теме
(2) ben_art, так оно там и так есть? или нужно конкретно, что бы в базе сохранялись настройки?
4. Артём Рогов (ben_art) 12 30.05.14 13:42 Сейчас в теме
(3) qwinter, Уже разобрался прошу прощения за первый коммент , меня смутила запись о не возможности сохранения настроек , а она оказывается есть и в список и в файл )
5. Яков Коган (Yashazz) 2092 03.06.14 16:14 Сейчас в теме
Баян. Автор, как насчёт загрузки картинок, работы с объединёнными ячейками, формулами, иерархией строк? Как насчёт скрытых разным образом строк?
6. Павел Алексеенко (qwinter) 505 03.06.14 16:30 Сейчас в теме
(5) Yashazz, может вам еще ключи от квартиры где деньги лежат?
7. hzhz hzhz (hzhz) 12 06.06.14 10:13 Сейчас в теме
После загрузки сохраненных настроек, поля ВИД ДОКУМЕНТА и ТАБЛИЧНАЯ ЧАСТЬ не устанавливаются из настроек.(у себя исправил)
8. Павел Алексеенко (qwinter) 505 06.06.14 11:35 Сейчас в теме
(7) hzhz, исправил, спасибо за замечание)
9. марина иванова (marinasnsd) 10.06.14 17:20 Сейчас в теме
Уважаемый qwinter!
Можно ли с помощью вашей обработки формировать номенклатуру с характеристиками с определенными свойствами (все свойства характеристики номенклатуры задаются в соответствующих полях файла загрузки)?
10. Павел Алексеенко (qwinter) 505 10.06.14 17:53 Сейчас в теме
(9) marinasnsd, с помощью этой обработки настроить загрузку номенклатуры сразу с характеристиками, можно только зная программирование 1С (так как например в УТ11 характеристики это отдельный справочник).
11. Артём Рогов (ben_art) 12 16.06.14 16:36 Сейчас в теме
Подскажите пожалуйста как восстанавливать параметры при открытии формы ?
12. Павел Алексеенко (qwinter) 505 16.06.14 20:20 Сейчас в теме
(11) ben_art, не совсем понял, что вы именно хотите?
13. Артём Рогов (ben_art) 12 16.06.14 20:33 Сейчас в теме
Ну в 8.2 на обычных формах , настройки сохранялись с возможностью восстанавливать их при открытии формы. чтоб не нажимать кнопку "восстановить настройки" а они сами востанавливались
14. Павел Алексеенко (qwinter) 505 16.06.14 21:04 Сейчас в теме
(13) ben_art, для управляемых форм такого в пользовательском интерфейсе нет. Откройте обработку в конфигураторе, и в свойствах формы поставьте: автоматически сохранять значения.
15. Артём Рогов (ben_art) 12 16.06.14 21:09 Сейчас в теме
да с этим понятно , я знаю что сохранение и восстановление происходит только в форме на клиенте (не как в 8.2) , вот и спрашиваю может есть способы вызывать команду восстановления без нажатия кнопки. (
16. Павел Алексеенко (qwinter) 505 16.06.14 21:18 Сейчас в теме
(15) ben_art, чтобы была кнопка восстанавливать автоматически или нет? Можно сделать реквизит, и при открытии присваивать его свойству формы.
17. Павел Алексеенко (qwinter) 505 18.06.14 15:51 Сейчас в теме
(9) marinasnsd, а вот теперь можно)))
18. Павел Алексеенко (qwinter) 505 19.06.14 16:09 Сейчас в теме
(15) ben_art, добавил и такую возможность)))
19. Артём Рогов (ben_art) 12 19.06.14 16:52 Сейчас в теме
Ого , спасибо огроменное )
20. Артём Рогов (ben_art) 12 20.06.14 12:38 Сейчас в теме
только теперь ещё и ссылку на объект сохраняет , а надо чтоб был тот из которого вызвана
21. Павел Алексеенко (qwinter) 505 20.06.14 14:27 Сейчас в теме
22. Павел Алексеенко (qwinter) 505 20.06.14 14:38 Сейчас в теме
(20) ben_art, в процедуре ВосстановитьНастройкиИзСостоянияВыполнения
	ТипОбъектаСправочника	= Неопределено;
	СсылкаИсточника			= Неопределено;
	ИмяВидаРегистра			= Неопределено;
	ТабличнаяЧастьИсточника	= Неопределено;
	СсылкаДокумента 		= Неопределено;
	РегистрДокумента		= Неопределено;
	
	ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);	
	ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);
	
	ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);	
	УстановитьИсточник();	
	
	ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);
...Показать Скрыть

заменить, на:
	ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);	
	ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
	ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);
	
	Если НЕ ВыполняетсяЗаполнениеТЧОбъекта Тогда
		ТипОбъектаСправочника	= Неопределено;
		СсылкаИсточника			= Неопределено;
		ИмяВидаРегистра			= Неопределено;
		ТабличнаяЧастьИсточника	= Неопределено;
		СсылкаДокумента 		= Неопределено;
		РегистрДокумента		= Неопределено;
		
		ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);	
		УстановитьИсточник();	
		ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);
		ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
	КонецЕсли;
...Показать Скрыть


обработку, обновил.
23. Артём Рогов (ben_art) 12 20.06.14 15:13 Сейчас в теме
(22) qwinter, Спасибо заработало )))
24. Сергей Сергеевич (onyx) 20 23.06.14 18:15 Сейчас в теме
В модуле формы (Строка 894) ошибка:
Если ОбъектНайден  Тогда

25. Павел Алексеенко (qwinter) 505 23.06.14 18:52 Сейчас в теме
(24) onyx, я так понял, это по поводу обновления данных найденных элементов справочников? Это поведение стандартной типовой загрузки, а не ошибка, она не обновляет данные. Как показали вы, ни в коем случае нельзя делать. Это нарушит логику загрузок всего остального, кроме справочников.
Если вы хотите обновлять данные справочников, то надо чуть выше после:
		Если РежимЗагрузки = 0 Тогда
			
			ЗагружаемыйОбъект = Неопределено;
			Если Не Запрос = Неопределено Тогда
				СтрокаОшибок = "";
				Для каждого СтрокаПоиска Из СтрокиПоиска Цикл
					
					ЗначениеРеквизита = Неопределено;
					
					ТекущаяСтрока.Свойство(СтрокаПоиска.ИмяРеквизита,ЗначениеРеквизита);
					Если ПустаяСтрока(ЗначениеРеквизита) Тогда
						СтрокаОшибок = ?(ПустаяСтрока(СтрокаОшибок),"",СтрокаОшибок + ", ") + СтрокаПоиска.ПредставлениеРеквизита;
					Иначе
						Запрос.УстановитьПараметр(СтрокаПоиска.ИмяРеквизита,ТекущаяСтрока[СтрокаПоиска.ИмяРеквизита]);
					КонецЕсли;
					
				КонецЦикла;
				
				Если Не ПустаяСтрока(СтрокаОшибок) Тогда
					Сообщить("Строка " + НомерТекущейСтроки + " не может быть записана.Не указано значение ключевых реквизитов: " + СтрокаОшибок,СтатусСообщения.Важное);
					Продолжить;
				КонецЕсли;
				
				Выборка = Запрос.Выполнить().Выбрать();
				Если Выборка.Следующий() Тогда
					ЗагружаемыйОбъект = Выборка.Ссылка.ПолучитьОбъект();
				КонецЕсли;
				
			КонецЕсли;
			
			ОбъектНайден = Не ЗагружаемыйОбъект = Неопределено;
			Если Не ОбъектНайден Тогда
				Если НеСоздаватьНовыхЭлементов Тогда
					Продолжить;
				Иначе
					ЗагружаемыйОбъект = Справочники[МетаданныеИсточника.Имя].СоздатьЭлемент();
				КонецЕсли;
				
			КонецЕсли;
...Показать Скрыть
добавить:
			Если ОбъектНайден и ЗамещатьСуществующиеЗаписи Тогда 	
				ОбъектНайден = Ложь;
			КонецЕсли;

То же самое сделать в процедуре: ЗагрузитьПодчиненныеСправочники
И воспользоваться соответствующей настройкой
26. НЕ ЗНАЮ (NE_ZNAIY) 23.06.14 19:25 Сейчас в теме
qwinter (Павел) могли бы вы дать ваши контактные данные (почта) для связи?
мой kidus@yandex.ru
27. Константин Купрюхин (BlackStar) 02.07.14 10:27 Сейчас в теме
Отличная обработка! Спасибо!
28. Кирилл Раковский (RakovskiyK) 22.07.14 14:05 Сейчас в теме
Отличная обработка! Спасибо, большое.
Не смотря на то, что я использовал ее в самописной конфигурации и пришлось чуть-чуть допилить - работает идеально. Позволила сэкономить действительно много времени на ввод первичной информации.
Автору респект и плюс в карму!
29. Павел Алексеенко (qwinter) 505 22.07.14 14:44 Сейчас в теме
(28) RakovskiyK, а что если не секрет допиливали? Она вроде должна и так работать в самописных конфигурациях.
30. Сергей Иванов (xten) 38 29.07.14 22:29 Сейчас в теме
Подскажите, пожалуйста, возможно ли с помощью Вашей обработки выгрузить данные из таблицы Excel (6-10 столбцов )в документ Взаимозачеты задолженности в УТ 11. Позволяет ли Ваша обработка непосредственно после загрузки в табличную часть обработки данных из excel выбрать нужный документ и загрузить туда предварительно отображенные данные ? Спасибо.
31. Павел Алексеенко (qwinter) 505 29.07.14 22:55 Сейчас в теме
(30) xten, Вы немного сумбурно построили вопрос, и я немного его не понимаю. Вам требуется после открытия документа эксель и получения дынных выбрать друго отличный от первоначального документ? Обработка работает по принципу, Вы выбираете документ (принадобности табличную часть или движение по регистру) и настраиваете загрузку, потом открываете документ эксель, и затем загружаете данные.
32. Сергей Иванов (xten) 38 30.07.14 10:15 Сейчас в теме
Извиняюсь, возможно некоректно вопрос поставил, два дня только с УТ 11 работаю )) Значит, как я понимаю, органичений по конкретному типу документов нет? Загружаить из ексель можно в табличную часть любого документа?
33. Павел Алексеенко (qwinter) 505 30.07.14 10:20 Сейчас в теме
(32) xten, Вы все поняли правильно, нет никаких ограничений, можно загружать в любую табличную часть, любого документа или справочника.
34. Сергей Иванов (xten) 38 30.07.14 11:28 Сейчас в теме
Супер, ОГРОМНОЕ СПАСИБО ВАМ !!! )))
35. Ivan B (wolverine87) 04.08.14 16:31 Сейчас в теме
Отличная обработка! Спасибо!
36. Ерофеев Юрий (luic) 25.08.14 12:51 Сейчас в теме
37. Гость 31.08.14 22:32 Сейчас в теме
У меня версия:

1С:Предприятие 8.2 (8.2.17.153)
Управление торговлей, редакция 10.3.13.2 (10.3.13.2.2)

При открытие файла ЗагрузкаДанныхИзТабличногоДокумента_Q(Управляемые формы).epf
выдает ошибку:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента_УФ.МодульОбъекта(40,21)}: Переменная не определена (СтроковыеФункцииКлиентСервер)
ВызватьИсключение <<?>>СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(

Подскажите, что не так.
38. Павел Алексеенко (qwinter) 505 01.09.14 13:24 Сейчас в теме
(37) Гость, замените:
ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ЭлементОписаниеКоманды.Представление);

на
Выполнить("ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ТекстСообщения, ЭлементОписаниеКоманды.Представление);");

И
ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтрока,
			КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));

на
Выполнить("	ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтрока,
					|	КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));");
39. Oleg Ya (yaguarrr) 69 18.09.14 09:15 Сейчас в теме
При загрузке в ПТУ (либо регистр сведений Штрихкоды НМКЛ), поиск по характеристикам общим для вида номенклатуры не идет по наименованию для вида номенклатуры. А так обработка очень хорошая, съэкономила достаточно личного времени
40. Павел Алексеенко (qwinter) 505 18.09.14 10:35 Сейчас в теме
(39) yaguarrr, немного подправил обработку. Теперь такую настройку можно сделать, вот таким образом:
Устанавливаете режим загрузки: Загрузка в регистр сведений. Затем добавляете справочник: Виды номенклатуры, настраиваете загрузку их. Затем добавляете справочник: Характеристики номенклатуры, и в нем в поле владелец ставите устанавливать по настройке Вид номенклатуры и настраиваете поиск по требуемым элементам. А затем в настройке загрузки в регистр в поле характеристики ставите устанавливать по настройке Характеристики номенклатуры.
41. Oleg Ya (yaguarrr) 69 18.09.14 11:46 Сейчас в теме
(40) qwinter,
Все взлетело - и для регистра сведений и для документа ПТУ, полет нормальный. Благодарю за сверхоперативность.
Неплохо бы добавить данный пример в описание обработки, не каждый сам с первого раза сделает
42. Денис Сидельников (dvsidelnikov) 3 27.09.14 22:23 Сейчас в теме
Автор выручай ;)

Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.51.1)

При открытии говорит:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента_УФ.МодульОбъекта(40,21)}: Переменная не определена (СтроковыеФункцииКлиентСервер)
ВызватьИсключение <<?>>СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
43. Денис Сидельников (dvsidelnikov) 3 28.09.14 08:08 Сейчас в теме
Люди добрые, подскажите, а как бы заставить обработку не вставлять строку в табличную часть документа, если не было найдено значение в справочнике 1С по коду для одного из полей текущей строки табличного документа

Допустим: бежит обработка по табличному документу, считывает значение артикула из табличного документа, пытается найти номенклатуру в 1С по данному артикулу, не находит и как следствие не создаёт строку в вводе остатков, плавно переходя к обработке следующей строки табличного документа.
44. Павел Алексеенко (qwinter) 505 28.09.14 13:34 Сейчас в теме
(42) dvsidelnikov, чуть выше уже было описано, как исправить. Запихните код в оператор Выполнить.
dvsidelnikov; +1 Ответить
45. Павел Алексеенко (qwinter) 505 28.09.14 13:46 Сейчас в теме
(43) dvsidelnikov, в событии "После добавления строки":
Если не ЗначениеЗаполнено(ТекущиеДанные.РеквизитСтроки) Тогда
 Объект.ТЗ.Удалить(ТекущиеДанные);
КонецЕсли;
plus1s_a; dvsidelnikov; +2 Ответить
46. Евгений Кузнецов (zzzhen) 14 01.10.14 12:24 Сейчас в теме
Здравствуйте!
При нажатии "Загрузить"
Конфигурация "Розница", платформа 8.3
Сообщение - "Использование модальных окон в данном режиме запрещено"
что делать?
спасибо
47. Павел Алексеенко (qwinter) 505 01.10.14 15:14 Сейчас в теме
(46) zzzhen,
Всю процедуру "КомандаЗагрузить" заменить на:
&НаКлиенте
Процедура КомандаЗагрузить(Команда)
	
	СтруктураТекстВопроса = ПолучитьТекстВопросаИсточника();
	КоличествоЭлементов = ТаблицаПодготовленныхДанных.Количество();
	
	Если НЕ ПустаяСтрока(СтруктураТекстВопроса.Ошибка) Тогда
		
		ТекстПредупреждения = СтруктураТекстВопроса.Ошибка;
		
		Если ВерсияПлатформы83 Тогда
			Выполнить("
			|	ПоказатьПредупреждение(, ТекстПредупреждения);
		    |");
		Иначе
				Предупреждение(ТекстПредупреждения);
		КонецЕсли;
			
	Иначе
		
		нПараметры = Новый Структура;	
		ТекстВопроса = "Загрузить "+КоличествоЭлементов  + СтруктураТекстВопроса.ТекстВопроса;
		Если ВерсияПлатформы83 Тогда
			Выполнить("
			|	ОписаниеОповещения = Новый ОписаниеОповещения(""ВопросНачатьЗагрузкуДанных"", ЭтотОбъект, нПараметры);
			|	ПоказатьВопрос(ОписаниеОповещения, ТекстВопроса, РежимДиалогаВопрос.ДаНет, 60);
			|");
		Иначе
			ОтветНаВопрос = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);
			ВопросНачатьЗагрузкуДанных(ОтветНаВопрос, нПараметры);
		КонецЕсли;
			
	КонецЕсли;	
		
КонецПроцедуры

&НаКлиенте
Процедура ВопросНачатьЗагрузкуДанных(РезультатВопроса, ДополнительныеПараметры) Экспорт
	
	Если РезультатВопроса = КодВозвратаДиалога.Да Тогда 
		ОчиститьСообщения();
		ЗагрузитьДанныеСервер();
		
		Если ВыполняетсяЗаполнениеТЧОбъекта Тогда
			ПараметрыКоманды = Новый Структура("ДополнительнаяОбработкаСсылка, ОбъектыНазначения, СопровождающийТекст");
			ПараметрыКоманды.ДополнительнаяОбработкаСсылка = ОбъектСсылка;
			ПараметрыКоманды.СопровождающийТекст = "";
			
			Состояние(ПараметрыКоманды.СопровождающийТекст);
			
			РезультатВыполнения = ВыполнитьКомандуНапрямую(ИдентификаторКоманды, ПараметрыКоманды);
			ЗагрузитьРезультат(РезультатВыполнения);	
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть
48. Mark Tven (MarkTven) 05.10.14 14:25 Сейчас в теме
в УТ для Украины редакция 3
не работает регистрация обработки в базе:
{Форма.Форма.Форма(4652)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода
Выполнить("
по причине:
{(2,95)}: Переменная не определена (ЭтотОбъект)
ОписаниеОповещения = Новый ОписаниеОповещения("ЗарегистрироватьвИБПослеПомещенияВХранилище", <<?>>ЭтотОбъект);
49. Денис Сидельников (dvsidelnikov) 3 24.10.14 13:25 Сейчас в теме
Люди добрые, а загрузка в табличную часть справочника имеет место быть? что-то я не нашёл.
50. Павел Алексеенко (qwinter) 505 24.10.14 13:32 Сейчас в теме
(49) dvsidelnikov, в режиме "Поточная загрузка".
dvsidelnikov; +1 Ответить
51. Анастасия Азарова (an.azarova) 4 06.11.14 12:36 Сейчас в теме
Работало, после обновления сломалась :(
52. Павел Алексеенко (qwinter) 505 06.11.14 12:53 Сейчас в теме
(51) an.azarova, здравсвуйте. Какую ошибку пишет? Какая конфигурация?
53. Анастасия Азарова (an.azarova) 4 06.11.14 18:00 Сейчас в теме
{Форма.Форма.Форма(473)}: Значение не является значением объектного типа (Свойство)
СостояниеВыполнения.Свойство("ТекущаяВерсия", ВосстановленнаяТекущаяВерсия);
УНФ 1,5,20
54. Павел Алексеенко (qwinter) 505 06.11.14 20:31 Сейчас в теме
(53) an.azarova, у меня не воспроизводится. Что именно произошло когда перестало работать? У Вас, что то произошло с сохраненными настройками.
Как вариант замените:
	ВосстановленнаяТекущаяВерсия = Неопределено;
	СостояниеВыполнения.Свойство("ТекущаяВерсия", ВосстановленнаяТекущаяВерсия);

на:
	Если ТипЗнч(СостояниеВыполнения) <> Тип("Структура") Тогда 
		Возврат;
	КонецЕсли;
	
	ВосстановленнаяТекущаяВерсия = Неопределено;
	СостояниеВыполнения.Свойство("ТекущаяВерсия", ВосстановленнаяТекущаяВерсия);
...Показать Скрыть
55. Анастасия Азарова (an.azarova) 4 07.11.14 16:09 Сейчас в теме
56. Петр Яковлев (plus1s_a) 17.11.14 10:12 Сейчас в теме
Скачал. Попробую на ERP 2.0 при подготовке НСИ базы.
57. Павел Бодунов (BodunOff) 24.11.14 17:26 Сейчас в теме
Павел, прошу прощения за вопрос дилетанта, не могу разобраться с настройкой. Задача такая, есть дополнительные реквизиты вида номенклатуры "Для характеристик" (например, Размер и Цвет) со списком значений. Имеется ли возможность данной обработкой произвести сопоставление при загрузке характеристик с уже имеющимися в списке значением? Пробую пакетную загрузку характеристик, выбираю ТЧ Дополнительные реквизиты и получаю ошибку на выходе:
{Форма.Форма.Форма(2162)}: Поле объекта не обнаружено (Дополнительные значения)


Буду очень признателен за помощь!

P.S. Сорри за такое отображение кода, не могу понять что это, оригинал вот:
{Форма.Форма.Форма(2162)}: Поле объекта не обнаружено (Дополнительные значения)
58. Павел Алексеенко (qwinter) 505 24.11.14 21:08 Сейчас в теме
(57) BodunOff, а какая конфигурация? Ошибка происходит сразу после выбора ТЧ? Я попробовал в УТ 11.1 у меня все грузится.

Принцип работы Вами выбран правильно. Выбираете поточную загрузку справочника, добавляете табличную часть. Не забывайте по возможности ограничивать типы получаемых значений, например в УТ11 в реквизит Значение в табличной части "дополнительные реквизиты" имеет очень много типов, лучше ограничить его до одного нужного.
59. Павел Бодунов (BodunOff) 24.11.14 22:10 Сейчас в теме
Конфигурация УТ 11.1.9.56. Ошибка происходит на этапе проверки внесенных данных. Выбираю следующие значения, см. скрины.


Прикрепленные файлы:
60. Павел Бодунов (BodunOff) 24.11.14 22:44 Сейчас в теме
...например в УТ11 в реквизит Значение в табличной части "дополнительные реквизиты" имеет очень много типов, лучше ограничить его до одного нужного...

Так и выбираю один тип "Дополнительное значение" чтобы оно к табличной части пробилось
61. Павел Алексеенко (qwinter) 505 26.11.14 21:47 Сейчас в теме
(60) BodunOff, это ошибка в функции: "ПолучитьВозможныеЗначения":
замените:
				Если ЭтоСправочник  И ТипЗнч(Справочники[Строка(МетаданныеТипа)].ПустаяСсылка()[ИскатьПо]) = Тип("Число") Тогда
					Попытка
						Представление = Число(Представление);	
					Исключение
						//ОписаниеОшибки()
					КонецПопытки;
				КонецЕсли;
...Показать Скрыть
на
				Если ЭтоСправочник  Тогда
					Если ТипЗнч(Справочники[Строка(МетаданныеТипа.Имя)].ПустаяСсылка()[ИскатьПо]) = Тип("Число") Тогда
						Попытка
							Представление = Число(Представление);	
						Исключение
							//ОписаниеОшибки()
						КонецПопытки;
					КонецЕсли;
				КонецЕсли;
...Показать Скрыть

или скачайте обновленный файл.
62. Павел Алексеенко (qwinter) 505 26.11.14 21:51 Сейчас в теме
(60) BodunOff, однако для загрузки дополнительных значений, надо еще создать дополнительную настройку для справочника "Дополнительные значения" и установить ее как используемую для значения дополнительных значений. Пример во вложении.
Прикрепленные файлы:
Характеристика.qxlz
63. Павел Бодунов (BodunOff) 26.11.14 22:19 Сейчас в теме
Спасибо огромное! Всё получилось как надо!!! Если бы можно было поставить ещё пару звёзд они все были бы ваши, я искал эту обработку с момента перехода на управляемые формы)))
64. Гость 03.12.14 14:18 Сейчас в теме
БГУ 8.2
обработка не запускается
65. Павел Алексеенко (qwinter) 505 03.12.14 15:30 Сейчас в теме
(64) Гость, откройте БГУ в режиме "управляемое приложение".
66. Гость 04.12.14 15:26 Сейчас в теме
(65) qwinter, Спасибо открылась , но теперь при загрузке таблицы данных дает ошибку (в прикрепл.файле) БГУ 8.2.18.96 Конфигурация 1.0.25.9
Прикрепленные файлы:
ошибка.doc
67. Павел Алексеенко (qwinter) 505 04.12.14 15:45 Сейчас в теме
(66) Гость, ошибку исправил, скачайте обновленную обработку, или в модуле формы:
			Если ЭтоДокумент Тогда
			ТекстЗапроса =
				"Выбрать Первые 1
				|Объект.Ссылка КАК Ссылка
				|Из Документ."+МетаданныеИсточника.Имя+" КАК Документ
				|Где";
...Показать Скрыть
заменить на:
			Если ЭтоДокумент Тогда
			ТекстЗапроса =
				"Выбрать Первые 1
				|Объект.Ссылка КАК Ссылка
				|Из Документ."+МетаданныеИсточника.Имя+" КАК Объект
				|Где";
...Показать Скрыть
68. Павел Бодунов (BodunOff) 06.12.14 14:16 Сейчас в теме
Павел, возникла проблема загрузки характеристик номенклатуры (с доп. реквизитами) в одну из баз УТ 11. Не могу ни объяснить толком ни отловить самостоятельно ошибку. По-возможности напишите мне в скайп pavel.bodunov в любое удобное для Вас время для настройки на возмездной основе.
69. Anatoliy REESST (NOVOPRO) 11.12.14 07:35 Сейчас в теме
Д.д.
Ну выполнил нижеуказанную процедуру, как до этого не работало так и сейчас не работает:

в процедуре ВосстановитьНастройкиИзСостоянияВыполнения
ТипОбъектаСправочника = Неопределено;
СсылкаИсточника = Неопределено;
ИмяВидаРегистра = Неопределено;
ТабличнаяЧастьИсточника = Неопределено;
СсылкаДокумента = Неопределено;
РегистрДокумента = Неопределено;

ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);

ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);
УстановитьИсточник();

ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);

...Показать
заменить, на:
ВостановитьТаблицуИзСоответствия("ЗамещатьСуществующиеЗаписи", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("НеСоздаватьНовыхЭлементов", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РучнаяНумерацияКолонокТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПерваяСтрокаДанныхТабличногоДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПередЗаписьюОбъекта", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПослеДобавленияСтроки", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ПриЗаписиОбъекта", СостояниеВыполнения);

Если НЕ ВыполняетсяЗаполнениеТЧОбъекта Тогда
ТипОбъектаСправочника = Неопределено;
СсылкаИсточника = Неопределено;
ИмяВидаРегистра = Неопределено;
ТабличнаяЧастьИсточника = Неопределено;
СсылкаДокумента = Неопределено;
РегистрДокумента = Неопределено;

ВостановитьТаблицуИзСоответствия("РежимЗагрузки", СостояниеВыполнения);
УстановитьИсточник();
ВостановитьТаблицуИзСоответствия("СсылкаДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("СсылкаИсточника", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ИмяВидаРегистра", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("РегистрДокумента", СостояниеВыполнения);
ВостановитьТаблицуИзСоответствия("ТипОбъектаСправочника", СостояниеВыполнения);
КонецЕсли;

70. Павел Алексеенко (qwinter) 505 11.12.14 09:39 Сейчас в теме
Ну выполнил нижеуказанную процедуру, как до этого не работало так и сейчас не работает:
не работает что?
71. владимир лобанов (rez222) 03.01.15 09:23 Сейчас в теме

Добрый день,

1С:Предприятие 8.3 (8.3.5.1231)
Управление торговлей, редакция 11.1 (11.1.9.44)

пытаюсь загрузить реквизиты как дополнительные значения. Во вложении настройки.
Во время загрузки получаю ошибку, хотя предварительная загрузка в таблицу данных проходит успешно
{Форма.Форма.Форма(1570)}: Значение не является значением объектного типа (Ссылка)
Возврат ЗагружаемыйОбъект.Ссылка;

Не могу понять - это я что-то делаю неверно?

Спасибо.
Прикрепленные файлы:
дп.qxlz
72. Павел Алексеенко (qwinter) 505 03.01.15 13:56 Сейчас в теме
(71) rez222, ошибка на последней версии воспроизводится?
73. владимир лобанов (rez222) 03.01.15 20:43 Сейчас в теме
Разобрался. Дело было в используемой версии обработки.
Павел, спасибо!


Возник другой вопрос -

возможно ли настроить загрузку начальных остатков по контрагентам в табличную часть по типу расчетного документа - договор, счет, реализация и т.п.с подстановкой в "номер" ссылки на документ соответсвующего типа?
74. Павел Алексеенко (qwinter) 505 04.01.15 11:25 Сейчас в теме
(73) rez222, честно говоря не понял вопроса. Опишите подробнее.
75. Влад Димов (isteroid) 01.02.15 12:53 Сейчас в теме
Обработка позволяет считать данные и произвести настройки, но при попытке загрузки данных в базу выдает ошибку:
{(2,78)} Переменная не определена (ЭтотОбъект)
помогите - бухгалтера плачут, говорят, что ждать не могут
76. Павел Алексеенко (qwinter) 505 01.02.15 15:18 Сейчас в теме
(75) isteroid, какая у вас конфигурация? Какая версия конфигурации? И какая версия платформы?
77. - - (Rebelx) 935 05.02.15 20:39 Сейчас в теме
Не получается загрузить данные :(
Ругается еще на этапе проверки заполнения

Задача - установить для номенклатуры единицы измерения.

ут10

Таблица:
Артикул Единица_Наименование

Единицы - подчинены номенклатуре, созданы
Искать - по наименованию и владельцу (<Создаваемый объект>?), который задан артикулом. Настройка такая есть, но она не работает :(((

Пока выход видимо использовать "Вычислять", но как-то это не кошерно.
78. Павел Алексеенко (qwinter) 505 07.02.15 21:06 Сейчас в теме
(75) isteroid, исправил.
(77) Rebelx, добавил в обработку функционал для подобных загрузок данных.
79. Дмитрий Донской (Litvin2015) 08.02.15 13:41 Сейчас в теме
как восстанавливать старые данные при открытии новой формы?
80. Павел Алексеенко (qwinter) 505 08.02.15 14:08 Сейчас в теме
(79) Litvin2015, какие старые данные?
81. Александр Никифоров (intersoft_1c) 10.02.15 18:46 Сейчас в теме
Как с помощью обработки создавать новые элементы справочника. Я создаю заказ поставщику. Данные в табличное поле документа все заполняются. Надо чтобы если нет номенклатуры, то номенклатура сама создавалась.
82. Павел Алексеенко (qwinter) 505 10.02.15 18:56 Сейчас в теме
(81) intersoft_1c, после настройки основной таблицы добавляете настройку загрузки номенклатуры кнопкой "Добавить справочник", а в настройке табличной части документа у номенклатуры ставите режим "Устанавливать" и в значение по умолчанию выбираете настройку загрузки "1: Номенклатура".
83. Александр Никифоров (intersoft_1c) 10.02.15 19:11 Сейчас в теме
(82) qwinter,
А как надо настраивать справочник Номенклатуру, чтобы он искал по артикулу, если не нашел, то создать номенклатуру.
84. Павел Алексеенко (qwinter) 505 10.02.15 19:16 Сейчас в теме
(83) intersoft_1c, устанавливаете в настройке номенклатуры реквизиту "Артикул" настройку что он "Поле поиска"
85. Александр Никифоров (intersoft_1c) 10.02.15 19:28 Сейчас в теме
П(84) qwinter, Поставил галочку, что он поле поиска, Режим загрузки установил Искать, указал колонку поиска. Номенклатура не ищется а в поле артикул в таблице данных в таблице 1.Номенклатура выходит просто Артикул, а в таблице Настройка Номенклатура вообще пустая
86. Павел Алексеенко (qwinter) 505 10.02.15 19:42 Сейчас в теме
(85) intersoft_1c, загрузку данных непосредственно делали? При получении таблицы данных так и должно быть.
87. Александр Никифоров (intersoft_1c) 10.02.15 21:42 Сейчас в теме
(86) qwinter,Все получилось,Спасибо. Еще вопрос. Можно сделать так, чтобы поиск по артикулу происходило только в одной группе.
88. Павел Алексеенко (qwinter) 505 10.02.15 22:07 Сейчас в теме
(87) intersoft_1c, реквизиту "Родитель" поставьте, что оно является полем поиска и режим устанавливать, и выберете требуемую группу. При не нахождении номенклатуры, новые будут создавать в этой же папке.
89. Александр Никифоров (intersoft_1c) 11.02.15 10:09 Сейчас в теме

(88) qwinter, Если так сделать, то он перестает искать по артикулу, сразу создает всю номенклатуру в этой папке.
90. Павел Алексеенко (qwinter) 505 11.02.15 14:03 Сейчас в теме
(89) intersoft_1c, а вы при этом случайно с реквизита артику поле поиска не сняли?
91. Александр Никифоров (intersoft_1c) 11.02.15 15:40 Сейчас в теме
(90) qwinter, Нет не снимал. Такая задача уже не стоит, поиск сказали нужен по всей номенклатуре. Обработка хорошая, но только нет описания по настройке.
92. Павел Алексеенко (qwinter) 505 11.02.15 20:29 Сейчас в теме
(91) intersoft_1c, сейчас даже на добавление в нее нового функционала времени особенно нет, так что описание на данный момент точно не в приоритете. Может кто то из пользователей захочет сделать такое доброе дело, думаю было бы востребовано. Можно даже сделать отдельную статью.
93. Алиса Гусейнова (alisaguzel) 13.02.15 15:54 Сейчас в теме
Прошу помощи!!! Я ни чего не могу поделать с загрузкой бух. проводок... ВидСубконто проставила. Но все равно не получается. Может делаю настройки неверно? Счета учета встают на место, сумма отображается корректно, но субконто пустое. Маюсь уже вторую неделю. Результат ноль. Буду очень признательна за помощь.
Прикрепленные файлы:
94. Павел Алексеенко (qwinter) 505 13.02.15 16:41 Сейчас в теме
(93) alisaguzel, ограничьте искомые типы (колонка "Описание типов") оставьте там только справочник номенклатуры. Режим загрузки "Искать". Если не получится то прикрепите саму настройку и пример файла.
95. Stas Bobkov (stas1kbob) 33 13.02.15 18:36 Сейчас в теме
{Форма.Форма.Форма(2066)}: Ошибка при вызове метода контекста (Область)
Для К = 1 По ТабДокумент.ШиринаТаблицы Цикл ТабДокумент.Область("R"+Формат((ПерваяСтрокаДанныхТабличногоДокумента - 1), "ЧГ=0") + "C" + Формат(К, "ЧГ=0")).Текст = "Колонка" + К КонецЦикла;
по причине:
Область не найдена: RC1
96. Павел Алексеенко (qwinter) 505 13.02.15 23:22 Сейчас в теме
(95) stas1kbob, исправил. Скачайте обновленную обработку, или обновите код процедуры "ПолучитьТаблицуДанныхНаСервере"
Процедура ПолучитьТаблицуДанныхНаСервере()
	
	СформироватьСтруктуруКолонок();
	СформироватьКолонкиТаблицыПодготовленныхДанных();
	
	ТаблицаПодготовленныхДанных.Очистить();
	
	Если ПерваяСтрокаДанныхТабличногоДокумента > ТабличныйДокумент.ВысотаТаблицы Тогда Возврат КонецЕсли;
	
	Для н = 1 По ТабличныйДокумент.ВысотаТаблицы - ПерваяСтрокаДанныхТабличногоДокумента + 1 Цикл ТаблицаПодготовленныхДанных.Добавить() КонецЦикла;
	
	Таблица = РеквизитФормыВЗначение("ТаблицаПодготовленныхДанных");
	
	ОбластьДанных = ТабличныйДокумент.ПолучитьОбласть("R" + Формат((ПерваяСтрокаДанныхТабличногоДокумента), "ЧГ=0") + "C1:R" + Формат(ТабличныйДокумент.ВысотаТаблицы, "ЧГ=0") + "C" + Формат(ТабличныйДокумент.ШиринаСтраницы, "ЧГ=0"));
		
	ТабДокумент = Новый ТабличныйДокумент;
	Для К = 1 По ТабличныйДокумент.ШиринаТаблицы Цикл ТабДокумент.Область("R1C" + Формат(К, "ЧГ=0")).Текст = "Колонка" + К КонецЦикла;
	Для Каждого Колонка Из ДополнительныеСвойства.Колонки Цикл Если Колонка.Значение.НомерКолонки <> 0 Тогда ТабДокумент.Область("R1C" + Формат(Колонка.Значение.НомерКолонки, "ЧГ=0")).Текст = Колонка.Ключ КонецЕсли КонецЦикла;
	
	ТабДокумент.Вывести(ОбластьДанных);	
		
	Построитель = Новый ПостроительЗапроса;
	Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТабДокумент.Область("R1C1:R" + Формат(ТабДокумент.ВысотаТаблицы, "ЧГ=0") + "C" + Формат(ТабДокумент.ШиринаСтраницы, "ЧГ=0")));
	ТаблицаПостроитель = Построитель.Результат.Выгрузить();
	ТаблицаПостроитель.Колонки.Вставить(0);
	
	ПоискЗагружемыхОбъектПроизведен = Ложь;
	Для Каждого Колонка Из ДополнительныеСвойства.Колонки Цикл Если НЕ Колонка.Значение.КолонкаОбработана Тогда ПолучитьКолонкуТаблицыДанных(ДополнительныеСвойства.Колонки, Колонка, Таблица, ТаблицаПостроитель, ПоискЗагружемыхОбъектПроизведен) КонецЕсли КонецЦикла;	

	Если РежимЗагрузки = 0 Тогда
		Для каждого СтрокаНастрок Из ТаблицыНастроек Цикл
			Префикс = ?(СтрокаНастрок.Значение = "ТаблицаЗагружаемыхРеквизитов", "", СтрокаНастрок.Значение);
			Колонка = ДополнительныеСвойства.Колонки[Префикс + "ОбъектЗагрузки"];		
			ПолучитьСсылкиОбъектовЗагрузкиТипаСправочник(Таблица, СтрокаНастрок.Значение, СтрокаНастрок.Справочник, Префикс);
		КонецЦикла;
	КонецЕсли;
	
	ЗначениеВРеквизитФормы(Таблица, "ТаблицаПодготовленныхДанных");
	
	Если СписокОшибок.Количество() > 0 Тогда
		Сообщить("Выявлено ячеек, содержащих ошибки/неоднозначное представление: " + СписокОшибок.Количество())
	КонецЕсли
	
КонецПроцедуры
...Показать Скрыть
97. Алиса Гусейнова (alisaguzel) 16.02.15 13:59 Сейчас в теме
(94) qwinter, Здравствуйте. Я сохранила файл настроек. Пршу посмотреть. Это один из вариантов. Эксперементировала много, меняла режимы загрузки. Речь идет о потоковой загрузке документов. (Операция). Дт 41.1 Субконто - КТ 60.01 Субконто, Содержание, Сумма. Документы создаются с космической скоростью, все точно и верно, суммы встают наместо, счета бухгалтерского учета, все верно. Но субконто пустое.... Очень признательна если поможите. Низкий поклон.
Прикрепленные файлы:
настройка 1.qxlz
98. Павел Алексеенко (qwinter) 505 16.02.15 21:28 Сейчас в теме
(97) alisaguzel, ваша ошибка, что Вы не выбрали по чему искать выбранные вами субконто (выбирается в представлении дополнительных условий). Прикладываю Ваш вариант настройки с данным исправлением.
Прикрепленные файлы:
настройка 1.qxlz
99. Алиса Гусейнова (alisaguzel) 16.02.15 22:53 Сейчас в теме
(98) qwinter,
Результат тот же. В чистой базе пробовала, все точно так же.
1. Если грузить - Движение документа Операция, субконто появляется (указываешь документ в который грузишь)
2 При потоковой загрузке результат с пустыми субконто.
Очень уж мне важна потоковая загрузка. Операций в день около 300.
Извините. Спасибо.
Прикрепленные файлы:
Оставьте свое сообщение