[БП 3.0] Свертка БП 2.0 или БП 3.0 документами "Ввод начальных остатков" в БП 3.0 beta

0. Алексей Ермилов (Alex_E) 1488 02.04.16 17:53 Сейчас в теме
Новое воплощение старой идеи http://infostart.ru/public/118486/
Много взято отсюда http://infostart.ru/public/303564/
Движок переноса данных http://infostart.ru/public/421541/
В планах включить сюда же http://infostart.ru/public/117966/, пока не реализовано.

01.08.2016 - Версия 6.0.6.0 - добавлен раздел ввода остатков "Товары отгруженные", исправлены ошибки, учтены некоторые хотелки пользователей
11.09.2016 - Версия 6.0.6.5 - расширен функционал, исправлены замеченные ошибки
16.09.2016 - Версия 6.1.0.0 - изменен перенос учетной политики, с учётом изменений в релизах с 3.0.44.*
18.10.2016 - Версия 6.2.2.4 - исправлен перенос учетной политике, полностью переработан перенос констант, изменен алгоритм переноса объектов.
18.02.2017 - Версия 6.2.2.6 - исправлены некоторые ошибки
23.04.2017 - Версия 6.3.3.3 - Много исправлений по свертке из 2.0 и переносу справочников и документов.

Перейти к публикации

Комментарии
108. mikle vedekhin (MikleVV) 21.03.17 15:48 Сейчас в теме
Заплатил денюшку, скачал обработку, запустил, не смог подключиться к исходной базе.

"Не удалось подключится к другой программе: -2147221005(0x800401F3): Недопустимая строка с указанием класса . Не удалось подключится к другой программе: {ВнешняяОбработка.СверткаИПереносБП_БП30.МодульОбъекта(177)}: Ошибка при вызове конструктора (COMObject)
COMConnector = Новый COMObject(ИмяCOMСоединителя()); // "V83.COMConnector"
по причине:
-2147221005(0x800401F3): Недопустимая строка с указанием класса"


Сложилось впечатление, что с базовой версией не работает. Это так?

Или я как всегда что-то не так сделал?
109. Алексей Ермилов (Alex_E) 1488 21.03.17 15:50 Сейчас в теме
(108) Разницы подключения к базовой или ПРОФ нет, недопустимая строка с указанием класса - часто попытка подключитьсЯ к базе на платформе 8.3 из под 8.2 или что-то подобное...
110. mikle vedekhin (MikleVV) 21.03.17 15:59 Сейчас в теме
Везде 8.3 Вот скриншот
Прикрепленные файлы:
111. Алексей Ермилов (Alex_E) 1488 21.03.17 16:06 Сейчас в теме
(110) Этот скриншот ничего не показывает - нужно видеть, что выбрано в обработке, а не то, что выбрано для базы приемника. Источник может быть и на другой версии платформы, здесь же мы видим информацию по приёмнику, которую в обработке не выбираем
112. mikle vedekhin (MikleVV) 21.03.17 16:33 Сейчас в теме
Скриншот с базы - источника.

Приемник сделан просто выгрузкой конфигурации из источника и загрузкой её в приемник. У них не может быть разная конфигурация :-(
Прикрепленные файлы:
113. mikle vedekhin (MikleVV) 21.03.17 16:39 Сейчас в теме
Извините: сам дурак, естественно.

В обработке не была выбрана платформа источника. Выбрал 8.3 - все заработало.

Дураконеустойчивость :-(
114. Алексей Ермилов (Alex_E) 1488 21.03.17 16:40 Сейчас в теме
115. mikle vedekhin (MikleVV) 21.03.17 20:24 Сейчас в теме
Алексей, играюсь тут с обработкой и возникло несколько вопросов.

- В табличке переноса справочников и документов очень не хватает кнопочек "выбрать все" "снять выбор на всем". Их там нет, или я их просто не заметил?

- попробовал попереносить некоторые справочники. У меня на один элемент уходит по 6-7 секунд. Если рискну переносить справочник номенклатуры это займет более 10 часов. Это так и должно быть или у меня опять что-то не так настроено?
116. Алексей Ермилов (Alex_E) 1488 22.03.17 08:04 Сейчас в теме
(115) Встаете в нужную таблицу, кнопочки слева вверху...
117. mikle vedekhin (MikleVV) 22.03.17 14:40 Сейчас в теме
(116) Галочки нашёл, спасибо. Однако они не действуют на список типов объектов для переноса. Действуют только на список ссылок. Но и на том спасибо - уже хорошо.

А что по второму вопросу? Можно как-то настроить так, чтобы быстрее справочник переносился?

База - файловая. Находится на твердотельном диске, все на нём просто летает. А вот перенос - еле дышит :-(
118. Алексей Ермилов (Alex_E) 1488 22.03.17 14:51 Сейчас в теме
(117) Галочки можно прилепить к любой таблице или сделать свои для каждой - то не проблема, а вот про быстрее сделать перенос - там идёт куча рекурсий, можно попытаться их убрать, но....я долго приходил к этому варианту - желания ломать и делать по новой как то нет - меня устраивает (как минимум пока , этот алгоритм).. Сего помощью уже столько всего починено/перенесено, что просто жалко времени на передел, с неявным результатом. Даже сейча по выходу новых платформ и релизов приходится ингда что то допиливать, но, ещё раз пока совсем работать не перестанет, думаю оставлю так...
119. mikle vedekhin (MikleVV) 22.03.17 15:01 Сейчас в теме
(118) Спасибо за ответ. Поставил галочку "на сервере" и был поражен. Где-то в Вашем описании читал, что все пойдет "немнго" быстрее, только без строки состояния переноса. Ничего себе "немножко"

На тесте переносил 20 записей. При галочке "на сервере" быстрее в 7 раз!

так что запустил перенос номенклатуры - посмотрим что получится.
Мне главное понять что после свертки с обменом с УТ настает....

Вопросик: а что означает кнопка в таблице списка типов для переноса, называемая "заполнить документами без соответствия"? В описании не нашёл :-(
120. Алексей Ермилов (Alex_E) 1488 22.03.17 15:14 Сейчас в теме
(119)
Вопросик: а что означает кнопка в таблице списка типов для переноса, называемая "заполнить документами без соответствия"? В описании не нашёл :-(
- бывают ситуёвины, когдла в источнике на понаделаны документы, которых неи в типовой, и включать их в состав новой базы желания нету, а вот движения этих документов перенести хочется - вот для таких случаЁв это и сделано - документы перенесутся в операции вручную со всеми движениями.
121. Алексей Ермилов (Alex_E) 1488 22.03.17 15:18 Сейчас в теме
(119)
Мне главное понять что после свертки с обменом с УТ настает....
про обмен с УТ - тут всё весело - есть регистр сведений - Соответствие объектов для обмена или типа того, вот его бы заполнить - тады всё будет нормально, а так, при синхронизации придётся поаизгалятся всего скорее. Здесь обмен идет по ГУИД, что там было в регистре - хз, может всё и ровно встанет....
122. Денис Грачёв (denis1c@) 23.04.17 03:53 Сейчас в теме
Интересно, почему ВСЕ операции переносятся без аналитики? см. пример 2017-04-23_03-44-36.png
База файловая. Перенос из БП 2.0 в БП 3.0
Строку
ИмяСубконто  = стрCOM.Key.PredefinedDataName;

завернул в Попытку, т.к. вываливается с ошибкой.
СтрCOM.Value

содержит пустую строку.

В отладчике стрСОМ имеет такую структуру: см. стрСОМ.png
Прикрепленные файлы:
123. Денис Грачёв (denis1c@) 23.04.17 04:01 Сейчас в теме
А еще ВСЕ счета на оплату покупателю переносятся без табличных частей.
P.S. Буду, конечно, в отладчике разбираться, но может раньше кто-то ответит, где копать.
Прикрепленные файлы:
124. Алексей Ермилов (Alex_E) 1488 23.04.17 07:52 Сейчас в теме
(123) Выложил новую версию, возможно Ваши ошибки там решены. Пришлите почту в личку - вышлю. Если ошибки повторятся, то хотелось бы посмотреть на базу, например через амми админ.
125. Денис Грачёв (denis1c@) 23.04.17 14:48 Сейчас в теме
Почту в личку сбросил.
Еще интересует, т.к. я из двух баз БП 2.0 сливаю в одну 3.0, можно ли малой кровью изменить обработку, чтобы контрагентов искать по ИНН, КПП (если они заполнены), дабы не плодить дубли?
126. Алексей Ермилов (Alex_E) 1488 23.04.17 18:33 Сейчас в теме
(125)
можно ли малой кровью изменить обработку, чтобы контрагентов искать по ИНН, КПП (если они заполнены),
- код открыт, там можно даже по аналогии с сотрудниками из 2.0 сделать контрагентов отдельной процедурой, с каким угодно поиском, так то ищет по ГУИД, но потом можно поиском и заменой решить проблему с дублями, или написать по ИНН КПП поиск
denis1c@; +1 Ответить
127. Денис Грачёв (denis1c@) 23.04.17 19:52 Сейчас в теме
К сожалению, (на моих данных) последняя версия обработки менее работоспособная, чем предыдущая.
Ошибки при выборе Организации СОМ, заполнении списка в "ссылки для переноса" и по кнопке "заполнить документами без соответствия".
Прикрепленные файлы:
128. Денис Грачёв (denis1c@) 24.04.17 04:16 Сейчас в теме
Заменил (взял из новой версии обработки) процедуру _СубконтоСчета и бух.операции загрузились нормально.
С документом "Счет на оплату покупателю" тоже разобрался. В используемой мной конфигурации БП 3.0 у "Счета" не было табличной части "Услуги", из за этого в счета с услугами не перегружались табличные части. Немного подправил модуль:
В то место, где условие
				//Табличные части
				Для Каждого тчCOM Из РеквCOM.Metadata().TabularSections Цикл
					Если НовОбъект.Метаданные().ТабличныеЧасти.Найти(тчCOM.Имя) <> Неопределено Тогда

добавил подветку ИначеЕсли:
					ИначеЕсли _ИдентификаторCOM = "СчетНаОплатуПокупателю" и тчCOM.Имя = "Услуги" Тогда  //загрузим услуги в товары
						Для Каждого стрCOM Из РеквCOM[тчCOM.Name] Цикл
							НовСтрока = НовОбъект.Товары.Добавить();
							Для Каждого реквТЧCOM Из РеквCOM.Метаданные().ТабличныеЧасти[тчCOM.Name].Реквизиты Цикл //Цикл по колонкам тч
								
								Если НовОбъект.Метаданные().ТабличныеЧасти["Товары"].Реквизиты.Найти(реквТЧCOM.Name) = Неопределено Тогда Продолжить КонецЕсли;
								
								Если Найти(реквТЧCOM.Name, "Удалить") > 0 Тогда Продолжить КонецЕсли;
								
								Если ПримитивныйТип(стрCOM[реквТЧCOM.Name]) и ПримитивныйТип(НовСтрока[реквТЧCOM.Name]) Тогда
									НовСтрока[реквТЧCOM.Name] = стрCOM[реквТЧCOM.Name];
								ИначеЕсли Коннект.XMLString(стрCOM[реквТЧCOM.Name]) <> _СтрокаXML Тогда //На всякий случай, чтоб сам себя не записывал
									НовСтрока[реквТЧCOM.Name] = _ПеренестиРеквизит(стрCOM[реквТЧCOM.Name]);
								Иначе
									НовСтрока[реквТЧCOM.Name] = _Ссылка;
								КонецЕсли;
								
							КонецЦикла;
							Если _ТипОбъекта = "Документ" и ИмяКонфигурацииИсточника = "БП20" Тогда
							КонецЕсли;
						КонецЦикла;
...Показать Скрыть


все заработало.
Теперь осталось после переноса поработать напильником... )

P.S. Спасибо автору за труд!
129. Алексей Ермилов (Alex_E) 1488 24.04.17 07:16 Сейчас в теме
(127)Проверю, но лучше бы посмотреть....

(128) В счетах ТЧ Услуги убрали уже больше года назад, не столкнулся наверное по двум причинам - 1. сворачивал более свежии конфигурации; 2 Счета движений не делают, потому при сверке из не видно. За ошибку спасибо, поправлю.
130. Алексей Ермилов (Alex_E) 1488 24.04.17 07:47 Сейчас в теме
(127) Попробовал перенос организаций - перенеслось без ошибок...