Справка о среднем заработке для определения размера пособия по безработице (ЗБУ 1.0 и ЗУП 2.5)

0. Сергей Щепинов (Chip2003) 24 02.08.16 18:24 Сейчас в теме
Для службы занятости, биржи труда (приложение к приказу ДТиЗН города Москвы от 06.11.2014 № 638)

Перейти к публикации

Лучшие комментарии
13. Василий Сурков (Svasily) 21.12.16 10:15 Сейчас в теме
Доработал для своей ситуации (множество внутренних совместителей на суммированном учёте и сменном графике) Ваш отчёт.
По поводу того, что делать с внутренними совместителями на суммированном учёте мы тут пришли к мнению, что рассчитывать раздельно по основным и совместителям, а потом складывать средний заработок нельзя, т. к. понятия нормы времени для таких совместителей нет. Во-первых, они не могут работать больше половины нормы основного сотрудника, а во-вторых при сменном графике они могут отработать 5 часов за 3 месяца, а остальные дня выходные (не отпуск за свой счёт) и это всё законно.

В итоге среднечасовой заработок считается от суммы фактически отработанных часов и зарплаты основного и совместителя,
а индивидуальная норма часов (за вычетом периодов по п. 4 положения) - сложным 16-этажным запросом - только для основного сотрудника.

В помощь, если кто захочет повторить:
В общем, сделал в цикле по сотрудникам физлица заполнение и расчёт документа оплата по среднему и взял у документа совместителя табличную часть РасчетСреднего и подгрузил её в документ основного, после чего пересчитал документ основного, типа того :
Если ВсегоСотрудников>1 Тогда
		ДокументОплатаПоСреднемуЗаработку.РасчетСреднего.Загрузить(ТЗПоСреднему);
		ДокументОплатаПоСреднемуЗаработку.Записать();
		ДокументОплатаПоСреднемуЗаработку.Рассчитать(Новый Структура("Начисления,РасчетСреднего",Истина,Ложь), Истина);
		ДокументОплатаПоСреднемуЗаработку.Записать(РежимЗаписиДокумента.Проведение);
	КонецЕсли;
...Показать Скрыть


Определение среднечасового заработка:

СреднечасовойЗаработок = ОплатаПоСреднемуЗаработкуПереопределяемый.РасчетСреднегоЗаработка(ДокументОплатаПоСреднемуЗаработку, Истина, МесяцевРасчетногоПериода, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаНачало, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаОкончание);


Чтобы в таблицу отсутствий попадали больничные, а они туда должны попадать переписал запрос:
ВЫБРАТЬ РАЗРЕШЕННЫЕ
		Начисления.Сотрудник,
		Начисления.ВидРасчета.ОбозначениеВТабелеУчетаРабочегоВремени КАК ПричинаОтсутствия,
		Начисления.ПериодДействияНачало КАК ДатаОтсутствияНачала,
		Начисления.ПериодДействияКонец КАК ДатаОтсутствияОкончания
	ИЗ
		РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК Начисления
	ГДЕ
		Начисления.Сотрудник = &Сотрудник
		и Начисления.ВидРасчета.ВидВремени = Значение(Перечисление.ВидыВремени.ЦелодневноеНеотработанное)
		и Начисления.ВидРасчета<>Значение(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ДниНеоплачиваемыеСогласноТабелю)
		и Начисления.ВидРасчета<>Значение(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ОплатаПоСреднемуОтпКалендарныеДни)
		И Начисления.ПериодДействияКонец >= &ГраницаОтсутствий
	
	УПОРЯДОЧИТЬ ПО
		ДатаОтсутствияНачала
...Показать Скрыть
hellf; Chip2003; +2 Ответить 2
24. hellf (hellf) 17 01.02.17 13:42 Сейчас в теме
(17)да, там в принципе немножко совсем дописать.
где считается СреднедневнойЗаработок, можно добавить условие
Если Сотрудник.ГрафикРаботы.СуммированныйУчетРабочегоВремени=ИсТИНА тогда
		СреднечасовойЗаработок = ОплатаПоСреднемуЗаработкуПереопределяемый.РасчетСреднегоЗаработка(ДокументОплатаПоСреднемуЗаработку, Истина, МесяцевРасчетногоПериода, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаНачало, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаОкончание);
		
		Запрос = Новый Запрос;
		
		Запрос.УстановитьПараметр("НачалоПериода", ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаНачало);
		Запрос.УстановитьПараметр("КонецПериода", ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаОкончание);
		
		Запрос.УстановитьПараметр("РабочийДень", Перечисления.ВидыДнейПроизводственногоКалендаря.Рабочий);
		Запрос.УстановитьПараметр("ПредпраздничныйДень", Перечисления.ВидыДнейПроизводственногоКалендаря.Предпраздничный);
		
		Запрос.Текст =
		"ВЫБРАТЬ
		|	СУММА(ВЫБОР
		|			КОГДА РегламентированныйПроизводственныйКалендарь.ВидДня = &РабочийДень
		|				ТОГДА 1
		|			ИНАЧЕ 0
		|		КОНЕЦ) КАК ЧислоРабочихДней,
		|	СУММА(ВЫБОР
		|			КОГДА РегламентированныйПроизводственныйКалендарь.ВидДня = &ПредпраздничныйДень
		|				ТОГДА 1
		|			ИНАЧЕ 0
		|		КОНЕЦ) КАК ЧислоПредпраздничныхДней,
		|РАЗНОСТЬДАТ(&НачалоПериода, &КонецПериода, МЕСЯЦ) + 1 КАК КоличествоМесяцев
		|ИЗ
		|	РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
		|ГДЕ
		|	РегламентированныйПроизводственныйКалендарь.ДатаКалендаря МЕЖДУ &НачалоПериода И &КонецПериода";
		
		ВыборкаКалендаря = Запрос.Выполнить().Выбрать();
		Если ВыборкаКалендаря.Следующий() тогда
			ЧислоРабочихДнейВГоду = ?(ВыборкаКалендаря.ЧислоРабочихДней = NULL, 0, ВыборкаКалендаря.ЧислоРабочихДней); 
			ЧислоПредпраздничныхДнейВГоду = ?(ВыборкаКалендаря.ЧислоПредпраздничныхДней= NULL, 0, ВыборкаКалендаря.ЧислоПредпраздничныхДней);
			КоличествоМесяцев= ВыборкаКалендаря.КоличествоМесяцев;
		Иначе 
			ЧислоРабочихДнейВГоду = 0;
			ЧислоПредпраздничныхДнейВГоду = 0;
		КонецЕсли;
		
		
		СреднеМесячноеЧислоРабочихЧасов = Окр((ЧислоРабочихДнейВГоду*8+ЧислоПредпраздничныхДнейВГоду*7)/КоличествоМесяцев,2);
...Показать Скрыть
Chip2003; +1 Ответить
Остальные комментарии
1. Александр (mmtv68) 21 21.09.16 16:03 Сейчас в теме
Обновление от 29.08.2016: Исправлена ошибка вывода отсутствий: выводятся не все, а за последние 12 месяцев - в скаченном варианте у меня выводятся все.
2. Сергей Щепинов (Chip2003) 24 22.09.16 00:51 Сейчас в теме
(1) mmtv68, да, описание написал, а файл, конечно, обновить забыл! Спасибо, что подсказали, теперь обновил!
3. Василий Сурков (Svasily) 02.11.16 14:33 Сейчас в теме
Скачал, посмотрел. Форма конечно ваша, московская, от нашей отличается, но это не главное. И у Вас и в другом аналогичном решении не учитывается средний заработок внутренних совместителей. Насколько я понимаю, эти средние заработки надо суммировать для этой справки.
4. Сергей Щепинов (Chip2003) 24 03.11.16 11:17 Сейчас в теме
(3) Svasily, в организации, под которую я делал эту форму нет совместителей, поэтому особо не стал заморачиваться. По-хорошему, думаю, да, надо по физлицу формировать и складывать базу среднего. Здесь можно попробовать сформировать по каждому сотруднику свой средний и как-то их объединить с учетом предела и расчета, используя расшифровку.
5. Сергей Щепинов (Chip2003) 24 03.11.16 11:48 Сейчас в теме
(3) Svasily, Хотя еще есть мнение, что нужно 2 справки для такого физлица, т.к. в справке есть пункты: "на условиях полного рабочего дня (недели)" и "на условиях неполного рабочего дня (недели)"
6. Василий Сурков (Svasily) 07.11.16 14:23 Сейчас в теме
У нас и основные работники и совместители работают по сменному графику. Охранники. Так что никакого неполного рабочего дня.
7. Владимир Snegnii (tradeagent) 21.11.16 12:37 Сейчас в теме
Здравствуйте.
Исправьте, пожалуйста, ошибку: при получении ответственного лица не делается отбор по организации. В случае если в базе больше чем одна организация, это приводит к проблеме.
8. Владимир Snegnii (tradeagent) 21.11.16 12:46 Сейчас в теме
И пожелание - добавьте в обработку, что если у сотрудника не найден график, то пусть пользователю выдается понятное для него сообщение об ошибке, а не так, как сейчас, когда обработка прекращает свою работу и выдает проблемную строку кода.
9. Сергей Щепинов (Chip2003) 24 21.11.16 16:35 Сейчас в теме
(7) tradeagent, Не очень понял о каком ответственном лице идет речь? Руководитель и главный бухгалтер просто выбираются из справочника физлиц.
10. Сергей Щепинов (Chip2003) 24 21.11.16 16:36 Сейчас в теме
(8) tradeagent, вслепую вроде поправил обработку незаполненых графиков. Проверить не на ком.
11. hellf (hellf) 17 14.12.16 16:25 Сейчас в теме
Если у сотрудника установлен суммированный учет, то средний заработок все равно считает среднедневной, а не среднечасовой почему-то.
12. hellf (hellf) 17 15.12.16 09:05 Сейчас в теме
(11) причем в печатной форме расчета среднего все правильно- по часам и рассчитан среднечасовой. а вот в комментарии расчет по дням и в справку идет он.
13. Василий Сурков (Svasily) 21.12.16 10:15 Сейчас в теме
Доработал для своей ситуации (множество внутренних совместителей на суммированном учёте и сменном графике) Ваш отчёт.
По поводу того, что делать с внутренними совместителями на суммированном учёте мы тут пришли к мнению, что рассчитывать раздельно по основным и совместителям, а потом складывать средний заработок нельзя, т. к. понятия нормы времени для таких совместителей нет. Во-первых, они не могут работать больше половины нормы основного сотрудника, а во-вторых при сменном графике они могут отработать 5 часов за 3 месяца, а остальные дня выходные (не отпуск за свой счёт) и это всё законно.

В итоге среднечасовой заработок считается от суммы фактически отработанных часов и зарплаты основного и совместителя,
а индивидуальная норма часов (за вычетом периодов по п. 4 положения) - сложным 16-этажным запросом - только для основного сотрудника.

В помощь, если кто захочет повторить:
В общем, сделал в цикле по сотрудникам физлица заполнение и расчёт документа оплата по среднему и взял у документа совместителя табличную часть РасчетСреднего и подгрузил её в документ основного, после чего пересчитал документ основного, типа того :
Если ВсегоСотрудников>1 Тогда
		ДокументОплатаПоСреднемуЗаработку.РасчетСреднего.Загрузить(ТЗПоСреднему);
		ДокументОплатаПоСреднемуЗаработку.Записать();
		ДокументОплатаПоСреднемуЗаработку.Рассчитать(Новый Структура("Начисления,РасчетСреднего",Истина,Ложь), Истина);
		ДокументОплатаПоСреднемуЗаработку.Записать(РежимЗаписиДокумента.Проведение);
	КонецЕсли;
...Показать Скрыть


Определение среднечасового заработка:

СреднечасовойЗаработок = ОплатаПоСреднемуЗаработкуПереопределяемый.РасчетСреднегоЗаработка(ДокументОплатаПоСреднемуЗаработку, Истина, МесяцевРасчетногоПериода, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаНачало, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаОкончание);


Чтобы в таблицу отсутствий попадали больничные, а они туда должны попадать переписал запрос:
ВЫБРАТЬ РАЗРЕШЕННЫЕ
		Начисления.Сотрудник,
		Начисления.ВидРасчета.ОбозначениеВТабелеУчетаРабочегоВремени КАК ПричинаОтсутствия,
		Начисления.ПериодДействияНачало КАК ДатаОтсутствияНачала,
		Начисления.ПериодДействияКонец КАК ДатаОтсутствияОкончания
	ИЗ
		РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК Начисления
	ГДЕ
		Начисления.Сотрудник = &Сотрудник
		и Начисления.ВидРасчета.ВидВремени = Значение(Перечисление.ВидыВремени.ЦелодневноеНеотработанное)
		и Начисления.ВидРасчета<>Значение(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ДниНеоплачиваемыеСогласноТабелю)
		и Начисления.ВидРасчета<>Значение(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ОплатаПоСреднемуОтпКалендарныеДни)
		И Начисления.ПериодДействияКонец >= &ГраницаОтсутствий
	
	УПОРЯДОЧИТЬ ПО
		ДатаОтсутствияНачала
...Показать Скрыть
hellf; Chip2003; +2 Ответить 2
14. Василий Сурков (Svasily) 21.12.16 10:22 Сейчас в теме
У Вас, Сергей, мне остался совершенно непонятным момент:
//коэффициент индексации после расчетного периода применим ко всему среднему, но исключим его из расчета среднего

Вы берёте среднедневной заработок, который документ расчёта среднего уже вычисляет с учётом коэффициента индексации,
потом снова умножаете на коэффициент индексации.
Может, я чего-то недогоняю.

Ну и норму Вы берёте по производственному календарю, без учёта п. 4 постановления № 62, т.е. без вычета периодов оплаты по среднему и прочее.
15. Василий Сурков (Svasily) 21.12.16 10:33 Сейчас в теме
Ещё я впал в ступор - есть сотрудники на несуммированном учёте, но на сменном графике и с почасовой оплатой.
Положение предписывает на несуммированном учёте использовать среднедневные показатели, как-то мне это сильно не понравилось, оставил пока среднечасовые, тем более, что расчёта среднедневной индивидуальной нормы у меня пока нет. Пусть расчётчики разбираются, если что.
16. Василий Сурков (Svasily) 21.12.16 13:47 Сейчас в теме
В приведённый выше запрос надо добавить

и Начисления.ВидРасчета<>Значение(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ОплатаПоСреднему)


И, похоже, придётся возиться ещё с индивидуальной нормой по несуммированному учёту.
17. Сергей Щепинов (Chip2003) 24 21.12.16 14:07 Сейчас в теме
(12) , (15) у нас нет суммированного учета, сменщиков и совместителей, поэтому увы не заморачивался на этот счет соверешнно, да и тестировать расчеты не на ком.
18. Сергей Щепинов (Chip2003) 24 21.12.16 14:40 Сейчас в теме
(13) По поводу нормы, я опирался на статью из Консультанта "Зарплата", 2012, N 4 "СРЕДНЯЯ ЗАРПЛАТА: ЕЩЕ ОДИН СПОСОБ РАСЧЕТА":

«4. При исчислении среднего заработка из расчетного периода исключается время, а также начисленные за это время суммы,»

Среднемесячное число рабочих дней в расчетном периоде - показатель, который определяют для конкретного расчетного периода. При этом учитывают нормативное количество рабочих дней в расчетном периоде по графику, установленному для работника. Для расчета показателя удобно воспользоваться такой формулой:

[Среднемесячное число рабочих дней в расчетном периоде] = [Нормативное количество рабочих дней в расчетном периоде по установленному графику] : [3 месяца]

Пример 2. Работник уволился 13 марта 2012 г. Он обратился в бухгалтерию с просьбой выдать ему справку о среднем заработке для службы занятости. Какой средний заработок нужно указать в справке, если известны следующие данные:
- должностной оклад работника - 28 000 руб., выплат и начислений, помимо оклада, не было;
- в декабре 2011 г. из 22 рабочих дней работник пропустил 12 дней (сотрудник находился на больничном);
- январь и февраль 2012 г. отработаны полностью по графику пятидневной рабочей недели?

Решение. Сумма учитываемых выплат составит 68 727,27 руб. [28 000 руб. : 22 раб. дн. x (22 раб. дн. - 12 раб. дн.) + 28 000 руб. x 2 мес.].
В расчетном периоде отработано всего 46 раб. дн. (10 раб. дн. + 16 раб. дн. + 20 раб. дн.).
Воспользовавшись первой формулой, получим, что средний дневной заработок равен 1494,07 руб. (68 727,27 руб. : 46 раб. дн.).
Определим среднемесячное число рабочих дней в расчетном периоде (последняя формула). Оно равно 19,33 [(22 раб. дн. + 16 раб. дн. + 20 раб. дн.) : 3 мес.].
Получаем, что средний заработок (см. вторую формулу) для отражения в справке составит 28 880,37 руб. (1494,07 руб. x 19,33 дн.).
19. Сергей Щепинов (Chip2003) 24 21.12.16 14:46 Сейчас в теме
(13)
Чтобы в таблицу отсутствий попадали больничные, а они туда должны попадать переписал запрос:

В моей постановке было четко указан список отсутствий (видимо из закона взят) - там не было больничных.
20. Сергей Щепинов (Chip2003) 24 21.12.16 14:57 Сейчас в теме
(14) Это сделано для того, что если вдруг была индексация между окончанием расчетного периода и датой увольнения, то этот коэффициент индексации должен применяться не по типовому (когда индексируется база среднего), а должен индексироваться уже конечный рассчитанный средний заработок. (так сказано в законе)
Поэтому я его исключаю из расчета среднего и умножаю на него конечный средний заработок.
21. Василий Сурков (Svasily) 21.12.16 15:17 Сейчас в теме
Спасибо, Сергей, похоже Вы правы. Индивидуальная норма не нужна. Мы зациклились на нашем замудрённом расчёте сверхурочных, где есть какое-то официальное письмо, что нужно вычислять индивидуальную норму. А тут, похоже, просто норма по графику.
22. Василий Сурков (Svasily) 27.12.16 14:57 Сейчас в теме
Продолжу. Только я расслабился, как выяснилось, что расчёт количества отработанных недель для суммированного учёта и сменного графика вообще неверный - берётся отработано дней из расчёта среднего за год и делится на 5.
Придётся возрождать мой 16-этажный запрос...
Пишу не в упрёк автору, а для таких же попаданцев, как я с этим отчётом. Нам надо сократить несколько тысяч человек, расчётчики на ушах...
23. hellf (hellf) 17 01.02.17 13:41 Сейчас в теме
24. hellf (hellf) 17 01.02.17 13:42 Сейчас в теме
(17)да, там в принципе немножко совсем дописать.
где считается СреднедневнойЗаработок, можно добавить условие
Если Сотрудник.ГрафикРаботы.СуммированныйУчетРабочегоВремени=ИсТИНА тогда
		СреднечасовойЗаработок = ОплатаПоСреднемуЗаработкуПереопределяемый.РасчетСреднегоЗаработка(ДокументОплатаПоСреднемуЗаработку, Истина, МесяцевРасчетногоПериода, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаНачало, ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаОкончание);
		
		Запрос = Новый Запрос;
		
		Запрос.УстановитьПараметр("НачалоПериода", ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаНачало);
		Запрос.УстановитьПараметр("КонецПериода", ДокументОплатаПоСреднемуЗаработку.ПериодРасчетаСреднегоЗаработкаОкончание);
		
		Запрос.УстановитьПараметр("РабочийДень", Перечисления.ВидыДнейПроизводственногоКалендаря.Рабочий);
		Запрос.УстановитьПараметр("ПредпраздничныйДень", Перечисления.ВидыДнейПроизводственногоКалендаря.Предпраздничный);
		
		Запрос.Текст =
		"ВЫБРАТЬ
		|	СУММА(ВЫБОР
		|			КОГДА РегламентированныйПроизводственныйКалендарь.ВидДня = &РабочийДень
		|				ТОГДА 1
		|			ИНАЧЕ 0
		|		КОНЕЦ) КАК ЧислоРабочихДней,
		|	СУММА(ВЫБОР
		|			КОГДА РегламентированныйПроизводственныйКалендарь.ВидДня = &ПредпраздничныйДень
		|				ТОГДА 1
		|			ИНАЧЕ 0
		|		КОНЕЦ) КАК ЧислоПредпраздничныхДней,
		|РАЗНОСТЬДАТ(&НачалоПериода, &КонецПериода, МЕСЯЦ) + 1 КАК КоличествоМесяцев
		|ИЗ
		|	РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
		|ГДЕ
		|	РегламентированныйПроизводственныйКалендарь.ДатаКалендаря МЕЖДУ &НачалоПериода И &КонецПериода";
		
		ВыборкаКалендаря = Запрос.Выполнить().Выбрать();
		Если ВыборкаКалендаря.Следующий() тогда
			ЧислоРабочихДнейВГоду = ?(ВыборкаКалендаря.ЧислоРабочихДней = NULL, 0, ВыборкаКалендаря.ЧислоРабочихДней); 
			ЧислоПредпраздничныхДнейВГоду = ?(ВыборкаКалендаря.ЧислоПредпраздничныхДней= NULL, 0, ВыборкаКалендаря.ЧислоПредпраздничныхДней);
			КоличествоМесяцев= ВыборкаКалендаря.КоличествоМесяцев;
		Иначе 
			ЧислоРабочихДнейВГоду = 0;
			ЧислоПредпраздничныхДнейВГоду = 0;
		КонецЕсли;
		
		
		СреднеМесячноеЧислоРабочихЧасов = Окр((ЧислоРабочихДнейВГоду*8+ЧислоПредпраздничныхДнейВГоду*7)/КоличествоМесяцев,2);
...Показать Скрыть
Chip2003; +1 Ответить
25. Сергей Щепинов (Chip2003) 24 01.02.17 17:12 Сейчас в теме