Сканирование в справочнике номенклатуры и документах по акцизной марке (Розница 2.2, платформа 8.3.9)

0. Александр NoName (tupoy) 9 14.05.17 21:46 Сейчас в теме
Сканирование в справочнике номенклатуры и документах по акцизной марке, а так же в обработке отбора номенклатуры.

Перейти к публикации

Комментарии
1. Егор Иванов (user635667_bolonevegor) 31 16.05.17 06:15 Сейчас в теме
Не перестаешь удивлять! Буду тестить. Спасибо.
2. Максим Радченко (coolseo) 23 20.05.17 03:14 Сейчас в теме
Здравствуйте, тестирую, в процедуре вы указываете Событие = "Штрихкод", а правильно
Событие = "ПолученШтрихкод", а так же ВводДоступен() всегда возвращает ложь и не заходит в условие, в общем я все это выпилил полетело

1С:Предприятие 8.3 (8.3.9.2233), Розница, редакция 2.2 (2.2.5.25)

&НаКлиенте
Процедура СканМарк_ВнешнееСобытиеВместо(Источник, Событие, Данные)
	
	Если ВводДоступен() И НЕ ЗначениеЗаполнено(Объект.ПодписьЧекаЕГАИС) И СтрДлина(Данные) <> 68 Тогда
		ПодключаемоеОборудованиеРТКлиент.ВнешнееСобытиеОборудования(ЭтотОбъект, Источник, Событие, Данные);
	КонецЕсли;
	
	Если Событие = "ПолученШтрихкод" И СтрДлина(Данные) = 68 Тогда
		РезультатПоиска = СканМарк_АлкогольныеПроцедурыИФункцииКлиент.ДанныеПоискаПоАлкоМаркеКлиент(Данные);
		ДобавлениеНоменклатуры(РезультатПоиска);
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть
3. Егор Иванов (user635667_bolonevegor) 31 21.05.17 05:17 Сейчас в теме
А у меня пишет:
Платформа: 1С:Предприятие 8.3 (8.3.9.2170)
Конфигурация: Розница, редакция 2.2 (2.2.5.23)

Расширение конфигурации: Разблокировать реквизиты (2.2.5.23)
Расширение конфигурации: Группировка пива для продажи (1.0)
Расширение конфигурации: Список номенклатуры (1)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент

Ошибки:
--------------------------------------------------------------------------------
21.05.2017 10:13:56
СканированиеВДокументахПоАкцизнойМарке (1.1): Критичная: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации
В чем может быть проблема? В несовместимости с другими расширениями?
upd - я отключил все расширения - ошибка осталась. может платформа или версия конфигурации не те?
п.с. и вопрос не в тему - а если я в центральной базе подключаю расширение оно распространится по РИБ само или в каждой точке его вручную ставить придется?
4. Егор Иванов (user635667_bolonevegor) 31 21.05.17 06:45 Сейчас в теме
Я отключил все расширения и обновил конфигурацию до последней версии и платформу до последней девятой. не помогло(
Платформа: 1С:Предприятие 8.3 (8.3.9.2233)
Конфигурация: Розница, редакция 2.2 (2.2.5.27) (http://v8.1c.ru/retail/)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент
Локализация: Информационная база: русский (Россия), Сеанс: русский (Россия)
Вариант интерфейса: Версия 8.2

Ошибки:
--------------------------------------------------------------------------------
21.05.2017 11:42:43
СканированиеВДокументахПоАкцизнойМарке (1.1): Критичная: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации
5. Максим Радченко (coolseo) 23 21.05.17 12:32 Сейчас в теме
6. Максим Радченко (coolseo) 23 21.05.17 12:32 Сейчас в теме
(4)Выключить совместимость с 8.3.8, т.е включить возможность изменения в базе.
Тут использованы новые приему которые только 8.3.9
Оставьте свое сообщение