план обмена

[ Закрыто ]
Страницы: 1

в состав плана обмена помещены документы. надо создать сообщение обмена изменениярегистраций только для проведенных документов.как это организовать?в чем ошибка
Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза) Экспорт

ОбъектМетаданных=ЭлементДанных.Метаданные();

Если Метаданные.Документы.Содержит(ОбъектМетаданных) Тогда
Если ЭлементДанных.Проведен Тогда
ОтправкаЭлемента=ОтправкаЭлементаДанных.Авто;
КонецЕсли;
КонецЕсли;
//.....................................
КонецПроцедуры


как запросом обратится к результатуРегистрации


По идее, нужно устанавливать не Авто для проведенных документов (Авто и так установлено у каждого элемента, который обрабатывается в этом обработчике), а Игнорировать - для не проведенных.

Ответили: (4) (9)

(3) ssa, сейчас попробуем

Ответили: (5)

(4) silai89, а можно как нибудь обратится запросом к результату регистраций и выбрать изменения только проведенных документов и их записать в файл

Ответили: (6)

(5) Обратиться то можно, только зачем такие сложности. По-моему, оптимально решить этот вопрос при формировании файла выгрузки.

Ответили: (7)

(6) ssa, не получается


ни в выбратьИзменения() ни в ЗарегистрироватьИзменения()

Ответили: (9)

(8) silai89,
"ни в выбратьИзменения() ни в ЗарегистрироватьИзменения()" - ?
Имел в виду, что в ПриОтправкеДанныхПодчиненному() нужно сделать то, что написано в (3), т.е. анализировать текущий ЭлементДанных и если это документ и он не проведен - установить ОтравкаЭлемента = Игнорировать. Либо, если нужно удалить в периферийной базе: ОтравкаЭлемента = Удалить.

Страницы: 1

Тема закрыта.
Запрещено добавлять сообщения в закрытую тему.


Каким соцсетями пользуетесь?

В контакте

33.91% (731)

Не пользуюсь соц.сетями

18.37% (396)

Facebook

14.33% (309)

Одноклассники

10.11% (218)

Google+

7.84% (169)

Mail.ru

4.41% (95)

Twitter

4.08% (88)

Linkedin

3.06% (66)

LiveJournal

2.18% (47)

Другие

1.72% (37)