план обмена

[ Закрыто ]
Страницы: 1

в состав плана обмена помещены документы. надо создать сообщение обмена изменениярегистраций только для проведенных документов.как это организовать?в чем ошибка
Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза) Экспорт

ОбъектМетаданных=ЭлементДанных.Метаданные();

Если Метаданные.Документы.Содержит(ОбъектМетаданных) Тогда
Если ЭлементДанных.Проведен Тогда
ОтправкаЭлемента=ОтправкаЭлементаДанных.Авто;
КонецЕсли;
КонецЕсли;
//.....................................
КонецПроцедуры


как запросом обратится к результатуРегистрации


По идее, нужно устанавливать не Авто для проведенных документов (Авто и так установлено у каждого элемента, который обрабатывается в этом обработчике), а Игнорировать - для не проведенных.

Ответили: (4) (9)

(3) ssa, сейчас попробуем

Ответили: (5)

(4) silai89, а можно как нибудь обратится запросом к результату регистраций и выбрать изменения только проведенных документов и их записать в файл

Ответили: (6)

(5) Обратиться то можно, только зачем такие сложности. По-моему, оптимально решить этот вопрос при формировании файла выгрузки.

Ответили: (7)

(6) ssa, не получается


ни в выбратьИзменения() ни в ЗарегистрироватьИзменения()

Ответили: (9)

(8) silai89,
"ни в выбратьИзменения() ни в ЗарегистрироватьИзменения()" - ?
Имел в виду, что в ПриОтправкеДанныхПодчиненному() нужно сделать то, что написано в (3), т.е. анализировать текущий ЭлементДанных и если это документ и он не проведен - установить ОтравкаЭлемента = Игнорировать. Либо, если нужно удалить в периферийной базе: ОтравкаЭлемента = Удалить.

Страницы: 1

Тема закрыта.
Запрещено добавлять сообщения в закрытую тему.

Алкогольная декларация для Бухгалтерии 7.7 и УСН 7.7 (Приложения 5, 6, 7, 8 и 11, 12) в формате 4.30
Открыть


Что обычно Вы делаете в Excel?

Другое.

32.47% (63)

Формирую своды из различных источников данных.

23.71% (46)

Разрабатываю отчеты по данным из 1С Предприятия.

15.98% (31)

Делаю шаблоны ввода для загрузки данных в 1С Предприятие.

14.95% (29)

Программирую макросы на VBA для автоматизации рутинных операций.

8.25% (16)

Разрабатываю сложные отчеты.

4.64% (9)